gcc warns that function 'qbman_pull_desc_set_token' is not used.
drivers/staging/fsl-mc/bus/dpio/qbman-portal.c:525:13: warning:
‘qbman_pull_desc_set_token’ defined but not used [-Wunused-function]
In the current code we remove that function.
Fixes: 321eecb06bfb ("bus: fsl-mc: dpio: add QBMan p
Use a blank line after components_show() function declaration.
Signed-off-by: Quytelda Kahja
---
drivers/staging/most/core.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/most/core.c b/drivers/staging/most/core.c
index 0ab2de5ecf18..67e2d7f29967 100644
--- a/drivers/staging
> Are you sure this will work?
Well, my goal was just to replace the code that could crash the kernel
and let somebody with a better understanding of this particular driver
write the recovery code, if necessary. It seemed from context that
the BUG_ON() calls were being used like assert() though, s
Indent the parameters for a function call that extends past 80 characters.
Signed-off-by: Quytelda Kahja
---
drivers/staging/most/core.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/most/core.c b/drivers/staging/most/core.c
index 67e2d7f29967..8d311970225
On Tue, Mar 06, 2018 at 01:23:18AM -0800, Quytelda Kahja wrote:
> > Are you sure this will work?
> Well, my goal was just to replace the code that could crash the kernel
> and let somebody with a better understanding of this particular driver
> write the recovery code, if necessary. It seemed from
On Mon, Mar 05, 2018 at 11:41:43PM +0530, Arushi Singhal wrote:
> On Mon, Mar 5, 2018 at 3:33 PM, Dan Carpenter
> wrote:
>
> > On Mon, Mar 05, 2018 at 04:02:06AM +0530, Arushi Singhal wrote:
> > > Replace printk having a log level with the appropriate
> > > net_*macro_ratelimited.
> > > It's bett
Replace literal bytestring with CIPHER_ID_WPA_WEP40 constant.
Signed-off-by: Quytelda Kahja
---
drivers/staging/ks7010/ks_hostif.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ks7010/ks_hostif.c
b/drivers/staging/ks7010/ks_hostif.c
index 7935ba56bb1d..05f7
These pointers can't be NULL so I have removed the checks.
The checking was sort of problematic as well because it didn't make
sense. In _nbu2ss_read_request_data() the && should have been ||. In
nbu2ss_gad_get_frame() we know that "pgadget" is non-NULL and "udc" is
an offset from "pgadget" so i
On Mon, Mar 05, 2018 at 02:19:11AM +0530, Arushi Singhal wrote:
> Replace printk having a log level with the appropriate
> net_*macro_ratelimited.
> It's better to use actual device name as a prefix in error messages.
> Indentation is also changed, to fix the checkpatch issue.
>
> Signed-off-by:
On Tue, Mar 6, 2018 at 2:33 AM, Julia Lawall wrote:
>
>
> On Mon, 5 Mar 2018, Arushi Singhal wrote:
>
>>
>>
>> On Mon, Mar 5, 2018 at 3:33 PM, Dan Carpenter
>> wrote:
>> On Mon, Mar 05, 2018 at 04:02:06AM +0530, Arushi Singhal wrote:
>> > Replace printk having a log level with the ap
On Mon, Mar 05, 2018 at 01:02:56PM +0530, Arushi Singhal wrote:
> Replace printk having a log level with the appropriate
> net_*macro_ratelimited.
> It's better to use actual device name as a prefix in error messages.
> Indentation is also changed, to fix the checkpatch issue if line is not
> exce
On Mon, Mar 05, 2018 at 06:52:54AM +0100, Kirill Marinushkin wrote:
> In the current implementation, `rmmod snd_bcm2835` does not release
> resources properly. It causes an oops when trying to list sound devices.
>
> This commit fixes it.
>
> Steps to reproduce:
>
>
> $ rmmod snd_bcm2835
>
This patchset fixes errors and checks found by checkpatch.pl in the
staging/iio/meter. These series fixes:
* Removes the use of 4 digit octal by replaces IIO_DEV_ATTR_CH_OFF by
IIO_DEVICE_ATTR;
* Removes unnecessary macro;
* Aligns open parenthesis;
After apply this patch series, meter go
The macro IIO_DEV_ATTR_CH_OFF is a wrapper for IIO_DEVICE_ATTR, with a
tiny change in the name definition. This extra macro does not improve
the readability and also creates some checkpatch errors.
This patch fixes the checkpatch.pl errors:
staging/iio/meter/ade7753.c:391: ERROR: Use 4 digit octa
This patch removes the macro IIO_DEV_ATTR_CH_OFF. The macro
IIO_DEV_ATTR_CH_OFF is not required, due to the replace of it by the
direct use of IIO_DEVICE_ATTR in files staging/iio/meter/ade7759.c and
staging/iio/meter/ade7753.c.
Signed-off-by: Rodrigo Siqueira
---
drivers/staging/iio/meter/meter
This patch fixes the checkpatch.pl checks:
staging/iio/meter/ade7854-spi.c:19: CHECK: Alignment should match open
parenthesis
staging/iio/meter/ade7854-spi.c:44: CHECK: Alignment should match open
parenthesis
staging/iio/meter/ade7854-spi.c:70: CHECK: Alignment should match open
parenthesis
stagin
On Mon, Mar 5, 2018 at 10:30 AM, Christian Borntraeger
wrote:
> On 01/16/2018 03:18 AM, Deepa Dinamani wrote:
>> All the current architecture specific defines for these
>> are the same. Refactor these common defines to a common
>> header file.
>>
>> The new common linux/compat_time.h is also usefu
On Tue, Mar 06, 2018 at 09:26:07AM -0300, Rodrigo Siqueira wrote:
> @@ -63,7 +63,7 @@ int ade7758_probe_trigger(struct iio_dev *indio_dev)
> int ret;
>
> st->trig = iio_trigger_alloc("%s-dev%d",
> - spi_get_device_id(st->us)->name,
> +
On 03/06/2018 01:46 PM, Arnd Bergmann wrote:
> On Mon, Mar 5, 2018 at 10:30 AM, Christian Borntraeger
> wrote:
>> On 01/16/2018 03:18 AM, Deepa Dinamani wrote:
>>> All the current architecture specific defines for these
>>> are the same. Refactor these common defines to a common
>>> header file.
Signed-off-by: Peter Große
---
drivers/staging/rtl8723bs/hal/rtl8723b_hal_init.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8723bs/hal/rtl8723b_hal_init.c
b/drivers/staging/rtl8723bs/hal/rtl8723b_hal_init.c
index d6cef9e8378d..50f12ee91345 100644
--- a
On Tue, Mar 06, 2018 at 04:02:11PM +0100, Peter Große wrote:
> Signed-off-by: Peter Große
> ---
> drivers/staging/rtl8723bs/hal/rtl8723b_hal_init.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/staging/rtl8723bs/hal/rtl8723b_hal_init.c
> b/drivers/staging/rtl8
On Tue, 6 Mar 2018, Arushi Singhal wrote:
>
>
> On Mon, Mar 5, 2018 at 1:07 PM, Julia Lawall wrote:
>
>
> On Mon, 5 Mar 2018, Arushi Singhal wrote:
>
> > Replace printk having a log level with the appropriate
> > net_*macro_ratelimited.
> > It's better to use actual devi
On 03/06/18 13:14, Greg Kroah-Hartman wrote:
> On Mon, Mar 05, 2018 at 06:52:54AM +0100, Kirill Marinushkin wrote:
>> In the current implementation, `rmmod snd_bcm2835` does not release
>> resources properly. It causes an oops when trying to list sound devices.
>>
>> This commit fixes it.
>>
>> Ste
On Sun, Mar 04, 2018 at 10:17:16PM -0700, k...@exchange.microsoft.com wrote:
> From: "lantianyu1...@gmail.com"
That's not a "name" :(
Please fix and resend.
thanks,
greg k-h
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdr
Some code cleanup and bug fixes based on warnings reported by sparse
when building on x86.
Ioana Radulescu (5):
staging: fsl-mc/dpio: Fix incorrect cast
staging: fsl-mc/dpio: Fix cast truncate warning
staging: fsl-mc/dpio: Use __leXX types where needed
staging: fsl-mc/dpio: Fix incorrect m
Move the cast in dpaa2_sg_get_addr() to the right place.
Signed-off-by: Ioana Radulescu
---
drivers/staging/fsl-mc/include/dpaa2-fd.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/fsl-mc/include/dpaa2-fd.h
b/drivers/staging/fsl-mc/include/dpaa2-fd.h
index 3
Structures that are mapped to hardware registers should explicitly
specify the expected endianness for fields larger than 1 byte.
Signed-off-by: Ioana Radulescu
---
drivers/staging/fsl-mc/bus/dpio/qbman-portal.c | 16
drivers/staging/fsl-mc/bus/dpio/qbman-portal.h | 24 +
Sparse reports the following warning:
drivers/staging/fsl-mc/include/dpaa2-fd.h:421:30:
warning: cast truncates bits from constant value (7fff becomes 7fff)
Fix this by explicitly masking the value with 0x.
Signed-off-by: Ioana Radulescu
---
drivers/staging/fsl-mc/include/dpaa2-fd.h | 4
In qbman_swp_alt_fq_state(), we need to mask the fqid value
before converting it to little endian, otherwise we write a
wrong value to hardware when running in big endian mode.
Signed-off-by: Ioana Radulescu
---
drivers/staging/fsl-mc/bus/dpio/qbman-portal.c | 2 +-
1 file changed, 1 insertion(+
Function qbman_pull_desc_set_token() is not used at all, so remove it.
Signed-off-by: Ioana Radulescu
---
drivers/staging/fsl-mc/bus/dpio/qbman-portal.c | 5 -
1 file changed, 5 deletions(-)
diff --git a/drivers/staging/fsl-mc/bus/dpio/qbman-portal.c
b/drivers/staging/fsl-mc/bus/dpio/qbman
If there is a pending work, we just need to add the new dr into
the dr_list.
This is suggested by Michael Kelley.
Signed-off-by: Dexuan Cui
Cc: Vitaly Kuznetsov
Cc: Jack Morgenstein
Cc: sta...@vger.kernel.org
Cc: Stephen Hemminger
Cc: K. Y. Srinivasan
Cc: Michael Kelley (EOSG)
---
drivers/
1. With the patch "x86/vector/msi: Switch to global reservation mode"
(4900be8360), the recent v4.15 and newer kernels always hang for 1-vCPU
Hyper-V VM with SR-IOV. This is because when we reach hv_compose_msi_msg()
by request_irq() -> request_threaded_irq() -> __setup_irq()->irq_startup()
-> __
> -Original Message-
> From: Ruxandra Ioana Ciocoi Radulescu
> Sent: Tuesday, March 6, 2018 7:44 PM
> To: gre...@linuxfoundation.org
> Cc: de...@driverdev.osuosl.org; linux-ker...@vger.kernel.org; Roy Pledge
> ; Laurentiu Tudor
> Subject: [PATCH 5/5] staging: fsl-mc/dpio: Remove dead code
When we hot-remove the device, we first receive a PCI_EJECT message and
then receive a PCI_BUS_RELATIONS message with bus_rel->device_count == 0.
The first message is offloaded to hv_eject_device_work(), and the second
is offloaded to pci_devices_present_work(). Both the paths can be running
list_
Since we serialize the present/eject work items now, we don't need the
semaphore any more.
This is suggested by Michael Kelley.
Signed-off-by: Dexuan Cui
Cc: Vitaly Kuznetsov
Cc: Jack Morgenstein
Cc: sta...@vger.kernel.org
Cc: Stephen Hemminger
Cc: K. Y. Srinivasan
Cc: Michael Kelley (EOSG)
No functional change.
Signed-off-by: Dexuan Cui
Fixes: bdd74440d9e8 ("PCI: hv: Add explicit barriers to config space access")
Cc: Vitaly Kuznetsov
Cc: sta...@vger.kernel.org
Cc: Stephen Hemminger
Cc: K. Y. Srinivasan
---
drivers/pci/host/pci-hyperv.c | 2 +-
1 file changed, 1 insertion(+), 1
Changes in v2 are:
Patch 1, 6: no change since v1.
Patch 2,4,5: I added these new patches, as suggested by Michael Kelley.
Patch 3: Removed the unnecessary drain_workqueue(), as suggested by Michael
Kelley.
Changes in v3 are:
Patch 5: minimized the scope of the spinlock, as suggested by Michael
When we're in the function, hpdev->state must be hv_pcichild_ejecting:
see hv_pci_eject_device().
Signed-off-by: Dexuan Cui
Cc: Vitaly Kuznetsov
Cc: Jack Morgenstein
Cc: sta...@vger.kernel.org
Cc: Stephen Hemminger
Cc: K. Y. Srinivasan
Cc: Michael Kelley (EOSG)
---
drivers/pci/host/pci-hype
> -Original Message-
> From: Dexuan Cui
> Sent: Tuesday, March 6, 2018 10:22 AM
> To: bhelg...@google.com; linux-...@vger.kernel.org; KY Srinivasan
> ;
> Stephen Hemminger ; o...@aepfle.de;
> a...@canonical.com;
> jasow...@redhat.com
> Cc: linux-ker...@vger.kernel.org; driverdev-devel@lin
> -Original Message-
> From: Dexuan Cui
> Sent: Tuesday, March 6, 2018 10:22 AM
> To: bhelg...@google.com; linux-...@vger.kernel.org; KY Srinivasan
> ;
> Stephen Hemminger ; o...@aepfle.de;
> a...@canonical.com;
> jasow...@redhat.com
> Cc: linux-ker...@vger.kernel.org; driverdev-devel@lin
> -Original Message-
> From: Dexuan Cui
> Sent: Tuesday, March 6, 2018 10:22 AM
> To: bhelg...@google.com; linux-...@vger.kernel.org; KY Srinivasan
> ;
> Stephen Hemminger ; o...@aepfle.de;
> a...@canonical.com;
> jasow...@redhat.com
> Cc: linux-ker...@vger.kernel.org; driverdev-devel@lin
Fix partial warnings of checkpatch.pl for drivers/staging/greybus/i2c.c
Signed-off-by: Horatiu Vultur
---
drivers/staging/greybus/i2c.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/greybus/i2c.c b/drivers/staging/greybus/i2c.c
index 58a37de..aec3cc6
> -Original Message-
> From: Dexuan Cui
> Sent: Tuesday, March 6, 2018 10:22 AM
> To: bhelg...@google.com; linux-...@vger.kernel.org; KY Srinivasan
> ;
> Stephen Hemminger ; o...@aepfle.de;
> a...@canonical.com;
> jasow...@redhat.com
> Cc: linux-ker...@vger.kernel.org; driverdev-devel@lin
> -Original Message-
> From: Dexuan Cui
> Sent: Tuesday, March 6, 2018 10:22 AM
> To: bhelg...@google.com; linux-...@vger.kernel.org; KY Srinivasan
> ;
> Stephen Hemminger ; o...@aepfle.de;
> a...@canonical.com;
> jasow...@redhat.com
> Cc: linux-ker...@vger.kernel.org; driverdev-devel@lin
Hi
On 03/06, Dan Carpenter wrote:
> On Tue, Mar 06, 2018 at 09:26:07AM -0300, Rodrigo Siqueira wrote:
> > @@ -63,7 +63,7 @@ int ade7758_probe_trigger(struct iio_dev *indio_dev)
> > int ret;
> >
> > st->trig = iio_trigger_alloc("%s-dev%d",
> > - spi_get_d
On Mon, 2018-03-05 at 13:19 +0530, Himanshu Jha wrote:
> Remove unnecessary comments since the definitions are pretty clear
> with their macro names.
>
> Signed-off-by: Himanshu Jha
> ---
> drivers/staging/iio/accel/adis16201.c | 82 +--
>
> 1 file changed, 10 in
Hi Shreeya,
> I was just going through your patch for giving myself
> a habit of reading patches.
Great!
> I see here that there are many comments which are necessary
> have also been removed.
> Jonathan told that some of the names do not explain
> much about the how registers are related to th
On Tue, Mar 6, 2018 at 4:48 AM, Christian Borntraeger
wrote:
>
>
> On 03/06/2018 01:46 PM, Arnd Bergmann wrote:
>> On Mon, Mar 5, 2018 at 10:30 AM, Christian Borntraeger
>> wrote:
>>> On 01/16/2018 03:18 AM, Deepa Dinamani wrote:
All the current architecture specific defines for these
a
This patchset fixes errors and checks found by checkpatch.pl in the
staging/iio/meter. These series fixes:
* Removes the use of 4 digit octal by replaces IIO_DEV_ATTR_CH_OFF by
IIO_DEVICE_ATTR;
* Removes unnecessary macro;
* Aligns open parenthesis;
Changes v2:
- Aligns one extra open par
This patch removes the macro IIO_DEV_ATTR_CH_OFF. The macro
IIO_DEV_ATTR_CH_OFF is not required, due to the replace of it by the
direct use of IIO_DEVICE_ATTR in files staging/iio/meter/ade7759.c and
staging/iio/meter/ade7753.c.
Signed-off-by: Rodrigo Siqueira
---
drivers/staging/iio/meter/meter
This patch fixes the checkpatch.pl checks:
staging/iio/meter/ade7854-spi.c:19: CHECK: Alignment should match open
parenthesis
staging/iio/meter/ade7854-spi.c:44: CHECK: Alignment should match open
parenthesis
staging/iio/meter/ade7854-spi.c:70: CHECK: Alignment should match open
parenthesis
stagin
The macro IIO_DEV_ATTR_CH_OFF is a wrapper for IIO_DEVICE_ATTR, with a
tiny change in the name definition. This extra macro does not improve
the readability and also creates some checkpatch errors.
This patch fixes the checkpatch.pl errors:
staging/iio/meter/ade7753.c:391: ERROR: Use 4 digit octa
There is no need for the calls to BUG_ON() in this driver, which are
used to check if mbo or mbo->context are NULL; mbo is never NULL, and
if mbo->context is NULL it would have already been dereferenced and
oopsed before reaching the BUG_ON().
Signed-off-by: Quytelda Kahja
---
drivers/staging/mo
Hi,
Hope you are doing well.
We are a database providing company which provides lists/databases for
various industries across the globe and we can provide you with contact
details of decision makers and influencers of your target market.
All the contacts include Contact name, Job title, ma
From: HariPrasath Elango
dev_dbg includes the function name & line number by default when dynamic
debugging is enabled. Hence__func__ is reduntant here and removed.
Signed-off-by: HariPrasath Elango
---
drivers/staging/iio/meter/ade7758_trigger.c | 2 +-
1 file changed, 1 insertion(+), 1 delet
On Wed, Mar 07, 2018 at 10:40:05AM +0530, hariprasath.ela...@gmail.com wrote:
> From: HariPrasath Elango
>
> dev_dbg includes the function name & line number by default when dynamic
> debugging is enabled. Hence__func__ is reduntant here and removed.
>
> Signed-off-by: HariPrasath Elango
> ---
From: HariPrasath Elango
dev_dbg includes the function name & line number by default when dynamic
debugging is enabled. Hence__func__ is reduntant here and removed.
Signed-off-by: HariPrasath Elango
---
drivers/staging/iio/meter/ade7758_trigger.c | 2 +-
1 file changed, 1 insertion(+), 1 delet
The kernel would like to remove all VLA usage. This switches to a
simple kasprintf() instead.
Signed-off-by: Kees Cook
---
drivers/staging/lustre/lustre/llite/xattr.c | 19 +--
1 file changed, 13 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/lustre/lustre/llite/xatt
On Tue, Mar 6, 2018 at 9:30 AM, syzbot
wrote:
> Hello,
>
> syzbot hit the following crash on upstream commit
> 094b58e1040a44f991d7ab628035e69c4d6b79c9 (Mon Mar 5 19:57:06 2018 +)
> Merge tag 'linux-kselftest-4.16-rc5' of
> git://git.kernel.org/pub/scm/linux/kernel/git/shuah/linux-kselftest
I
59 matches
Mail list logo