On 02/17/2018 01:54 AM, Laura Abbott wrote:
> On 02/16/2018 04:17 AM, Alexey Skidanov wrote:
>>
>>
>> On 02/16/2018 01:48 AM, Laura Abbott wrote:
>>> On 02/12/2018 02:33 PM, Alexey Skidanov wrote:
Current ion kernel mapping implementation uses vmap() to map previously
allocated buffers
This patch fixes up unncessary parentheses warning found by checkpatch.pl script
Signed-off-by: Yash Omer
---
drivers/staging/ks7010/ks_hostif.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ks7010/ks_hostif.c
b/drivers/staging/ks7010/ks_hostif.c
index 7bd56
On Sat, Feb 17, 2018 at 12:58:46PM +0530, Yash Omer wrote:
> This patch fixes up unnecessary parenthesis issue found by checkpatch.pl
>
> Signed-off-by: Yash Omer
> ---
> drivers/staging/ks7010/ks_hostif.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/staging/
On Mon, 12 Feb 2018 17:57:31 +0300
Dan Carpenter wrote:
> On Mon, Feb 12, 2018 at 08:05:22PM +0530, Himanshu Jha wrote:
> > But these should be done when we have *more* instances.
> >
> > For eg:
> > I added a tab space in function static int adis16201_read_raw() argument
> > to match open pare
On Tue, 13 Feb 2018 01:16:05 +0530
Himanshu Jha wrote:
> On Mon, Feb 12, 2018 at 05:57:31PM +0300, Dan Carpenter wrote:
> > On Mon, Feb 12, 2018 at 08:05:22PM +0530, Himanshu Jha wrote:
> > > But these should be done when we have *more* instances.
> > >
> > > For eg:
> > > I added a tab space
On Mon, 12 Feb 2018 16:10:01 +0300
Dan Carpenter wrote:
> On Mon, Feb 12, 2018 at 05:24:58PM +0530, Himanshu Jha wrote:
> > Use sign_extend32 function instead of manually coding it. Also, adjust a
> ^
> > switch block to explicitly
On Mon, 12 Feb 2018 17:45:42 +0300
Dan Carpenter wrote:
> On Mon, Feb 12, 2018 at 08:11:57PM +0530, Himanshu Jha wrote:
> > On Mon, Feb 12, 2018 at 04:18:26PM +0300, Dan Carpenter wrote:
> > > I think -M is prefered for these types of diffs? Not sure.
> >
> > I wrote about that in the cover
On Sat, Feb 17, 2018 at 12:58:46PM +0530, Yash Omer wrote:
> This patch fixes up unnecessary parenthesis issue found by checkpatch.pl
>
> Signed-off-by: Yash Omer
> ---
> drivers/staging/ks7010/ks_hostif.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/staging/
On Sat, Feb 17, 2018 at 03:26:45PM +0530, Yash Omer wrote:
> This patch fixes up unncessary parentheses warning found by checkpatch.pl
> script
>
> Signed-off-by: Yash Omer
> ---
> drivers/staging/ks7010/ks_hostif.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/driver
On Fri, Feb 16, 2018 at 02:26:55PM -0800, Quytelda Kahja wrote:
> Fix a coding style warning from checkpatch.pl. Use GNU extensions to create
> references to the results of problem macro arguments when they are evaluated
> so
> that they can be used safely multiple times.
>
> Signed-off-by: Quyt
On Fri, 16 Feb 2018 11:16:58 -0200
Rodrigo Siqueira wrote:
> Hi Daniel
>
> > Hi Rodrigo,
> >
> > I think this is a nice finding. One comment inline:
> >
> > On Vi, 2018-02-16 at 10:50 -0200, rodrigosiqueira wrote:
> > > This patch fixes the checkpatch.pl warning:
> > >
> > > drivers/staging
This patchset has been introduced for the cleanup of
adis16209 driver.
This patchset cleans up miscellaneous code fragments
and improves the code readability.
Shreeya Patel (3):
Staging: iio: adis16209: Use SPDX identifier
Staging: iio: adis16209: Remove unnecessary comments and add suitable
Use SPDX identifier format instead of GPLv2. Also rearrange the
headers in alphabetical order.
Signed-off-by: Shreeya Patel
---
drivers/staging/iio/accel/adis16209.c | 7 +++
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/iio/accel/adis16209.c
b/drivers/stagin
Remove some unnecessary comments and therefore, add _REG suffix
for registers. Group the control register and register field
macros together.
Also, align function arguments to match open parentheses using
tabs.
Signed-off-by: Shreeya Patel
---
drivers/staging/iio/accel/adis16209.c | 209
Use sign_extend32 function instead of manually coding it. Also, adjust a
switch block to explicitly match channels and return -EINVAL as default
case which improves code readability.
Signed-off-by: Shreeya Patel
---
drivers/staging/iio/accel/adis16209.c | 15 ++-
1 file changed, 10 i
On Sat, Feb 17, 2018 at 12:23:53PM +, Jonathan Cameron wrote:
> On Mon, 12 Feb 2018 16:10:01 +0300
> Dan Carpenter wrote:
>
> > On Mon, Feb 12, 2018 at 05:24:58PM +0530, Himanshu Jha wrote:
> > > Use sign_extend32 function instead of manually coding it. Also, adjust a
> >
Check the return value of of the register_lte_tty_driver() call in the
module initialization function.
Signed-off-by: Quytelda Kahja
---
drivers/staging/gdm724x/gdm_mux.c | 6 +-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/gdm724x/gdm_mux.c
b/drivers/staging
17 matches
Mail list logo