Hi there, probably the function name is misleading, but
L3317: kiblnd_destroy_conn(conn, !peer);
This function will NOT free the connection if peer is NULL, and…
L3320:if (!peer)
L3321 continue;
It means the connection is not freed in L3322 and later.
Regards
Liang
On 23
Hi, I just realized the “free_conn” parameter is unused in kernel source, but
it’s actually used in the original patch:
https://review.whamcloud.com/#/c/17892 , so I think it should be fixed in the
kernel.
Regards
Liang
On 23/01/2018, 4:02 PM, "Zhen, Liang" wrote:
Hi there, probably the
On Tue, Jan 23, 2018 at 09:25:41AM +, Zhen, Liang wrote:
> Hi, I just realized the “free_conn” parameter is unused in kernel source, but
> it’s actually used in the original patch:
> https://review.whamcloud.com/#/c/17892 , so I think it should be fixed in
> the kernel.
>
Dmitry already s
Split each of the functions into two for each of send/recv buffers
Signed-off-by: Mohammed Gamal
---
drivers/net/hyperv/netvsc.c | 35 +++
1 file changed, 27 insertions(+), 8 deletions(-)
diff --git a/drivers/net/hyperv/netvsc.c b/drivers/net/hyperv/netvsc.c
inde
Commit 0cf737808ae7 ("hv_netvsc: netvsc_teardown_gpadl() split")
introduced a regression causing VMs not to shutdown on pre-Wind2016
hosts after netvsc_remove_device() is called. This was caused as the
GPADL teardown sequence was changed.
This patch restores the old behavior for pre-Win2016 hosts,
Commit 0cf737808ae7 ("hv_netvsc: netvsc_teardown_gpadl() split") introduced
a regression that caused VMs not to shutdown after netvsc_device_remove() is
called. This is caused by GPADL teardown sequence change, and while that was
necessary to fix issues with Win2016 hosts, it did introduce a regre
From: Colin Ian King
Variable ns is being initialized with a value that is never read, ns
is being re-assigned a new value later on. Remove the redundant
initialization.
Cleans up clang warning:
drivers/staging/comedi/drivers/dt2811.c:310:21: warning: Value stored
to 'ns' during its initializati
On Sat, Jan 20, 2018 at 12:10:55AM +0530, Shreeya Patel wrote:
> Change names of some variables and functions to conform
> to the kernel coding style. The changes include some removal
> of CamelCase warnings and renaming the variable and field names
> that encode their type (eg the pointers seem to
From: Colin Ian King
Structure pwrcfgcmd is being zero'd at initialization however this
value is never read as few statements later in a loop it is being
assigned a new value, hence the initialization is redundant and
can be removed.
Cleans up clang warning:
drivers/staging/rtl8188eu/hal/pwrseqc
Vitaly Kuznetsov writes:
> "Michael Kelley (EOSG)" writes:
>
>> On Fri, 19 Jan 2018, Thomas Gleixner wrote:
>>
>>>
>>> You added '#include ' to mshyperv.h which is included in
>>> vclock_gettime.c and pulls in other stuff which fails to expand
>>
>> Is the declaration of hyperv_reenlightenm
Vitaly Kuznetsov writes:
>
> > "Michael Kelley (EOSG)" writes:
> >
> >> On Fri, 19 Jan 2018, Thomas Gleixner wrote:
> >>
> >>>
> >>> You added '#include ' to mshyperv.h which is included
> >>> in
> >>> vclock_gettime.c and pulls in other stuff which fails to expand
> >>
> >> Is the declarat
"Michael Kelley (EOSG)" writes:
> Vitaly Kuznetsov writes:
>>
>> > "Michael Kelley (EOSG)" writes:
>> >
>> >> On Fri, 19 Jan 2018, Thomas Gleixner wrote:
>> >>
>> >>>
>> >>> You added '#include ' to mshyperv.h which is included
>> >>> in
>> >>> vclock_gettime.c and pulls in other stuff which
Since nothing builds/depends on RTLHALMAC_ST and RTLPHYDM_ST, we could
remove them.
Furthermore, they are totally undocumented
Signed-off-by: Corentin Labbe
---
drivers/staging/rtlwifi/Kconfig | 10 --
1 file changed, 10 deletions(-)
diff --git a/drivers/staging/rtlwifi/Kconfig b/driver
Nothing in kernel use VIDEO_ATOMISP_OV8858 since commit 3a81c7660f80 ("media:
staging: atomisp: Remove IMX sensor support")
Lets remove this kconfig option.
Signed-off-by: Corentin Labbe
---
drivers/staging/media/atomisp/i2c/Kconfig | 12
1 file changed, 12 deletions(-)
diff --git
Since nothing builds/depends on FB_TFT_SSD1325, we could remove it.
Signed-off-by: Corentin Labbe
---
drivers/staging/fbtft/Kconfig | 6 --
1 file changed, 6 deletions(-)
diff --git a/drivers/staging/fbtft/Kconfig b/drivers/staging/fbtft/Kconfig
index dba676761d72..84b2e7ebc024 100644
--- a
> -Original Message-
> From: Mohammed Gamal [mailto:mga...@redhat.com]
> Sent: Tuesday, January 23, 2018 4:34 AM
> To: net...@vger.kernel.org
> Cc: linux-ker...@vger.kernel.org; de...@linuxdriverproject.org; KY
> Srinivasan ; Haiyang Zhang ;
> Stephen Hemminger ; vkuzn...@redhat.com;
> ca
On Tue, 23 Jan 2018 10:34:03 +0100
Mohammed Gamal wrote:
> Commit 0cf737808ae7 ("hv_netvsc: netvsc_teardown_gpadl() split") introduced
> a regression that caused VMs not to shutdown after netvsc_device_remove() is
> called. This is caused by GPADL teardown sequence change, and while that was
> n
On Tue, Jan 23, 2018 at 4:37 PM, Corentin Labbe wrote:
> Nothing in kernel use VIDEO_ATOMISP_OV8858 since commit 3a81c7660f80 ("media:
> staging: atomisp: Remove IMX sensor support")
> Lets remove this kconfig option.
First of all, I hardly understand how that change is related.
Second, did you
On Tue, Jan 23, 2018 at 07:31:27PM +0200, Andy Shevchenko wrote:
> On Tue, Jan 23, 2018 at 4:37 PM, Corentin Labbe wrote:
> > Nothing in kernel use VIDEO_ATOMISP_OV8858 since commit 3a81c7660f80
> > ("media: staging: atomisp: Remove IMX sensor support")
> > Lets remove this kconfig option.
>
> F
Assign true or false to boolean variables instead of an integer value.
This issue was detected with the help of Coccinelle.
Signed-off-by: Gustavo A. R. Silva
---
drivers/android/binder.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/android/binder.c b/driver
On Tue, Jan 23 2018, Dan Carpenter wrote:
> On Tue, Jan 23, 2018 at 09:25:41AM +, Zhen, Liang wrote:
>> Hi, I just realized the “free_conn” parameter is unused in kernel source,
>> but it’s actually used in the original patch:
>> https://review.whamcloud.com/#/c/17892 , so I think it should
This patchset removes some warnings generated by checkpatch
for cleanup of the rtl8723bs driver. Also some additional
cleanups are introduced in the *[1/4] and *[3/4] patches
to make the code according to the kernel coding style.
Changes in v2
-Rebase and resend all patches.
Changes in v3
-Ed
Replace true and false keywords with "x" and "!x"
respectively to follow the kernel coding style.
Signed-off-by: Shreeya Patel
---
drivers/staging/rtl8723bs/hal/sdio_ops.c | 30 ++
1 file changed, 14 insertions(+), 16 deletions(-)
diff --git a/drivers/staging/rtl8723
Change names of some variables and functions to conform
to the kernel coding style. The changes include some removal
of CamelCase warnings and renaming the variable and field names
that encode their type (eg the pointers seem to start with p).
Signed-off-by: Shreeya Patel
---
Changes in v3
-Ed
"oldmem==NULL;"
The above bug under the ifdef code would have caused a GCC
warning if it were ever compiled. Hence, remove the dead ifdefed
code from the file.
Signed-off-by: Shreeya Patel
---
Changes in v3
-Remove dead code.
drivers/staging/rtl8723bs/hal/sdio_ops.c | 15 ---
1 f
If "x" is compared to NULL, use "!x" instead of it, so as
to follow the kernel coding style.
Signed-off-by: Shreeya Patel
---
drivers/staging/rtl8723bs/hal/sdio_ops.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/rtl8723bs/hal/sdio_ops.c
b/
Fix inconsistent IS_ERR and PTR_ERR in vdic_get_ipu_resources.
The proper pointer to be passed as argument is ch.
This issue was detected with the help of Coccinelle.
Fixes: 0b2e9e7947e7 ("media: staging/imx: remove confusing IS_ERR_OR_NULL
usage")
Signed-off-by: Gustavo A. R. Silva
---
driver
From: Tianyu Lan
The "next" variable is redundant in hv_get_next_write_location().
This patch is to remove it and return write_index directly.
Signed-off-by: Tianyu Lan
---
drivers/hv/ring_buffer.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/hv/ring_buffer.c
28 matches
Mail list logo