Signed-off-by: Luis Gerhorst
Acked-by: Jonny Schaefer
Acked-by: Alexander Wuerstlein
---
drivers/staging/fbtft/fbtft-core.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/fbtft/fbtft-core.c
b/drivers/staging/fbtft/fbtft-core.c
index 34b1c81..566f89c 100
The Linux kernel coding style states that braces should only be used
when necessary.
This fixes the checkpatch warning
WARNING: line over 80 characters
+ } else if (display->regwidth == 8 && display->buswidth == 9 &&
par->spi) {
introduced by patch #1.
Signed-off-by: Luis Gerhorst
Acked
This removes the following warning issued by checkpatch
WARNING: suspect code indent for conditional statements (8, 8)
+ } else
+ if (display->regwidth == 8 && display->buswidth == 9 && par->spi) {
Signed-off-by: Luis Gerhorst
Acked-by: Jonny Schaefer
Acked-by: Alexander Wuerstlein
Good day
This is to inform you after much deliberation on your countless efforts to get
your payment without success and with regard to your dealings with impostors. I
wish to inform you that a resolution has been reached by members of the payment
committee to get your funds cleared and deliv
The usage of strchr requires inclusion of string.h.
Fixes: 0c38cda64aec ("tools: hv: remove unnecessary header files and netlink
related code")
Signed-off-by: Olaf Hering
---
tools/hv/hv_fcopy_daemon.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/tools/hv/hv_fcopy_daemon.c b/tools/hv/hv_
On Mon, 8 Jan 2018 01:30:29 +0200
Andy Shevchenko wrote:
> On Sat, Jan 6, 2018 at 2:42 PM, Jonathan Cameron wrote:
> > On Thu, 4 Jan 2018 22:06:31 +0530
>
> >> /* Setup Register Bit Designations (AD7152_REG_CHx_SETUP) */
> >> -#define AD7152_SETUP_CAPDIFF (1 << 5)
> >> +#define AD71
On Sun, Jan 07, 2018 at 03:08:01PM +, George Edward Bulmer wrote:
> This fixes three instances of checkpatch warning:
> WARNING: line over 80 characters
>
> Signed-off-by: George Edward Bulmer
> ---
> drivers/staging/iio/light/tsl2x7x.c | 9 ++---
> 1 file changed, 6 insertions(+), 3 del
On Sun, Jan 07, 2018 at 05:17:42PM +, Jonathan Cameron wrote:
> On Sun, 07 Jan 2018 08:42:27 -0800
> Joe Perches wrote:
>
> > On Sun, 2018-01-07 at 16:28 +, Jonathan Cameron wrote:
> > > On Sun, 7 Jan 2018 15:08:01 +
> > > George Edward Bulmer wrote:
> > >
> > > > This fixes thre
On Mon, Jan 08, 2018 at 11:28:13AM +0530, Sumit Pundir wrote:
> Fixes the following coding style issue as noted by checkpatch.pl
> at multiple lines:
>
> Comparison to NULL could be written "!token"
>
> Signed-off-by: Sumit Pundir
Since you're not really fixing anything here, besides silencing
On Thu, Dec 21, 2017 at 04:43:27PM +0100, Christoph Volkert wrote:
> This is a duplicate patch. We fixed a typo and this was still left as a
> temporary file. (emacs…) Sorry. The patch with Message-Id
> <1513869932-27407-3-git-send-email-fabian_hue...@web.de> is the right one.
>
> We can provide a
On Mon, Jan 08, 2018 at 11:07:41AM +0100, Luis Gerhorst wrote:
> Signed-off-by: Luis Gerhorst
> Acked-by: Jonny Schaefer
> Acked-by: Alexander Wuerstlein
> ---
> drivers/staging/fbtft/fbtft-core.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
I can't take a patch without any chan
On Mon, Jan 08, 2018 at 11:06:37AM +0100, Luis Gerhorst wrote:
> The Linux kernel coding style states that braces should only be used
> when necessary.
>
> This fixes the checkpatch warning
>
> WARNING: line over 80 characters
> + } else if (display->regwidth == 8 && display->buswidth == 9 &&
On Thu, Dec 28, 2017 at 12:24:17PM +0200, Elad Wexler wrote:
> Fixed a coding style issue
>
> Signed-off-by: Elad Wexler
> ---
> drivers/staging/ccree/ssi_hash.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
Why did you send this twice?
> diff --git a/drivers/staging/ccree/ssi_ha
On Mon, 2018-01-08 at 15:02 +0300, Dan Carpenter wrote:
> On Sun, Jan 07, 2018 at 05:17:42PM +, Jonathan Cameron wrote:
> > On Sun, 07 Jan 2018 08:42:27 -0800
> > Joe Perches wrote:
> >
> > > On Sun, 2018-01-07 at 16:28 +, Jonathan Cameron wrote:
> > > > On Sun, 7 Jan 2018 15:08:01 +
On Sun, Jan 07, 2018 at 12:14:35PM +, Gilad Ben-Yossef wrote:
> The ccree driver source files were using an inconsistent
> naming convention stemming from what the company was called
> when they were added.
>
> Move to a single consistent naming convention for better
> code readability.
>
> S
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git
staging-testing
head: 1dbf40a0663ec52c0f718d5805b134933cc60372
commit: c64cea1d7df653e2f3f111f81b68f507adb61cc4 [346/364] staging: lustre:
discard cfs_time_seconds()
config: ia64-allmodconfig (attached as .config)
compil
On Sun, Dec 24, 2017 at 04:38:02AM +0100, Michael Panzlaff wrote:
> To be applied on:
> git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git
> Branch:
> staging-next
That's not needed to be in the changelog text.
I'll hand-edit it for now, but please don't include it in future
patches.
On Sun, Dec 24, 2017 at 04:38:02AM +0100, Michael Panzlaff wrote:
> This patch changes the indentation of the statements after case labels.
> The linux coding guidelines do not explicitly mentiond this but pretty
> much all existing code doesn't put any statements into the same line of
> their belo
On Fri, Dec 29, 2017 at 12:06:49AM +0100, Philippe Loctaux wrote:
> Fixed a coding style issue.
>
> Signed-off-by: Philippe Loctaux
> ---
> drivers/staging/most/aim-sound/sound.c | 12 ++--
> 1 file changed, 6 insertions(+), 6 deletions(-)
This file is not in my tree anymore, please alw
On Fri, Dec 29, 2017 at 12:06:50AM +0100, Philippe Loctaux wrote:
> Removed unnecessary parentheses in a if statement.
>
> Signed-off-by: Philippe Loctaux
> ---
> drivers/staging/most/aim-sound/sound.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
Also not in my tree anymore :(
__
On Thu, Dec 28, 2017 at 11:15:30PM +0100, Philippe Loctaux wrote:
> Removed unnecessary parentheses in the if statement.
>
> Signed-off-by: Philippe Loctaux
> ---
> drivers/staging/vme/devices/vme_user.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/staging/vm
On Fri, Dec 22, 2017 at 07:53:52PM +0530, Sumit Pundir wrote:
> This patch fixes a coding style issue as noted by
> checkpatch.pl related to unnecessary parentheses.
>
> This patch fixes the following checkpatch.pl warning:
>
> WARNING: Unnecessary parentheses around 'priv->basic_rates'.
>
> Sig
On Mon, Dec 25, 2017 at 11:05:34AM +0530, Sumit Pundir wrote:
> This patch fixes a few coding style issues as noted by checkpatch.pl
> related to unnecessary parantheses.
>
> This patch fixes the following checkpatch.pl warnings:
>
> WARNING: Unnecessary parentheses around 'priv->eeprom[EEP_OFS_M
> -Original Message-
> From: SF Markus Elfring [mailto:elfr...@users.sourceforge.net]
> Sent: Sunday, January 7, 2018 3:10 PM
> To: de...@linuxdriverproject.org; net...@vger.kernel.org; Haiyang Zhang
> ; KY Srinivasan ; Stephen
> Hemminger
> Cc: LKML ; kernel-janit...@vger.kernel.org
> S
On Mon, Jan 8, 2018 at 8:15 PM, Johan Hovold wrote:
> Since you're not really fixing anything here, besides silencing a
> checkpatch suggestion when run with the --strict option (or on staging
> code), I suggest you reword you commit summary (Subject) to, for
> example:
>
> staging: greyb
Fixed coding style issue regarding null comparison at multiple lines.
Issue reported by checkpatch.pl
Signed-off-by: Sumit Pundir
---
v2:
Updated the patch title and description.
drivers/staging/greybus/camera.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git
Fixes checkpatch warnings:
CHECK: Prefer using the BIT macro
Signed-off-by: Valentin Vidic
---
drivers/staging/pi433/pi433_if.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/pi433/pi433_if.c b/drivers/staging/pi433/pi433_if.c
index 960249c600a5..f56425ffb
Fixes checkpatch warnings:
CHECK: Unnecessary parentheses around 'mantisse != mantisse16'
CHECK: Unnecessary parentheses around 'mantisse != mantisse20'
CHECK: Unnecessary parentheses around 'mantisse != mantisse24'
Signed-off-by: Valentin Vidic
---
drivers/staging/pi433/rf69.c | 6 +++---
Fixes checkpatch warnings:
CHECK: Alignment should match open parenthesis
---
drivers/staging/pi433/pi433_if.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/pi433/pi433_if.c b/drivers/staging/pi433/pi433_if.c
index f56425ffbe90..edcd7e798f99 1006
On 01/08/2018 10:50 AM, Sumit Pundir wrote:
> Fixed coding style issue regarding null comparison at multiple lines.
> Issue reported by checkpatch.pl
>
> Signed-off-by: Sumit Pundir
Looks good. The subject should say "staging" rather than "Staging"
but that's probably not a big deal.
Reviewed
> These messages are not displayed anywhere else:
> "unable to allocate receive buffer of size %u\n"
> "unable to allocate send buffer of size %u\n",
>
> After set ret = -ENOMEM; and cleanup, we won't know which buffer allocation
> failed without the error message.
Do you notice a Linux allocati
On Mon, 2018-01-08 at 18:03 +0300, Dan Carpenter wrote:
> On Mon, Jan 08, 2018 at 11:06:37AM +0100, Luis Gerhorst wrote:
> > The Linux kernel coding style states that braces should only be used
> > when necessary.
> >
> > This fixes the checkpatch warning
> >
> > WARNING: line over 80 characters
On Mon, Jan 08, 2018 at 10:27:01AM -0800, Joe Perches wrote:
> On Mon, 2018-01-08 at 18:03 +0300, Dan Carpenter wrote:
> > On Mon, Jan 08, 2018 at 11:06:37AM +0100, Luis Gerhorst wrote:
> > > The Linux kernel coding style states that braces should only be used
> > > when necessary.
> > >
> > > Thi
On Mon, 2018-01-08 at 22:26 +0300, Dan Carpenter wrote:
> On Mon, Jan 08, 2018 at 10:27:01AM -0800, Joe Perches wrote:
> > On Mon, 2018-01-08 at 18:03 +0300, Dan Carpenter wrote:
> > > On Mon, Jan 08, 2018 at 11:06:37AM +0100, Luis Gerhorst wrote:
> > > > The Linux kernel coding style states that b
> There are counterexamples in the subsystem.
Staging is essentially one giant counter example.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
This issue is introduced by the commit ("ION: Sys_heap:
Add cached pool to spead up cached buffer alloc"), the gfp_mask low
order pool is overlapped by the high order inside the loop, so the
gfp_mask of all pools are set to high_order_gfp_flags.
Signed-off-by: Zeng Tao
---
drivers/staging/andro
On 2018/1/9 18:43, Zeng Tao wrote:
> This issue is introduced by the commit ("ION: Sys_heap:
> Add cached pool to spead up cached buffer alloc"), the gfp_mask low
> order pool is overlapped by the high order inside the loop, so the
> gfp_mask of all pools are set to high_order_gfp_flags.
>
Tha
On Mon, Jan 8, 2018 at 5:28 PM, Greg Kroah-Hartman
wrote:
> On Sun, Jan 07, 2018 at 12:14:35PM +, Gilad Ben-Yossef wrote:
>> The ccree driver source files were using an inconsistent
>> naming convention stemming from what the company was called
>> when they were added.
>>
>> Move to a single c
38 matches
Mail list logo