On Tue, Dec 05, 2017 at 12:50:25AM +, Dilger, Andreas wrote:
> On Dec 4, 2017, at 11:42, Aliaksei Karaliou wrote:
> >
> > On 12/04/2017 11:40 AM, Dan Carpenter wrote:
> >> On Sun, Dec 03, 2017 at 07:59:07PM +0300, ak wrote:
> >>> Thank you for your extensive comments.
> >>>
> >>> I've also t
Signed-off-by: Martijn Coenen
---
MAINTAINERS | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/MAINTAINERS b/MAINTAINERS
index aa71ab52fd76..da8264fc09d4 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -859,7 +859,8 @@ F: kernel/configs/android*
ANDROID DRIVERS
M: Greg K
Add Todd Kjos and myself, remove Riley (who no
longer works at Google).
Signed-off-by: Martijn Coenen
---
Changes in v2: adds commit message.
MAINTAINERS | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/MAINTAINERS b/MAINTAINERS
index aa71ab52fd76..da8264fc09d4 100644
--- a
Am 04.12.2017 um 21:05 schrieb Simon Sandström:
> On Mon, Dec 04, 2017 at 09:59:02PM +0200, Marcus Wolf wrote:
>>
>> Hi Simon, hi Dan,
>>
>> if you both are of the same opinion, for me, it's fine, if we go with two
>> functions.
>>
>> But I don't get the advantage, if we split approx. 10 function
On Mon, Dec 04, 2017 at 09:59:02PM +0200, Marcus Wolf wrote:
> Keep in mind, that if you split the functions, in the interface
> implementation you also need more code:
>
> SET_CHECKED(rf69_set_sync_enable(dev->spi, rx_cfg->enable_sync));
>
> will have to be converted in something like
>
> if (r
Hi Hans,
On 04.12.2017 17:04, Hans Verkuil wrote:
> Hi Dmitry,
>
> As you already mention in the TODO, this should become a v4l2 codec driver.
>
> Good existing examples are the coda, qcom/venus and mtk-vcodec drivers.
>
> One thing that is not clear from this code is if the tegra hardware is a
Am 05.12.2017 um 13:16 schrieb Dan Carpenter:
> On Mon, Dec 04, 2017 at 09:59:02PM +0200, Marcus Wolf wrote:
>> Keep in mind, that if you split the functions, in the interface
>> implementation you also need more code:
>>
>> SET_CHECKED(rf69_set_sync_enable(dev->spi, rx_cfg->enable_sync));
>>
>>
On Tue, Dec 05, 2017 at 01:40:02PM +0100, Marcus Wolf wrote:
> > It's not the greatest, but it's not the worst... The configuration for
> > ->enable_sync is a bit spread out and it might be nice to move it all to
> > one function?
> >
> > I liked Simon's naming scheme and I thought it was clear w
On 12/05/17 13:17, Dmitry Osipenko wrote:
> Hi Hans,
>
> On 04.12.2017 17:04, Hans Verkuil wrote:
>> Hi Dmitry,
>>
>> As you already mention in the TODO, this should become a v4l2 codec driver.
>>
>> Good existing examples are the coda, qcom/venus and mtk-vcodec drivers.
>>
>> One thing that is no
On Mon, Dec 04, 2017 at 10:58:23PM +0300, Dan Carpenter wrote:
> On Wed, Nov 29, 2017 at 07:46:21PM +0300, Roman Storozhenko wrote:
> > There are two reasons for that:
>
> What I'm asking is there are two reasons for what? Where is the first
> part of that paragraph?
Hello, Dan!
Now I understan
The return value isn't initialized on some success paths.
Fixes: c5f39d07860c ("staging: ccree: fix leak of import() after init()")
Signed-off-by: Dan Carpenter
diff --git a/drivers/staging/ccree/ssi_hash.c b/drivers/staging/ccree/ssi_hash.c
index a2e8a9d32e00..3855c42e61af 100644
--- a/drivers/
The following changes since commit 4fbd8d194f06c8a3fd2af1ce560ddb31f7ec8323:
Linux 4.15-rc1 (2017-11-26 16:01:47 -0800)
are available in the Git repository at:
git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git/
tags/staging-4.15-rc3
for you to fetch changes up to e168e9845d9
This patch fixes the following checkpatch.pl error:
WARNING: line over 80 characters
SET_CHECKED(rf69_set_fifo_fill_condition(dev->spi, afterSyncInterrupt));
ERROR: that open brace { should be on the previous line
+ else
+ {
ERROR: else should follow close brace '}'
+ }
+
This patch fixes the following checkpatch.pl error:
ERROR: spaces required around that '+=' (ctx:WxV) +
position +=temp;
^
Signed-off-by: Oliver Graute
---
drivers/staging/pi433/pi433_if.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/driv
This patch fixes the following checkpatch.pl errors:
ERROR: that open brace { should be on the previous line
#344: FILE: pi433_if.c:344:
+ if(retval) /* wait was interrupted */
+ {
ERROR: space required before the open parenthesis '('
#344: FILE: pi433_if.c:344:
+ if(retval) /*
Renames enum modShaping and its values to get rid of checkpatch.pl
warnings: "Avoid CamelCase: ".
Signed-off-by: Simon Sandström
---
drivers/staging/pi433/pi433_if.c | 2 +-
drivers/staging/pi433/pi433_if.h | 2 +-
drivers/staging/pi433/rf69.c | 21 +++--
drivers/staging
Basically just 's//\t/', to fix checkpatch.pl warnings:
"please, no spaces at the start of a line".
Signed-off-by: Simon Sandström
---
drivers/staging/pi433/rf69_enum.h | 207 +++---
1 file changed, 103 insertions(+), 104 deletions(-)
diff --git a/drivers/sta
Fixes checkpatch.pl warnings "Avoid CamelCase ".
Signed-off-by: Simon Sandström
---
drivers/staging/pi433/pi433_if.c | 32 -
drivers/staging/pi433/rf69_registers.h | 44 +-
2 files changed, 38 insertions(+), 38 deletions(-)
diff --gi
Renames the enum optionOnOff and its values optionOn, optionOff to enum
option_on_off and OPTION_ON, OPTION_OFF. Fixes checkpatch.pl warnings:
"Avoid CamelCase: , , ".
Signed-off-by: Simon Sandström
---
drivers/staging/pi433/pi433_if.c | 34 ++---
drivers/staging/pi433/p
These patches fixes a bunch of code style issues in staging/pi433. The first
patch fixes indentation in rf69_enum.h and the rest of the patches fixes
CamelCase issues and other minor issues in all of staging/pi433.
Changes in v2:
- Instead of fixing CamelCase issue in enum data_mode, remov
Call rf69_set_data_mode with DATAMODUL_MODE value directly.
Signed-off-by: Simon Sandström
---
drivers/staging/pi433/pi433_if.c | 2 +-
drivers/staging/pi433/rf69.c | 15 ++-
drivers/staging/pi433/rf69.h | 2 +-
drivers/staging/pi433/rf69_enum.h | 6 --
4 files chan
SET_CHECKED returns from the function on failure and in pi433_probe it is
necessary to free the GPIOs and the device on failure.
Signed-off-by: Simon Sandström
---
drivers/staging/pi433/pi433_if.c | 28 +---
1 file changed, 21 insertions(+), 7 deletions(-)
diff --git a/d
Splits rf69_set_crc_enabled(dev, enabled) into
rf69_enable_crc(dev) and rf69_disable_crc(dev).
Signed-off-by: Simon Sandström
---
drivers/staging/pi433/pi433_if.c | 22 --
drivers/staging/pi433/rf69.c | 18 ++
drivers/staging/pi433/rf69.h | 4 ++--
3
The enum is now only used for ioctl, so move it pi433_if.h.
Signed-off-by: Simon Sandström
---
drivers/staging/pi433/pi433_if.h | 5 +
drivers/staging/pi433/rf69_enum.h | 5 -
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/pi433/pi433_if.h b/drivers/stagi
Splits rf69_set_sync_enabled(dev, enabled) into
rf69_enable_sync(dev) and rf69_disable_sync(dev).
Signed-off-by: Simon Sandström
---
drivers/staging/pi433/pi433_if.c | 21 +++--
drivers/staging/pi433/rf69.c | 18 ++
drivers/staging/pi433/rf69.h | 4 ++--
Renames variable thresholdDecrement in struct pi433_rx_cfg to
threshold_decrement to get rid of checkpatch.pl warning
"Avoid CamelCase: ".
Signed-off-by: Simon Sandström
---
drivers/staging/pi433/pi433_if.c | 2 +-
drivers/staging/pi433/pi433_if.h | 2 +-
2 files changed, 2 insertions(+), 2 dele
Replaces the functions rf69_set_amplifier_1, _2, _3 with two
functions: rf69_enable_amplifier(dev, amp_mask) and
rf69_disable_amplifier(dev, amp_mask).
Signed-off-by: Simon Sandström
---
drivers/staging/pi433/pi433_if.c | 6 +++---
drivers/staging/pi433/rf69.c | 46 -
On 12/02/2017 07:53 AM, Greg KH wrote:
This is one of the item in the TODO list before been able to unstage ION
which is my real need.
Why does it matter where in the tree this code is? Don't go adding new
things to it that are not needed. Who needs this? What userspace code
wants this type o
This was found using checkpatch.pl's SPLIT_STRING warning. While joining
these strings makes for long lines, the kernel codebase consistently
does it this way to make user-visible strings easier to grep for.
Signed-off-by: Genki Sky
---
drivers/staging/vc04_services/bcm2835-camera/bcm2835-camera
This was found using checkpatch.pl's EMBEDDED_FUNCTION_NAME warning.
It is easier to be consistent and always use __func__ instead of having
to remember to update any hardcoded references to the original name.
Signed-off-by: Genki Sky
---
drivers/staging/vc04_services/bcm2835-camera/mmal-vchiq.c
Hi,
This is v3 of a patch series to fix some checkpatch.pl warnings in
drivers/staging/vc04_services/bcm2835-camera/*
Changes from v2 [2]:
- Provide more detailed description in commit messages
Changes from v1 [1]:
- Split single patch into multiple patches
- Remove reference to eudyptula in com
This was found using checkpatch.pl's MULTILINE_DEREFERENCE warning.
Putting the dereference onto one line makes them easier to read,
especially when part of a larger expression (in this case, function
arguments and ternary operator), and when the dereferences are short
(as they are here).
Signed-o
On Tue, Dec 05, 2017 at 03:01:42PM -0800, Laura Abbott wrote:
> On 12/02/2017 07:53 AM, Greg KH wrote:
> > > This is one of the item in the TODO list before been able to unstage ION
> > > which is my real need.
> > Why does it matter where in the tree this code is? Don't go adding new
> > things t
Added spaces around '+'. Warning found using checkpatch.pl
---
drivers/staging/rtl8192u/ieee80211/dot11d.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/dot11d.c
b/drivers/staging/rtl8192u/ieee80211/dot11d.c
index 64b13a5..ba284bf 100644
--
On Wed, Dec 06, 2017 at 12:35:29PM +0530, Akash Kumar wrote:
> Added spaces around '+'. Warning found using checkpatch.pl
> ---
> drivers/staging/rtl8192u/ieee80211/dot11d.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/staging/rtl8192u/ieee80211/dot11d.c
> b/d
35 matches
Mail list logo