From: Colin Ian King
Pointer cc_base is being assigned but is never read, hence it is
redundant and can be removed. Cleans up clang warning:
drivers/staging/ccree/ssi_driver.c:235:2: warning: Value stored to
'cc_base' is never read
Signed-off-by: Colin Ian King
---
drivers/staging/ccree/ssi_d
crypto_ahash_import() may be called either after
crypto_ahash_init() or without such call. Right now
we always internally call init() as part of
import(), thus leaking memory and mappings if the
user has already called init() herself.
Fix this by only calling init() internally if the
state is not
The driver was using a function naming scheme
including common prefixes for driver global
functions based on the code module they came from.
The combination of long names with long common
prefixes made the whole thing too long for a human
to parse.
Switch to simple and shorter function naming
sch
Fold common code copying MAC to/from a temp. buffer
into an inline function instead of keeping multiple
open coded versions of same.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_buffer_mgr.c | 89 ++
1 file changed, 37 insertions(+), 52 deletions(
Make the code more readable by using a local variable
for commonly use expression in the AEAD part of the driver.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_aead.c | 10 --
1 file changed, 4 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/ccree/ssi_aead.c b
Remove unneeded cast of the return value of dev_get_drvdata()
to struct ssi_drvdata * for better readability.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_pm.c | 12
1 file changed, 4 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/ccree/ssi_pm.c b/drive
This is another batch of ccree fixes & cleanups.
The first patch is a bug fix. All others are pure
readability and coding style fixes.
Changes from v1:
- Fix several coding style issues pointed out by
Dan Carpenter.
- Added two more patches of similar issues that
surfaced during the review.
Remove a common parameter named cc_base with the pointer
to the mapped command registers which was used by the
old register access macros that are not longer in use.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_aead.c| 2 +-
drivers/staging/ccree/ssi_cipher.c | 12
Make the code more readable by using a local variables
for commonly use expressions in the buffer manager part
of the driver.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_buffer_mgr.c | 18 ++
1 file changed, 10 insertions(+), 8 deletions(-)
diff --git a/drivers
Remove necessary braces for single statement blocks to
improve code readabilty.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_buffer_mgr.c | 6 ++
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/ccree/ssi_buffer_mgr.c
b/drivers/staging/ccree/ssi
Make the code more readable by using a local variable.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_pm.c | 12
1 file changed, 8 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/ccree/ssi_pm.c b/drivers/staging/ccree/ssi_pm.c
index e1bc4c5..d60143c 100644
The driver was full of code checking "if (x != 0)".
Replace by "if (x)" for better readability.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_aead.c| 28 +--
drivers/staging/ccree/ssi_buffer_mgr.c | 74 ++---
drivers/staging/ccree/ssi_ciph
Hi Colin,
Thank you very much for your patch.
On Thu, Nov 9, 2017 at 10:13 AM, Colin King wrote:
> From: Colin Ian King
>
> Pointer cc_base is being assigned but is never read, hence it is
> redundant and can be removed. Cleans up clang warning:
>
> drivers/staging/ccree/ssi_driver.c:235:2: war
On Nov 3, 2017, at 06:36, Roman Storozhenko wrote:
>
> On Fri, Nov 03, 2017 at 12:46:18PM +0100, Greg Kroah-Hartman wrote:
>> On Sun, Oct 29, 2017 at 08:58:39PM +0300, Roman Storozhenko wrote:
>>> There are two reasons for that:
>>> 1) As Linus Torvalds said we should use kernel types:
>>> http:/
On Thu, Nov 9, 2017 at 1:06 PM, Dilger, Andreas
wrote:
> On Nov 3, 2017, at 06:36, Roman Storozhenko wrote:
>>
>> On Fri, Nov 03, 2017 at 12:46:18PM +0100, Greg Kroah-Hartman wrote:
>>> On Sun, Oct 29, 2017 at 08:58:39PM +0300, Roman Storozhenko wrote:
There are two reasons for that:
1)
On Thu, Nov 09, 2017 at 08:27:28AM +0200, Gilad Ben-Yossef wrote:
> On Tue, Nov 7, 2017 at 12:43 PM, Dan Carpenter
> wrote:
> > On Tue, Nov 07, 2017 at 09:40:02AM +, Gilad Ben-Yossef wrote:
> >> --- a/drivers/staging/ccree/ssi_pm.c
> >> +++ b/drivers/staging/ccree/ssi_pm.c
> >> @@ -90,20 +90,
Reviewed-by: Dan Carpenter
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
Instead of x86_hyper being either NULL on bare metal or a pointer to a
struct hypervisor_x86 in case of the kernel running as a guest merge
the struct into x86_platform and x86_init.
This will remove the need for wrappers making it hard to find out what
is being called. With dummy functions added
Booting a Xen PVH guest requires a special boot entry as it is
mandatory to setup some Xen-specific interfaces rather early. When grub
or OVMF are used as boot loaders, however, those will fill the boot
parameters in zeropage and there is no longer a need to do something
PVH specific in the early b
The x86_hyper pointer is only used for checking whether a virtual
device is supporting the hypervisor the system is running on.
Use an enum for that purpose instead and drop the x86_hyper pointer.
Cc: k...@microsoft.com
Cc: haiya...@microsoft.com
Cc: sthem...@microsoft.com
Cc: akata...@vmware.com
From: Colin Ian King
The PI433_IOC_WR_RX_CFG case is missing a break and will fall through
to the default case and errorenously return -EINVAL. Fix this by
adding in missing break.
Detected by CoverityScan, CID#1461286 ("Missing break in switch")
Fixes: f81f0b5c9a30 ("pi433: sanitize ioctl")
Si
Hello Juergen,
The changes to vmw_balloon.c looks good.
Acked-by: Xavier Deguillard
Xavier
On Thu, Nov 09, 2017 at 02:27:36PM +0100, Juergen Gross wrote:
> The x86_hyper pointer is only used for checking whether a virtual
> device is supporting the hypervisor the system is running on.
>
> Use
On Tue, 7 Nov 2017 21:07:50 +0100
Greg Kroah-Hartman wrote:
> It's good to have SPDX identifiers in all files to make it easier to
> audit the kernel tree for correct licenses.
>
> Update the wilc100 driver files with the correct SPDX license identifier
> based on the license text in the file it
I need to send v3. With this v2 set, there is a small bug in the RX
initialization that causes failure on little-endian kernels.
David.
On 11/08/2017 04:51 PM, David Daney wrote:
We are adding the Cavium OCTEON-III network driver. But since
interacting with the input and output queues is do
From: Carlos Munoz
Add bindings for Common Ethernet Interface (BGX) block.
Signed-off-by: Carlos Munoz
Signed-off-by: Steven J. Hill
Signed-off-by: David Daney
---
.../devicetree/bindings/net/cavium-bgx.txt | 61 ++
1 file changed, 61 insertions(+)
create mode 10
We are adding the Cavium OCTEON-III network driver. But since
interacting with the input and output queues is done via special CPU
local memory, we also need to add support to the MIPS/Octeon
architecture code. Aren't SoCs nice in this way?
The first six patches add the SoC support needed by the
From: Carlos Munoz
LMTDMA/LMTST operations move data between cores and I/O devices:
* LMTST operations can send an address and a variable length
(up to 128 bytes) of data to an I/O device.
* LMTDMA operations can send an address and a variable length
(up to 128) of data to the I/O device and
From: Carlos Munoz
Add a global resource manager to manage tagged pointers within
bootmem allocated memory. This is used by various functional
blocks in the Octeon core like the FPA, Ethernet nexus, etc.
Signed-off-by: Carlos Munoz
Signed-off-by: Steven J. Hill
Signed-off-by: David Daney
---
From: Carlos Munoz
>From the hardware user manual: "The FPA is a unit that maintains
pools of pointers to free L2/DRAM memory. To provide QoS, the pools
are referenced indirectly through 1024 auras. Both core software
and hardware units allocate and free pointers."
Signed-off-by: Carlos Munoz
S
Signed-off-by: David Daney
---
MAINTAINERS | 6 ++
1 file changed, 6 insertions(+)
diff --git a/MAINTAINERS b/MAINTAINERS
index 9a24f56e0451..142af33adc35 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -3212,6 +3212,12 @@ W: http://www.cavium.com
S: Supported
F: drivers/mmc/ho
Previous patch sets USE_ASYNC_IOBDMA to 1 unconditionally. Remove
USE_ASYNC_IOBDMA from all if statements. Remove dead code caused by
the change.
Signed-off-by: David Daney
---
drivers/staging/octeon/ethernet-defines.h | 6 ---
drivers/staging/octeon/ethernet-rx.c | 25 -
drivers
Remove CONFIG_CAVIUM_OCTEON_CVMSEG_SIZE and automatically calculate
the amount of CVMSEG space needed.
1st 128-bytes: Use by IOBDMA
2nd 128-bytes: Reserved by kernel for scratch/TLS emulation.
3rd 128-bytes: OCTEON-III LMTLINE
New config variable CONFIG_CAVIUM_OCTEON_EXTRA_CVMSEG provisions
addit
On Thu, Nov 09, 2017 at 05:19:55PM +, Colin King wrote:
> From: Colin Ian King
>
> The PI433_IOC_WR_RX_CFG case is missing a break and will fall through
> to the default case and errorenously return -EINVAL. Fix this by
> adding in missing break.
Folded and pushed...
On 11/06/2017 07:59 AM, Benjamin Gaignard wrote:
Put include in alphabetic order
Acked-by: Laura Abbott
Signed-off-by: Benjamin Gaignard
---
drivers/staging/android/ion/ion.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/android/ion/i
On 11/06/2017 07:59 AM, Benjamin Gaignard wrote:
Instead a getting only one common device "/dev/ion" for
all the heaps this patch allow to create one device
entry ("/dev/ionX") per heap.
Getting an entry per heap could allow to set security rules
per heap and global ones for all heaps.
Allocatio
On Thu, Nov 09, 2017 at 05:19:55PM +, Colin King wrote:
> From: Colin Ian King
>
> The PI433_IOC_WR_RX_CFG case is missing a break and will fall through
> to the default case and errorenously return -EINVAL. Fix this by
> adding in missing break.
>
Could you fix PI433_IOC_RD_RX_CFG as well?
> + priv->phy_np = of_parse_phandle(pdev->dev.of_node, "phy-handle", 0);
> + priv->phy_mode = of_get_phy_mode(pdev->dev.of_node);
> + /* If phy-mode absent, default to SGMII. */
> + if (priv->phy_mode < 0)
> + priv->phy_mode = PHY_INTERFACE_MODE_SGMII;
> +
> + if (pr
> + if (link_changed != 0) {
> + struct port_status status;
> +
> + if (link_changed > 0) {
> + netdev_info(netdev, "Link is up - %d/%s\n",
> + priv->phydev->speed,
> + priv->phydev->dupl
Several types of control operations require that the underlying RNDIS
infrastructure be restarted. This patch changes the ordering of the
shutdown to avoid race conditions.
Stop all transmits before doing RNDIS halt. This involves stopping the
network device transmit queues, then waiting for all o
On Wed, 18 Oct 2017 12:52:12 +0100
Colin King wrote:
> From: Colin Ian King
>
> The variable region_start is assigned twice, the first value is
> never read and redundant, so can be removed. We can clean up the
> code further by assigning rg_start directly rather than using the
> temporary var
40 matches
Mail list logo