This is another batch of ccree fixes & cleanups.
The first patch is a bug fix. All others are pure
readability and coding style fixes.
Gilad Ben-Yossef (8):
staging: ccree: fix leak of import() after init()
staging: ccree: use more readable func names
staging: ccree: simplify AEAD using loc
Make the code more readable by using a local variable
for commonly use expression in the AEAD part of the driver.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_aead.c | 10 --
1 file changed, 4 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/ccree/ssi_aead.c b
Make the code more readable by using a local variable.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_pm.c | 12
1 file changed, 8 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/ccree/ssi_pm.c b/drivers/staging/ccree/ssi_pm.c
index e1bc4c5..d60143c 100644
The driver was using a function naming scheme
including common prefixes for driver global
functions based on the code module they came from.
The combination of long names with long common
prefixes made the whole thing hard for a human
to parse.
Make the semantic change of switching to simple
func
crypto_ahash_import() may be called either after
crypto_ahash_init() or without such call. Right now
we always internally call init() as part of
import(), thus leaking memory and mappings if the
user has already called init() herself.
Fix this by only calling init() internally if the
state is not
Make the code more readable by using a local variables
for commonly use expressions in the buffer manager part
of the driver.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_buffer_mgr.c | 18 ++
1 file changed, 10 insertions(+), 8 deletions(-)
diff --git a/drivers
Remove necessary braces for single statement blocks to
improve code readabilty.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_buffer_mgr.c | 6 ++
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/ccree/ssi_buffer_mgr.c
b/drivers/staging/ccree/ssi
Fold common code copying MAC to/from a temp. buffer
into an inline function instead of keeping multiple
open coded versions of same.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_buffer_mgr.c | 92 ++
1 file changed, 38 insertions(+), 54 deletions(
The driver was full of code checking "if (x != 0)".
Replace by "if (x)" for better readability.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_aead.c| 34 +++---
drivers/staging/ccree/ssi_buffer_mgr.c | 74 ++---
drivers/staging/ccree/ssi_c
On Tue, Nov 07, 2017 at 09:39:58AM +, Gilad Ben-Yossef wrote:
> @@ -780,11 +766,10 @@ static inline int ssi_buffer_mgr_aead_chain_iv(
> unsigned int iv_size_to_authenc = crypto_aead_ivsize(tfm);
> unsigned int iv_ofs = GCM_BLOCK_RFC4_IV_OFFSET;
> /* Cha
On Tue, Nov 07, 2017 at 09:39:59AM +, Gilad Ben-Yossef wrote:
> Make the code more readable by using a local variable
> for commonly use expression in the AEAD part of the driver.
>
> Signed-off-by: Gilad Ben-Yossef
> ---
> drivers/staging/ccree/ssi_aead.c | 10 --
> 1 file changed,
On Tue, Nov 07, 2017 at 09:40:01AM +, Gilad Ben-Yossef wrote:
> @@ -669,21 +690,12 @@ void cc_unmap_aead_request(struct device *dev, struct
> aead_request *req)
> }
> if (drvdata->coherent &&
> (areq_ctx->gen_ctx.op_type == DRV_CRYPTO_DIRECTION_DECRYPT) &&
> - lik
On Tue, Nov 07, 2017 at 09:40:02AM +, Gilad Ben-Yossef wrote:
> --- a/drivers/staging/ccree/ssi_pm.c
> +++ b/drivers/staging/ccree/ssi_pm.c
> @@ -90,20 +90,24 @@ int cc_pm_resume(struct device *dev)
> int cc_pm_get(struct device *dev)
> {
> int rc = 0;
> + struct ssi_drvdata *drvdat
do_gettimeofday() is deprecated and slower than necessary for the purpose
of reading the seconds. This changes rtl_op_suspend/resume to use
ktime_get_real_seconds() instead, which is simpler and avoids confusion
about whether it is y2038-safe or not.
Signed-off-by: Arnd Bergmann
---
This duplicat
On Tue, Nov 07, 2017 at 09:40:03AM +, Gilad Ben-Yossef wrote:
> diff --git a/drivers/staging/ccree/ssi_aead.c
> b/drivers/staging/ccree/ssi_aead.c
> index f1a3976..e9d03ee 100644
> --- a/drivers/staging/ccree/ssi_aead.c
> +++ b/drivers/staging/ccree/ssi_aead.c
> @@ -240,7 +240,7 @@ static void
Now that the SPDX tag is in all greybus files, that identifies the
license in a specific and legally-defined manner. So the extra GPL text
wording can be removed as it is no longer needed at all.
This is done on a quest to remove the 700+ different ways that files in
the kernel describe the GPL l
It's good to have SPDX identifiers in all files to make it easier to
audit the kernel tree for correct licenses.
Update the drivers/staging/greybus files files with the correct SPDX
license identifier based on the license text in the file itself. The
SPDX identifier is a legally binding shorthand
Now that the SPDX tag is in all most driver files, that identifies the
license in a specific and legally-defined manner. So the extra GPL text
wording can be removed as it is no longer needed at all.
This is done on a quest to remove the 700+ different ways that files in
the kernel describe the G
Now that the SPDX tag is in all comedi files, that identifies the
license in a specific and legally-defined manner. So the extra GPL text
wording can be removed as it is no longer needed at all.
This is done on a quest to remove the 700+ different ways that files in
the kernel describe the GPL li
It's good to have SPDX identifiers in all files to make it easier to
audit the kernel tree for correct licenses.
Update the drivers/staging/most files files with the correct SPDX
license identifier based on the license text in the file itself. The
SPDX identifier is a legally binding shorthand, w
Now that the SPDX tag is in all comedi files, that identifies the
license in a specific and legally-defined manner. So the extra GPL text
wording can be removed as it is no longer needed at all.
This is done on a quest to remove the 700+ different ways that files in
the kernel describe the GPL li
One .h file was missing a SPDX tag, and another one was wrong after
looking at the text of the license itself, so fix both of these issues
up at the same time.
Cc: David Kershner
Cc: Thomas Gleixner
Cc: Kate Stewart
Cc: Philippe Ombredanne
Signed-off-by: Greg Kroah-Hartman
---
drivers/stagin
It's good to have SPDX identifiers in all files to make it easier to
audit the kernel tree for correct licenses.
Update the drivers/staging/comedi files files with the correct SPDX
license identifier based on the license text in the file itself. The
SPDX identifier is a legally binding shorthand,
It's good to have SPDX identifiers in all files to make it easier to
audit the kernel tree for correct licenses.
Update the drivers/staging/unisys files files with the correct SPDX
license identifier based on the license text in the file itself. The
SPDX identifier is a legally binding shorthand,
Now that the SPDX tag is in all unisys driver files, that identifies the
license in a specific and legally-defined manner. So the extra GPL text
wording can be removed as it is no longer needed at all.
This is done on a quest to remove the 700+ different ways that files in
the kernel describe the
It's good to have SPDX identifiers in all files to make it easier to
audit the kernel tree for correct licenses.
Update the drivers/staging/lustre files files with the correct SPDX
license identifier based on the license text in the file itself. The
SPDX identifier is a legally binding shorthand,
On Tue, Nov 07, 2017 at 08:42:07AM -0600, Alex Elder wrote:
> On 11/07/2017 07:58 AM, Greg Kroah-Hartman wrote:
> > It's good to have SPDX identifiers in all files to make it easier to
> > audit the kernel tree for correct licenses.
> >
> > Update the drivers/staging/greybus files files with the c
On 11/07/2017 07:58 AM, Greg Kroah-Hartman wrote:
> It's good to have SPDX identifiers in all files to make it easier to
> audit the kernel tree for correct licenses.
>
> Update the drivers/staging/greybus files files with the correct SPDX
> license identifier based on the license text in the file
On 11/07/2017 07:58 AM, Greg Kroah-Hartman wrote:
> Now that the SPDX tag is in all greybus files, that identifies the
> license in a specific and legally-defined manner. So the extra GPL text
> wording can be removed as it is no longer needed at all.
>
> This is done on a quest to remove the 700
On 11/07/2017 08:47 AM, Greg Kroah-Hartman wrote:
> On Tue, Nov 07, 2017 at 08:42:07AM -0600, Alex Elder wrote:
>> On 11/07/2017 07:58 AM, Greg Kroah-Hartman wrote:
>>> It's good to have SPDX identifiers in all files to make it easier to
>>> audit the kernel tree for correct licenses.
>>>
>>> Updat
Hi Greg,
On Tue 07 Nov 2017 at 13:58, Greg Kroah-Hartman
wrote:
> It's good to have SPDX identifiers in all files to make it easier to
> audit the kernel tree for correct licenses.
>
> Update the drivers/staging/greybus files files with the correct SPDX
> license identifier based on the license te
Hi Greg,
On Tue 07 Nov 2017 at 13:58, Greg Kroah-Hartman
wrote:
> Now that the SPDX tag is in all greybus files, that identifies the
> license in a specific and legally-defined manner. So the extra GPL text
> wording can be removed as it is no longer needed at all.
>
> This is done on a quest to
On Tue, Nov 07, 2017 at 02:58:41PM +0100, Greg Kroah-Hartman wrote:
> It's good to have SPDX identifiers in all files to make it easier to
> audit the kernel tree for correct licenses.
>
> Update the drivers/staging/greybus files files with the correct SPDX
> license identifier based on the licens
On Tue, Nov 07, 2017 at 02:58:42PM +0100, Greg Kroah-Hartman wrote:
> Now that the SPDX tag is in all greybus files, that identifies the
> license in a specific and legally-defined manner. So the extra GPL text
> wording can be removed as it is no longer needed at all.
>
> This is done on a quest
This patch fixes the issue:
CHECK: usleep_range is preferred over udelay; see
Documentation/timers/timers-howto.txt
Signed-off-by: Joshua Abraham
---
drivers/staging/dgnc/dgnc_cls.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/dgnc/dgnc_cls.c b/drivers/sta
From: Colin Ian King
The early initialization of val is redundant as the value is never
read and is updated inside a for-loop. Remove the initialization
and move the declaration and initialization to the for-loop scope.
Cleans up clang warning:
drivers/staging/comedi/drivers/usbdux.c:812:15: war
From: Colin Ian King
Variable val32 is being assigned a zero value that is never read
since val32 is being updated immediately afterwards. Remove this
redundant assignment, cleans up clang warning:
drivers/staging/rtl8712/hal_init.c:339:2: warning: Value stored
to 'val32' is never read
Signed-
It's good to have SPDX identifiers in all files to make it easier to
audit the kernel tree for correct licenses.
Update the xgifb/XGI_main_26.c file with the correct SPDX license
identifier based on the license text in the file itself. The SPDX
identifier is a legally binding shorthand, which can
It's good to have SPDX identifiers in all files to make it easier to
audit the kernel tree for correct licenses.
Update the wlan-ng driver files with the correct SPDX license identifier
based on the license text in the file itself. The SPDX identifier is a
legally binding shorthand, which can be
It's good to have SPDX identifiers in all files to make it easier to
audit the kernel tree for correct licenses.
Update the vt6655 driver files with the correct SPDX license identifier
based on the license text in the file itself. The SPDX identifier is a
legally binding shorthand, which can be u
It's good to have SPDX identifiers in all files to make it easier to
audit the kernel tree for correct licenses.
Update the wilc100 driver files with the correct SPDX license identifier
based on the license text in the file itself. The SPDX identifier is a
legally binding shorthand, which can be
It's good to have SPDX identifiers in all files to make it easier to
audit the kernel tree for correct licenses.
Update the android driver files with the correct SPDX license identifier
based on the license text in the file itself. The SPDX identifier is a
legally binding shorthand, which can be
It's good to have SPDX identifiers in all files to make it easier to
audit the kernel tree for correct licenses.
Update the vt6656 driver files with the correct SPDX license identifier
based on the license text in the file itself. The SPDX identifier is a
legally binding shorthand, which can be u
Now that the SPDX tag is in all vt6656 files, that identifies the
license in a specific and legally-defined manner. So the extra GPL text
wording can be removed as it is no longer needed at all.
This is done on a quest to remove the 700+ different ways that files in
the kernel describe the GPL li
Now that the SPDX tag is in all android files, that identifies the
license in a specific and legally-defined manner. So the extra GPL text
wording can be removed as it is no longer needed at all.
This is done on a quest to remove the 700+ different ways that files in
the kernel describe the GPL l
Now that the SPDX tag is in all vt6655 files, that identifies the
license in a specific and legally-defined manner. So the extra GPL text
wording can be removed as it is no longer needed at all.
This is done on a quest to remove the 700+ different ways that files in
the kernel describe the GPL li
> -Original Message-
> From: devel [mailto:driverdev-devel-boun...@linuxdriverproject.org] On
> Behalf Of Greg Kroah-Hartman
> Sent: Tuesday, November 7, 2017 8:59 AM
> To: de...@driverdev.osuosl.org
> Cc: Kate Stewart ; Greg Kroah-Hartman
> ; Michael Fabry
> ; Philippe Ombredanne
> ; Chris
On Tue, Nov 07, 2017 at 02:58:41PM +0100, Greg Kroah-Hartman wrote:
> It's good to have SPDX identifiers in all files to make it easier to
> audit the kernel tree for correct licenses.
>
> Update the drivers/staging/greybus files files with the correct SPDX
> license identifier based on the licens
On Tue, Nov 07, 2017 at 02:58:42PM +0100, Greg Kroah-Hartman wrote:
> Now that the SPDX tag is in all greybus files, that identifies the
> license in a specific and legally-defined manner. So the extra GPL text
> wording can be removed as it is no longer needed at all.
>
> This is done on a quest
On Wed, Nov 01, 2017 at 08:52:56PM +, Jake Oshins wrote:
> > -Original Message-
> > From: Dexuan Cui
> > Sent: Wednesday, November 1, 2017 1:31 PM
> > To: Bjorn Helgaas ; linux-...@vger.kernel.org; Jake
> > Oshins ; KY Srinivasan ;
> > Stephen Hemminger
> > Cc: de...@linuxdriverproject
On Nov 7, 2017, at 06:58, Greg Kroah-Hartman wrote:
>
> It's good to have SPDX identifiers in all files to make it easier to
> audit the kernel tree for correct licenses.
>
> Update the drivers/staging/lustre files files with the correct SPDX
> license identifier based on the license text in the
This patch fixes the checkpatch.pl warning:
"CHECK: multiple assignments should be avoided"
Signed-off-by: Joshua Abraham
---
drivers/staging/fsl-dpaa2/ethernet/dpaa2-eth.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/fsl-dpaa2/ethernet/dpaa2-eth.c
b/dri
> -Original Message-
> From: Bjorn Helgaas [mailto:helg...@kernel.org]
> Sent: Tuesday, November 7, 2017 4:15 PM
> To: Jake Oshins
> Cc: Dexuan Cui ; Bjorn Helgaas
> ; linux-...@vger.kernel.org; KY Srinivasan
> ; Stephen Hemminger ;
> de...@linuxdriverproject.org; linux-ker...@vger.kernel.
On Wed, Nov 01, 2017 at 08:30:53PM +, Dexuan Cui wrote:
>
> The effective_affinity_mask is always set when an interrupt is assigned in
> __assign_irq_vector() -> apic->cpu_mask_to_apicid(), e.g. for struct apic
> apic_physflat: -> default_cpu_mask_to_apicid() ->
> irq_data_update_effective_aff
> From: Bjorn Helgaas [mailto:helg...@kernel.org]
> Sent: Tuesday, November 7, 2017 5:08 PM
> On Wed, Nov 01, 2017 at 08:30:53PM +, Dexuan Cui wrote:
> >
> > Please consider this for v4.14, if it's not too late.
>
> What would be the rationale for putting it in v4.14? After the merge
> window
From: Vitaly Kuznetsov
Date: Thu, 2 Nov 2017 11:35:29 +0100
> It was found that netvsc driver doesn't survive e.g.
>
> # while true; do ethtool -L eth0 combined 4; ethtool -L eth0 combined 8; done"
>
> test. I was able to identify a hang in guest/host communication, it is
> fixed by PATCH1 of
On Wed, Nov 08, 2017 at 01:27:02AM +, Dexuan Cui wrote:
> > From: Bjorn Helgaas [mailto:helg...@kernel.org]
> > Sent: Tuesday, November 7, 2017 5:08 PM
> > On Wed, Nov 01, 2017 at 08:30:53PM +, Dexuan Cui wrote:
> > >
> > > Please consider this for v4.14, if it's not too late.
> >
> > What
On 07-11-17, 14:58, Greg Kroah-Hartman wrote:
> Now that the SPDX tag is in all greybus files, that identifies the
> license in a specific and legally-defined manner. So the extra GPL text
> wording can be removed as it is no longer needed at all.
>
> This is done on a quest to remove the 700+ di
On 07-11-17, 14:58, Greg Kroah-Hartman wrote:
> It's good to have SPDX identifiers in all files to make it easier to
> audit the kernel tree for correct licenses.
>
> Update the drivers/staging/greybus files files with the correct SPDX
> license identifier based on the license text in the file its
On Tue, Nov 7, 2017 at 5:58 AM, Greg Kroah-Hartman
wrote:
> Now that the SPDX tag is in all greybus files, that identifies the
> license in a specific and legally-defined manner. So the extra GPL text
> wording can be removed as it is no longer needed at all.
>
> This is done on a quest to remove
On Tue, Nov 7, 2017 at 5:58 AM, Greg Kroah-Hartman
wrote:
> It's good to have SPDX identifiers in all files to make it easier to
> audit the kernel tree for correct licenses.
>
> Update the drivers/staging/greybus files files with the correct SPDX
> license identifier based on the license text in
On Tue, Nov 7, 2017 at 7:28 PM, Greg Kroah-Hartman
wrote:
> It's good to have SPDX identifiers in all files to make it easier to
> audit the kernel tree for correct licenses.
>
> Update the drivers/staging/greybus files files with the correct SPDX
> license identifier based on the license text in
On Tue, Nov 7, 2017 at 7:28 PM, Greg Kroah-Hartman
wrote:
> Now that the SPDX tag is in all greybus files, that identifies the
> license in a specific and legally-defined manner. So the extra GPL text
> wording can be removed as it is no longer needed at all.
>
> This is done on a quest to remove
On Wed, Nov 08, 2017 at 12:35:43AM +, Dilger, Andreas wrote:
> On Nov 7, 2017, at 06:58, Greg Kroah-Hartman
> wrote:
> >
> > It's good to have SPDX identifiers in all files to make it easier to
> > audit the kernel tree for correct licenses.
> >
> > Update the drivers/staging/lustre files f
On Tue, Nov 07, 2017 at 09:09:35PM +, Kershner, David A wrote:
> > -Original Message-
> > From: devel [mailto:driverdev-devel-boun...@linuxdriverproject.org] On
> > Behalf Of Greg Kroah-Hartman
> > Sent: Tuesday, November 7, 2017 8:59 AM
> > To: de...@driverdev.osuosl.org
> > Cc: Kate S
65 matches
Mail list logo