On Sun, Nov 05, 2017 at 03:27:38AM +, Bryan O'Donoghue wrote:
> Asynchronous operation completion handler's lives are made easier if there
> is a generic pointer that can store private data associated with the
> operation. This patch adds a pointer field to operation.h and get/set
As I mention
On Sun, Nov 05, 2017 at 03:27:39AM +, Bryan O'Donoghue wrote:
> Loopback has its own internal method for tracking and timing out
> asynchronous operations however previous patches make it possible to use
> functionality provided by operation.c to do this instead. Using the code in
> operation.c
Hi,
in a recent discussion [1] with Phil Elwell pointed out that the VPU firmware
of the Raspberry Pi isn't aware of an unload of the vchiq kernel module after a
successful registration.
So my question is there a proper way to prevent a platform driver from
unloading?
[1] - https://github.com
On Sun, Nov 05, 2017 at 01:32:26PM +0100, Stefan Wahren wrote:
> Hi,
>
> in a recent discussion [1] with Phil Elwell pointed out that the VPU
> firmware of the Raspberry Pi isn't aware of an unload of the vchiq
> kernel module after a successful registration.
Why not fix that to allow the module
When the row scan order is reversed (the default) we also need to
reverse the column scan order. This was not done previously, resulting
in a mirrored display.
Also add support for 180 degree display rotation, in which case simply
disable reversed row and column scan order.
Tested on an Adafruit
Return value from kzalloc was not checked in
device_init_td*_ring before using it.
Signed-off-by: Pierre-Yves Kerbrat
---
drivers/staging/vt6655/device_main.c | 43
1 file changed, 29 insertions(+), 14 deletions(-)
diff --git a/drivers/staging/vt6655/device_
On 05/11/17 12:24, Johan Hovold wrote:
+ if (error) {
gb->error++;
+ gb->iteration_count++;
+ }
And this looks like an unrelated bug fix that should go in it's own
patch, right?
I pinged t
Asynchronous operation completion handler's lives are made easier if there
is a generic pointer that can store private data associated with the
operation. This patch adds a pointer field to struct gb_operation and
get/set methods to access that pointer.
Signed-off-by: Bryan O'Donoghue
Cc: Johan H
Loopback has its own internal method for tracking and timing out
asynchronous operations however previous patches make it possible to use
functionality provided by operation.c to do this instead. Using the code in
operation.c means we can completely subtract the timer, the work-queue, the
kref and
Commit d9fb3754ecf8 ("greybus: loopback: Relax locking during loopback
operations") changes the holding of the per-connection mutex to be less
restrictive because at the time of that commit per-connection mutexes were
encapsulated by a per-driver level gb_dev.mutex.
Commit 8e1d6c336d74 ("greybus:
v2:
- Added Reviewed-by Johan for patch #3
- Added fix for mutex hold duration.
Johan mentioned the holding of this across a gb_operation_send() call.
Looking at this it shows a bug that crept in between two commits detailed
in patch#1 here.
- Split a separate bugfix from Mitch which had been
Commit 12927835d211 ("greybus: loopback: Add asynchronous bi-directional
support") does what it says on the tin - namely, adds support for
asynchronous bi-directional loopback operations.
What it neglects to do though is increment the per-connection
gb->iteration_count on an asynchronous operation
Commit d9fb3754ecf8 ("greybus: loopback: Relax locking during loopback
operations") changes the holding of the per-connection mutex to be less
restrictive because at the time of that commit per-connection mutexes were
encapsulated by a per-driver level gb_dev.mutex.
Commit 8e1d6c336d74 ("greybus:
v3:
- Patch #1 Cc: linux-ker...@vger.kernel.or -> Cc:
linux-ker...@vger.kernel.org
v2:
- Added Reviewed-by Johan for patch #3
- Added fix for mutex hold duration.
Johan mentioned the holding of this across a gb_operation_send() call.
Looking at this it shows a bug that crept in between two c
Asynchronous operation completion handler's lives are made easier if there
is a generic pointer that can store private data associated with the
operation. This patch adds a pointer field to struct gb_operation and
get/set methods to access that pointer.
Signed-off-by: Bryan O'Donoghue
Cc: Johan H
Loopback has its own internal method for tracking and timing out
asynchronous operations however previous patches make it possible to use
functionality provided by operation.c to do this instead. Using the code in
operation.c means we can completely subtract the timer, the work-queue, the
kref and
Commit 12927835d211 ("greybus: loopback: Add asynchronous bi-directional
support") does what it says on the tin - namely, adds support for
asynchronous bi-directional loopback operations.
What it neglects to do though is increment the per-connection
gb->iteration_count on an asynchronous operation
On Mon, Oct 02, 2017 at 05:49:52PM +0200, gre...@linuxfoundation.org wrote:
> On Mon, Oct 02, 2017 at 03:41:42PM +, Kershner, David A wrote:
> > Hey Greg, we think the code for visorbus is ready to be moved out
> > of staging, can you review it to see if we have missed anything?
>
> I think yo
Additional code readability and simplification patches.
These goes on top the previous patch set sent to the list.
Gilad Ben-Yossef (3):
staging: ccree: simplify error handling logic
staging: ccree: simplify registers access
staging: ccree: simplify ioread/iowrite
drivers/staging/ccree/cc_
The register offset calculation macro was taking a HW block base
parameter that was not actually used. Simplify the whole thing
by dropping it and rename the macro for better readability.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_regs.h | 15
drivers/stagi
Turn the code sites that don't require any special handling
on error return to a simple return.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_driver.c | 28
1 file changed, 12 insertions(+), 16 deletions(-)
diff --git a/drivers/staging/ccree/ssi_driv
Registers ioread/iowrite operations were done via macros,
sometime using a "magical" implicit parameter.
Replace all register access with simple inline macros.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_hal.h | 33 --
drivers/staging/ccree/cc_regs.h
On Sun, Nov 05, 2017 at 06:19:41PM +0100, Pierre-Yves Kerbrat wrote:
> Return value from kzalloc was not checked in
> device_init_td*_ring before using it.
>
Nah... It will still crash but just later so this change doesn't add
anything and just makes it harder for other people to see that the co
On Mon, Nov 06, 2017 at 06:55:49AM +, Gilad Ben-Yossef wrote:
> Additional code readability and simplification patches.
> These goes on top the previous patch set sent to the list.
Please label your 0/X patches the same way your patches are, with the
prefix of the subsystem, otherwise they get
On Mon, Nov 6, 2017 at 9:38 AM, Greg Kroah-Hartman
wrote:
> On Mon, Nov 06, 2017 at 06:55:49AM +, Gilad Ben-Yossef wrote:
>> Additional code readability and simplification patches.
>> These goes on top the previous patch set sent to the list.
>
> Please label your 0/X patches the same way your
On Mon, Nov 06, 2017 at 09:41:09AM +0200, Gilad Ben-Yossef wrote:
> On Mon, Nov 6, 2017 at 9:38 AM, Greg Kroah-Hartman
> wrote:
> > On Mon, Nov 06, 2017 at 06:55:49AM +, Gilad Ben-Yossef wrote:
> >> Additional code readability and simplification patches.
> >> These goes on top the previous pat
26 matches
Mail list logo