Now that the IRDA code has moved under drivers/staging/irda/, update the
MAINTAINERS file with the new location.
Reported-by: Joe Perches
Signed-off-by: Greg Kroah-Hartman gre...@linuxfoundation.org
---
MAINTAINERS | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/MAINTAINER
Greetings,
0day kernel testing robot got the below dmesg and the first bad commit is
https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/char-misc.git
char-misc-next
commit 74310e06be4d74dcf67cd108366710dee5c576d5
Author: Sherry Yang
AuthorDate: Wed Aug 23 08:46:41 2017 -0700
Commit:
A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing in e-mail?
A: No.
Q: Should I include quotations after my reply?
http://daringfireball.net/2007/07/on_top
On Tue, Aug 29, 2017 at 11:4
Now that the IRDA networking code has moved into drivers/staging/, the
link order is changed for when it is initialized if built into the
system. This can cause a crash when initializing as the netfilter core
hasn't been initialized yet.
So force the IRDA code to be built as a module, preventing
[Patch 1/2] : Replace 'IELength' and 'IEs' of struct wlan_bssid_ex with
'ie_length' and 'ies'
[Patch 2/2] : Remove wrongly commented out lines from the code and
rename 'ies' to 'ie' as per suggestions
Janani Sankara Babu (2):
staging:rtl8188eu:core Fix Avoid CamelCase
staging:rtl8188eu:core F
This patch is created to solve the CamelCase issue. The members
'IEs' and 'IELength' of struct wlan_bssid_ex are modified to 'ies'
and 'ie_length' to solve the issue.And all the places where these
variables are referenced inside rtl8188eu driver are also changed.
Signed-off-by: Janani Sankara B
This patch is created to solve the CamelCase issue. The members 'IEs' and
'IELength' of struct wlan_bssid_ex are being modified to 'ie' and
'ie_length' to solve the issue. And all the places where these variables
are referenced inside rtl8188eu driver are also changed.
Signed-off-by: Janani Sankar
You're sending this wrong.
The [PATCH 2/2] is fixing the stuff I complained about in [PATCH 1/2].
The patches need to be folded into a single patch and the subject should
say "[PATCH v3] staging: rtl8188eu: Rename CamelCase variables". Please
can you resend it.
regards,
dan carpenter
__
On Tue, Aug 29, 2017 at 11:44:37AM +0300, Alex Briskin wrote:
> A change was made to the commit message itself.
> In V1, as pointed out by Andy, I left module_driver instead of
> module_usb_driver in the commit message.
Dont't forget to fix the subject. "Driver registration ..." is not
compliant t
Hi Greg,
On Sun, Aug 27, 2017 at 5:03 PM, Greg Kroah-Hartman
wrote:
> The IRDA code has long been obsolete and broken. So, to keep people
> from trying to use it, and to prevent people from having to maintain it,
> let's move it to drivers/staging/ so that we can delete it entirely from
> the ke
Hi,
On Tue, Aug 15, 2017 at 10:04:56PM +0200, Hans de Goede wrote:
> On some devices the USB Type-C port power (USB PD 2.0) negotiation is
> done by a separate port-controller IC, while the current limit is
> controlled through another (charger) IC.
>
> It has been decided to model this by modell
Hi Ping-Ke, hi Larry,
I noticed your commit in linux-next today using the in-tree script at
scripts/checkkconfigsymbols.py [0]. The script showed that it uses
CONFIG_RTL_DEBUG in an #ifdef statement - this symbol, however, does not exist,
and should probably be CONFIG_RTLWIFI_DEBUG instead.
I att
On Tue, 29 Aug 2017 12:59:00 +0200
Geert Uytterhoeven wrote:
> Hi Greg,
>
> On Sun, Aug 27, 2017 at 5:03 PM, Greg Kroah-Hartman
> wrote:
> > The IRDA code has long been obsolete and broken. So, to keep people
> > from trying to use it, and to prevent people from having to maintain it,
> > let'
On Tue, Aug 29, 2017 at 12:59:27PM +0200, Andreas Ziegler wrote:
> Hi Ping-Ke, hi Larry,
>
> I noticed your commit in linux-next today using the in-tree script at
> scripts/checkkconfigsymbols.py [0]. The script showed that it uses
> CONFIG_RTL_DEBUG in an #ifdef statement - this symbol, however,
On Tue, Aug 29, 2017 at 01:11:31PM +0200, Stefano Brivio wrote:
> On Tue, 29 Aug 2017 12:59:00 +0200
> Geert Uytterhoeven wrote:
>
> > Hi Greg,
> >
> > On Sun, Aug 27, 2017 at 5:03 PM, Greg Kroah-Hartman
> > wrote:
> > > The IRDA code has long been obsolete and broken. So, to keep people
> > >
Hi,
On Tue, Aug 15, 2017 at 10:04:57PM +0200, Hans de Goede wrote:
> Register the 5V boost converter as a regulator named "usb_otg_vbus".
>
> This commit also adds support for bq24190_platform_data, through which
> non device-tree platforms can pass the regulator_init_data (containing
> mappings
Hi,
On Tue, Aug 15, 2017 at 10:04:58PM +0200, Hans de Goede wrote:
> Export the input current limit of the charger as a
> POWER_SUPPLY_PROP_INPUT_CURRENT_LIMIT property on the charger
> power_supply class device.
>
> Signed-off-by: Hans de Goede
> ---
Thanks, queued.
-- Sebastian
> drivers/p
The debugging output in deinit_priv is guarded by an #ifdef using
CONFIG_RTL_DEBUG. This symbol does not exist and should be
CONFIG_RTLWIFI_DEBUG instead.
Signed-off-by: Andreas Ziegler
---
drivers/staging/rtlwifi/halmac/rtl_halmac.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
di
This patch is created to solve the CamelCase issue. The members 'IEs' and
'IELength' of struct wlan_bssid_ex are being modified to 'ie' and
'ie_length' to solve the issue. And all the places where these variables
are referenced inside rtl8188eu driver are also changed.
Signed-off-by: Janani Sankar
Hi,
On Tue, Aug 15, 2017 at 10:04:59PM +0200, Hans de Goede wrote:
> On some devices the USB Type-C port power (USB PD 2.0) negotiation is
> done by a separate port-controller IC, while the current limit is
> controlled through another (charger) IC.
>
> It has been decided to model this by modell
Hi,
Thank you for your reviews / queuing!
On 29-08-17 13:40, Sebastian Reichel wrote:
Hi,
On Tue, Aug 15, 2017 at 10:04:59PM +0200, Hans de Goede wrote:
On some devices the USB Type-C port power (USB PD 2.0) negotiation is
done by a separate port-controller IC, while the current limit is
cont
On Tue, Aug 29, 2017 at 05:01:20PM +0530, Janani Sankara Babu wrote:
> This patch is created to solve the CamelCase issue. The members 'IEs' and
> 'IELength' of struct wlan_bssid_ex are being modified to 'ie' and
> 'ie_length' to solve the issue. And all the places where these variables
> are refer
Hi Greg,
On Tue, Aug 29, 2017 at 1:28 PM, Greg Kroah-Hartman
wrote:
> On Tue, Aug 29, 2017 at 01:11:31PM +0200, Stefano Brivio wrote:
>> On Tue, 29 Aug 2017 12:59:00 +0200
>> Geert Uytterhoeven wrote:
>> > On Sun, Aug 27, 2017 at 5:03 PM, Greg Kroah-Hartman
>> > wrote:
>> > > The IRDA code has
Hi,
On Tue, Aug 29, 2017 at 01:53:24PM +0200, Hans de Goede wrote:
> Hi,
>
> Thank you for your reviews / queuing!
>
> On 29-08-17 13:40, Sebastian Reichel wrote:
> > Hi,
> >
> > On Tue, Aug 15, 2017 at 10:04:59PM +0200, Hans de Goede wrote:
> > > On some devices the USB Type-C port power (USB
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git
staging-testing
head: 59b5306d1db0b53e39a676643b9781ba35813bb4
commit: 59b5306d1db0b53e39a676643b9781ba35813bb4 [445/445] staging: r8822be:
Fix typo for CONFIG_RTLWIFI_DEBUG
config: ia64-allyesconfig (attached as .config
This patch makes use of predefined identifier __func__ inorder to clear
the warning: Prefer using '"%s...", __func__' to using 'update_bmc_sta',
this function's name, in a string
Signed-off-by: Janani Sankara Babu
---
drivers/staging/rtl8188eu/core/rtw_ap.c | 2 +-
1 file changed, 1 insertion(+
On 08/29/2017 06:30 AM, Andreas Ziegler wrote:
The debugging output in deinit_priv is guarded by an #ifdef using
CONFIG_RTL_DEBUG. This symbol does not exist and should be
CONFIG_RTLWIFI_DEBUG instead.
Signed-off-by: Andreas Ziegler
NACK.
Yes, there is a problem; however, CONFIG_RTLWIFI_DEB
On Tue, Aug 29, 2017 at 09:10:10AM -0500, Larry Finger wrote:
> On 08/29/2017 06:30 AM, Andreas Ziegler wrote:
> > The debugging output in deinit_priv is guarded by an #ifdef using
> > CONFIG_RTL_DEBUG. This symbol does not exist and should be
> > CONFIG_RTLWIFI_DEBUG instead.
> >
> > Signed-off-
On Tue, Aug 29, 2017 at 02:11:39PM +0200, Geert Uytterhoeven wrote:
> Hi Greg,
>
> On Tue, Aug 29, 2017 at 1:28 PM, Greg Kroah-Hartman
> wrote:
> > On Tue, Aug 29, 2017 at 01:11:31PM +0200, Stefano Brivio wrote:
> >> On Tue, 29 Aug 2017 12:59:00 +0200
> >> Geert Uytterhoeven wrote:
> >> > On Sun
> On Aug 29, 2017, at 4:36 AM, Dexuan Cui wrote:
>
>> From: Dexuan Cui
>> Sent: Tuesday, August 22, 2017 21:21
>>> ...
>>> ...
>>> The only problem here would be the potential for a guest and a host app
>> to
>>> have a conflict wrt port numbers, even though they would be able to
>>> operate fin
From: Greg Kroah-Hartman
Date: Tue, 29 Aug 2017 09:09:29 +0200
> Now that the IRDA code has moved under drivers/staging/irda/, update the
> MAINTAINERS file with the new location.
>
> Reported-by: Joe Perches
> Signed-off-by: Greg Kroah-Hartman gre...@linuxfoundation.org
Applied.
_
From: Greg Kroah-Hartman
Date: Tue, 29 Aug 2017 11:14:17 +0200
> Now that the IRDA networking code has moved into drivers/staging/, the
> link order is changed for when it is initialized if built into the
> system. This can cause a crash when initializing as the netfilter core
> hasn't been init
From: Geert Uytterhoeven
Date: Tue, 29 Aug 2017 12:59:00 +0200
> Hi Greg,
>
> On Sun, Aug 27, 2017 at 5:03 PM, Greg Kroah-Hartman
> wrote:
>> The IRDA code has long been obsolete and broken. So, to keep people
>> from trying to use it, and to prevent people from having to maintain it,
>> let's
From: Greg Kroah-Hartman
Date: Tue, 29 Aug 2017 16:48:50 +0200
> On Tue, Aug 29, 2017 at 02:11:39PM +0200, Geert Uytterhoeven wrote:
>> Hi Greg,
>>
>> On Tue, Aug 29, 2017 at 1:28 PM, Greg Kroah-Hartman
>> wrote:
>> > On Tue, Aug 29, 2017 at 01:11:31PM +0200, Stefano Brivio wrote:
>> >> On Tue,
Signed-off-by: harsha
---
drivers/staging/android/ion/ion.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/android/ion/ion.c
b/drivers/staging/android/ion/ion.c
index 93e2c90..a2d36b3 100644
--- a/drivers/staging/android/ion/ion.c
+++ b/drivers/staging/androi
On Tue, Aug 29, 2017 at 09:35:07AM -0700, David Miller wrote:
> From: Greg Kroah-Hartman
> Date: Tue, 29 Aug 2017 11:14:17 +0200
>
> > Now that the IRDA networking code has moved into drivers/staging/, the
> > link order is changed for when it is initialized if built into the
> > system. This ca
1. Register the driver with module_usb_driver macro instead of module_init
and module_exit.
2. Remove redundant code.
Signed-off-by: Alex Briskin
---
drivers/staging/most/hdm-usb/hdm_usb.c | 20 +---
1 file changed, 1 insertion(+), 19 deletions(-)
diff --git a/drivers/staging
On Tue, Aug 29, 2017 at 10:49:54PM +0530, harsha wrote:
> Signed-off-by: harsha
> ---
> drivers/staging/android/ion/ion.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/staging/android/ion/ion.c
> b/drivers/staging/android/ion/ion.c
> index 93e2c90..a2d36b3 100
On Tue, Aug 29, 2017 at 07:26:08PM +0200, Greg KH wrote:
> On Tue, Aug 29, 2017 at 09:35:07AM -0700, David Miller wrote:
> > From: Greg Kroah-Hartman
> > Date: Tue, 29 Aug 2017 11:14:17 +0200
> >
> > > Now that the IRDA networking code has moved into drivers/staging/, the
> > > link order is chan
From: Greg KH
Date: Tue, 29 Aug 2017 19:26:08 +0200
> On Tue, Aug 29, 2017 at 09:35:07AM -0700, David Miller wrote:
>> From: Greg Kroah-Hartman
>> Date: Tue, 29 Aug 2017 11:14:17 +0200
>>
>> > Now that the IRDA networking code has moved into drivers/staging/, the
>> > link order is changed for
When moving the IRDA code out of net/ into drivers/staging/irda/net, the
link order changes when IRDA is built into the kernel. That causes a
kernel crash at boot time as netfilter isn't initialized yet.
To fix this, build and link the irda networking code in the same exact
order that it was prev
From: Greg KH
Date: Tue, 29 Aug 2017 19:46:22 +0200
> When moving the IRDA code out of net/ into drivers/staging/irda/net, the
> link order changes when IRDA is built into the kernel. That causes a
> kernel crash at boot time as netfilter isn't initialized yet.
>
> To fix this, build and link t
Fixes checkpatch.pl warning: Use WARN_ON() rather than BUG_ON() and BUG()
Signed-off-by: harsha
---
drivers/staging/android/ion/ion.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/android/ion/ion.c
b/drivers/staging/android/ion/ion.c
index 93e2c90..a2d36b3
On Tue, Aug 29, 2017 at 11:30:22PM +0530, harsha wrote:
> Fixes checkpatch.pl warning: Use WARN_ON() rather than BUG_ON() and BUG()
>
> Signed-off-by: harsha
I still need a real name here.
> ---
> drivers/staging/android/ion/ion.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> di
On Tue, Aug 29, 2017 at 10:49:45AM -0700, David Miller wrote:
> From: Greg KH
> Date: Tue, 29 Aug 2017 19:46:22 +0200
>
> > When moving the IRDA code out of net/ into drivers/staging/irda/net, the
> > link order changes when IRDA is built into the kernel. That causes a
> > kernel crash at boot t
Hi,
harsha, this is my real name.
There is no need to call BUG() over here as this error is not very basic and
BUG() tends to bring the system down so calling WARN_ON() is preferable.
Please correct me if I am wrong as this is my first contribution.
I am unable to send any direct mail from gmail(
Fixes checkpatch.pl warning: Use WARN_ON() rather than BUG_ON() and BUG()
Signed-off-by: harsha
---
drivers/staging/android/ion/ion.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/android/ion/ion.c
b/drivers/staging/android/ion/ion.c
index 93e2c90..a2d36b3
On Wed, Aug 30, 2017 at 12:51:01AM +0530, harsha wrote:
> Hi,
> harsha, this is my real name.
That's your full name that you use to sign legal documents? No last
name? No capital letter at the beginning?
> There is no need to call BUG() over here as this error is not very basic and
> BUG() ten
On Tuesday 29 August 2017 01:42:08 David Miller wrote:
> From: Greg Kroah-Hartman
> Date: Sun, 27 Aug 2017 17:03:30 +0200
>
> > The IRDA code has long been obsolete and broken. So, to keep people
> > from trying to use it, and to prevent people from having to maintain it,
> > let's move it to dri
binder_alloc_selftest tests that alloc_new_buf handles page allocation and
deallocation properly when allocate and free buffers. The test allocates 5
buffers of various sizes to cover all possible page alignment cases, and
frees the buffers using a list of exhaustive freeing order.
Test: boot the
Add tracepoints in binder transaction allocator to
record lru hits and alloc/free page.
Signed-off-by: Sherry Yang
---
drivers/android/binder_alloc.c | 27 +++--
drivers/android/binder_trace.h | 55 ++
2 files changed, 80 insertions(+), 2 d
Use helper functions buffer_next and buffer_prev instead
of list_entry to get the next and previous buffers.
Signed-off-by: Sherry Yang
---
drivers/android/binder_alloc.c | 24 +++-
1 file changed, 15 insertions(+), 9 deletions(-)
diff --git a/drivers/android/binder_alloc.c
Add the number of active, lru, and free pages for
each binder process in binder stats
Signed-off-by: Sherry Yang
---
drivers/android/binder.c | 2 ++
drivers/android/binder_alloc.c | 28
drivers/android/binder_alloc.h | 2 ++
3 files changed, 32 insertions(+)
Hold on to the pages allocated and mapped for transaction
buffers until the system is under memory pressure. When
that happens, use linux shrinker to free pages. Without
using shrinker, patch "android: binder: Move buffer out
of area shared with user space" will cause a significant
slow down for sm
Binder driver allocates buffer meta data in a region that is mapped
in user space. These meta data contain pointers in the kernel.
This patch allocates buffer meta data on the kernel heap that is
not mapped in user space, and uses a pointer to refer to the data mapped.
Also move alloc->buffers in
Long,
> When storvsc is sending I/O to Hyper-v, it may allocate a bigger
> buffer descriptor for large data payload that can't fit into a
> pre-allocated buffer descriptor. This bigger buffer is freed on return
> path.
>
> If I/O request to Hyper-v fails due to ring buffer busy, the storvsc
> all
It is prefered to use '"%s...", __func__ instead of function names for
logging. This commit replaces hardcoded function name strings to the
more preferred '"%s...", __func__' style. These warnings were reported
by checkpatch.pl.
Signed-off-by: Jonathan Whitaker
Changes in v2:
- Wrapped the cha
v2: Undo the renaming of the dft_eps_id variable in hci_pdn_table_ind
to resolve a compiler error.
Signed-off-by: Nick Fox
---
drivers/staging/gdm724x/hci_packet.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/gdm724x/hci_packet.h
b/drivers/staging/gdm724x/
> -Original Message-
> From: Martin K. Petersen [mailto:martin.peter...@oracle.com]
> Sent: Tuesday, August 29, 2017 6:31 PM
> To: Long Li
> Cc: KY Srinivasan ; Haiyang Zhang
> ; James E . J . Bottomley
> ; de...@linuxdriverproject.org; linux-
> s...@vger.kernel.org; linux-ker...@vger.kern
Fixed coding style issue
Signed-off-by: Harsha Sharma
---
drivers/staging/rtl8712/xmit_linux.c | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8712/xmit_linux.c
b/drivers/staging/rtl8712/xmit_linux.c
index d13fd15..03c6b0c 100644
--- a/drivers/stagin
On Wed, Aug 30, 2017 at 12:51:02AM +0530, harsha wrote:
> Fixes checkpatch.pl warning: Use WARN_ON() rather than BUG_ON() and BUG()
>
> Signed-off-by: harsha
> ---
> drivers/staging/android/ion/ion.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/staging/androi
FYI, we noticed the following commit:
commit: 66d98e78e44ccb969cb3196995759d200e64b49b ("irda: move net/irda/ to
drivers/staging/irda/net/")
url:
https://github.com/0day-ci/linux/commits/Greg-Kroah-Hartman/irda-move-it-to-drivers-staging-so-we-can-delete-it/20170829-090816
in testcas
On Tue, Aug 29, 2017 at 05:46:57PM -0700, Sherry Yang wrote:
> Use helper functions buffer_next and buffer_prev instead
> of list_entry to get the next and previous buffers.
>
> Signed-off-by: Sherry Yang
> ---
> drivers/android/binder_alloc.c | 24 +++-
> 1 file changed, 15
Greg-Kroah-Hartman/irda-move-it-to-drivers-staging-so-we-can-delete-it/20170829-090816
>
> in testcase: trinity
> with following parameters:
>
> runtime: 300s
>
> test-description: Trinity is a linux system call fuzz tester.
> test-url: http://codemonkey.org.uk/proj
gt;> url:
>> https://github.com/0day-ci/linux/commits/Greg-Kroah-Hartman/irda-move-it-to-drivers-staging-so-we-can-delete-it/20170829-090816
>>
>> in testcase: trinity
>> with following parameters:
>>
>> runtime: 300s
>>
>> test-description:
65 matches
Mail list logo