The define CURRENT_FILE_PC was not being used, so just remove it.
Signed-off-by: David Kershner
Reviewed-by: David Binder
---
drivers/staging/unisys/visorbus/visorchipset.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/unisys/visorbus/visorchipset.c
b/drivers/staging/uni
From: Charles Daniels
Replaced the one and only call to COVER in iochannel.h.
Signed-off-by: Charles Daniels
Signed-off-by: David Kershner
Reviewed-by: David Binder
---
drivers/staging/unisys/include/channel.h | 4
drivers/staging/unisys/include/iochannel.h | 2 +-
2 files changed, 1
From: Alex Curtin
VISOR_VBUS_CHANNEL_SIGNATURE just pointed to VISOR_CHANNEL_SIGNATURE, so
this replaces the redundant definition with VISOR_CHANNEL_SIGNATURE.
Signed-off-by: Alex Curtin
Signed-off-by: David Kershner
Reviewed-by: David Binder
---
drivers/staging/unisys/visorbus/vbuschannel.h
From: Sameer Wadgaonkar
This patch makes function definitions more consistent by having function
name and return values on the same line.
Signed-off-by: Sameer Wadgaonkar
Signed-off-by: David Kershner
Reviewed-by: David Binder
---
drivers/staging/unisys/visorbus/visorbus_main.c | 131 ++-
From: Sameer Wadgaonkar
The VISOR_VNIC_CHANNEL_OK_CLIENT and VISOR_HBA_CHANNEL_OK_CLIENT macros
were not being used. They can be removed.
Signed-off-by: Sameer Wadgaonkar
Signed-off-by: David Kershner
Reviewed-by: David Binder
---
drivers/staging/unisys/include/iochannel.h | 12
From: Mark Foresta
Placed /* on line 1 alone rather than start comment.
Signed-off-by: Mark Foresta
Signed-off-by: David Kershner
Reviewed-by: David Binder
---
drivers/staging/unisys/visorbus/visorbus_private.h | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/sta
From: Sameer Wadgaonkar
Remove check for xbus in typename_show() function in
visorbus_main.c.
Signed-off-by: Sameer Wadgaonkar
Signed-off-by: David Kershner
Reviewed-by: David Binder
---
drivers/staging/unisys/visorbus/visorbus_main.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
di
From: Sameer Wadgaonkar
Removed checks for dev->visorchannel in visorbus_release_device()
and visorbus_remove_instance() since it is also checked in the
visorchannel_destroy() function.
Signed-off-by: Sameer Wadgaonkar
Signed-off-by: David Kershner
Reviewed-by: David Binder
---
drivers/stagi
From: Charles Daniels
Fixed incorrect function declaration style in visorinput/visorinput.c
by placing the function names on the same line as the return.
Signed-off-by: Charles Daniels
Signed-off-by: David Kershner
Reviewed-by: David Binder
---
drivers/staging/unisys/visorinput/visorinput.c
From: Erik Arfvidson
Rename fix_vbus_dev_info to something clearer: publish_vbus_dev_info.
Signed-off-by: Erik Arfvidson
Signed-off-by: David Kershner
Reviewed-by: David Binder
---
drivers/staging/unisys/visorbus/visorbus_main.c | 15 +++
1 file changed, 7 insertions(+), 8 deleti
From: Alex Curtin
VISOR_VSWITCH_CHANNEL_SIGNATURE is a redundant definition that points to
VISOR_CHANNEL_SIGNATURE. It wasn't being used, so it has been removed.
Signed-off-by: Alex Curtin
Signed-off-by: David Kershner
Reviewed-by: David Binder
---
drivers/staging/unisys/include/iochannel.h
From: Armin Schoenlieb
This is a patch to the rtw_xmit.c file that fixes up a comment/80 character
warning found by the checkpatch.pl tool
Signed-off-by: Armin Schoenlieb
---
drivers/staging/rtl8188eu/core/rtw_xmit.c | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/dr
This patch replaces call to tty_open_by_driver with a tty_kopen.
Signed-off-by: Okash Khawaja
---
drivers/staging/speakup/spk_ttyio.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- a/drivers/staging/speakup/spk_ttyio.c
+++ b/drivers/staging/speakup/spk_ttyio.c
@@ -158,7 +158,7 @@
The commit 12e84c71b7d4ee (tty: export tty_open_by_driver) exports
tty_open_by_device to allow tty to be opened from inside kernel which
works fine except that it doesn't handle contention with user space or
another kernel-space open of the same tty. For example, opening a tty
from user space while
Since we have tty_kopen, we no longer need to export tty_open_by_driver.
This patch makes this function static.
Signed-off-by: Okash Khawaja
---
drivers/tty/tty_io.c |3 +--
include/linux/tty.h |5 -
2 files changed, 1 insertion(+), 7 deletions(-)
--- a/drivers/tty/tty_io.c
+++ b/
Hi,
I have reworked the previous patch set. These are the changes:
1. Patch 1 fixes tty->count mismatch reported by check_tty_count when a
tty is kopened.
2. Patch 1 incorporates patch 4 in the previous patch set - it returns
-ENODEV when tty is not configured.
Thanks,
Okash
On Mon, Jul 17, 2017 at 4:35 PM, Hans Verkuil wrote:
> On 17/07/17 16:26, Arnd Bergmann wrote:
>> Let me try again without ccache for now and see what warnings remain.
>> We can find a solution for those first, and then decide how to deal with
>> ccache.
>
> Sounds good.
>
> I'm OK with applying
On Thu, Jul 13, 2017 at 09:26:50PM +0200, Philipp wrote:
>
> > On 13. Jul 2017, at 17:45, Sakari Ailus wrote:
> >
> > On Thu, Jul 13, 2017 at 08:55:43AM +0200, Philipp Guendisch wrote:
> >> This patch fixed code alignment to open paranthesis.
> >> Semantic should not be affected by this patch.
>
> -Original Message-
> From: Greg KH [mailto:g...@kroah.com]
> Sent: Monday, July 17, 2017 8:38 AM
> To: Arvind Yadav
> Cc: Kershner, David A ; Sell, Timothy C
> ; Thompson, Bryan E.
> ; jon.fri...@unisys.com; Binder, David
> Anthony ; *S-Par-Maintainer
> ; de...@driverdev.osuosl.org; linu
> Sure. I can fix the tty->count mismatch based on Alan's suggestion. However I
> don't understand why the exclusivity flag should belong to tty_port and not
> tty_struct. It will be good to know why.
We are trying to move all the flags that we can and structs into the
tty_port, except any tha
On Mon, Jul 17, 2017 at 10:53:25PM +0300, Dan Carpenter wrote:
> > + if (len + 1 > n) {
>
> It's more idiomatic to say "if (len >= n)". Plus that's a good habbit
My reasoning behind using "((len + 1) > n)" is that len represents the length of
the string without null-termination. "buf" is requi
Four fields in struct fpgaimage are char arrays of length MAX_STR (256).
The amount of data read into these buffers is controlled by a length
field in the bitstream file read from userspace. If a corrupt or
malicious firmware file was supplied, kernel data beyond these buffers
can be overwritten ar
The bitstream storage variables were changed from char to u8 arrays to
prevent issues such as negative lengths. This change makes the code
compatible with the "data" field in "struct firmware" which is of type
u8.
Signed-off-by: Jacob von Chorus
---
drivers/staging/gs_fpgaboot/gs_fpgaboot.c | 24
On Mon, 2017-07-17 at 20:47 -0400, Jacob von Chorus wrote:
> The bitstream storage variables were changed from char to u8 arrays to
> prevent issues such as negative lengths. This change makes the code
> compatible with the "data" field in "struct firmware" which is of type
> u8.
>
> Signed-off-by
On Mon, Jul 17, 2017 at 06:22:08PM -0700, Joe Perches wrote:
> read_bitstream takes an int rdsize, not a u16.
> and this function will overflow tbuf if len > 64
>
> static void readinfo_bitstream(char *bitdata, char *buf, int *offset)
> {
> char tbuf[64];
> s32 len;
>
> /* read s
On Monday 17 July 2017 06:03 PM, Greg KH wrote:
> On Sat, Jul 15, 2017 at 01:21:54PM +0530, suni...@techveda.org wrote:
>> From: Suniel Mahesh
>>
>> It is recommended to use managed function devm_kzalloc, which
>> simplifies driver cleanup paths and driver code.
>> This patch does the following:
>
On Mon, Jul 17, 2017 at 09:36:58PM +, Kershner, David A wrote:
> > -Original Message-
> > From: Greg KH [mailto:g...@kroah.com]
> > Sent: Monday, July 17, 2017 8:38 AM
> > To: Arvind Yadav
> > Cc: Kershner, David A ; Sell, Timothy C
> > ; Thompson, Bryan E.
> > ; jon.fri...@unisys.com;
attribute_group are not supposed to change at runtime. All functions
working with attribute_group provided by work
with const attribute_group. So mark the non-const structs as const.
Signed-off-by: Arvind Yadav
---
Changes in v2:
Change log typo was not correct.
drivers/staging/u
Fix checkpatch warning to add space around the substraction operation
Signed-off-by: Hari Prasath
---
drivers/staging/iio/adc/ad7280a.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/iio/adc/ad7280a.c
b/drivers/staging/iio/adc/ad7280a.c
index d5ab83f..d7
From: Colin Ian King
Trivial fix to spelling mistakes in dev_dbg debug messages
"wiat" -> "wait"
"fonud" -> "found"
Signed-off-by: Colin Ian King
---
drivers/staging/pi433/pi433_if.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/pi433/pi433_if.c b/dri
On 18 July 2017 06:38:08 BST, Hari Prasath wrote:
>Fix checkpatch warning to add space around the substraction operation
>
>Signed-off-by: Hari Prasath
>---
> drivers/staging/iio/adc/ad7280a.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
>diff --git a/drivers/staging/iio/adc/ad7
On Mon, Jul 17, 2017 at 10:53:21PM +0200, ArminSchoenlieb wrote:
> From: Armin Schoenlieb
>
> This is a patch to the rtw_xmit.c file that fixes up a comment/80 character
> warning found by the checkpatch.pl tool
It's ironic that your changelog violates this same issue :(
___
On Mon, Jul 17, 2017 at 04:16:48PM -0400, David Kershner wrote:
> From: David Binder
>
> Removes unnecessary checks for a NULL pointer in a non-API function.
>
> Signed-off-by: David Binder
> Signed-off-by: David Kershner
> Reviewed-by: David Binder
> ---
> drivers/staging/unisys/visorhba/vi
On Mon, Jul 17, 2017 at 04:16:59PM -0400, David Kershner wrote:
> From: Sameer Wadgaonkar
>
> Added checks for functions probe, remove, pause and resume in
> visorbus_register_visor_driver() and removed these checks from
> the individual functions itself.
>
> Signed-off-by: Sameer Wadgaonkar
>
On Mon, Jul 17, 2017 at 04:17:05PM -0400, David Kershner wrote:
> From: Zohaib
I need a "real" and "full" name please for all kernel changes.
thanks,
greg k-h
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/
On Mon, Jul 17, 2017 at 04:17:06PM -0400, David Kershner wrote:
> From: Zohaib
Same name issue here.
thanks,
greg k-h
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On Mon, Jul 17, 2017 at 04:17:04PM -0400, David Kershner wrote:
> From: Zohaib
>
> Leading comment changed to follow surrounding convention.
>
> Signed-off-by: Zohaib
> Signed-off-by: David Kershner
> Reviewed-by: David Binder
> ---
> drivers/staging/unisys/visorbus/visorchipset.c | 3 ++-
>
On Mon, Jul 17, 2017 at 04:17:10PM -0400, David Kershner wrote:
> From: Mark Foresta
>
> Moved /* to own line at beginning of struct visor_vbus_deviceinfo to follow
> standard.
>
> Signed-off-by: Mark Foresta
> Signed-off-by: David Kershner
> Reviewed-by: David Binder
> ---
> drivers/staging
On Mon, Jul 17, 2017 at 04:17:11PM -0400, David Kershner wrote:
> From: Mark Foresta
>
> Placed /* on line 1 alone rather than start comment.
>
> Signed-off-by: Mark Foresta
> Signed-off-by: David Kershner
> Reviewed-by: David Binder
> ---
> drivers/staging/unisys/visorbus/visorbus_private.h
On Mon, Jul 17, 2017 at 04:17:22PM -0400, David Kershner wrote:
> From: Sameer Wadgaonkar
>
> Cleaned up the in-line comments in the structure and added a
> kernel-doc like comment for the structure.
>
> Signed-off-by: Sameer Wadgaonkar
> Signed-off-by: David Kershner
> Reviewed-by: David Bind
On Mon, Jul 17, 2017 at 04:17:17PM -0400, David Kershner wrote:
> From: Charles Daniels
>
> Fixed incorrectly styled function definitions in visorbus/visorchipset.c
> by placing the function names on the same line as the return.
>
> Signed-off-by: Charles Daniels
> Signed-off-by: David Kershner
On Mon, Jul 17, 2017 at 04:16:40PM -0400, David Kershner wrote:
> This series fixes some more style issues with the code found
> during our internal review.
I've applied most of these, please rebase and fix up the remaining ones
and resend.
thanks,
greg k-h
__
On Tue, Jul 18, 2017 at 10:54:21AM +0530, Arvind Yadav wrote:
> attribute_group are not supposed to change at runtime. All functions
> working with attribute_group provided by work
> with const attribute_group. So mark the non-const structs as const.
>
> Signed-off-by: Arvind Yadav
> ---
> Chang
On Mon, Jul 17, 2017 at 08:19:45PM +0530, Gaurav Pathak wrote:
> staging: rts5208: Fix coding style issue caught by checkpatch.pl related to
> function name in debug print and shorten few lines over 80 char
No, only do one-type-of-thing per patch. It would make sense to maybe
fix an 80 char line
On Sat, Jul 15, 2017 at 11:43:05AM +, Joseph Wright wrote:
> Declare private function static to fix sparse warning:
>
> ion_cma_heap.c:109:5: warning: symbol '__ion_add_cma_heaps' \
> was not declared. Should it be static?
>
> Signed-off-by: Joseph Wright
> ---
> Changes in v3:
> - M
On Wed, Jul 12, 2017 at 09:38:50PM +0100, alfonsolimaas...@gmail.com wrote:
> From: Alfonso Lima Astor
>
> These variables were set to u16 and u32 although they always hold a little
> endian value.
>
> This patch fixes multiple sparse warnings like:
> drivers/staging/wlan-ng/prism2sta.c:375:46:
101 - 146 of 146 matches
Mail list logo