File size before:
textdata bss dec hex filename
6712 960 52181932001
drivers/staging/unisys/visorbus/visorbus_main.o
File size After adding 'const':
textdata bss dec hex filename
6840 832 52181932001
drivers/staging/unis
Hi Joe,
On 06/22/2017 07:07 PM, Joe Perches wrote:
> On Thu, 2017-06-22 at 16:35 +0300, laurentiu.tu...@nxp.com wrote:
>> From: Laurentiu Tudor
>>
>> Several macros were triggering this checkpatch.pl warning:
>>"Macro argument reuse '$arg' - possible side-effects?"
>> Fix the warning by turni
-Yossef/staging-ccree-bug-fixes-and-TODO-items-for-4-13/20170623-134445
config: sparc64-allmodconfig (attached as .config)
compiler: sparc64-linux-gnu-gcc (Debian 6.1.1-9) 6.1.1 20160705
reproduce:
wget
https://raw.githubusercontent.com/01org/lkp-tests/master/sbin/make.cross -O
~/bin
A recent commit included linux/slab.h in linux/irq.h. This breaks the build
of vdso32 on a 64bit kernel.
The reason is that linux/irq.h gets included into the vdso code via
linux/interrupt.h which is included from asm/mshyperv.h. That makes the
32bit vdso compile fail, because slab.h includes the
On Fri, 23 Jun 2017, Thomas Gleixner wrote:
> A recent commit included linux/slab.h in linux/irq.h. This breaks the build
> of vdso32 on a 64bit kernel.
>
> The reason is that linux/irq.h gets included into the vdso code via
> linux/interrupt.h which is included from asm/mshyperv.h. That makes th
CHECK: Macro argument reuse 'pframe' - possible side-effects?
Convert get_tofr_ds macro to inline functions to fix checkpatch check
Signed-off-by: Jaya Durga
---
drivers/staging/rtl8712/wifi.h | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8712/wifi
On Mon, Jun 19, 2017 at 10:11:07AM +, ? ? wrote:
> From: Pan Li
>
> Convertn __le to cpu type when access pd_header count.
I think you have a typo in this sentance :(
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverp
On Thu, Jun 22, 2017 at 12:10:04PM +0530, Jaya Durga wrote:
> From: Jaya Durga
>
> Fix checkpatch.pl warning of the form "CHECK" Macro argument 'x'
> may be better as '(x)' to avoid precedence issues.
>
> Signed-off-by: Jaya Durga
> ---
> drivers/staging/rtl8712/osdep_intf.h | 2 +-
> 1 file c
On Sat, Jun 17, 2017 at 03:21:22PM +1200, Derek Robson wrote:
> Fixed checkpatch warnings "Use #include instead of "
> Found using checkpatch
>
> Signed-off-by: Derek Robson
>
> V1 had vauge subject.
> ---
Please move the V1 below the --- line.
thanks,
greg k-h
__
On Fri, Jun 16, 2017 at 01:23:59PM +0800, Jhih-Ming Hunag wrote:
> Hi,
>
> I fixed some coding style following scripts/checkpatch.pl suggestion.
>
> Signed-off-by: Jhih-Ming Hunag
> ---
> drivers/staging/android/ion/ion.c | 8
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff
On Sat, Jun 17, 2017 at 03:03:24PM +1200, Derek Robson wrote:
> Fixed checkpatch.pl warnings of the form "function definition argument
> 'foo' should also have an identifier name" in header files.
>
> Signed-off-by: Derek Robson
>
> V1 had vague subject
> ---
Same as before...
_
On Mon, Jun 19, 2017 at 10:11:34AM +, ? ? wrote:
> From: Pan Li
>
> Add tcpci_write16_le for pd_message header type __le16.
That says what it does, but you need to explain _why_ it is needed as
well.
thanks,
greg k-h
___
devel mailing list
de...@
On Thu, Jun 22, 2017 at 03:42:35PM +0530, Jaya Durga wrote:
> Fix checkpatch.pl Warning: Symbolic permissions 'S_IRUGO | S_IWUSR'
> are not preferred.Consider using octal permissions '0644'.
>
> Signed-off-by: Jaya Durga
> --6
What is this last line for? Please fix up and resend.
thanks,
gre
On Mon, Jun 19, 2017 at 10:51:21PM +0530, Simran Singhal wrote:
> This patch removes typedefs from enum _logical_chip_type_t and enum
> _clock_type_t and rename them to logical_chip_type_t and clock_type_t
> respectively.
Why are you doing two different typedef fixups in a single patch?
Please onl
On Sat, Jun 17, 2017 at 07:02:46PM +0300, Kamal Heib wrote:
> Fix the following sparse warnings:
>
> prism2mgmt.c:188:25: warning: incorrect type in assignment (different base
> types)
> prism2mgmt.c:188:25:expected unsigned short [unsigned] [addressable]
> [usertype] tx_rate
> prism2mgmt.c:
On Fri, Jun 16, 2017 at 03:35:07PM +0530, Jaya Durga wrote:
> when building with make C=1 CF=-D__CHECK_ENDIAN__
>
> drivers/staging/wlan-ng/hfa384x_usb.c:3383:36: warning: cast to restricted
> __le16
>
> fixed by using the le16_to_cpus function.
>
> Signed-off-by: Jaya Durga
> ---
> drivers/s
On Tue, Jun 20, 2017 at 02:36:37PM +0530, simran singhal wrote:
> This patch changes the type of variable done from int to boolean. As it
> is been used as a boolean in the function sfw_test_rpc_done(). It also
> makes the code more readable and bool data type also requires less
> memory in compari
On Thu, Jun 15, 2017 at 05:06:30PM +0100, James Simmons wrote:
>
> > On Wed, 2017-06-14 at 11:01 -0400, James Simmons wrote:
> > > Cleanup many of the over 80 characters reported by checkpatch
> >
> > Please don't let checkpatch get in the way of lustre
> > readability.
> >
> > lustre commonly u
On Wed, Jun 14, 2017 at 11:01:20AM -0400, James Simmons wrote:
> -void ldlm_extent_policy_wire_to_local(const union ldlm_wire_policy_data
> *wpolicy,
> - union ldlm_policy_data *lpolicy)
> +void
> +ldlm_extent_policy_wire_to_local(const union ldlm_wire_policy_data
On Thu, Jun 15, 2017 at 05:17:12PM +0800, Gao Zhuang wrote:
> Clip longer than 80 chars lines.
> Fix more "80 char" warnings than [PATCH v1].
> Keep 4 "80 char" warnings for readability.
This text makes no sens to me at all sorry. Please read how to properly
version your patches and write a chang
On Wed, Jun 14, 2017 at 11:01:21AM -0400, James Simmons wrote:
> Cleanup all braces that was reported by checkpatch. The only
> issue not fixed up is in mdc_lock.c. Removing the braces in
> the case of mdc_lock.c will break the build.
>
> Signed-off-by: James Simmons
> ---
> drivers/staging/lust
On Thu, Jun 15, 2017 at 10:28:47AM +0530, bincy_k_phi...@yahoo.co.in wrote:
> From: bincy k philip
Please use Capital Letters for your name.
>
> trivial fix for extra space error
>
> Signed-off-by: bincy k philip
> ---
> drivers/staging/octeon-usb/octeon-hcd.c | 2 +-
> 1 file changed, 1 ins
On Thu, Jun 15, 2017 at 01:04:55AM +0530, srishti sharma wrote:
> Fixed alignment so that it matched open parenthesis.
>
> Signed-off-by: srishti sharma
> ---
> .../staging/vc04_services/bcm2835-audio/bcm2835-ctl.c | 18
> +-
> 1 file changed, 9 insertions(+), 9 deletions(-)
W
On Thu, Jun 22, 2017 at 04:36:56PM +0300, Gilad Ben-Yossef wrote:
> Fix a bug where the transformation init code did
> not register a setkey method for none hash based MACs.
"none hash based MACs"? Is that the correct language, I don't
understand it, sorry, can you expand on it a bit in your v3 s
On Thu, Jun 22, 2017 at 04:36:57PM +0300, Gilad Ben-Yossef wrote:
> Add support for the older CryptoCell 710 and 630P hardware revisions.
No, I do not want to add new features to staging drivers where ever
possible. I want you to spend your time fixing up the code to be good
enough to get it out
On Thu, Jun 22, 2017 at 04:36:59PM +0300, Gilad Ben-Yossef wrote:
> Some SoC which implement CryptoCell have a dedicated clock
> tied to it, some do not. Implement clock support if exists
> based on device tree data and tie power management to it.
>
> Signed-off-by: Gilad Ben-Yossef
> ---
> driv
On Wed, Jun 21, 2017 at 05:49:32PM +0530, simran singhal wrote:
> Use the current logging style.
> Coalesce formats where appropriate.
>
> Signed-off-by: simran singhal
> ---
> drivers/staging/rtl8192u/ieee80211/ieee80211_rx.c | 34
> ++-
> 1 file changed, 14 insertions(+),
On Sat, Jun 17, 2017 at 03:26:32PM +1200, Derek Robson wrote:
> Fixed checkpatch.pl warnings of "function definition argument FOO should
> also have an identifier name"
> Found using checkpatch
>
> Signed-off-by: Derek Robson
>
> V1 had vauge subjet
v2 does as well :(
Also this V1 line needs t
Hm. For some reason the great mail filtering scheme decided to push
this past my inbox :-/
On Sat, Jun 17, 2017 at 12:44 AM, Joe Perches wrote:
> On Fri, 2017-06-16 at 19:45 +0200, Frans Klaver wrote:
>> The header field in struct pd_message is declared as an __le16 type. The
>> data in the messa
On Fri, Jun 16, 2017 at 12:05 PM, Jaya Durga wrote:
> when building with make C=1 CF=-D__CHECK_ENDIAN__
>
> drivers/staging/wlan-ng/hfa384x_usb.c:3383:36: warning: cast to restricted
> __le16
>
> fixed by using the le16_to_cpus function.
>
> Signed-off-by: Jaya Durga
> ---
> drivers/staging/wla
On Sat, 24 Jun 2017, Frans Klaver wrote:
> Hm. For some reason the great mail filtering scheme decided to push
> this past my inbox :-/
>
> On Sat, Jun 17, 2017 at 12:44 AM, Joe Perches wrote:
> > On Fri, 2017-06-16 at 19:45 +0200, Frans Klaver wrote:
> >> The header field in struct pd_message
On Fri, Jun 23, 2017 at 9:50 PM, Greg KH wrote:
> On Thu, Jun 15, 2017 at 01:04:55AM +0530, srishti sharma wrote:
>> Fixed alignment so that it matched open parenthesis.
>>
>> Signed-off-by: srishti sharma
>> ---
>> .../staging/vc04_services/bcm2835-audio/bcm2835-ctl.c | 18
>> +---
Fixed alignment so that it matched open parenthesis.
Signed-off-by: srishti sharma
---
Changes in v2:
-Fix all checks of the type "alignment should match open parenthesis" for a
file in the same patch.
.../staging/vc04_services/bcm2835-audio/bcm2835-ctl.c | 18 +-
1 file chan
On Sat, Jun 24, 2017 at 8:11 AM, srishti sharma wrote:
> On Fri, Jun 23, 2017 at 9:50 PM, Greg KH wrote:
>> On Thu, Jun 15, 2017 at 01:04:55AM +0530, srishti sharma wrote:
>>> Fixed alignment so that it matched open parenthesis.
>>>
>>> Signed-off-by: srishti sharma
>>> ---
>>> .../staging/vc04
Hi Gilad,
[auto build test WARNING on staging/staging-testing]
[also build test WARNING on next-20170623]
[cannot apply to v4.12-rc6]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux/commits/Gilad-Ben
35 matches
Mail list logo