Replace CamelCase variable name with underscores to comply
with the standard kernel coding style.
Signed-off-by: Janusz Lisiecki
---
drivers/staging/ks7010/ks_hostif.c | 26 +-
drivers/staging/ks7010/ks_hostif.h | 2 +-
2 files changed, 14 insertions(+), 14 deletions(-)
Replace CamelCase local variables' name with underscores to comply
with the standard kernel coding style.
Changed:
- LinkSpeed
- TransmittedFrameCount
- ReceivedFragmentCount
- FailedCount
- FCSErrorCount
Signed-off-by: Janusz Lisiecki
---
drivers/staging/ks7010/ks_hostif.c | 33
Fixes a sparse warning:
drivers/staging/media/atomisp/platform/intel-mid/intel_mid_pcihelpers.c:35:5:
warning: symbol 'qos' was not declared. Should it be static?
Signed-off-by: Valentin Vidic
---
drivers/staging/media/atomisp/platform/intel-mid/intel_mid_pcihelpers.c | 1 -
1 file changed, 1
On 05/07/2017 08:47 AM, Riccardo Marotti wrote:
> From: Riccardo
>
> Fixed a brace coding style issue, found via checkpatch.
>
> Signed-off-by: Riccardo Marotti
> ---
> drivers/staging/rtl8192u/ieee80211/ieee80211_module.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --g
Fixed a brace coding style issue, found via checkpatch.
Signed-off-by: Riccardo Marotti
---
drivers/staging/rtl8192u/ieee80211/ieee80211_module.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_module.c
b/drivers/staging/rtl8192
Fix sparse warning "warning: Variable length array is used." by using
kmalloc_array to allocate the required amount of memory instead and
kfree to deallocate memory after use.
Signed-off-by: Guru Das Srinagesh
---
v2:
- Added missing check for NULL return value of kmalloc_array()
drivers/st
Fix sparse warning "warning: Variable length array is used." by using
kmalloc_array to allocate the required amount of memory instead and
kfree to deallocate memory after use.
Signed-off-by: Guru Das Srinagesh
---
v3:
- Fixed checkpatch warning: Comparison to NULL could be written "!fullname"
A kernel cloned from
git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git and
built with the latest RTL8723BS driver included (CONFIG_RTL8723BS=m)
fails when booting on an Intel Atom device with the RTL8723BS wifi
chipset due to an error in
drivers/staging/rtl8723bs/os_dep/ioctl_cf
On Sat, 6 May 2017 20:20:57 -0700
Greg KH wrote:
> On Fri, May 05, 2017 at 02:00:43AM +0800, Jamie Huang wrote:
> > ERROR: Macros with multiple statements should be enclosed in a do -
> > while loop Detected by scripts/checkpatch.pl -f
> >
> > Signed-off-by: Jamie Huang
> > ---
> > drivers/sta
Hi Greg,
On Sun, May 7, 2017 at 4:32 AM, Greg KH wrote:
> On Wed, May 03, 2017 at 01:12:40PM +0100, Salvatore Benedetto wrote:
>> Fix all CODE_INDENT type errors reported by checkpatch
>> in rtxt.c
>>
>> Signed-off-by: Salvatore Benedetto
>> ---
>> drivers/staging/vt6656/rxtx.c | 49
>> +++
On Sun, May 07, 2017 at 11:23:26AM +0100, salvatore benedetto wrote:
> Hi Greg,
>
> On Sun, May 7, 2017 at 4:32 AM, Greg KH wrote:
> > On Wed, May 03, 2017 at 01:12:40PM +0100, Salvatore Benedetto wrote:
> >> Fix all CODE_INDENT type errors reported by checkpatch
> >> in rtxt.c
> >>
> >> Signed-o
On 05/05/17 01:38, Brian Masney wrote:
> This patch renames the tsl2x7x_core.c file to tsl2x7x.c so that the
> naming convention is consistent with other IIO light drivers outside
> of staging.
>
> Signed-off-by: Brian Masney
Applied to the togreg branch of iio.git and pushed out as testing
for t
On 05/05/17 01:38, Brian Masney wrote:
> There is a tsl2x7x.h header that is only used by tsl2x7x.c. This patch
> moves the contents of the header file into the C code with the driver.
>
> Signed-off-by: Brian Masney
> ---
> drivers/staging/iio/light/tsl2x7x.c | 76 ++-
>
On 04/05/17 21:38, Enric Balletbo i Serra wrote:
> Do not include the paragraph about writing to the Free Software
> Foundation's mailing address from the sample GPL notice. The FSF
> has changed addresses in the past, and may do so again. Linux
> already includes a copy of the GPL.
>
> Signed-off
On 04/05/17 21:38, Enric Balletbo i Serra wrote:
> Fix the output from checkpatch.pl like:
> Symbolic permissions 'S_IRUSR' are not preferred.
> Consider using octal permissions '0400'.
>
> Also fix the alignment DEVICE_ATTR variables as should match open
> parenthesis.
>
> Signed-off-by: Enr
On Sat, Apr 08, 2017 at 08:32:36PM +0200, Guillaume Brogi wrote:
> On Sat, Apr 08, 2017 at 12:31:25PM +0200, Greg Kroah-Hartman wrote:
> > On Sun, Mar 26, 2017 at 12:24:14AM +0100, Guillaume Brogi wrote:
> > >
> > > This patch fixes the following sparse warnings:
> > > drivers/staging/rtl8192u/r81
I work for Arm on maintaining the TrustZone CryptoCell driver.
Signed-off-by: Gilad Ben-Yossef
---
The original patch went out with the patch set introducing the ccree
driver but somehow failed to end up in Linus's tree, maybe because
I omitted the "staging:" prefix.
---
MAINTAINERS | 8 ++
Fix all PARENTHESIS_ALIGNMENT type errors reported by checkpatch
in rtxt.c
Signed-off-by: Salvatore Benedetto
---
drivers/staging/vt6656/rxtx.c | 70 +++
1 file changed, 37 insertions(+), 33 deletions(-)
diff --git a/drivers/staging/vt6656/rxtx.c b/driver
Remove useless and wrong min/max macros.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_crypto_ctx.h | 6 --
1 file changed, 6 deletions(-)
diff --git a/drivers/staging/ccree/cc_crypto_ctx.h
b/drivers/staging/ccree/cc_crypto_ctx.h
index 31ccf51..216d247 100644
--- a/drivers/s
The patchset includes various code cleanups for the ccree driver:
- Clean several checpatch errors and warnings
- Remove internal HW testing code not relevant for upstream
The patch set should be applied on top of 'commit 9c0223832982
("staging:r8188eu: remove unused definitions from include/ieee8
Remove a bunch of cruft being used in HW debugging but not useful
or compiled for driver use or development.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_bitops.h | 27
drivers/staging/ccree/cc_hw_queue_defs.h | 36 -
drivers/staging/ccree/cc_pal_log.h
Replace open coded struct zeroing with a memset call.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_hw_queue_defs.h | 9 +
1 file changed, 1 insertion(+), 8 deletions(-)
diff --git a/drivers/staging/ccree/cc_hw_queue_defs.h
b/drivers/staging/ccree/cc_hw_queue_defs.h
inde
Drop uneeded include guard for __KERNEL__.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_lli_defs.h | 6 ++
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/ccree/cc_lli_defs.h
b/drivers/staging/ccree/cc_lli_defs.h
index d9758e6..c84b142 100644
--
Move from stdint style int_t/uint_t to kernel style u/s types.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_crypto_ctx.h| 75 +-
drivers/staging/ccree/cc_hw_queue_defs.h | 57 ++
drivers/staging/ccree/cc_lli_defs.h | 10 +--
drivers/staging
Fix checkpatch reported white space style violations
in cc_hw_queue_defs.h
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_hw_queue_defs.h | 82 +++-
1 file changed, 38 insertions(+), 44 deletions(-)
diff --git a/drivers/staging/ccree/cc_hw_queue_defs.h
The MSB64 is defined in two include file. One copy
is sufficient.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_lli_defs.h | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/ccree/cc_lli_defs.h
b/drivers/staging/ccree/cc_lli_defs.h
index 8c978b1..d9758e6 100644
Fix checkpatch reported white space style violations
in cc_lli_defs.h
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_lli_defs.h | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/staging/ccree/cc_lli_defs.h
b/drivers/staging/ccree/cc_lli_defs.h
index 75
Fix various checkpatch warnings and errors in LLI macro definitions
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_lli_defs.h | 28
1 file changed, 20 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/ccree/cc_lli_defs.h
b/drivers/staging/ccr
Fix enum and struct definition coding style by removing uneeded typedef and
s/CamelCase/snake_case/g.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_hw_queue_defs.h | 54 +++-
drivers/staging/ccree/ssi_aead.c | 54
Fix for warnings reported by checkpatch.pl:
- Multiline comment style
- Bare "unsigned"
- Missing blank line after declarations
- Un-needed braces around single-statement branch
Signed-off-by: Avraham Shukron
---
.../platform/intel-mid/atomisp_gmin_platform.c | 45 ++
Fix for error (not warnings) reported by checkpatch.pl
Specifically:
- missing whitespace around "=" and after ","
- indentation with spaces instead of tabs
- lines starting with a whitespace
This patch does not affect the compiled code in any way.
Signed-off-by: Avraham Shukron
---
.../plat
Fixed coding style issue
Signed-off-by: Jaya Durga
---
drivers/staging/rtl8712/ieee80211.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/rtl8712/ieee80211.c
b/drivers/staging/rtl8712/ieee80211.c
index 512bf16..66d9daf 100644
--- a/drivers/staging
The driver attempts to alter memory that is mapped to PCI device.
This is because tx_fwinfo_8190pci points to skb->data.
Move the pci_map_single to when completed buffer is ready to be mapped with
psdec is empty to drop on mapping error.
Fixes slow operation and tx queue fails.
Signed-off-by: M
EPROM_CMD is 2 byte aligned on PCI map so calling with rtl92e_readl
will return invalid data so use rtl92e_readw.
The device is unable to select the right eeprom type.
Signed-off-by: Malcolm Priestley
Cc:
---
drivers/staging/rtl8192e/rtl8192e/r8192E_dev.c | 2 +-
1 file changed, 1 insertion(+)
BSSID has two byte alignment on PCI ioremap correct the write
by swapping to 16 bits first.
This fixes a problem that the device associates fail because
the filter is not set correctly.
Signed-off-by: Malcolm Priestley
Cc:
---
drivers/staging/rtl8192e/rtl8192e/r8192E_dev.c | 9 +
1 fil
Fixed coding style issue
Signed-off-by: Jaya Durga
---
drivers/staging/rtl8712/ieee80211.c | 7 ---
drivers/staging/rtl8712/rtl871x_ioctl_linux.c | 25 +
drivers/staging/rtl8712/rtl871x_ioctl_rtl.c | 9 -
drivers/staging/rtl8712/rtl871x_mlme.c
Closing braces should match the first characters of the opening.
Signed-off-by: Geert Uytterhoeven
---
drivers/staging/ccree/ssi_hash.c | 28 ++--
1 file changed, 14 insertions(+), 14 deletions(-)
diff --git a/drivers/staging/ccree/ssi_hash.c b/drivers/staging/ccree/ssi_
With gcc 4.1.2:
drivers/staging/ccree/ssi_hash.c:1990: error: unknown field
‘template_ahash’ specified in initializer
drivers/staging/ccree/ssi_hash.c:1991: error: unknown field ‘init’
specified in initializer
drivers/staging/ccree/ssi_hash.c:1991: warning: missing braces around
ini
From: Markus Elfring
Date: Sun, 7 May 2017 22:07:16 +0200
A single character (line break) should be put into a sequence.
Thus use the corresponding function "seq_putc".
This issue was detected by using the Coccinelle software.
Signed-off-by: Markus Elfring
---
drivers/android/binder.c | 2 +-
Fix sparse warnings: "symbol not declared; should it be static?"
Signed-off-by: Guru Das Srinagesh
---
drivers/staging/media/atomisp/pci/atomisp2/atomisp_fops.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/media/atomisp/pci/atomisp2/atomisp_f
On Sun, May 07, 2017 at 04:24:51PM -0700, Joe Perches wrote:
> On Sun, 2017-05-07 at 02:23 -0700, Guru Das Srinagesh wrote:
> > Fix sparse warning "warning: Variable length array is used." by using
> > kmalloc_array to allocate the required amount of memory instead and
> > kfree to deallocate memor
On Sun, 2017-05-07 at 02:23 -0700, Guru Das Srinagesh wrote:
> Fix sparse warning "warning: Variable length array is used." by using
> kmalloc_array to allocate the required amount of memory instead and
> kfree to deallocate memory after use.
[]
> diff --git a/drivers/staging/lustre/lustre/llite/xa
On Mon, 2017-05-08 at 00:45 +0530, Jaya Durga wrote:
> Fixed coding style issue
Please list the various renames you are doing.
BeaconPeriod-> beacon_period
DSConfig-> ds_config
ATIMWindow -> atim_window
etc...
And it's generally better to do these while avoiding
changing line b
All below warnings are found and fixed by checkpatch.pl:
CHECK: struct mutex definition without comment
CHECK: Alignment should match open parenthesis
WARNING: Symbolic permissions 'S_IWUSR | S_IRUGO' are not preferred.
Below errors are false positives:
ade7753.c:382: ERROR: Use 4 digit octal (077
This patch set fixes various endian issues. Sparse was used to discover these
issues and also to check the fixes.
Patch 01 fixes the EAP header structure descriptions.
Patches 2 and 3 fix descriptions for SDIO structures used as headers
when building frames to pass to the SDIO device.00
Code is
Sparse emits warning: cast to restricted __be16. EAP header uses
network byte order. The structures used to describe it should use
__beXX data types.
Change data type unsigned short -> __be16.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/eap_packet.h | 4 ++--
1 file changed, 2 in
Target device is little endian. Host interface data structures used
for building frames to pass to target device should use little endian
data types. All u16 structure members in ks_hostif.h need to be
changed to __le16, Sparse can then be used to make sure we update all
code that touches these dat
Target device is little endian. Host interface data structures used
for building frames to pass to target device should use little endian
data types. All u32 structure members in ks_hostif.h need to be
changed to __le32.
Change all u16 data types in host interface structures to be
__le32.
Signed-
On Mon, May 08, 2017 at 12:16:17AM -0400, Harinath Nampally wrote:
> All below warnings are found and fixed by checkpatch.pl:
> CHECK: struct mutex definition without comment
> CHECK: Alignment should match open parenthesis
> WARNING: Symbolic permissions 'S_IWUSR | S_IRUGO' are not preferred.
You
On Mon, May 08, 2017 at 01:38:47AM -0400, harinath Nampally wrote:
> Hi Greg,
>
> Thank you so much for your time to review.
> Sure I will break up into multiple patches and create patch series.
> But I wonder 'one thing' per patch means one kind of warnings per patch?
Yes it does.
> For exampl
kernel coding style doesn't allow the return statement
in void function.
Signed-off-by: Surender Polsani
---
Changes for v2:
corrected subject line as suggested
Changes for v3:
modified from line as suggested by Greg KH
placed a semicolon in label for fixing build error
Changes for v4:
changes ma
On Mon, May 08, 2017 at 11:22:35AM +0530, Surender Polsani wrote:
> kernel coding style doesn't allow the return statement
> in void function.
>
> Signed-off-by: Surender Polsani
> ---
> Changes for v2:
> corrected subject line as suggested
> Changes for v3:
> modified from line as suggested by G
On Mon, 2017-05-08 at 07:59 +0200, Greg KH wrote:
> On Mon, May 08, 2017 at 11:22:35AM +0530, Surender Polsani wrote:
> > kernel coding style doesn't allow the return statement
> > in void function.
> >
> > Signed-off-by: Surender Polsani
> > ---
> > Changes for v2:
> > corrected subject line as
53 matches
Mail list logo