Fixing warnings found by sparse on rtl8192u/ieee80211.
drivers/staging/rtl8192u/ieee80211//ieee80211_rx.c:1318:45: warning: incorrect
type in assignment (different base types)
drivers/staging/rtl8192u/ieee80211//ieee80211_rx.c:1318:45:expected
unsigned short [unsigned] [usertype] len
drivers
Hi,
On 10-04-17 21:52, Greg Kroah-Hartman wrote:
On Mon, Apr 10, 2017 at 09:02:36PM +0200, Hans de Goede wrote:
Hi,
On 09-04-17 21:06, Greg Kroah-Hartman wrote:
On Sun, Apr 09, 2017 at 11:40:15AM +0200, Hans de Goede wrote:
Hi,
On 09-04-17 11:37, Greg Kroah-Hartman wrote:
On Sun, Apr 09, 2
From: Colin Ian King
trivial fix to spelling mistake in pr_info message
Signed-off-by: Colin Ian King
---
drivers/staging/rtl8723bs/hal/rtl8723b_hal_init.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8723bs/hal/rtl8723b_hal_init.c
b/drivers/staging/r
From: Markus Elfring
Date: Tue, 11 Apr 2017 14:54:35 +0200
The use of the logging function "dev_err" was introduced here on 2016-09-26.
I find the following implementation details worth for another look.
* Reduce expressions for the first input parameter "dev".
* Omit an extra module prefix in
From: Colin Ian King
Fix a few spelling mistakes in RT_TRACE messages and split up
wide lines to span multiple lines
Signed-off-by: Colin Ian King
---
drivers/staging/rtl8723bs/core/rtw_ioctl_set.c | 4 +++-
drivers/staging/rtl8723bs/core/rtw_mlme_ext.c | 4 +++-
drivers/staging/rtl8723bs/os_
On Mon, Apr 10, 2017 at 01:15:41PM +1000, Tobin C. Harding wrote:
> Driver uses identifier 'rc' to hold the value for error return
> code. The rest of the driver predominately uses 'ret' for this
> purpose. It is easier to follow the code if one name is used for one
> task.
>
> Rename identifier '
On Sun, Apr 09, 2017 at 12:25:25AM +0100, Andrea della Porta wrote:
> Fixed unaligned function parameters issues, as per checkpatch warning
>
> Signed-off-by: Andrea della Porta
> ---
> Changes in v3:
> - rebased on staging-testing
>
> .../vc04_services/bcm2835-audio/bcm2835-pcm.c | 43
>
On Sun, Apr 09, 2017 at 12:25:44AM +0100, Andrea della Porta wrote:
> Fixed checkpatch warning about line over 80 chars
But it's still over 80 chars...
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/li
Change the config packet format used in handle_set_wfi_drv_handler()
to align the host driver with the new format used in the wilc firmware.
The change updates the format in which the host driver provides the
firmware with the drv_handler index and also uses two new
fields viz. "mode" and 'name" i
On 04/10/2017 11:47 PM, Laurent Pinchart wrote:
> Hi Laura,
>
> Thank you for the patch.
>
> On Monday 03 Apr 2017 11:57:55 Laura Abbott wrote:
>> When CMA was first introduced, its primary use was for DMA allocation
>> and the only way to get CMA memory was to call dma_alloc_coherent. This
>> pu
On Tue, Apr 11, 2017 at 10:11:43PM +0530, Aditya Shankar wrote:
> Change the config packet format used in handle_set_wfi_drv_handler()
> to align the host driver with the new format used in the wilc firmware.
So does this break devices with "old" firmware?
Where is the "new" firmware? What is en
Hi,
recently i found that vchiq_test -f doesn't work anymore with current mainline
(4.11-rc6) and linux-next (20170404) on my Raspberry Pi Zero. The issue is
always reproducible, but the error behavior isn't deterministic. Sometimes
vchiq_test hangs and sometimes i get an error message from vch
On Sat, Apr 8, 2017 at 1:58 PM, Deepa Dinamani wrote:
>> I have no problem merging this patch into audit/next for v4.12, would
>> you prefer me to do that so at least this patch is merged?
>
> This would be fine.
> But, I think whoever takes the last 2 deletion patches should also take them.
> I'm
From: Colin Ian King
char array cmd is being scanned in using a %4s scanf format
specifier and so cmd must be an array of 5 chars. Increase size
to 5 chars to ensure we don't have an overflow.
Detected with static analysis by cppcheck:
"(error) Width 4 given in format string (no. 1) is larger t
On Sun, Apr 09, 2017 at 02:47:45PM +0100, alfonsolimaas...@gmail.com wrote:
> On Sat, Apr 01, 2017 at 09:24:58AM +0200, Sebastian Haas wrote:
> > Hi Alfonso,
> >
> > On Wed, Mar 29, 2017 at 07:50:11PM +0100, alfonsolimaas...@gmail.com wrote:
> > > diff --git a/drivers/staging/rtl8188eu/include/odm
On Tue, Apr 11, 2017 at 03:15:32PM +0200, SF Markus Elfring wrote:
> From: Markus Elfring
> Date: Tue, 11 Apr 2017 14:54:35 +0200
>
> The use of the logging function "dev_err" was introduced here on 2016-09-26.
>
> I find the following implementation details worth for another look.
> * Reduce ex
On Tue, Apr 11, 2017 at 04:03:07PM +0200, Greg Kroah-Hartman wrote:
> On Mon, Apr 10, 2017 at 01:15:41PM +1000, Tobin C. Harding wrote:
> > Driver uses identifier 'rc' to hold the value for error return
> > code. The rest of the driver predominately uses 'ret' for this
> > purpose. It is easier to
Driver SDIO code initializes a completion that is never used. It can
be safely removed.
Remove unused completion.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sdio.c | 1 -
drivers/staging/ks7010/ks7010_sdio.h | 1 -
2 files changed, 2 deletions(-)
diff --git a/drivers/sta
Driver SDIO private data structure description includes a spin_lock
that is never used. This data structure only contains a pointer to the
sdio_func and a pointer to the main device private data. A spin_lock
is not required here.
Remove unused spin_lock.
Signed-off-by: Tobin C. Harding
---
driv
The purpose of this patch set is to improve the readability of the
SDIO code within the driver. There are no changes to functionality
introduced by this series.
The ks7010 driver currently implements the WEXT interface. Currently,
wi-fi kernel drivers are expected to use the CFG80211 interface. Th
Driver SDIO code allocates memory for a buffer that is never used. It
can be safely removed.
Remove unused buffer, including allocation and freeing of memory.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sdio.c | 14 +++---
drivers/staging/ks7010/ks7010_sdio.h | 1
Driver SDIO header describes a structure that is never used. It can be
safely removed.
Remove unused structure description.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sdio.h | 6 --
1 file changed, 6 deletions(-)
diff --git a/drivers/staging/ks7010/ks7010_sdio.h
b/d
struct work_struct uses identifier ks_wlan_wakeup_task, this is
confusing because the 'task' suffix implies that this is a
tasklet_struct instead of a work struct. Suffix 'work' would be more
clear. The code would be easier to read if it followed the principle
of least surprise and used the 'work'
When declaring a function with a function pointer as parameter, having
the parameters to the function pointer prototype with explicit
identifiers does not add that much extra meaning to the code. In this
case the identifiers are 'arg1' and 'arg2', these definitely do not
add extra meaning to the co
Currently a pointer to the tasklet_struct used for bottom half
processing on the receive path is within the hw_info_t structure. This
structure is then embedded in the device private data
structure. Having the tasklet_struct nested does not add meaning to
the device private data, device private dat
SDIO header file does not use kernel doc format struct
comments. Adding them aids readability and enables documentation to be
built from the source code. Other comments may be tidied up as we do this.
Add kernel format struct comments. Tidy up comments.
Signed-off-by: Tobin C. Harding
---
drive
Header has multiple constants defined using preprocessor
directive. In the cases where these are an integer progression an
enumeration type can be used. Doing so adds documentation to the code
and makes the usage explicit.
Replace (integer progression) preprocessor constants with enumeration type.
SDIO code currently has a number of unneeded comments. Following
kernel coding style we do not need extraneous comments, especially on
code where it is clear what is being done. Spelling typos can be
fixed.
Remove unnecessary comments, fix typos in comments.
Signed-off-by: Tobin C. Harding
---
Currently driver uses a hardware information struct description to
group some SDIO related functionality (work, work queue, sdio private
data pointer). This structure is then embedded in the device private
data structure. Having nested structures described in different header
files means that to vi
goto label includes 'err_' suffix but is executed on non-error paths.
Remove err_ suffix from goto label.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sdio.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/ks7010/ks7010_sdio.c
ks_sdio_card structure description does not have a kernel doc format
comment.
Add kernel doc format comment to struct ks_sdio_card.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sdio.h | 8
1 file changed, 8 insertions(+)
diff --git a/drivers/staging/ks7010/ks7010_
Checkpatch emits CHECK: Please don't use multiple blank lines.
Remove multiple blank lines.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sdio.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/ks7010/ks7010_sdio.c
b/drivers/staging/ks7010/ks7010_sdio.c
in
Checkpatch emits WARNING: please, no space before tabs.
Remove space before tabs.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sdio.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ks7010/ks7010_sdio.c
b/drivers/staging/ks7010/ks7010_sd
Driver SDIO code is currently in files name ks7010_sdio.[ch]. These
names are not uniform with the rest of the files in this driver. This
driver only covers a single chipset, the file prefix does not add any
extra information. Other in-tree SDIO drivers typically call these
files sdio.[ch]. This is
Checkpatch emits WARNING: quoted string split across lines.
Concatenate string onto single line.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sdio.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/ks7010/ks7010_sdio.c
b/drivers/stagi
Driver SDIO code uses helper functions to do IO to the SDIO
device. Current helpers handle IO of a single byte as well as
multi-byte. Driver predominately uses single byte IO. If the
common case is made simple it simplifies the whole driver. The common
case can be made simple by splitting the multi
On 04/04/2017 05:47 AM, Sakari Ailus wrote:
Hi Steve, Philipp and Pavel,
On Mon, Mar 27, 2017 at 05:40:34PM -0700, Steve Longerbeam wrote:
From: Philipp Zabel
This driver can handle SoC internal and external video bus multiplexers,
controlled either by register bit fields or by a GPIO. The
$ make versioncheck | grep staging
./drivers/staging/greybus/light.c: 15 linux/version.h not needed.
Signed-off-by: Darryl T. Agostinelli
---
drivers/staging/greybus/light.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/greybus/light.c b/drivers/staging/greybus/l
$ make versioncheck | grep staging
./drivers/staging/lustre/lustre/include/lustre/lustre_user.h: 49
linux/version.h not needed.
Signed-off-by: Darryl T. Agostinelli
---
drivers/staging/lustre/lustre/include/lustre/lustre_user.h | 1 -
1 file changed, 1 deletion(-)
diff --git a/driv
$ make versioncheck | grep staging
./drivers/staging/media/atomisp/pci/atomisp2/atomisp_internal.h: 331: need
linux/version.h
Signed-off-by: Darryl T. Agostinelli
---
drivers/staging/media/atomisp/pci/atomisp2/atomisp_internal.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/dr
$ make versioncheck | grep staging
./drivers/staging/rtl8723bs/include/drv_types.h: 25 linux/version.h not
needed.
Signed-off-by: Darryl T. Agostinelli
---
drivers/staging/rtl8723bs/include/drv_types.h | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/rtl8723bs/incl
$ make versioncheck | grep staging
./drivers/staging/rtl8723bs/include/ioctl_cfg80211.h: 18 linux/version.h
not needed.
Signed-off-by: Darryl T. Agostinelli
---
drivers/staging/rtl8723bs/include/ioctl_cfg80211.h | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/rt
$ make includecheck | grep staging
./drivers/staging/rtl8723bs/include/drv_types.h: rtw_efuse.h is included
more than once.
Signed-off-by: Darryl T. Agostinelli
---
drivers/staging/rtl8723bs/include/drv_types.h | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/rtl87
$ make includecheck | grep staging
./drivers/staging/greybus/uart.c: linux/serial.h is included more than once.
Signed-off-by: Darryl T. Agostinelli
---
drivers/staging/greybus/uart.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/greybus/uart.c b/drivers/staging/
From: Skanda Guruanand
Sparse generates warnings where cast to restricted types are made.
This commit changes types of struct fields to match endianness.
Signed-off-by: Skanda Guruanand
---
I have modified struct lu_dirpage in lustre_idl.h file to remove the sparse
warnings
where cast to restr
Attention!
I am General Attorney to the (IMF) INTERNATIONAL MONITORY FUND OF (ECOWAS)
AUTHORITY) And We wish to inform you that a power of attorney was forwarded to
our office this morning by two gentlemen, one of them is an American national
and he is Mr. David W. Deane by name while the other
On Tue, Apr 11, 2017 at 11:01:15PM -0500, Darryl T. Agostinelli wrote:
> $ make versioncheck | grep staging
> ./drivers/staging/greybus/light.c: 15 linux/version.h not needed.
>
> Signed-off-by: Darryl T. Agostinelli
Why is everything indented here?
And your subject lines can be imp
On Tue, Apr 11, 2017 at 09:22:37PM -0700, skanda.kash...@gmail.com wrote:
> From: Skanda Guruanand
Your subject is odd, please match other commits made for this driver
when you resend it.
> Sparse generates warnings where cast to restricted types are made.
> This commit changes types of struct f
On Tue, Apr 11, 2017 at 11:19:51PM -0500, Darryl T. Agostinelli wrote:
> $ make includecheck | grep staging
> ./drivers/staging/rtl8723bs/include/drv_types.h: rtw_efuse.h is included
> more than once.
>
> Signed-off-by: Darryl T. Agostinelli
Same thing goes for this series as well..
49 matches
Mail list logo