On 31/03/17 11:21, simran singhal wrote:
> Change the name of function from adis16060_spi_write_than_read()
> to adis16060_spi_write_then_read(). change "than" to "then" as
> its time depended.
>
> Signed-off-by: simran singhal
Applied.
> ---
>
> v2:
>-Change the subject.
>-Add signed-o
On 31/03/17 16:08, simran singhal wrote:
> Some type conversions like casting a pointer to a pointer of same type,
> casting to the original type using addressof(&) operator etc. are not
> needed. Therefore, remove them. Done using coccinelle:
Please write a more specific commit message. No where
On 31/03/17 16:08, simran singhal wrote:
> Some type conversions like casting a pointer to a pointer of same type,
> casting to the original type using addressof(&) operator etc. are not
> needed. Therefore, remove them. Done using coccinelle:
>
> @@
> type t;
> t *p;
> t a;
> @@
> (
> - (t)(a)
>
On 31/03/17 16:08, simran singhal wrote:
> Some type conversions like casting a pointer to a pointer of same type,
> casting to the original type using addressof(&) operator etc. are not
> needed. Therefore, remove them. Done using coccinelle:
>
> @@
> type t;
> t *p;
> t a;
> @@
> (
> - (t)(a)
>
On 31/03/17 03:47, Arushi Singhal wrote:
> The driver needs to insure atomicity during frequency
> changes of bus and device. The iiodev->mlock as used
> was not doing that. Replace it with the drivers existing
> buffer lock and execute spi_write directly.
>
> Signed-off-by: Arushi Singhal
Firstl
On 30/03/17 10:55, Guru Das Srinagesh wrote:
> This fixes the coding style issue of using S_IWUSR in place of 4-digit
> octal numbers.
>
> Issue detected by checkpatch.
>
> Signed-off-by: Guru Das Srinagesh
Applied to the togreg branch of iio.git and pushed out as testing
for the autobuilders to
See patch title. Check the part number...
On 29/03/17 09:36, Andrea della Porta wrote:
> Fixed the followinf checkpatch warning:
> WARNING: braces {} are not necessary for single statement blocks
> #258: FILE: drivers/staging/iio/accel/adis16209.c:258:
> + if (ret) {
> +
rtw_software_encrypt used only once and does not changed.
Replace it with 0.
Signed-off-by: Ivan Safonov
---
drivers/staging/rtl8188eu/os_dep/os_intfs.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/staging/rtl8188eu/os_dep/os_intfs.c
b/drivers/staging/rtl8188eu
rtw_software_decrypt used only once and does not changed.
Replace it with 0.
Signed-off-by: Ivan Safonov
---
drivers/staging/rtl8188eu/os_dep/os_intfs.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8188eu/os_dep/os_intfs.c
b/drivers/staging/rtl8188eu/
Value of this variable has no changes, and used once.
Replace software_decrypt with its value.
Signed-off-by: Ivan Safonov
---
drivers/staging/rtl8188eu/include/drv_types.h | 1 -
drivers/staging/rtl8188eu/os_dep/os_intfs.c | 3 +--
2 files changed, 1 insertion(+), 3 deletions(-)
diff --git a
Value of this variable does not changed after initialization.
Replace software_encrypt with its default value.
Signed-off-by: Ivan Safonov
---
drivers/staging/rtl8188eu/include/drv_types.h | 1 -
drivers/staging/rtl8188eu/os_dep/os_intfs.c | 3 +--
2 files changed, 1 insertion(+), 3 deletions(
sw_encrypt always is 0. Replace sw_encrypt with 0.
Signed-off-by: Ivan Safonov
---
drivers/staging/rtl8188eu/core/rtw_xmit.c| 10 --
drivers/staging/rtl8188eu/hal/rtl8188eu_xmit.c | 3 +--
drivers/staging/rtl8188eu/include/rtw_security.h | 1 -
drivers/staging/rtl8188eu/os_de
sw_decrypt always is 0, so replace it with 0.
Signed-off-by: Ivan Safonov
---
drivers/staging/rtl8188eu/core/rtw_recv.c| 4 ++--
drivers/staging/rtl8188eu/include/rtw_security.h | 1 -
drivers/staging/rtl8188eu/os_dep/os_intfs.c | 1 -
3 files changed, 2 insertions(+), 4 deletions(-
$ make includecheck
./drivers/staging/lustre/lustre/ptlrpc/layout.c: ../include/lustre_debug.h is
included more than once.
Signed-off-by: Darryl T. Agostinelli
---
drivers/staging/lustre/lustre/ptlrpc/layout.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/lustre/lustre/ptlr
From: Dan Cashman
Address checkpatch errors encountered in rf.c by removing use of spaces
and replacing with properly aligned tabs.
Signed-off-by: Daniel Cashman
---
drivers/staging/vt6656/rf.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/vt665
From: Dan Cashman
This patchset fixes the checkpatch-reported kernel style guide violations for
rf.c in the vt6656 staging area. Specifically, the first patch fixes the
errors, which are all spaces -> tabs conversions, and the second and third fix
the warnings, which are an embedded function na
From: Dan Cashman
Wrap arguments of call to vnt_control_out() to avoid exceeding 80
character limit, but maintain alignment.
Signed-off-by: Daniel Cashman
---
drivers/staging/vt6656/rf.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/vt6656/rf.c b/drivers
From: Dan Cashman
Change embedded function name in vnt_rf_set_txpower with %s format with
__func__ argument to make it consistent with other part of if-else and
kernel coding style standards as reported by checkpatch.
Signed-off-by: Daniel Cashman
---
drivers/staging/vt6656/rf.c | 2 +-
1 file
On Thu, Mar 30, 2017 at 12:03 AM, Prasant Jalan wrote:
> Checkpatch emits WARNING: Avoid multiple line dereference.
>
> Trivial indentation improvement helps fix the checkpatch warning.
>
> Signed-off-by: Prasant Jalan
> ---
> drivers/staging/rtl8712/rtl871x_xmit.c | 12 ++--
> 1 file ch
On Mon, 2017-04-03 at 09:43 +0530, Prasant Jalan wrote:
> On Thu, Mar 30, 2017 at 12:03 AM, Prasant Jalan
> wrote:
> > Checkpatch emits WARNING: Avoid multiple line dereference.
> >
> > Trivial indentation improvement helps fix the checkpatch warning.
[]
> > diff --git a/drivers/staging/rtl8712/
+ linux-wireless
"Tobin C. Harding" writes:
> On Fri, Mar 31, 2017 at 09:58:51AM +0200, Wolfram Sang wrote:
>>
>> > The code is untested, I have hardware in the mail.
>>
>> Cool!
>
> The card I have is a Spectec FCC ID: S2Y-WLAN-11B-G which I believe is
> a SDW-823 and should use the ks7010 dr
On Mon, Apr 3, 2017 at 10:27 AM, Joe Perches wrote:
> On Mon, 2017-04-03 at 09:43 +0530, Prasant Jalan wrote:
>> On Thu, Mar 30, 2017 at 12:03 AM, Prasant Jalan
>> wrote:
>> > Checkpatch emits WARNING: Avoid multiple line dereference.
>> >
>> > Trivial indentation improvement helps fix the check
Checkpatch emits WARNING: Avoid multiple line dereference.
Checkpatch warning is fixed by:
* Trivial indentation improvement and
* Using += instead of + helps shortening the statement.
Signed-off-by: Prasant Jalan
---
v2:
* Used += instead of + (pointed out by Joe Perches)
* Rebased t
23 matches
Mail list logo