If v4l2_subdev_call() gets the global frame interval values,
it returned 0 and it could be checked whether numerator is zero or not.
If the numerator is not zero, the fps could be calculated in this function.
If not, it just returns 0.
Signed-off-by: Daeseok Youn
---
V2: split error handling, th
The css_pipe_id was checked with 'CSS_PIPE_ID_COPY' in previous if-
statement. In this case, if the css_pipe_id equals to 'CSS_PIPE_ID_COPY',
it could not enter the next if-statement. But the "next" if-statement
has the condition to check whether the css_pipe_id equals to
'CSS_PIPE_ID_COPY' or not.
The V4L2_FIELD_ANY is zero, so the (!field) is same meaning
with (field == V4L2_FIELD_ANY) in if-statement.
Signed-off-by: Daeseok Youn
---
V2: one(2/4) of this series was updated so I tried to send them again.
drivers/staging/media/atomisp/pci/atomisp2/atomisp_cmd.c | 2 +-
1 file changed, 1 i
On Thu, 16 Mar 2017 17:50:10 +
Alan Cox wrote:
> > + if (IS_ENABLED(CONFI_PM)) {
>
> I think not.
>
> Please actually test build both ways at the very least.
>
> Alan
>
I did test and it did compile both ways. I didn't think about checking
the output of the compilation and I don't ha
On Mon, 2017-03-20 at 23:40 +0300, Dan Carpenter wrote:
> On Mon, Mar 20, 2017 at 07:53:18AM -0700, Michael Zoran wrote:
> > On Mon, 2017-03-20 at 16:57 +0300, Dan Carpenter wrote:
> > > On Mon, Mar 20, 2017 at 04:06:00AM -0700, Michael Zoran wrote:
> > > > On Mon, 2017-03-20 at 13:55 +0300, Dan Ca
On Tue, Mar 14, 2017 at 09:20:11PM +1100, Tobin C. Harding wrote:
[snip]
Drop this series please. (patch 1 of set already merged).
thanks,
Tobin.
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinf
Checkpatch emits CHECK: No space is necessary after a cast.
Remove unnecessary space after cast.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/michael_mic.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/ks7010/michael_mic.c
b/drivers/stagi
Checkpatch emits CHECK: multiple assignments should be avoided.
Move multiple line assignment to individual lines.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks_hostif.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/ks7010/ks_hostif.c
b/d
Driver return statement code exhibits a degree of uncleanliness.
Driver return statement code is non-uniform in its use of
identifiers, both variables and goto labels.
goto statements occasionally are used with out clean up code instead
of returning directly.
Variables are defined (at declaratio
Checkpatch emits CHECK: Alignment should match open parenthesis.
Fix alignment to open parenthesis in line with kernel coding style.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sdio.c | 4 ++--
drivers/staging/ks7010/ks_wlan_net.c | 16
2 files changed, 1
Checkpatch emits CHECK: Unbalanced braces around else
statement. Statements in question are single statements so we do not
need braces. Checkpatch also warns about multiple line dereference for
this code.
Fix if/else/else if statement use of braces. Fix function argument layout
at the same time si
Checkpatch emits CHECK: Please use a blank line after
function/struct/union/enum declarations.
Add blank line after function definition.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks_wlan_net.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/ks7010/ks_wlan_ne
Comparison, equal to zero, is redundant
'if (foo == 0)' is equal to 'if (!foo)'
Typical kernel coding style is to use the shorter form.
Remove unnecessary zero comparison.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks_wlan_net.c | 4 ++--
1 file changed, 2 insertions(+), 2 d
Driver uses multiple identifier names for the same task (retval, ret,
rc). It would be easier to read the code if a single task is
identified with a single name. 'ret' is the most common return value
identifier name found in the kernel tree, following the principle of
least surprise using 'ret' is
Driver uses different label forms for similar purposes. It would be
more clear if single use case has uniform label. 'out' is generic and
adds no meaning to label.
Documentation/process/coding-style.rst:
Choose label names which say what the goto does or why the goto
exists.
Rename labels so as t
Function uses goto label with no clean up code. In this case we
should just return directly.
Remove goto statement, return directly on error.
Signed-off-by: Tobin C. Harding
---
'/* length check fail */' comment added because preceding line is a
standard function return value check followed by
Comparison, does not equal zero, is redundant
'if (foo != 0)' is equal to 'if (foo)'
Typical kernel coding style is to use the shorter form.
Remove unnecessary non-zero comparison.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sdio.c | 4 ++--
drivers/staging/ks7010/ks_h
The function atomisp_restore_iumit_reg is unused when PM is disabled.
Adding __maybe_unused to the function definition avoids a warning.
The function atomisp_mrfld_power_down is defined only when PM is
enabled. So in atomisp_pci_probe, it should be called only when PM is
enabled.
Signed-off-by: J
These patches address a few outstanding checkpatch warnings/errors in
rf.c, mainly due to space/indentation (style) issues.
---
drivers/staging/vt6656/rf.c | 17 +
1 file changed, 9 insertions(+), 8 deletions(-)
---
___
devel mailing li
Resolving 5 instances of checkpatch error/warning statements generated
due to:
ERROR: code indent should use tabs where possible
CHECK: Alignment should match open parenthesis
Signed-off-by: Matthew Giassa
---
drivers/staging/vt6656/rf.c | 11 ++-
1 file changed, 6 insertions(+), 5 delet
Resolving 2 checkpatch warnings generated due to:
CHECK: spaces preferred around that '-'
Signed-off-by: Matthew Giassa
---
drivers/staging/vt6656/rf.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/vt6656/rf.c b/drivers/staging/vt6656/rf.c
index 0e3a62
Hi unknown,
[auto build test ERROR on linuxtv-media/master]
[also build test ERROR on v4.11-rc3 next-20170320]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux/commits/unknown/staging-radio-bcm2048-Fix
On 03/20/2017 10:23 AM, Philipp Zabel wrote:
Hi Steve, Russell,
On Mon, 2017-03-20 at 14:17 +, Russell King - ARM Linux wrote:
On Mon, Mar 20, 2017 at 03:00:51PM +0100, Philipp Zabel wrote:
On Mon, 2017-03-20 at 12:08 +, Russell King - ARM Linux wrote:
The same document says:
Sca
On Mon, 2017-03-20 at 10:22 -0700, Eric Anholt wrote:
> Michael Zoran writes:
>
> > > > Since the API is completely documented, I see no reason we or
> > > > anybody
> > > > couldn't essentially rewrite the driver while it's in
> > > > staging. I
> > > > just
> > > > think it would be best for e
If this frame contains IV/ICV fields, ether_type field located a little farther.
This bug already fixed here:
https://github.com/lwfinger/rtl8188eu/blob/master/core/rtw_recv.c#L569 .
Signed-off-by: Ivan Safonov
---
drivers/staging/rtl8188eu/core/rtw_recv.c | 2 +-
1 file changed, 1 insertion(+)
On Sun, Mar 19, 2017 at 06:44:53PM +0530, Arushi Singhal wrote:
> Improve readability by fixing multiple checkpatch.pl
> issues in speakup driver.
>
> Arushi Singhal (2):
> staging: speakup: Moved OR operator to previous line.
> staging: speakup: spaces preferred around operator
You have sent
On Tue, Mar 21, 2017 at 12:03:50PM +0530, Arushi Singhal wrote:
>
>
> On Tue, Mar 21, 2017 at 11:41 AM, Greg KH wrote:
>
> On Sun, Mar 19, 2017 at 06:44:53PM +0530, Arushi Singhal wrote:
> > Improve readability by fixing multiple checkpatch.pl
> > issues in speakup driver.
> >
>
101 - 127 of 127 matches
Mail list logo