On 05/03/17 06:59, Derek Robson wrote:
> Changed file permission to octal style.
> Found using checkpatch
>
> Signed-off-by: Derek Robson
Hi Derek,
I've already applied a similar patch to the iio.git tree. It just hasn't made
it to the main staging tree quite yet.
Thanks,
Joanthan
> ---
> dr
Improve readability by fixing multiple checkpatch.pl
issues in sm750fb driver.
Arushi Singhal (3):
staging: sm750fb: fixes add blank line after function/struct/union/enum
declarations
staging: sm750fb: function prototype argument should have an identifier name
staging: sm750fb: Alignment s
function prototype arguments like 'struct vb_device_info *','unsigned
long' etc. should have an identifier name.
Signed-off-by: Arushi Singhal
---
drivers/staging/sm750fb/ddk750_display.h | 2 +-
drivers/staging/sm750fb/ddk750_mode.h| 2 +-
drivers/staging/sm750fb/ddk750_power.h | 2 +-
dr
This patch fixes the warnings reported by checkpatch.pl
for please use a blank line after function/struct/union/enum
declarations.
Signed-off-by: Arushi Singhal
---
drivers/staging/sm750fb/ddk750_display.h | 1 +
drivers/staging/sm750fb/ddk750_mode.h| 2 ++
drivers/staging/sm750fb/ddk750_pow
Fix checkpatch issues: "CHECK: Alignment should match open parenthesis".
Signed-off-by: Arushi Singhal
---
drivers/staging/sm750fb/ddk750_mode.c | 69 +--
1 file changed, 34 insertions(+), 35 deletions(-)
diff --git a/drivers/staging/sm750fb/ddk750_mode.c
b/driv
The function ieee80211_tkip_null on being called, simply returns
back. The function hasn't been mentioned in the TODO and doesn't have
FIXME code around. Hence, ieee80211_tkip_null and its calls have
been removed.
This was done using Coccinelle.
@@
identifier f;
@@
void f(...) {
-return;
}
Si
On Sun, 2017-03-05 at 16:54 +0530, Arushi Singhal wrote:
> Improve readability by fixing multiple checkpatch.pl
> issues in sm750fb driver.
Remember to prefix the subject of the 0/n patch with the subsystem.
> Arushi Singhal (3):
> staging: sm750fb: fixes add blank line after function/struct/u
Doubly linked lists which are iterated using list_empty
and list_entry macros have been replaced with list_for_each_entry_safe
macro.
This makes the iteration simpler and more readable.
This patch replaces the while loop containing list_empty and list_entry
with list_for_each_entry_safe.
This w
Doubly linked lists which are iterated using list_empty
and list_entry macros have been replaced with list_for_each_entry_safe
macro.
This makes the iteration simpler and more readable.
This patch replaces the while loop containing list_empty and list_entry
with list_for_each_entry_safe.
This w
Doubly linked lists which are iterated using list_empty
and list_entry macros have been replaced with list_for_each_entry_safe
macro.
This makes the iteration simpler and more readable.
This patch replaces the while loop containing list_empty and list_entry
with list_for_each_entry_safe.
This w
Doubly linked lists which are iterated using list_empty
and list_entry macros have been replaced with list_for_each_entry_safe
macro.
This makes the iteration simpler and more readable.
This patch replaces the while loop containing list_empty and list_entry
with list_for_each_entry_safe.
This w
Doubly linked lists which are iterated using list_empty
and list_entry macros have been replaced with list_for_each_entry_safe
macro.
This makes the iteration simpler and more readable.
This patch replaces the while loop containing list_empty and list_entry
with list_for_each_entry_safe.
This w
This patch-series replaces the while loop containing list_empty and
list_entry with list_for_each_entry_safe.
simran singhal (5):
staging: lustre: Use list_for_each_entry_safe
staging: lustre: ptlrpc: Use list_for_each_entry_safe
staging: lustre: osc: Use list_for_each_entry_safe
staging:
On Sun, 5 Mar 2017, simran singhal wrote:
> Doubly linked lists which are iterated using list_empty
> and list_entry macros have been replaced with list_for_each_entry_safe
> macro.
> This makes the iteration simpler and more readable.
>
> This patch replaces the while loop containing list_emp
By the way, the above subject line is not correct. Normally one does not
put .c/.h in the subject line. Indeed, there is not really any
deterministic algorithm for choosing the subject line. You need to run
git log --oneline filename to see what others have done.
julia
On Sun, 5 Mar 2017, simr
On Sun, 5 Mar 2017, Julia Lawall wrote:
>
>
> On Sun, 5 Mar 2017, simran singhal wrote:
>
> > Doubly linked lists which are iterated using list_empty
> > and list_entry macros have been replaced with list_for_each_entry_safe
> > macro.
> > This makes the iteration simpler and more readable.
>
On Sun, 5 Mar 2017, simran singhal wrote:
> Doubly linked lists which are iterated using list_empty
> and list_entry macros have been replaced with list_for_each_entry_safe
> macro.
> This makes the iteration simpler and more readable.
>
> This patch replaces the while loop containing list_emp
On Sun, 5 Mar 2017, simran singhal wrote:
> Doubly linked lists which are iterated using list_empty
> and list_entry macros have been replaced with list_for_each_entry_safe
> macro.
> This makes the iteration simpler and more readable.
>
> This patch replaces the while loop containing list_emp
On Sun, Mar 5, 2017 at 11:09 PM, Julia Lawall wrote:
>
>
> On Sun, 5 Mar 2017, simran singhal wrote:
>
>> Doubly linked lists which are iterated using list_empty
>> and list_entry macros have been replaced with list_for_each_entry_safe
>> macro.
>> This makes the iteration simpler and more reada
On Sun, 5 Mar 2017, SIMRAN SINGHAL wrote:
> On Sun, Mar 5, 2017 at 11:09 PM, Julia Lawall wrote:
> >
> >
> > On Sun, 5 Mar 2017, simran singhal wrote:
> >
> >> Doubly linked lists which are iterated using list_empty
> >> and list_entry macros have been replaced with list_for_each_entry_safe
>
On Sun, Mar 5, 2017 at 10:47 PM, Julia Lawall wrote:
> By the way, the above subject line is not correct. Normally one does not
> put .c/.h in the subject line. Indeed, there is not really any
> deterministic algorithm for choosing the subject line. You need to run
> git log --oneline filename
On Sun, 5 Mar 2017, SIMRAN SINGHAL wrote:
> On Sun, Mar 5, 2017 at 10:47 PM, Julia Lawall wrote:
> > By the way, the above subject line is not correct. Normally one does not
> > put .c/.h in the subject line. Indeed, there is not really any
> > deterministic algorithm for choosing the subject
On Sun, Mar 5, 2017 at 11:18 PM, Julia Lawall wrote:
>
>
> On Sun, 5 Mar 2017, SIMRAN SINGHAL wrote:
>
>> On Sun, Mar 5, 2017 at 10:47 PM, Julia Lawall wrote:
>> > By the way, the above subject line is not correct. Normally one does not
>> > put .c/.h in the subject line. Indeed, there is not r
On Sun, 5 Mar 2017, SIMRAN SINGHAL wrote:
> On Sun, Mar 5, 2017 at 11:18 PM, Julia Lawall wrote:
> >
> >
> > On Sun, 5 Mar 2017, SIMRAN SINGHAL wrote:
> >
> >> On Sun, Mar 5, 2017 at 10:47 PM, Julia Lawall wrote:
> >> > By the way, the above subject line is not correct. Normally one does not
On Sun, Mar 05, 2017 at 12:17:21PM +0530, simran singhal wrote:
> The function atomisp_set_stop_timeout on being called, simply returns
> back. The function hasn't been mentioned in the TODO and doesn't have
> FIXME code around. Hence, atomisp_set_stop_timeout and its calls have been
> removed.
>
On Sun, 2017-03-05 at 10:14 -0800, Alison Schofield wrote:
> On Sun, Mar 05, 2017 at 12:17:21PM +0530, simran singhal wrote:
> > The function atomisp_set_stop_timeout on being called, simply returns
> > back. The function hasn't been mentioned in the TODO and doesn't have
> > FIXME code around. Hen
On Sat, Mar 04, 2017 at 04:37:43PM -0800, Steve Longerbeam wrote:
>
>
> On 03/04/2017 02:56 AM, Sakari Ailus wrote:
> >Hi Steve,
> >
> >On Fri, Mar 03, 2017 at 02:43:51PM -0800, Steve Longerbeam wrote:
> >>
> >>
> >>On 03/03/2017 03:45 AM, Sakari Ailus wrote:
> >>>On Thu, Mar 02, 2017 at 03:07:21
Updating macros to be wrapped in parentheses to accomodate checkpatch errors
throughout the header. This change, combined with the previous patch, resolves
all outstanding warnings/errors produce by checkpatch.
Signed-off-by: Matthew Giassa
---
drivers/staging/ks7010/ks_wlan_ioctl.h | 66 +++
Implementing some minor formatting changes to remove checkpatch warnings.
Removing space-hardtab instances. Removing C++-style line comments in favor of
C-style equivalent. Re-aligning function prototype arguments to remove related
checkpatch warning.
Signed-off-by: Matthew Giassa
---
drivers/st
On Sat, Mar 04, 2017 at 04:37:43PM -0800, Steve Longerbeam wrote:
>
>
> On 03/04/2017 02:56 AM, Sakari Ailus wrote:
> >That's a bit of a special situation --- still there are alike conditions on
> >existing hardware. You should return the buffers to the user with the ERROR
> >flag set --- or retu
Dear Sir/Madam,
I am Sgt Swanson Dennis, I have a good business proposal for you.
There are no risks involved and it is easy. Please reply for briefs
and procedures.
Best regards,
Sgt Swanson Dennis
___
devel mailing list
de...@linuxdriverproject.org
h
Dear Sir/Madam,
I am Sgt Swanson Dennis, I have a good business proposal for you.
There are no risks involved and it is easy. Please reply for briefs
and procedures.
Best regards,
Sgt Swanson Dennis
___
devel mailing list
de...@linuxdriverproject.org
h
Dear Sir/Madam,
I am Sgt Swanson Dennis, I have a good business proposal for you.
There are no risks involved and it is easy. Please reply for briefs
and procedures.
Best regards,
Sgt Swanson Dennis
___
devel mailing list
de...@linuxdriverproject.org
h
Fixed a coding style issue.
Signed-off-by: Mark Stenglein
---
drivers/staging/wlan-ng/hfa384x.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/wlan-ng/hfa384x.h
b/drivers/staging/wlan-ng/hfa384x.h
index 5f1851c85f12..f19984747b1e 100644
--- a/drivers/staging/wlan-ng/hfa384x
On 04-03-17, 21:37, simran singhal wrote:
> This patch replace "is is " with "is". The replacement couldn't be
> automated because sometimes the first "is" was meant to be another
> word.
>
> Signed-off-by: simran singhal
> ---
> drivers/staging/greybus/uart.c | 2 +-
> 1 file changed, 1 inserti
On Sun, Mar 05, 2017 at 09:09:12PM -0500, Mark Stenglein wrote:
> Fixed a coding style issue.
What issue would that be?
> Signed-off-by: Mark Stenglein
> ---
> drivers/staging/wlan-ng/hfa384x.h | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/drivers/staging/wlan-ng/hfa384x.h
> b/driv
On Fri 03-03-17 09:37:55, Laura Abbott wrote:
> On 03/03/2017 05:29 AM, Michal Hocko wrote:
> > On Thu 02-03-17 13:44:32, Laura Abbott wrote:
> >> Hi,
> >>
> >> There's been some recent discussions[1] about Ion-like frameworks. There's
> >> apparently interest in just keeping Ion since it works rea
37 matches
Mail list logo