Update the driver's HCI structs and associated endian-converter
functions with new driver-specific bitwise types. The new types
encourage correct endian-handling within the driver by triggering
sparse warnings when mixing with other types. The driver's
endian-converters provide correct and warning-
Make uniform definition of ioremap, ioremap_wc, ioremap_wt and
ioremap_cache, tree-wide.
Signed-off-by: Arvind Yadav
---
drivers/staging/i4l/act2000/act2000.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/i4l/act2000/act2000.h
b/drivers/staging/i4l/act2000/
Make uniform definition of ioremap, ioremap_wc, ioremap_wt and
ioremap_cache, tree-wide.
Signed-off-by: Arvind Yadav
---
drivers/staging/rtl8192u/r8192U.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8192u/r8192U.h
b/drivers/staging/rtl8192u/r8192U.h
in
On Wed, Jan 04, 2017 at 08:08:22PM -0800, Long Li wrote:
> From: Long Li
>
> The ring buffer code uses %= to calculate index. For x86/64, %= compiles to
> div, more than 10 times slower than sub.
>
> Replace div with sub for this data heavy code path.
>
> Signed-off-by: Long Li
> ---
> driver
On Thu, Jan 05, 2017 at 04:09:24PM +0530, Arvind Yadav wrote:
> Make uniform definition of ioremap, ioremap_wc, ioremap_wt and
> ioremap_cache, tree-wide.
That doesn't make much sense, and doesn't match the subject: or the
patch itself.
And what is with the "[v1]"?
thanks,
greg k-h
On Thu, Jan 05, 2017 at 04:15:03PM +0530, Arvind Yadav wrote:
> Make uniform definition of ioremap, ioremap_wc, ioremap_wt and
> ioremap_cache, tree-wide.
Same complaint about text here as well...
___
devel mailing list
de...@linuxdriverproject.org
http:
On Thu, Jan 05, 2017 at 02:39:55PM +0300, Dan Carpenter wrote:
> > @@ -179,7 +180,8 @@ static u32 hv_copyfrom_ringbuffer(
> > memcpy(dest, ring_buffer + start_read_offset, destlen);
> >
> > start_read_offset += destlen;
> > - start_read_offset %= ring_buffer_size;
> > + if (start_read
Please find my comment below.
Thanks
-Arvind
On Thursday 05 January 2017 05:16 PM, Greg KH wrote:
On Thu, Jan 05, 2017 at 04:09:24PM +0530, Arvind Yadav wrote:
Make uniform definition of ioremap, ioremap_wc, ioremap_wt and
ioremap_cache, tree-wide.
That doesn't make much sense, and doesn't mat
On Thu, Jan 05, 2017 at 05:25:05PM +0530, Arvind Yadav wrote:
> Please find my comment below.
Where? What happened to your email quoting?
> Thanks
> -Arvind
>
> On Thursday 05 January 2017 05:16 PM, Greg KH wrote:
> > On Thu, Jan 05, 2017 at 04:09:24PM +0530, Arvind Yadav wrote:
> > > Make unif
On Thu, Jan 05, 2017 at 01:03:41PM +0530, Aditya Shankar wrote:
> Connect to the highest rssi with the required SSID in the shadow
> table if the connection criteria is based only on the SSID.
> For the first matching SSID, an index to the table is saved.
> Later the index is updated if matching SS
Stephen Hemminger writes:
> On Wed, 4 Jan 2017 18:24:39 +0100
> Vitaly Kuznetsov wrote:
>
>> If we happen to receive interrupts during hv_set_host_time() execution
>> our adjustments may get inaccurate. Make the whole function atomic.
>> Unfortunately, we can's call do_settimeofday64() with int
Stephen Hemminger writes:
> On Wed, 4 Jan 2017 18:24:38 +0100
> Vitaly Kuznetsov wrote:
>
>> With TimeSync version 4 protocol support we started updating system time
>> continuously through the whole lifetime of Hyper-V guests. Every 5 seconds
>> there is a time sample from the host which trigg
On Thu, Jan 05, 2017 at 12:56:16PM +1300, Derek Robson wrote:
> Debug code had very long lines.
> Reworked code to use several prints rather than one big print.
>
> Signed-off-by: Derek Robson
> ---
> drivers/staging/ks7010/ks_hostif.c | 32 +---
> 1 file changed, 25
On Wed, Jan 04, 2017 at 07:10:39PM -0600, Scott Matheina wrote:
> The patch series addresses some coding style issues contained within the file.
>
> Scott Matheina (2):
> drivers/staging/rtl8188eu/core/rtw_ap.c un-necessary parenthesis
> drivers/staging/rtl8188eu/core/rtw_ap.c Alignment should
On Wed, Jan 04, 2017 at 07:10:40PM -0600, Scott Matheina wrote:
> Fixed coding style issue, un-necessary parenthesis present
>
> Signed-off-by: Scott Matheina
Again, problems with your subject, does it make sense?
Look at what others do for this driver, it should look something like:
[P
The network device operation for reading statistics is only called
in one place, and it ignores the return value. Having a structure
return value is potentially confusing because some future driver could
incorrectly assume that the return value was used.
Fix all drivers with ndo_get_stats64 to hav
From: Greg Kroah-Hartman
While the timesync protocol was a great idea, it never ended up getting
implemented by any known hardware devices. It's also a bit
"interesting" in how it ties into the platform controller.
So, just remove it for now. It's not needed, no one uses it, and it's a
stumbli
On Thu, 05 Jan 2017 13:35:58 +0100
Vitaly Kuznetsov wrote:
> I was thinking about it but to me what do_adjtimex() does looks too
> low-level for drivers (e.g. calling write_seqcount_begin(),
> __timekeeping_set_tai_offset(), tk_update_leap_state()). To me (again, I
> probably know not that much a
From: Stephen Hemminger
Date: Thu, 5 Jan 2017 09:31:36 -0800
> The network device operation for reading statistics is only called
> in one place, and it ignores the return value. Having a structure
> return value is potentially confusing because some future driver could
> incorrectly assume that
On 05/01/17 17:39, Greg Kroah-Hartman wrote:
> From: Greg Kroah-Hartman
>
> While the timesync protocol was a great idea, it never ended up getting
> implemented by any known hardware devices. It's also a bit
> "interesting" in how it ties into the platform controller.
>
> So, just remove it fo
On 01/05/2017 12:25 PM, Bryan O'Donoghue wrote:
> On 05/01/17 17:39, Greg Kroah-Hartman wrote:
>> From: Greg Kroah-Hartman
>>
>> While the timesync protocol was a great idea, it never ended up getting
>> implemented by any known hardware devices. It's also a bit
>> "interesting" in how it ties in
On 01/05/2017 11:39 AM, Greg Kroah-Hartman wrote:
> From: Greg Kroah-Hartman
>
> While the timesync protocol was a great idea, it never ended up getting
> implemented by any known hardware devices. It's also a bit
> "interesting" in how it ties into the platform controller.
>
> So, just remove
Hi Vladimir,
On 01/04/2017 04:25 AM, Vladimir Zapolskiy wrote:
Hi Steve,
On 01/03/2017 10:57 PM, Steve Longerbeam wrote:
Enables the OV5642 parallel-bus sensor, and the OV5640 MIPI CSI-2 sensor.
Both hang off the same i2c2 bus, so they require different (and non-
default) i2c slave addresses.
Refactor code to remove multi-line derefs and code duplication
Signed-off-by: Emil Gedda
---
Yet again, sorry for the spam, still new to sending in patches and
everything related, but I'm more than happy being able to contribute.
Tried contacting the mentioned people in the relevant TODO, but a
On Wednesday, January 04, 2017 3:56 AM, Ian Abbott wrote:
> I've had these clean-up patches for the daqboard2000 driver sitting
> around for a few months, with a view to adding support for more boards
> in the same series, and adding support for extra subdevice types. I
> never got around to doing
On Tue, Jan 03, 2017 at 10:19:29PM +0100, Arnd Bergmann wrote:
> On Tuesday, January 3, 2017 4:24:36 PM CET Greg Kroah-Hartman wrote:
> > On Wed, Mar 02, 2016 at 08:06:46PM +0100, Arnd Bergmann wrote:
> > > The icn, act2000 and pcbit drivers are all for very old hardware,
> > > and it is highly unl
On 01/04/2017 04:33 AM, Vladimir Zapolskiy wrote:
+
+ camera: ov5642@3c {
ov5642: camera@3c
done.
+ pwdn-gpios = <&gpio1 16 GPIO_ACTIVE_HIGH>; /* SD1_DAT0 */
+ reset-gpios = <&gpio1 17 GPIO_ACTIVE_LOW>; /* SD1_DAT1 */
Comments about SD1_* pad names are
On 01/04/2017 04:41 AM, Vladimir Zapolskiy wrote:
On 01/03/2017 10:57 PM, Steve Longerbeam wrote:
+
+ camera: adv7180@21 {
adv7180: camera@21
done.
+ pinctrl_ipu1_csi0: ipu1grp-csi0 {
Please rename node name to ipu1csi0grp.
done.
Steve
__
Removed unnecessary braces
Signed-off-by: Scott Matheina
---
drivers/staging/rtl8188eu/core/rtw_ap.c | 106
1 file changed, 53 insertions(+), 53 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_ap.c
b/drivers/staging/rtl8188eu/core/rtw_ap.c
index 55
Fixed style issue: Alignment should match open brace
Signed-off-by: Scott Matheina
---
drivers/staging/rtl8188eu/core/rtw_ap.c | 38 -
1 file changed, 18 insertions(+), 20 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_ap.c
b/drivers/staging/rtl818
Changed permissions to be in octal style.
Found by checkpatch.
Signed-off-by: Derek Robson
---
drivers/staging/greybus/camera.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/greybus/camera.c b/drivers/staging/greybus/camera.c
index 0ee291ca2c72..a
On 01/04/2017 05:33 AM, Vladimir Zapolskiy wrote:
Hi Steve,
On 01/03/2017 10:57 PM, Steve Longerbeam wrote:
Add the core media driver for i.MX SOC.
Signed-off-by: Steve Longerbeam
---
Documentation/devicetree/bindings/media/imx.txt | 205 +
v2 was sent before getting Rob's review com
'commit 2584cf83578c ("arch, drivers: don't
include directly, use instead")'
Make uniform definition of ioremap, ioremap_wc, ioremap_wt and
ioremap_cache, tree-wide.
Signed-off-by: Arvind Yadav
---
drivers/staging/i4l/act2000/act2000.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
dif
Thanks for your suggestion :).
I have done the changes as per your concern . Please review it.
Thanks :)
-Arvind
On Thursday 05 January 2017 05:35 PM, Greg KH wrote:
On Thu, Jan 05, 2017 at 05:25:05PM +0530, Arvind Yadav wrote:
Please find my comment below.
Where? What happened to your email
'commit 2584cf83578c ("arch, drivers: don't
include directly, use instead")'
Make uniform definition of ioremap, ioremap_wc, ioremap_wt and
ioremap_cache, tree-wide.
Signed-off-by: Arvind Yadav
---
drivers/staging/rtl8192u/r8192U.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --
On Fri, Jan 06, 2017 at 11:46:11AM +0530, Arvind Yadav wrote:
> 'commit 2584cf83578c ("arch, drivers: don't
> include directly, use instead")'
> Make uniform definition of ioremap, ioremap_wc, ioremap_wt and
> ioremap_cache, tree-wide.
I still don't understand what this means at all, do you?
Wh
On Fri, Jan 06, 2017 at 02:20:23PM +1300, Derek Robson wrote:
> Changed permissions to be in octal style.
> Found by checkpatch.
>
> Signed-off-by: Derek Robson
> ---
> drivers/staging/greybus/camera.c | 10 +-
> 1 file changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/s
From: Greg Kroah-Hartman
The Greybus driver subsystem has a mailing list, so list it in the
MAINTAINERS file so that people know to send patches there as well.
Signed-off-by: Greg Kroah-Hartman
diff --git a/MAINTAINERS b/MAINTAINERS
index cfff2c9e3d94..f6cb07684cea 100644
--- a/MAINTAINERS
+++
Changed permissions to be in octal style.
Found by checkpatch.
Signed-off-by: Derek Robson
---
This version of patch also make the file type part of the mask with the
permissions, as per recommendation from Greg K-H
drivers/staging/greybus/camera.c | 10 +-
1 file changed, 5 insertion
39 matches
Mail list logo