On Thu, Oct 27, 2016 at 11:20 AM, Greg KH wrote:
> On Thu, Oct 27, 2016 at 11:10:09AM +0530, Souptick Joarder wrote:
>> There are few functions where we need to free previously allocated memory
>> when kmalloc fails. Else it may lead to memory leakage.
>> In _init_cmd_priv() and _r8712_init_xmit_
There are few functions where we need to free previously allocated memory
when kmalloc fails.Else it may lead to memory leakage.In _init_cmd_priv()
and _r8712_init_xmit_priv(),in few places we are not freeing previously
allocated memory when kmalloc fails.
Signed-off-by: Souptick joarder
---
Cha
On Wed, 26 Oct 2016 17:22:50 +0300
Dan Carpenter wrote:
> On Tue, Oct 25, 2016 at 05:44:20PM +0200, Christian Gromm wrote:
> > From: Andrey Shvetsov
> >
> > This patch puts the synchronization procedure trigger for asynchronous
> > channels into the function hdm_configure_channel. Likewise, it
On Thu, Oct 27, 2016 at 10:57:07AM +0200, Christian Gromm wrote:
> On Wed, 26 Oct 2016 17:22:50 +0300
> Dan Carpenter wrote:
>
> > On Tue, Oct 25, 2016 at 05:44:20PM +0200, Christian Gromm wrote:
> > > From: Andrey Shvetsov
> > >
> > > This patch puts the synchronization procedure trigger for a
On Thu, 27 Oct 2016 12:00:28 +0300
Dan Carpenter wrote:
> On Thu, Oct 27, 2016 at 10:57:07AM +0200, Christian Gromm wrote:
> > On Wed, 26 Oct 2016 17:22:50 +0300
> > Dan Carpenter wrote:
> >
> > > On Tue, Oct 25, 2016 at 05:44:20PM +0200, Christian Gromm wrote:
> > > > From: Andrey Shvetsov
>
On Thu, Oct 27, 2016 at 01:00:47PM +0200, Christian Gromm wrote:
> On Thu, 27 Oct 2016 12:00:28 +0300
> Dan Carpenter wrote:
>
> > On Thu, Oct 27, 2016 at 10:57:07AM +0200, Christian Gromm wrote:
> > > On Wed, 26 Oct 2016 17:22:50 +0300
> > > Dan Carpenter wrote:
> > >
> > > > On Tue, Oct 25, 2
On Thu, Oct 27, 2016 at 01:00:01PM +0530, Souptick Joarder wrote:
> On Thu, Oct 27, 2016 at 11:20 AM, Greg KH wrote:
> > On Thu, Oct 27, 2016 at 11:10:09AM +0530, Souptick Joarder wrote:
> >> There are few functions where we need to free previously allocated memory
> >> when kmalloc fails. Else it
On Thu, Oct 27, 2016 at 01:46:13PM +0530, Souptick Joarder wrote:
> There are few functions where we need to free previously allocated memory
> when kmalloc fails.Else it may lead to memory leakage.In _init_cmd_priv()
> and _r8712_init_xmit_priv(),in few places we are not freeing previously
> allo
On Tue, Oct 25, 2016 at 11:22:30PM +0200, Arnd Bergmann wrote:
> After a recent bugfix, we get a warning about the use of an uninitialized
> variable:
>
> drivers/staging/lustre/lnet/libcfs/linux/linux-cpu.c: In function
> 'cfs_cpt_table_create_pattern':
> drivers/staging/lustre/lnet/libcfs/linux
On Thu, Oct 27, 2016 at 04:24:31AM +0300, Dan Carpenter wrote:
> On Wed, Oct 26, 2016 at 06:13:13PM -0700, Eric Anholt wrote:
> > Stefan Wahren writes:
> >
> > > This fixes the CamelCase of some variables.
> > >
> > > Signed-off-by: Stefan Wahren
> >
> > Greg, are these kinds of reformats somet
On Thursday, October 27, 2016 3:12:42 PM CEST Greg Kroah-Hartman wrote:
> On Tue, Oct 25, 2016 at 11:22:30PM +0200, Arnd Bergmann wrote:
> > After a recent bugfix, we get a warning about the use of an uninitialized
> > variable:
> >
> > drivers/staging/lustre/lnet/libcfs/linux/linux-cpu.c: In func
This command was sent behind serio's back and the answer to it was
confusing atkbd probe function which lead to the elantech touchpad
getting detected as a keyboard.
To prevent this from happening just let every party do its part of the
job.
Signed-off-by: Paul Fertser
---
drivers/staging/nvec/
Hi Paul,
thanks for finding the issue!
Am Donnerstag, 27. Oktober 2016, 16:55:14 CEST schrieb Paul Fertser:
> This command was sent behind serio's back and the answer to it was
> confusing atkbd probe function which lead to the elantech touchpad
> getting detected as a keyboard.
>
> To prevent t
Status quo on Toshiba ac100 (paz00) is that the integrated elantech touchpad is
detected as an ImPS/2 mouse and so it's kind of functional but advanced
synaptics configuration isn't available.
When only serio type is changed it leads to atkbd misdetecting the touchpad as
a keyboard. So first goes
This command was sent behind serio's back and the answer to it was
confusing atkbd probe function which lead to the elantech touchpad
getting detected as a keyboard.
To prevent this from happening just let every party do its part of the
job.
Signed-off-by: Paul Fertser
---
drivers/staging/nvec/
This reverts commit 36b30d6138f4677514aca35ab76c20c1604baaad.
This is necessary to detect paz00 (ac100) touchpad properly as one
speaking ETPS/2 protocol. Without it X.org's synaptics driver doesn't
work as the touchpad is detected as an ImPS/2 mouse instead.
Commit ec6184b1c717b8768122e25fe6d312
Am Donnerstag, 27. Oktober 2016, 17:22:07 CEST schrieb Paul Fertser:
> Status quo on Toshiba ac100 (paz00) is that the integrated elantech touchpad
> is detected as an ImPS/2 mouse and so it's kind of functional but advanced
> synaptics configuration isn't available.
>
> When only serio type is ch
On Thu, Oct 27, 2016 at 6:40 PM, Greg KH wrote:
> On Thu, Oct 27, 2016 at 01:46:13PM +0530, Souptick Joarder wrote:
>> There are few functions where we need to free previously allocated memory
>> when kmalloc fails.Else it may lead to memory leakage.In _init_cmd_priv()
>> and _r8712_init_xmit_pri
`ni_tio_clock_period_ps()` used to return the clock period in
picoseconds, and had a `BUG()` call for invalid cases. It was changed
to pass the clock period back via a pointer parameter and return an
error for the invalid cases. Unfortunately the code to handle
user-specified clock sources with u
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git
driver-core-testing
head: ae17f29d0bb84a43b6c5f3e9fac0b124960c53f7
commit: eb6b1b0ba7aa8da0b67bba65764d1258f87b924e [2/6] driver core: Functional
dependencies tracking support
config: parisc-allnoconfig (attached as
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git
driver-core-testing
head: ae17f29d0bb84a43b6c5f3e9fac0b124960c53f7
commit: eb6b1b0ba7aa8da0b67bba65764d1258f87b924e [2/6] driver core: Functional
dependencies tracking support
config: mips-allnoconfig (attached as .c
The kernel function ilookup5_nowait never returns
IS_ERR so we can remove the IS_ERR check in the
ll_md_blocking_ast() function.
Signed-off-by: James Simmons
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-8697
Reviewed-on: http://review.whamcloud.com/23151
Reported-by: Dan Carpenter
Reviewe
The first two patches are fixes for problems pointed out by
Dan Carpenter and Julia LaWall. Batch of fixes from the Lustre 2.8
version. Basic support for selinux which before this work
prevented lustre from running. First patch to cleanup lustre_idl.h
which is a uapi header. All these patches are i
From: Niu Yawei
It was discovered that to many ldlm locks where being
created on the server side to the point of memory
exhaustion. The work of LU-6529 introduced watermarks
to avoid this memory exhaustion. This is the client
side part of this work for the upstream client.
Signed-off-by: Niu Yaw
From: Lai Siyao
If MDS doesn't support striped directory, creating striped directory
from a userland utility such as 'lfs setdirstripe' should fail.
Signed-off-by: Lai Siyao
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6661
Reviewed-on: http://review.whamcloud.com/15123
Reviewed-by: Jame
From: Bobi Jam
If normal IO got short read/write, we'd restart the IO from where
we've accomplished until we meet EOF or error happens.
Signed-off-by: Bobi Jam
Signed-off-by: Jinshan Xiong
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6389
Reviewed-on: http://review.whamcloud.com/14123
R
From: Gregoire Pichon
This patch is the main client part of a new feature that supports
multiple modify metadata RPCs in parallel. Its goal is to improve
metadata operations performance of a single client, while maintening
the consistency of MDT reply reconstruction and MDT recovery
mechanisms.
From: Amir Shehata
Added a union to ptlrpc_bulk_desc for KVEC and KIOV buffers.
bd_type has been changed to be a bit mask. Bits are set in
bd_type to specify {put,get}{source,sink}{kvec,kiov}
changed all instances in the code to access the union properly
ASSUMPTION: all current code only works wi
From: wang di
Remove checks for cross-MDT operation, so cross-MDT
rename and link will be allowed.
Remove obsolete locality parameters in MDT lock API after all of
cross-MDT operations are allowed.
This is the client side changed only so the upstream
client can support this.
Signed-off-by: wan
From: wang di
Even though the server might already got the bulk
replay request, but bulk transfer timeout, let's
replay the bulk request, i.e. treat such replay as
same as no replied replay request (See
ptlrpc_replay_interpret()).
Signed-off-by: wang di
Intel-bug-id: https://jira.hpdd.intel.com
Earlier cl_avail_grant was changed to an unsigned int. Juila
Lawall reported for the upstream client the following which
affects the Intel branch as well:
drivers/staging/lustre/lustre/osc/osc_request.c:1045:5-24: WARNING: Unsigned
expression compared with zero: cli -> cl_avail_grant < 0
Since cl
From: wang di
If the user is requesting a stripe count larger than what
is supported in the file system then report back to the
user an error as well as what is the largest possible
striping.
Signed-off-by: wang di
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6602
Reviewed-on: http://rev
From: Sebastien Buisson
When encryption is enabled RPCs are encrypted just before being
sent. The encryption requires allocating memory in the encoding pool.
The current implementation in sptlrpc_enc_pool_get_pages() is
deadlock-prone. Indeed, if there is no more free pages in the pool,
all ptlrp
From: Hiroya Nozaki
Running multiple mounts at the same time results in
lustre_profile_list corruption when adding a new profile.
This patch adds a new spin_lock to protect the list and
avoid the bug
Signed-off-by: Hiroya Nozaki
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6600
Reviewed
From: Andreas Dilger
Do not use fix LLOG_CHUNK_SIZE (8192 bytes), and
it will get the llog_chunk_size from llog_log_hdr.
Accordingly llog header will be variable too, so
we can enlarge the bitmap in the header, then
have more records in each llog file.
Signed-off-by: Andreas Dilger
Signed-off-b
From: Bobi Jam
This really only affects clients that are attached to lustre
server running ZFS, because zfs does not update # of blocks
until the blocks are flushed to disk.
This patch update file's blocks attribute after OST_SYNC completes.
Signed-off-by: Bobi Jam
Intel-bug-id: https://jira.h
From: Hongchao Zhang
For IMA (Integrity Measurement Architecture), there are two xattr
"security.ima" and "security.evm" to protect the file to be modified
accidentally or maliciously, the two xattr are not compatible with
VBR, then disable it to workaround the problem currently and enable
it whe
From: wang di
Add active proc entry for MDC, and mark MDC to
be inactive once the MDC is deactivated.
Signed-off-by: wang di
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6586
Reviewed-on: http://review.whamcloud.com/14747
Reviewed-by: Lai Siyao
Reviewed-by: James Simmons
Reviewed-by: O
From: wang di
The minimum record size will be recorded in llh_size, which is
only used by fixed size record llog now, and also add another
flag LLOG_F_IS_FIXSIZE to indicate the fix size record llog.
Signed-off-by: wang di
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-7050
Reviewed-on: ht
From: Henri Doreau
Wait for a NRS policy to be fully started before allowing
to apply related tunings, so that all fields are properly
initialized.
Signed-off-by: Henri Doreau
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6673
Reviewed-on: http://review.whamcloud.com/15104
Reviewed-by: Em
From: Ben Evans
Put lu_seq_range related functions into a single .h.
Include directly from files which use it, and remove
definitions from lustre_idl.h.
Signed-off-by: Ben Evans
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6401
Reviewed-on: http://review.whamcloud.com/15952
Reviewed-by:
From: Sebastien Buisson
When trying to replace a dead sec context with a new one, we must
ensure the new context is already up-to-date.
If it is not the case, just return from sptlrpc_req_replace_dead_ctx()
and come later when the new context has been updated.
Signed-off-by: Sebastien Buisson
I
From: John L. Hammond
In struct lustre_md replace the struct lov_stripe_md *lsm member with
an opaque struct lu_buf layout which holds the layout metadata
returned by the server. Refactor the LOV object initialization and
layout change code to accommodate this. Simplify lov_unpackmd() and
support
From: Niu Yawei
Once reconnect happened during replay, we'd continue the open
replay with the last failed replay, but not the next.
Signed-off-by: Niu Yawei
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6802
Reviewed-on: http://review.whamcloud.com/15871
Reviewed-by: Jinshan Xiong
Review
From: Alex Zhuravlev
imp_peer_committed_transno should not decrease as this can
confuse the users if imp_peer_committed_transno is used to
check commit status.
Signed-off-by: Alex Zhuravlev
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-7079
Reviewed-on: http://review.whamcloud.com/16161
R
From: Gregoire Pichon
Atomically assign XIDs and put request and sending list so
we can learn the lowest unreplied XID at any point.
This allows to embed in every resquests the highest XID for
which a reply has been received and does not have an unreplied
lower-numbered XID.
This will be used b
From: Sebastien Buisson
Bring the ability to properly initiate security context
on SELinux-enabled client and store it on server side via
extended attribute.
Security context initialization is not atomic, but that would
require a wire protocol change to send security label in the
creation reques
From: Niu Yawei
While creating an echo device, echo_device_alloc() copies the lu_site
from MD stack, such kind of copy result in uninitialized mutex and
other potential issues.
Instead of copying the lu_site, we'd use the lu_site by pointer directly.
Signed-off-by: Niu Yawei
Signed-off-by: Ola
From: Henri Doreau
Notify copytool that a file could not be archived due to dataversion
change. This does not introduce any functional change but ensures
that errors are consistently reported in copytool logs.
Signed-off-by: Henri Doreau
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-5683
From: wang di
If the request is allowed to be sent during recovery,
and it is not timeout yet, then we do not need to
resend it in the final stage of recovery.
Unnecessary resend will cause the bulk request to resend the
request with different mbit, but same xid, and on the remote
server side, i
From: John L. Hammond
Add a new regular file ioctl LL_IOC_FUTIMES_3 similar to futimes() but
which allows setting of all three inode timestamps. Use this ioctl
during HSM restore to ensure that the volatile file has the same
timestamps as the file to be restored. Strengthen sanity-hsm test_24a
to
Hi Gregoire,
[auto build test WARNING on staging/staging-testing]
[also build test WARNING on next-20161027]
[cannot apply to v4.9-rc2]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
[Suggest to use git(>=2.9.0) format-patch --base= (or --b
The 'switch' statement in set_current_gate() had only two possible
scenarios, so it was replaced with an 'if' statement to make the code
shorter and easier to understand.
Signed-off-by: Elise Lennion
---
drivers/staging/sm750fb/ddk750_power.c | 24
1 file changed, 4 inse
Replace CamelCase function names with underscores to comply with
the standard kernel coding style.
Signed-off-by: Elise Lennion
---
drivers/staging/sm750fb/ddk750_chip.c| 4 ++--
drivers/staging/sm750fb/ddk750_display.c | 2 +-
drivers/staging/sm750fb/ddk750_hwi2c.c | 4 ++--
drivers/st
Shorter names are preferred by C variables naming convention, they are
easier to write and aren't more difficult to understand.
Signed-off-by: Elise Lennion
---
drivers/staging/sm750fb/ddk750_power.c | 26 +-
1 file changed, 13 insertions(+), 13 deletions(-)
diff --git a
There are few functions where we need to free previously allocated memory
when kmalloc fails. Else it may lead to memory leakage. In _init_cmd_priv()
and _r8712_init_xmit_priv(), in few places we are not freeing previously
allocated memory when kmalloc fails.
Signed-off-by: Souptick joarder
---
On Fri, Oct 28, 2016 at 05:48:34AM +0800, kbuild test robot wrote:
> tree:
> https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git
> driver-core-testing
> head: ae17f29d0bb84a43b6c5f3e9fac0b124960c53f7
> commit: eb6b1b0ba7aa8da0b67bba65764d1258f87b924e [2/6] driver core:
> F
57 matches
Mail list logo