Hi Janusz,
On 06/16/2016 07:21 PM, Janusz Krzysztofik wrote:
> As requested by media subsystem maintainers, here is an attempt to
> convert the omap1_camera driver to the vb2 framework. Also, conversion
> to the dmaengine framework, long awaited by ARM/OMAP maintainers, is
> done.
>
> Next, I'
On Wed, Jun 15, 2016 at 11:53:11PM +0200, Arnd Bergmann wrote:
> The recently-added ks7010 driver produces an annoying build warning:
>
> drivers/staging/ks7010/ks7010_config.c: In function
> 'ks_wlan_read_config_file':
> drivers/staging/ks7010/ks7010_config.c:263:8: error: assignment discards
>
Includes probably need a driver-wide clean up, but for now let's at
least group all includes from the sdio file together.
Signed-off-by: Wolfram Sang
---
drivers/staging/ks7010/ks7010_sdio.c | 7 +++
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/ks7010/ks7010_
So, here is a set of cleanups for the ks7010 driver. Biggest one is the removal
of the config file handling. But also some other improvements while playing
around with the driver. Please have a look, comment, apply. A branch can be
found here:
git://git.kernel.org/pub/scm/linux/kernel/git/wsa/linu
I verified that all but two settings from the config file can be set up
also via 'iwconfig' or 'iwpriv'. The two missing are ROM_FILE and
PhyInformationTimer. ROM_FILE can be easily dropped. There is only one
known firmware floating on the net, so, the name is fix and we can make
this constant. Fra
Until we switch to cfg80211 (if ever), we must do this manually.
Signed-off-by: Wolfram Sang
---
drivers/staging/ks7010/ks7010_sdio.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ks7010/ks7010_sdio.c
b/drivers/staging/ks7010/ks7010_sdio.c
index c3035b80dac
There is no need to continue then. Also, this enables us to remove an
ugly static variable.
Signed-off-by: Wolfram Sang
---
drivers/staging/ks7010/ks7010_sdio.c | 12 +---
1 file changed, 5 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/ks7010/ks7010_sdio.c
b/drivers/stagin
Signed-off-by: Wolfram Sang
---
drivers/staging/ks7010/ks7010_sdio.c | 3 ---
drivers/staging/ks7010/ks_wlan.h | 3 +++
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/ks7010/ks7010_sdio.c
b/drivers/staging/ks7010/ks7010_sdio.c
index d4cce78106a736..714f933a7d8
So the module will be loaded automatically on card insertion. Rename the
array while here.
Signed-off-by: Wolfram Sang
---
drivers/staging/ks7010/ks7010_sdio.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/ks7010/ks7010_sdio.c
b/drivers/staging/ks7010/
Move read/write functions to the top and driver struct to the end, so we
can remove all forward declarations.
Signed-off-by: Wolfram Sang
---
drivers/staging/ks7010/ks7010_sdio.c | 100 ---
1 file changed, 46 insertions(+), 54 deletions(-)
diff --git a/drivers/st
We are upstream now, we don't need seperate driver versioning.
Signed-off-by: Wolfram Sang
---
drivers/staging/ks7010/ks7010_sdio.h | 1 -
drivers/staging/ks7010/ks_wlan_ioctl.h | 2 +-
drivers/staging/ks7010/ks_wlan_net.c | 15 +--
3 files changed, 2 insertions(+), 16 deletion
No 79xx anymore, this is confusing. Add a comment saying that old
versions were probably named 7910/79xx.
Signed-off-by: Wolfram Sang
---
drivers/staging/ks7010/ks7010_sdio.c | 28 ++--
drivers/staging/ks7010/ks7010_sdio.h | 1 +
2 files changed, 15 insertions(+), 14 del
On Friday, June 17, 2016 10:26:38 AM CEST Wolfram Sang wrote:
> On Wed, Jun 15, 2016 at 11:53:11PM +0200, Arnd Bergmann wrote:
> > The recently-added ks7010 driver produces an annoying build warning:
> >
> > drivers/staging/ks7010/ks7010_config.c: In function
> > 'ks_wlan_read_config_file':
> > d
* Hans Verkuil [160617 00:07]:
> Hi Janusz,
>
> On 06/16/2016 07:21 PM, Janusz Krzysztofik wrote:
> > As requested by media subsystem maintainers, here is an attempt to
> > convert the omap1_camera driver to the vb2 framework. Also, conversion
> > to the dmaengine framework, long awaited by ARM
Hi Andrey,
> Am 16.06.2016 um 21:51 schrieb Andrey Utkin :
>
> On Tue, Jun 14, 2016 at 07:09:50PM +0200, H. Nikolaus Schaller wrote:
>>
>>> Am 14.06.2016 um 19:02 schrieb Andrey Utkin :
>>> Update: found drivers/input/joystick/as5011.c in mainline kernel,
>>> will look how it works with as5013 h
This fixes up a WARNING: 'Block comments use a trailing */ on a
separate line' found by the checkpatch.pl tool.
Signed-off-by: Ravishankar Karkala Mallikarjunayya
---
drivers/staging/comedi/drivers/dt2811.c | 248
1 file changed, 124 insertions(+), 124 deletions(
This fixes up a WARNING: 'Block comments use a trailing */ on a
separate line' found by the checkpatch.pl tool.
Signed-off-by: Ravishankar Karkala Mallikarjunayya
---
drivers/staging/comedi/drivers/dt2814.c | 72 +
1 file changed, 37 insertions(+), 35 deletions(-)
This fixes up a WARNING: 'Block comments use a trailing */ on a
separate line' found by the checkpatch.pl tool.
Signed-off-by: Ravishankar Karkala Mallikarjunayya
---
drivers/staging/comedi/drivers/dt2815.c | 140
1 file changed, 70 insertions(+), 70 deletions(-)
This fixes up a WARNING: 'Block comments use a trailing */ on a
separate line' found by the checkpatch.pl tool.
Signed-off-by: Ravishankar Karkala Mallikarjunayya
---
drivers/staging/comedi/drivers/dt2817.c | 64 -
1 file changed, 32 insertions(+), 32 deletions(-)
This patch adds the additional status parameter to function
free_anchored_buffers. This allows to dispatch further processing based
on this flag.
Signed-off-by: Andrey Shvetsov
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb.c | 8 +---
1 file changed, 5 insertions(+
This patch set is needed to fix issues of the hdm-usb module.
Christian Gromm (9):
staging: most: hdm-usb: remove unused macro HW_RESYNC
staging: most: hdm-usb: provide MBO status when freeing buffers
staging: most: hdm-usb: fix clear halt processing
staging: most: hdm-usb: stop core from
This patch is needed to ensure that submitted URBs get unlinked before
the driver calls usb_clear_halt(). Since the halt condition of an USB
endpoint is channel related, the work_struct is moved from a buffer
basis to a channel basis.
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-u
This patch removes the macro HW_RESYNC that is not used anymore.
Signed-off-by: Andrey Shvetsov
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/most/hdm-usb/hdm_usb.c
b/drivers/staging/most/hdm-usb/hdm
In order to have a consistent naming convention this patch renames
USB_DEV_ID_INIC to USB_DEV_ID_OS81118.
Signed-off-by: Andrey Shvetsov
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/st
This patch adds support for the OS81119 MOST network interface controller
to the driver.
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb.c | 5 -
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/most/hdm-usb/hdm_usb.c
b/drivers/staging/mos
This patch makes the write completion handler use the is_channel_healthy
flag to prevent the hdm from scheduling a second clear_halt workqueue in
case an endpoint reported a STALL condition.
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb.c | 3 +++
1 file changed, 3 inse
This patch removes the duplication of the expression
(urb->status == -ENOENT || urb->status == -ECONNRESET).
Signed-off-by: Andrey Shvetsov
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb.c | 8 ++--
1 file changed, 2 insertions(+), 6 deletions(-)
diff --git a/drive
This patch simplifies the code that initializes mbo->status.
Signed-off-by: Andrey Shvetsov
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb.c | 14 +-
1 file changed, 5 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/most/hdm-usb/hdm_usb.c
b/driv
This patch ensures that no more packets are submitted by the core in
case an USB endpoint has reported a broken pipe (-EPIPE).
Signed-off-by: Andrey Shvetsov
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff
It depends on user space whether this is safe or not: if programs
interpret the data as a signed time_t value, they will be broken
in y2038, and we have to redesign the entire interface.
Signed-off-by: Arnd Bergmann
---
drivers/staging/comedi/comedi_fops.c | 7 ---
1 file changed, 4 insertio
From: Wei Yongjun
In case of error, the function kthread_run() returns ERR_PTR()
and never returns NULL. The NULL test in the return value check
should be replaced with IS_ERR().
Signed-off-by: Wei Yongjun
---
drivers/staging/wilc1000/linux_wlan.c | 4 ++--
1 file changed, 2 insertions(+), 2 d
On Fri, Jun 10, 2016 at 06:53:36PM -0500, Bjorn Helgaas wrote:
> On Mon, May 30, 2016 at 04:17:57PM +0200, Vitaly Kuznetsov wrote:
> > kmemleak helped me to identify a memory leak in hv_pci_onchannelcallback()
> > and while fixing it I stumbled upon an unrelated issue(s) there.
> >
> > Vitaly Kuzn
Comedi uses 32-bit seconds for its timestamps, on both 32-bit and
64-bit machines. For all I can tell, this was originally meant as
a 'timespec', which would overflow in 2038 because of the use of
a signed 'long' on 32-bit machines, but it is now used as an
array of two unsigned 'lsampl_t' values i
Hi,
This is some clean up of old Ion interfaces and APIs. These are interfaces that
mostly existed before dma_buf was well integrated into the kernel along with
reservations for board files.
If there are objections to deletion I expect it to turn into a discussion about
what other APIs need to b
The ion_sg_table interface is mostly a reimplementation of
what dma_buf is doing. Clients should be using dma_buf APIs instead.
Signed-off-by: Laura Abbott
---
drivers/staging/android/ion/ion.c | 20
drivers/staging/android/ion/ion.h | 11 ---
2 files changed, 31 de
ion_carveout_allocate and ion_carveout_free aren't used outside of the
carveout heap. Get rid of the definitions.
Signed-off-by: Laura Abbott
---
drivers/staging/android/ion/ion_carveout_heap.c | 2 ++
drivers/staging/android/ion/ion_priv.h | 14 --
2 files changed, 2 inse
ion_reserve was supposed to be used to reserve memory in board files.
These days, board files are no more and there are other more controlled
mechanisms for reserving memory. Get rid of this function.
Signed-off-by: Laura Abbott
---
drivers/staging/android/ion/ion.c | 34 ---
The map_dma API interface was designed to generate an sg_table.
Currently, every client just creates the table at allocation time and
then returns the one table. Nothing happens on unmap_dma either.
Just get rid of the API and assign the sg_table directly.
Signed-off-by: Laura Abbott
---
driver
ion_phys was an interface used for older legacy behavior. sg_tables
are the standard now. Get rid of it.
Signed-off-by: Laura Abbott
---
drivers/staging/android/ion/ion.c | 26 -
drivers/staging/android/ion/ion.h | 19 --
drive
looks good to me.
On 2016/6/16 6:45, Jann Horn wrote:
> If /dev/binder is opened and the opener process then e.g. calls execve,
> proc->vma_vm_mm will still point to the location of the now-freed
> mm_struct. If the process then calls ioctl(binder_fd, ...), the dangling
> proc->vma_vm_mm pointer w
Greg,
I checkout your staging tree[1].
Not find this patch. Can you take it thanks!
[1]git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git
On 2016/6/5 23:02, Greg KH wrote:
> On Sun, Jun 05, 2016 at 04:51:23PM +0800, Chen Feng wrote:
>> Hi Greg,
>>
>> Can you take this patch?
>
On Wed, Jun 15, 2016 at 04:02:40AM +0100, James Simmons wrote:
>
> > > This may also possibly help to save cycles due to high usage and
> > > contention when using a generic kmem_cache (when they stay separate
> > > from others, thanks for the precision!).
> >
> > Have you measured this?
> >
> >
On Mon, May 30, 2016 at 03:21:27PM +0100, Luis de Bethencourt wrote:
> On 28/05/16 06:26, Ravishankar Karkala Mallikarjunayya wrote:
> > This is a patch to the s626.c file that fixes up a line over 80
> > characters issues found by the checkpatch.pl tool.
> >
> > Signed-off-by: Ravishankar Karkal
On Sat, May 28, 2016 at 10:56:48AM +0530, Ravishankar Karkala Mallikarjunayya
wrote:
> This is a patch to the s626.c file that fixes up a type issues like
> i.e Prefer kernel type 'u8' over 'uint8_t'
> Prefer kernel type 'u16' over 'uint16_t'
> Prefer kernel type 'u32' over 'uint32_t'
>
On Mon, May 16, 2016 at 11:04:31PM +0530, Amit Ghadge wrote:
> Fixed a warning issue to use 'unsigned int'.
>
> Signed-off-by: Amit Ghadge
> ---
> drivers/staging/comedi/drivers/quatech_daqp_cs.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
Doesn't apply to my tree :(
___
On Tue, May 17, 2016 at 10:23:44PM +0530, Amit Ghadge wrote:
> This is a patch to the quatech_daqp_cs.c file that fixes by using
> unsigned int instead of unsigned, following warning found by checkpatch.
> * WARNING: Prefer 'unsigned int' to bare use of 'unsigned'
>
> Signed-off-by: Amit Ghadge
>
On Thu, May 26, 2016 at 06:35:48PM -0500, Steven Laabs wrote:
> Fixed coding style issues.
That's very vague, please be specific and exact.
thanks,
greg k-h
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mai
On Tue, May 31, 2016 at 09:00:59PM -0300, Pedro Nieto wrote:
> From: PedroNieto
No space?
>
> Fixed a coding style issue.
Which one?
Please be specific.
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mail
On Wed, Jun 01, 2016 at 10:35:57AM +0100, Ian Abbott wrote:
> On 01/06/16 10:19, Ashwin Ravichandran wrote:
> > Fixed a coding style issue.
> >
> > Signed-off-by: Ashwin Ravichandran
> > ---
> > drivers/staging/comedi/drivers/addi-data/hwdrv_apci3501.c | 2 +-
> > drivers/staging/comedi/driver
On Wed, Jun 01, 2016 at 02:19:35AM -0700, Ashwin Ravichandran wrote:
> Fixed a coding style issue.
Which one?
And where are the 2648 previous patches in this series?
thanks,
greg k-h
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev
On Sun, Jun 05, 2016 at 08:10:50PM -0700, Andy Eleftherion wrote:
> Replaced ACCESS_ONCE calls with READ/WRITE_ONCE calls.
Why?
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
51 matches
Mail list logo