On Fri 2016-05-06 01:52:04, Jarkko Sakkinen wrote:
> On Mon, May 02, 2016 at 11:37:52AM -0400, Austin S. Hemmelgarn wrote:
> > On 2016-04-29 16:17, Jarkko Sakkinen wrote:
> > >On Tue, Apr 26, 2016 at 09:00:10PM +0200, Pavel Machek wrote:
> > >>On Mon 2016-04-25 20:34:07, Jarkko Sakkinen wrote:
> >
On 06/05/16 02:05, David Kershner wrote:
> From: Erik Arfvidson
>
> The following struct members were never used:
> putfile_active_buffer::pnext
> putfile_request::file_request_number
> putfile_request::data_sequence_number
>
> Signed-off-by: Erik Arfvidson
> Signed-off-by: David Kershner
>
On Wed, Apr 27, 2016 at 10:18:05AM +0200, Ingo Molnar wrote:
>
> * Andy Lutomirski wrote:
>
> > > What new syscalls would be needed for ssh to get all this support?
> >
> > This patchset or similar, plus some user code and an enclave to use.
> >
> > Sadly, on current CPUs, you also need Intel
On Tue, May 03, 2016 at 04:06:27AM -0500, Dr. Greg Wettstein wrote:
> It would be helpful and instructive for anyone involved in this debate
> to review the following URL which details Intel's SGX licening
> program:
>
> https://software.intel.com/en-us/articles/intel-sgx-product-licensing
I thin
On 06/05/16 03:26, David Kershner wrote:
> From: Erik Arfvidson
>
> The purpose of this patch is to clean up commenting and making the
> code with comments be pleasant to eyes. Also make commenting be
> consistent throughout the file.
>
> Signed-off-by: Erik Arfvidson
> Signed-off-by: David Ker
On 04/05/16 23:25, H Hartley Sweeten wrote:
The interrupt support available on this board is pretty limited but its
simple enough to give basic async command support.
This allows reading a single channel continuously using either the internal
or an external clock to trigger each conversion. The
On Fri, 6 May 2016, Jarkko Sakkinen wrote:
> On Tue, May 03, 2016 at 04:06:27AM -0500, Dr. Greg Wettstein wrote:
> > It would be helpful and instructive for anyone involved in this debate
> > to review the following URL which details Intel's SGX licening
> > program:
> >
> > https://software.inte
On Fri, May 06, 2016 at 09:14:43AM +0200, Pavel Machek wrote:
> On Fri 2016-05-06 01:52:04, Jarkko Sakkinen wrote:
> > On Mon, May 02, 2016 at 11:37:52AM -0400, Austin S. Hemmelgarn wrote:
> > > On 2016-04-29 16:17, Jarkko Sakkinen wrote:
> > > >On Tue, Apr 26, 2016 at 09:00:10PM +0200, Pavel Mache
On Fri, May 6, 2016 at 4:23 AM, Jarkko Sakkinen
wrote:
> On Wed, Apr 27, 2016 at 10:18:05AM +0200, Ingo Molnar wrote:
>>
>> * Andy Lutomirski wrote:
>>
>> > > What new syscalls would be needed for ssh to get all this support?
>> >
>> > This patchset or similar, plus some user code and an enclave
From: Dexuan Cui
Date: Wed, 4 May 2016 09:56:57 -0700
> +#define VMBUS_RINGBUFFER_SIZE_HVSOCK_RECV (5 * PAGE_SIZE)
> +#define VMBUS_RINGBUFFER_SIZE_HVSOCK_SEND (5 * PAGE_SIZE)
> +
> +#define HVSOCK_RCV_BUF_SZVMBUS_RINGBUFFER_SIZE_HVSOCK_RECV
...
> +struct hvsock_sock {
...
> + /* The '
Patch series containing fixes for the s-Par unisys drivers. Each
patch can be applied independently, if needed.
Alexander Curtin (1):
staging: unisys: visorhba: replace functionlike macro with function
David Binder (2):
staging: unisys: visorchannel: correct variable misspelling
staging: un
From: Erik Arfvidson
The following struct members were never used:
putfile_active_buffer::pnext
putfile_request::file_request_number
putfile_request::data_sequence_number
Signed-off-by: Erik Arfvidson
Signed-off-by: David Kershner
Reviewed-by: Luis de Bethencourt
---
drivers/staging/unisy
From: David Binder
Fixes the spelling of a global variable passed into a kernel macro.
Signed-off-by: David Binder
Signed-off-by: David Kershner
---
drivers/staging/unisys/visorbus/visorchipset.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/unisys/visorb
From: Alexander Curtin
The `set_no_disk_inquiry_request` function now uses the correct min
macro. Also I removed an unnecessary conditional.
Get rid of u8 casts, u32 len, and u32 lun (which is actually defined
as a u64 in the scsidev->lun field from whence it originated).
Signed-off-by: Alexand
From: Erik Arfvidson
this patch fixes the following sonarqube issue.
%Lx in format string (no. 1) requires 'unsigned long long'
but the argument type is 'unsigned long long'
Signed-off-by: Erik Arfvidson
Signed-off-by: David Kershner
---
drivers/staging/unisys/visorbus/visorbus_main.c | 10 ++
From: Erik Arfvidson
This patch removes misleading variable name with a more appropriate
name. Since ii is keeping track of fragments inside a for loop I
renamed it frag.
ii->frag
Signed-off-by: Erik Arfvidson
Signed-off-by: David Kershner
---
drivers/staging/unisys/visornic/visornic_main.c |
From: Tim Sell
Previously, if visorhba ever failed to create its thread, it would have
subsequently attempted to do a kthread_stop() on an invalid task_struct
pointer. This was fixed via the new visor_thread_stop() function, which
validates the task_struct pointer before doing the kthread_stop()
From: Erik Arfvidson
The purpose of this patch is to clean up commenting and making the
code with comments be pleasant to eyes. Also make commenting be
consistent throughout the file.
Signed-off-by: Erik Arfvidson
Signed-off-by: David Kershner
Reviewed-by: Luis de Bethencourt
---
drivers/sta
From: Tim Sell
By directly returning for the error-case, a test was eliminated. Also,
the old_state variable was removed as it was not necessary, and some
redundant parens were removed.
Signed-off-by: Tim Sell
Signed-off-by: David Kershner
---
drivers/staging/unisys/visorinput/visorinput.c |
From: Tim Sell
In del_scsipending_ent(), the error-path and main-path were switched, so
the error-path is handled like 'if (err) return;', and the main-path flows
down the left margin. This also allowed us to remove the initialization of
"sent".
Signed-off-by: Tim Sell
Signed-off-by: David Ker
From: David Binder
Addresses code audit feeback to switch from success handling to error
handling in visorhba_main.c/process_disk_notify().
Signed-off-by: David Binder
Signed-off-by: David Kershner
---
drivers/staging/unisys/visorhba/visorhba_main.c | 17 +
1 file changed, 9 i
On 05/05/2016 07:48 PM, Chen Feng wrote:
On 2016/5/6 1:09, Laura Abbott wrote:
On 05/04/2016 08:27 PM, Chen Feng wrote:
Makes the ion buffer always alloced from page pool, no matter
it's cached or not. In this way, it can improve the efficiency
of it.
Currently, there is no difference from c
This patch is to fix some coding style issues pointed
by scripts/checkpatch.pl
Signed-off-by: Bruno Carvalho
---
drivers/staging/gdm724x/gdm_mux.c | 6 --
drivers/staging/gdm724x/gdm_mux.h | 12 ++--
2 files changed, 10 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/gdm
Enables support of different map-on-demand values per NI. This is
required to support OPA coexistence with MLX5 cards. MLX5 does not
support FMR, which is enabled via map-on-demand. However OPA's
performance is greatly enahanced when FMR is enabled. In order
to enable coexistence of both of the
From: Amir Shehata
The functions used to query the NI state passes around the
individual fields of struct lnet_ioctl_config_data. To simplify
the code lets just pass struct lnet_ioctl_config directly.
Signed-off-by: Amir Shehata
Signed-off-by: James Simmons
Intel-bug-id: https://jira.hpdd.inte
From: Amir Shehata
Create and set the default o2iblnd tunables when the ko2iblnd
module loads. Move kiblnd_tunables_setup() to when the NI
iterface is initialized.
Signed-off-by: Amir Shehata
Signed-off-by: James Simmons
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-7101
Reviewed-on: htt
From: Amir Shehata
Convert a few macros in o2iblnd.h to inline functions.
Signed-off-by: Amir Shehata
Signed-off-by: James Simmons
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-7101
Reviewed-on: http://review.whamcloud.com/16367
Reviewed-by: Doug Oucharek
Reviewed-by: Olaf Weber
Review
From: Amir Shehata
The function kibnd_tunables_fini() no longer exist. Remove
it from o2iblnd.h
Signed-off-by: Amir Shehata
Signed-off-by: James Simmons
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-7101
Reviewed-on: http://review.whamcloud.com/16367
Reviewed-by: Doug Oucharek
Reviewed-
From: Amir Shehata
Currently the ko2iblnd creates a kib_tunable_t stucture
to allow the ko2iblnd driver to access the module parameters
throught the code. Some of those data fields also exist
in lnet_ni_t. Migrate to using the lnet_ni_t data fields
instead of kib_tunable_t.
Signed-off-by: Amir S
From: Amir Shehata
Enables support of different map-on-demand values per NI. This is
required to support OPA coexistence with MLX5 cards. MLX5 does not
support FMR, which is enabled via map-on-demand. However OPA's
performance is greatly enahanced when FMR is enabled. In order
to enable coexi
From: Amir Shehata
Add the ability to configure each NI interface at bring up.
Also give the ability for user land utilities to query the
configuration of each NI interface.
Signed-off-by: Amir Shehata
Signed-off-by: James Simmons
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-7101
Review
From: Amir Shehata
The LNet layer passes around the individual fields of struct
lnet_ioctl_config_data for the case of NI bring up. To simplify
the code lets just pass struct lnet_ioctl_config directly.
Signed-off-by: Amir Shehata
Signed-off-by: James Simmons
Intel-bug-id: https://jira.hpdd.in
From: Amir Shehata
For the case of when the connections supported fragment count
is smaller than what is supported locally only set ibr_why to
IBLND_REJECT_RDMA_FRAGS if the ko2iblnd protocol verison is
IBLND_MSG_VERSION.
Signed-off-by: Amir Shehata
Signed-off-by: James Simmons
Intel-bug-id: h
From: Amir Shehata
Currently for LNet all hardware configuration is done with
the modprobe configuration file. These settings are applied
to all hardware instances for a node. That makes it impossible
to configure two different pieces of infiniband hardware that
require very different settings to
On Fri, May 06, 2016 at 06:46:32PM -0400, Bruno Carvalho wrote:
> This patch is to fix some coding style issues pointed
> by scripts/checkpatch.pl
Which ones specifically?
Please be descriptive, as other commits are for this driver, take a look
at them for examples.
And remember, only do one "ty
35 matches
Mail list logo