On Mon, May 02, 2016 at 10:35:54AM +0530, rohitsakala wrote:
> NULL comparison has been changed to correct coding style.
>
> Signed-off-by: rohitsakala
Nah. Write your name properly like you did last time and fix your from
header...
regards,
dan carpenter
_
Reviewing drivers/staging/unisys/visorhba/visorhba_main.c
visor_thread_start()
I'm nervous about the error handling here. Is setting ->id to zero
really sufficient to prevent dereferencing ->task?
Still a lot of return -1;
grep "return -1;" drivers/staging/unisys/ -R
del_scsipending_ent()
flip
This patch changes data type of result variable from s32 to int. result
is used to get return value from wilc_send_config_pkt that has return
type of int.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/host_interface.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a
This patch changes data type of result variable from s32 to int. result
is used to get return value from wilc_send_config_pkt that has return
type of int.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/host_interface.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a
This patch changes conditional comparison of if statement as if (ret)
instead of using if (ret != 0)
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/host_interface.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/wilc1000/host_interface.c
b/drivers/
This patch renames result to ret that is used to get return value from
wilc_send_config_pkt. Some handle_*() functions are used as result,
others are used as ret. It will be changed as ret in all handle_*()
functions to match variable name.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc100
When handle_get_ip_address is called in hostIFthread that is a kernel
thread, it is not checked return type of this function. This patch
changes return type to void and removes braces if statement due to have
a single statement.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/host_inter
When handle_get_mac_address is called in hostIFthread that is a kernel
thread, it is not checked return type of this function. This patch
changes return type to void and removes braces if statement due to have
a single statement.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/host_inte
This patch renames result to ret that is used to get return value from
wilc_send_config_pkt. Some handle_*() functions are used as result,
others are used as ret. It will be changed as ret in all handle_*()
functions to match variable name.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc100
Reviewing drivers/staging/unisys/visornic/visornic_main.c
212 static int
213 visor_copy_fragsinfo_from_skb(struct sk_buff *skb, unsigned int
firstfraglen,
214unsigned int frags_max,
215struct phys_info frags[])
216
Reviewing drivers/staging/unisys/visorinput/visorinput.c
465 case KEY_NUMLOCK:
466 led = LED_NUML;
467 break;
468 default:
469 led = -1;
Just make this a direct return.
470 break;
471
Add Stuart Yoder as additional maintainer of fsl-mc bus driver.
Signed-off-by: Stuart Yoder
---
MAINTAINERS |1 +
1 file changed, 1 insertion(+)
diff --git a/MAINTAINERS b/MAINTAINERS
index 03e00c7..62db04e 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -4670,6 +4670,7 @@ F:sound/soc
> -Original Message-
> From: Greg KH [mailto:gre...@linuxfoundation.org]
> Sent: Friday, April 29, 2016 8:01 PM
> To: Stuart Yoder
> Cc: Jose Rivera ; de...@driverdev.osuosl.org;
> ag...@suse.de; a...@arndb.de;
> linux-ker...@vger.kernel.org; Yang-Leo Li
> Subject: Re: [PATCH 00/14] sta
- Original Message -
> From: "Dan Carpenter"
> Sent: Saturday, April 30, 2016 5:16:19 AM
>
> On Fri, Apr 29, 2016 at 04:41:02PM -0500, Aaron Sierra wrote:
> > There appear to be no in-kernel callers of vme_lm_attach (or
> > vme_lme_request for that matter), so this change only affects the
From: Gustavo Padovan
Move drv_name, the last field of sync_timeline_ops, to sync_timeline
and remove sync_timeline_ops.
struct sync_timeline_ops was just an extra abstraction on top of
fence_ops, and in the last few commits we removed all it ops in favor
of cleaner fence_ops.
Signed-off-by: Gu
From: Gustavo Padovan
Hi,
The following patches do a clean up on the sw_sync inteface. It starts by
removing struct sync_timeline_ops, which was creating unecessary wrappers
in the code and the start to organize the sync_timeline and sw_sync code
better.
sw_sync interface was moved to sw_sync.c
From: Gustavo Padovan
We don't want to export this from the kernel. This is interface is only
for testing and debug. So testers shall copy the ioctl info in their own
projects.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/sw_sync.c | 13 -
drivers/staging/android
From: Gustavo Padovan
Move the list_head members from sync_pt to struct fence was a mistake,
they will not be used by struct fence as planned before, so here we create
sync_pt again to bring the list heads back.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/sync.c | 40 +
From: Gustavo Padovan
When we call sync_print_fence() fence is always valid.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/sync_debug.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/android/sync_debug.c
b/drivers/staging/android/sync_deb
From: Gustavo Padovan
Most of the includes there are not necessary anymore.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/sync.c | 6 --
drivers/staging/android/sync.h | 3 ---
drivers/staging/android/sync_debug.c | 16
3 files changed, 25 deleti
From: Gustavo Padovan
The only use sync_timeline will have in upstream kernel is for debugging
through the SW_SYNC interface. So make it internal to SW_SYNC to avoid
people use it in the future.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/Kconfig | 16 +--
drivers/staging/and
From: Gustavo Padovan
We are moving out of staging/android so rename it to a name that is not
related to android anymore.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/sync.c | 36 ++--
1 file changed, 18 insertions(+), 18 deletions(-)
diff --git a
From: Gustavo Padovan
We can glue the sw_sync file operations directly on the sync framework
without the need to pass through sw_sync wrappers.
It only builds sw_sync debugfs file support if CONFIG_SW_SYNC is enabled.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/Makefile |
From: Gustavo Padovan
Now fence timeline is aware of the last signaled fence, as it
receives the increment to the current value in sync_timeline_signal().
That allow us to remove .has_signaled() from timeline_ops as we can
directly compare using timeline->value and fence->seqno in sync.c
Signed
From: Gustavo Padovan
Now that the value of fence and the timeline are not stored by sw_sync
anymore we can remove this extra abstraction to retrieve this data.
This patch changes both fence_ops (.fence_value_str and
.timeline_value_str) to return the str directly.
It also clean up struct sync_
From: Gustavo Padovan
As we moved value storage to sync_timeline and fence those two structs
became useless and can be removed now.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/sw_sync.c| 24 +++-
drivers/staging/android/sw_sync.h| 24 ++---
From: Gustavo Padovan
Split sync_debug and sw_sync in two different files.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/Makefile | 1 +
drivers/staging/android/sw_sync.c| 136 +++
drivers/staging/android/sync.h | 2 +
drivers/stag
From: Gustavo Padovan
After we removed sw_sync_timeline this arg has not been really used by
anyone, all its users pass the size of struct sync_timeline there.
So simplify this function but not requiring the size anymore.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/sync.c
On 2016-04-29 16:17, Jarkko Sakkinen wrote:
On Tue, Apr 26, 2016 at 09:00:10PM +0200, Pavel Machek wrote:
On Mon 2016-04-25 20:34:07, Jarkko Sakkinen wrote:
Intel(R) SGX is a set of CPU instructions that can be used by
applications to set aside private regions of code and data. The code
outsid
> -Original Message-
> From: Dan Carpenter [mailto:dan.carpen...@oracle.com]
> Sent: Monday, May 02, 2016 8:55 AM
> To: Kershner, David A
> Cc: gre...@linuxfoundation.org; driverdev-devel@linuxdriverproject.org;
> Sell, Timothy C; *S-Par-Maintainer; Binder, David Anthony
> Subject: Re: Time
Rename this member of struct mite_ring to 'descs' to help shorten the
long lines.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/mite.c | 28 ++--
drivers/staging/comedi/drivers/mite.h | 2 +-
2 files changed,
An allocated mite_channel will have its 'ring' member initialized
to point to the mite_ring that will be used for DMA. A non-allocated
mite_channel will have a 'ring' member set to NULL, either by a
channel release or due to the initial kzalloc of the 'mite' struct.
Refactor the code to use the mi
For aesthetics, add docbook comments for the exported functions.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/mite.c | 23 +++
drivers/staging/comedi/drivers/mite.h | 9 +
2 files changed, 28 insertions(+
These functions are basically the comedi_driver (*attach)/(*detach)
for this driver.
For aesthetics, rename mite_alloc() to mite_attach() and pass the
comedi_device pointer to it instead of the pci_dev pointer.
Move the functions to the end of the file. This is typically where
a comedi_drivers (*
Use a local variable for the mite_dma_desc pointer to help clarify
this function.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/mite.c | 22 ++
1 file changed, 10 insertions(+), 12 deletions(-)
diff --git a/driver
Rename this member of struct mite_ring to 'dma_addr' to help shorten the
long lines.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/mite.c | 16
drivers/staging/comedi/drivers/mite.h | 2 +-
2 files changed, 9 inserti
For aesthetics, move the functions that allocate/free and initialize
the mite dma ring. They are currently kind of scattered around the
code.
Add docbook comments for the exported functions.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/driv
For aesthetics, move this functions to a more logical spot in the
code and add a docbook comment for the exported function.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/mite.c | 176 ++
drivers/staging
Rename this struct to simply 'mite'. The current name is a bit redundant.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/mite.c | 33 +++---
drivers/staging/comedi/drivers/mite.h | 18
Move the module_init()/module_exit() so they are in the prefered spot
on the line after the function.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/mite.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/s
Rename this member of struct mite to 'mmio' to help shorten the long lines.
Add a local variable for the mite pointer in the ni_pcimio driver
to clarify and shorten the long lines.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/mite.c
Add a local variable to mite_buf_change() so that the prefered
form of passing a struct size, sizeof(*p), can be used.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/mite.c | 11 ++-
1 file changed, 6 insertions(+), 5 deletions
Introduce a helper function to handle the dma_free_coherent() of
the mite dma descriptors.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/mite.c | 33 -
1 file changed, 16 insertions(+), 17 deletions(-)
This "driver" is not a actually a comedi driver. It's a helper module that
handles DMA for the National Instruments boards that use the MITE ASIC.
This series is mostly an aesthetic cleanup that shortens the long struct
names and the members of the structs. It also shuffles around the functions
in
For aesthetics, make the actual "request" function static and change
mite_request_channel_in_range() into a wrapper that calls the internal
function. Change the inline function that requests any free channel
into an export that also calls the internal function.
Move the functions to a more logical
The dev_err() messages with pci_ioremap_bar() fails are just noise.
Remove them.
The 'use_win1' and 'fifo_size' dev_info() messages are also noise
but they may be useful when debugging. Change them to dev_dbg().
Absorb dump_chip_signnature() and change the pr_info() messages
to dev_dbg(). These a
Rename this name to 'mite_ring' to help shorten the long lines.
In the ni_660x driver, also shorten the private data member 'mite_rings'
to simply 'ring'.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/mite.c | 21 +--
For aesthetics, move these functions to a more logical spot in the
code and add docbook comments for the exported functions.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/mite.c | 76 +++
drivers/stagin
Rename this struct to 'mite_dma_desc' to help shorten the long lines.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/mite.c | 8
drivers/staging/comedi/drivers/mite.h | 4 ++--
2 files changed, 6 insertions(+), 6 deletions(-)
Currently all the drivers that use the mite driver have to call
mite_setup() after allocating and initializing the mite device
with mite_attach().
Move the mite_setup() call into mite_attach() to simplify the
drivers a bit and remove the need for the additional inline and
exported functions.
For
On Mon, May 02, 2016 at 04:38:27PM +, Sell, Timothy C wrote:
> After we get these changes in, is there a specific process we need to
> follow in order to have visornic inspected by the netdev folks
> (assume net...@vger.kernel.org) and visorhba inspected by the scsi folks
> (assume linux-s...@v
On Fri, Apr 29, 2016 at 11:39:10AM +0200, Vitaly Kuznetsov wrote:
> Kernel hang is observed when pci-hyperv module is release with device
> drivers still attached. E.g. when I do 'rmmod pci_hyperv' with BCM5720
> device pass-through-ed (tg3 module) I see the following:
>
> NMI watchdog: BUG: soft
On Wed 2016-04-27 13:27:08, Gustavo Padovan wrote:
> From: Gustavo Padovan
>
> struct sync_merge_data already have documentation on top of the
> struct definition. No need to duplicate it.
>
> Signed-off-by: Gustavo Padovan
> Reviewed-by: Maarten Lankhorst
> @@ -33,8 +33,8 @@ struct sync_merg
Hi!
> -}
> -EXPORT_SYMBOL(sync_file_merge);
> -
> static const char *android_fence_get_driver_name(struct fence *fence)
> {
> struct sync_timeline *parent = fence_parent(fence);
if this is meant to be used outside android, should it select some
better prefix than android_fence_?
Thanks,
2016-05-02 Pavel Machek :
> On Wed 2016-04-27 13:27:08, Gustavo Padovan wrote:
> > From: Gustavo Padovan
> >
> > struct sync_merge_data already have documentation on top of the
> > struct definition. No need to duplicate it.
> >
> > Signed-off-by: Gustavo Padovan
> > Reviewed-by: Maarten Lankh
Hi Pavel,
2016-05-02 Pavel Machek :
> Hi!
>
>
> > -}
> > -EXPORT_SYMBOL(sync_file_merge);
> > -
> > static const char *android_fence_get_driver_name(struct fence *fence)
> > {
> > struct sync_timeline *parent = fence_parent(fence);
>
> if this is meant to be used outside android, should
This patch fixes the checkpatch.pl warning:
WARNING: Macros with flow control statements should be avoided
+#define board_staging(str, fn) \
+static int __init runtime_board_check(void)\
+{ \
+ if (of_machine_is_compatible(str)
On Tue, May 03, 2016 at 06:01:56AM +0300, Nikita Eshkeev wrote:
> This patch fixes the checkpatch.pl warning:
>
> WARNING: Macros with flow control statements should be avoided
> +#define board_staging(str, fn) \
> +static int __init runtime_board_check(void) \
> +{
58 matches
Mail list logo