Implementing the mtd_ooblayout_ops interface is the new way of exposing
ECC/OOB layout to MTD users.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/hisi504_nand.c | 27 ---
1 file changed, 24 insertions(+), 3 deletions(-)
diff --git a/drivers/mtd/nand/hisi504_nand.c
Use the mtd_set_ecclayout() helper instead of directly assigning the
mtd->ecclayout field.
Signed-off-by: Boris Brezillon
---
drivers/mtd/mtdconcat.c | 2 +-
drivers/mtd/mtdpart.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/mtd/mtdconcat.c b/drivers/mtd/mtdco
ECC layout definitions are currently exposed using the nand_ecclayout
struct which embeds oobfree and eccpos arrays with predefined size.
This approach was acceptable when NAND chips were providing relatively
small OOB regions, but MLC and TLC now provide OOB regions of several
hundreds of bytes, w
Implementing the mtd_ooblayout_ops interface is the new way of exposing
ECC/OOB layout to MTD users.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/docg4.c | 33 -
1 file changed, 28 insertions(+), 5 deletions(-)
diff --git a/drivers/mtd/nand/docg4.c b/drive
Use the mtd_set_ecclayout() helper instead of directly assigning the
mtd->ecclayout field.
Signed-off-by: Boris Brezillon
---
drivers/mtd/devices/docg3.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/mtd/devices/docg3.c b/drivers/mtd/devices/docg3.c
index e7b2e43..6
Replace the default nand_ecclayout definitions for large and small page
devices with the equivalent mtd_ooblayout_ops.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/nand_base.c | 147 ---
include/linux/mtd/nand.h | 3 +
2 files changed, 99 inse
Implementing the mtd_ooblayout_ops interface is the new way of exposing
ECC/OOB layout to MTD users.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/lpc32xx_mlc.c | 50 --
drivers/mtd/nand/lpc32xx_slc.c | 41 +++---
2 files
Implementing the mtd_ooblayout_ops interface is the new way of exposing
ECC/OOB layout to MTD users. Modify the onenand drivers to switch to this
approach.
Signed-off-by: Boris Brezillon
---
drivers/mtd/onenand/onenand_base.c | 154 ++---
include/linux/mtd/onenand
Implementing the mtd_ooblayout_ops interface is the new way of exposing
ECC/OOB layout to MTD users.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/gpmi-nand/gpmi-nand.c | 52 ++
1 file changed, 40 insertions(+), 12 deletions(-)
diff --git a/drivers/mtd/nand
Implementing the mtd_ooblayout_ops interface is the new way of exposing
ECC/OOB layout to MTD users.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/fsl_ifc_nand.c | 232
1 file changed, 67 insertions(+), 165 deletions(-)
diff --git a/drivers/mtd/nan
Replace the nand_ecclayout definition by the equivalent mtd_ooblayout_ops
definition.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/nand_bch.c | 33 +++--
1 file changed, 11 insertions(+), 22 deletions(-)
diff --git a/drivers/mtd/nand/nand_bch.c b/drivers/mtd/n
Implementing the mtd_ooblayout_ops interface is the new way of exposing
ECC/OOB layout to MTD users.
Signed-off-by: Boris Brezillon
---
arch/arm/mach-pxa/spitz.c | 55 -
drivers/mtd/nand/sharpsl.c | 2 +-
include/linux/mtd/sharpsl.h | 2 +-
3 file
Implementing the mtd_ooblayout_ops interface is the new way of exposing
ECC/OOB layout to MTD users.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/sh_flctl.c | 87 ++---
1 file changed, 67 insertions(+), 20 deletions(-)
diff --git a/drivers/mtd/nand
Replace the nand_ecclayout definition by the equivalent mtd_ooblayout_ops
definition.
Signed-off-by: Boris Brezillon
---
drivers/staging/mt29f_spinand/mt29f_spinand.c | 48 +--
1 file changed, 30 insertions(+), 18 deletions(-)
diff --git a/drivers/staging/mt29f_spinand/m
Implementing the mtd_ooblayout_ops interface is the new way of exposing
ECC/OOB layout to MTD users.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/mxc_nand.c | 212 ++--
1 file changed, 105 insertions(+), 107 deletions(-)
diff --git a/drivers/mtd/na
Implementing the mtd_ooblayout_ops interface is the new way of exposing
ECC/OOB layout to MTD users.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/davinci_nand.c | 118 +++-
1 file changed, 44 insertions(+), 74 deletions(-)
diff --git a/drivers/mtd/nand
Implementing the mtd_ooblayout_ops interface is the new way of exposing
ECC/OOB layout to MTD users.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/s3c2410.c | 32 +++-
1 file changed, 27 insertions(+), 5 deletions(-)
diff --git a/drivers/mtd/nand/s3c2410.c b/dr
Implementing the mtd_ooblayout_ops interface is the new way of exposing
ECC/OOB layout to MTD users.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/sunxi_nand.c | 114 +++---
1 file changed, 52 insertions(+), 62 deletions(-)
diff --git a/drivers/mtd/nand
Implementing the mtd_ooblayout_ops interface is the new way of exposing
ECC/OOB layout to MTD users.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/sm_common.c | 93
1 file changed, 77 insertions(+), 16 deletions(-)
diff --git a/drivers/mtd/nand
Now that all NAND drivers have switch to mtd_ooblayout_ops, we can kill
the ecc->layout field.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/nand_base.c | 8
drivers/mtd/nand/nand_bch.c | 9 -
include/linux/mtd/nand.h | 2 --
3 files changed, 19 deletions(-)
diff --g
Implementing the mtd_ooblayout_ops interface is the new way of exposing
ECC/OOB layout to MTD users.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/vf610_nfc.c | 34 --
1 file changed, 4 insertions(+), 30 deletions(-)
diff --git a/drivers/mtd/nand/vf610_nfc.
Now that all MTD drivers have moved to the mtd_ooblayout_ops model we can
safely remove the struct nand_ecclayout definition, and all the remaining
places where it was still used.
Signed-off-by: Boris Brezillon
---
drivers/mtd/mtdchar.c | 12 ++---
drivers/mtd/mtdcore.c | 120
Implementing the mtd_ooblayout_ops interface is the new way of exposing
ECC/OOB layout to MTD users.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/pxa3xx_nand.c | 104 +
1 file changed, 64 insertions(+), 40 deletions(-)
diff --git a/drivers/mtd/nand
Implementing the mtd_ooblayout_ops interface is the new way of exposing
ECC/OOB layout to MTD users.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/omap2.c | 194 +++
1 file changed, 113 insertions(+), 81 deletions(-)
diff --git a/drivers/mtd/nan
On 02/01/2016 11:34 AM, Arnd Bergmann wrote:
> The amso1100 driver prints a phys_addr_t by casting it to a pointer,
> which causes a warning when phys_addr_t is 64-bit and pointers
> are 32-bit:
>
> drivers/staging/rdma/amso1100/c2.c: In function 'c2_rx_error':
> drivers/staging/rdma/amso1100/c2.c
2016-02-04 Maarten Lankhorst :
> Op 03-02-16 om 21:09 schreef Gustavo Padovan:
> > Hi Maarten,
> >
> > 2016-02-03 Maarten Lankhorst :
> >
> >> Op 03-02-16 om 14:25 schreef Gustavo Padovan:
> >>> From: Gustavo Padovan
> >>>
> >>> Turn sync_fence_info into __u64 type enable us to extend the struct
On Thursday 04 February 2016 07:15:05 Doug Ledford wrote:
> I've sent off a deletion of this file to Linus already, sorry.
>
Even better, thanks!
Arnd
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/m
From: Hari Prasath Gujulan Elango
Date: Thu, 4 Feb 2016 18:46:31 +0530
Replace the timer API's to initialize a timer & then assign the callback
function by the setup_timer() API.
Signed-off-by: Hari Prasath Gujulan Elango
---
drivers/staging/rdma/ehca/ehca_main.c | 3 +--
drivers/staging/rdma/
Op 04-02-16 om 14:05 schreef Gustavo Padovan:
> 2016-02-04 Maarten Lankhorst :
>
>> Op 03-02-16 om 21:09 schreef Gustavo Padovan:
>>> Hi Maarten,
>>>
>>> 2016-02-03 Maarten Lankhorst :
>>>
Op 03-02-16 om 14:25 schreef Gustavo Padovan:
> From: Gustavo Padovan
>
> Turn sync_fence_in
From: Hari Prasath Gujulan Elango
Replace the timer API's to initialize a timer & then assign the callback
function by the setup_timer() API.
Signed-off-by: Hari Prasath Gujulan Elango
---
v2: Unwanted text present in the commit comments
sections.Removed them
---
drivers/staging/rdma/e
Add static attribute calibbias_available to show available
configurations for the bias current.
API for setting bias measurement configuration:
0 - Normal measurement configuration (default): In normal measurement
configuration the device follows normal measurement flow. Pins BP
and BN ar
Replace non standard meas_conf attribute with the standard IIO
calibbias attribute.
API for setting bias measurement configuration:
0 - Normal measurement configuration (default): In normal measurement
configuration the device follows normal measurement flow. Pins BP
and BN are left float
> Subject: [PATCH] staging: rdma: use setup_timer() api
>
> From: Hari Prasath Gujulan Elango
>
Doug,
We are going to add this to the rdmavt/hfi1/qib work, with the appropriate
authorship credit. Otherwise, there will certainly be conflicts.
Hari,
Note that ehca is going away.
In additio
On Thu, Feb 04, 2016 at 09:38:32AM -0600, Mike Marciniszyn wrote:
> > Subject: [PATCH] staging: rdma: use setup_timer() api
> >
> > From: Hari Prasath Gujulan Elango
> >
>
> Doug,
>
> We are going to add this to the rdmavt/hfi1/qib work, with the appropriate
> authorship credit. Otherwise,
On 02/04/2016 03:50 PM, Cristina Moraru wrote:
> Replace non standard meas_conf attribute with the standard IIO
> calibbias attribute.
>
> API for setting bias measurement configuration:
>
> 0 - Normal measurement configuration (default): In normal measurement
> configuration the device follo
1. Adding NETIF_F_TSO6 feature flag;
2. Adding NETIF_F_HW_CSUM. NETIF_F_IPV6_CSUM and NETIF_F_IP_CSUM are
being deprecated;
3. Cleanup the coding style of flag assignment by using macro.
Signed-off-by: Simon Xiao
Reviewed-by: K. Y. Srinivasan
Reviewed-by: Haiyang Zhang
---
drivers/net/hyperv/
On Thu, 2016-02-04 at 18:24 +0900, Glen Lee wrote:
> From: Leo Kim
>
> This patch removes the warnings reported by checkpatch.pl
> for line over 80 characters.
>
> Signed-off-by: Leo Kim
> ---
> drivers/staging/wilc1000/coreconfigurator.c | 11 +++
> 1 file changed, 7 insertions(+), 4
Re:COMPENSATION
Attention: Beneficiary
Attn: Be informed that Your Contract/Inheritance Fund ATM CARD PIN is 1765.
Your daily Card Limit is 10,000.00 USD per day. The Card is valid till December
2017. And the Total Amount in the ATM VISA Card is One Million United State
Dollars. We await your
This patch changes return type of wilc_hif_set_cfg from s32 to int.
The result variable gets return value from wilc_mq_send that has data
type of int. It should be changed return type of this function as well
as data type of result variable.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc10
This patch changes return type of wilc_deinit from s32 to int.
The result variable gets return value from wilc_mq_send that has return
type of int. It should be changed return type of this function as well
as data type of result variable.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/
This patch renames pstrCfgParamVal to cfg_param to avoid camelcase.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/host_interface.c | 4 ++--
drivers/staging/wilc1000/host_interface.h | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/wilc1000/host_i
counter is used as for-loop control variable and indicating index of
struct wid array so that it is better to use int type.
There is no need to set to 0 when it is declared at the top of this
function. It is initialized as 0 in for-loop statement.
Signed-off-by: Chaehyun Lim
---
drivers/staging/
It should be returned error code as -EFAULT instead of 0 when hif_drv is
NULL.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/host_interface.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/wilc1000/host_interface.c
b/drivers/staging/wilc1000/host_
There is no need to set to 0 for counter variable before entering next
for-loop statement because counter is initialized again in for-loop
statement, so just remove it.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/coreconfigurator.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/
counter is used as for-loop control variable and indicating index of
struct wid array. It is to improve readability by changing counter
variable name as i because wilc_send_config_pkt has a similar argument
name as count.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/coreconfigurator.
wilc_send_config_pkt is returned 0 or -ETIMEDOUT according to return
value of wilc_wlan_cfg_get or wilc_wlan_cfg_set.
It is better to use int type to represent linux standard error code.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/coreconfigurator.c | 5 +++--
1 file changed, 3 inse
In this file,function names are otherwise used as pointers without &.
Found using coccinelle.
//
@r@
identifier f;
@@
f(...) { ... }
@@
identifier r.f;
@@
- &f
+ f
//
Signed-off-by: Bhumika Goyal
---
drivers/staging/iio/impedance-analyzer/ad5933.c | 8
1 file changed, 4 insertions(+
Commit 73584a40d748 ("staging: wilc1000: add ops resuem/suspend/wakeup in
cfg80211") causes following compilation error. This patch fixes this by
using suspend/resume under CONFIG_PM.
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c: In function
'wilc_create_wiphy':
>> drivers/staging/wilc1000/wi
On Thu, 4 Feb 2016 11:06:28 +0100
Boris Brezillon wrote:
> In order to make the ecclayout definition completely dynamic we need to
> rework the way the OOB layout are defined and iterated.
>
> Create a few mtd_ooblayout_xxx() helpers to ease OOB bytes manipulation
> and hide ecclayout internals
101 - 149 of 149 matches
Mail list logo