On Thu, Jan 21, 2016 at 10:20:28AM +0900, Chaehyun Lim wrote:
> This patch fixes coding style of kmalloc usage found by checkpatch.
> CHECK: Prefer kmalloc(sizeof(*new_msg)...) over kmalloc(sizeof(struct
> message)...)
>
> Signed-off-by: Chaehyun Lim
> ---
> drivers/staging/wilc1000/wilc_msgque
Larry Finger writes:
> Recently, it has been reported that D-Link DWA-582 cards, which use an
> RTL8812AE chip are not able to scan for 5G networks. The problems started
> with kernel 4.2, which is the first version that had commit d10101a60372
> ("rtlwifi: rtl8821ae: Fix problem with regulatory
On Thu, Jan 21, 2016 at 01:48:16PM +0530, Sudip Mukherjee wrote:
> On Thu, Jan 21, 2016 at 10:20:28AM +0900, Chaehyun Lim wrote:
> > This patch fixes coding style of kmalloc usage found by checkpatch.
> > CHECK: Prefer kmalloc(sizeof(*new_msg)...) over kmalloc(sizeof(struct
> > message)...)
> >
>
On 01/21/2016 02:52 AM, Kalle Valo wrote:
Larry Finger writes:
Recently, it has been reported that D-Link DWA-582 cards, which use an
RTL8812AE chip are not able to scan for 5G networks. The problems started
with kernel 4.2, which is the first version that had commit d10101a60372
("rtlwifi: rt
From: Hari Prasath Gujulan Elango
This patch replaces the clk_get() with devm_clk_get().
Accordingly,modified the error paths and removed clk_put() as well.
Signed-off-by: Hari Prasath Gujulan Elango
---
drivers/staging/iio/adc/spear_adc.c | 6 ++
1 file changed, 2 insertions(+), 4 deletion
These are all checkpatch.pl warnings, not sparse warnings.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On Wed, Jan 20, 2016 at 09:48:39PM -0200, Lucas Tanure wrote:
> The conversion from void pointer to any other pointer type is guaranteed by
> the C programming language.
>
> Signed-off-by: Lucas Tanure
> ---
> drivers/staging/comedi/drivers/s626.c | 8
> 1 file changed, 4 insertions(+),
On Thu, Jan 21, 2016 at 09:11:38AM +, Gujulan Elango, Hari Prasath (H.)
wrote:
> From: Hari Prasath Gujulan Elango
>
Your email address is missing here.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.l
On Thu, Jan 21, 2016 at 12:45:59PM +0300, Dan Carpenter wrote:
> On Thu, Jan 21, 2016 at 09:11:38AM +, Gujulan Elango, Hari Prasath (H.)
> wrote:
> > From: Hari Prasath Gujulan Elango
> >
>
> Your email address is missing here.
Hello Dan,
Many thanks for notifying.I am sending a v2.
regards
From: Hari Prasath Gujulan Elango
This patch replaces the clk_get() with devm_clk_get().
Accordingly,modified the error paths and removed clk_put() as well.
Signed-off-by: Hari Prasath Gujulan Elango
---
v2: email address was missing in the From field.
---
drivers/staging/iio/adc/spear
On Thu, Jan 21, 2016 at 5:55 PM, Dan Carpenter wrote:
> On Thu, Jan 21, 2016 at 01:48:16PM +0530, Sudip Mukherjee wrote:
>> On Thu, Jan 21, 2016 at 10:20:28AM +0900, Chaehyun Lim wrote:
>> > This patch fixes coding style of kmalloc usage found by checkpatch.
>> > CHECK: Prefer kmalloc(sizeof(*new_
On Thu, Jan 21, 2016 at 07:01:45PM +0900, Chaehyun Lim wrote:
> On Thu, Jan 21, 2016 at 5:55 PM, Dan Carpenter
> wrote:
> > On Thu, Jan 21, 2016 at 01:48:16PM +0530, Sudip Mukherjee wrote:
> >> On Thu, Jan 21, 2016 at 10:20:28AM +0900, Chaehyun Lim wrote:
> >> > This patch fixes coding style of k
From: Hari Prasath Gujulan Elango
Replace the led_classdev_register() with the platform managed version
devm_led_classdev_register() & henceforth remove the redundant
nvec_paz00_remove() function.
Signed-off-by: Hari Prasath Gujulan Elango
---
drivers/staging/nvec/nvec_paz00.c | 12 +--
On Thu, Jan 21, 2016 at 7:04 PM, Dan Carpenter wrote:
> On Thu, Jan 21, 2016 at 07:01:45PM +0900, Chaehyun Lim wrote:
>> On Thu, Jan 21, 2016 at 5:55 PM, Dan Carpenter
>> wrote:
>> > On Thu, Jan 21, 2016 at 01:48:16PM +0530, Sudip Mukherjee wrote:
>> >> On Thu, Jan 21, 2016 at 10:20:28AM +0900,
This patch renames pvBuffer to buf to avoid camelcase.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 10 +-
drivers/staging/wilc1000/wilc_msgqueue.h | 2 +-
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_msgqueue
This patch renames typedef from struct __Message_struct and renames it
to struct message.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 10 +-
drivers/staging/wilc1000/wilc_msgqueue.h | 8
2 files changed, 9 insertions(+), 9 deletions(-)
diff --git
This patch renames strCriticalSection to lock to avoid camelcase.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 18 +-
drivers/staging/wilc1000/wilc_msgqueue.h | 2 +-
2 files changed, 10 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/w
V2:
A 18/27 patch of series has a wrong name as tail_msg, which is should be
changed to pstrTailMsg. I fixed it in V2.
Chaehyun Lim (27):
staging: wilc1000: rename struct __Message_struct
staging: wilc1000: rename pvBuffer in struct message
staging: wilc1000: rename u32Length in struct messa
This patch renames u32Length to len to avoid camelcase.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 8
drivers/staging/wilc1000/wilc_msgqueue.h | 2 +-
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_msgqueue.c
This patch renames u32ReceiversCount to recv_count to avoid camelcase.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 10 +-
drivers/staging/wilc1000/wilc_msgqueue.h | 2 +-
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/wilc10
This patch renames pstrNext to next to avoid camelcase.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 12 ++--
drivers/staging/wilc1000/wilc_msgqueue.h | 2 +-
2 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_msgqu
This patch renames u32RecvBufferSize to recv_buf_size to avoid
camelcase.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 8
drivers/staging/wilc1000/wilc_msgqueue.h | 2 +-
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/wilc100
This patch removes typedef from struct WILC_MsgQueueHandle and renames
it to struct message_queue.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/host_interface.c | 2 +-
drivers/staging/wilc1000/wilc_msgqueue.c | 14 +++---
drivers/staging/wilc1000/wilc_msgqueue.h | 18
This patch renames pHandle to mq to avoid camelcase.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 22 +++---
drivers/staging/wilc1000/wilc_msgqueue.h | 2 +-
2 files changed, 12 insertions(+), 12 deletions(-)
diff --git a/drivers/staging/wilc1000/w
This patch renames pvSendBuffer to send_buf to avoid camelcase.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 8
drivers/staging/wilc1000/wilc_msgqueue.h | 2 +-
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_msg
This patch renames pstrTailMsg to tail_msg to avoid camelcase.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_msgqueue.c
b/drivers/staging/wilc1000/wilc_msgqueue.c
This patch renames bExiting to exiting to avoid camelcase.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 8
drivers/staging/wilc1000/wilc_msgqueue.h | 2 +-
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_msgqueue
This patch renames pHandle to mq to avoid camelcase.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 34
drivers/staging/wilc1000/wilc_msgqueue.h | 2 +-
2 files changed, 18 insertions(+), 18 deletions(-)
diff --git a/drivers/staging/
This patch renames pHandle to mq to avoid camelcase
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 18 +-
drivers/staging/wilc1000/wilc_msgqueue.h | 2 +-
2 files changed, 10 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_m
This patch renames pstrMessageList to msg_list to avoid camelcase.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 20 ++--
drivers/staging/wilc1000/wilc_msgqueue.h | 2 +-
2 files changed, 11 insertions(+), 11 deletions(-)
diff --git a/drivers/stagin
This patch renames pstrMessge to msg to avoid camelcase.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_msgqueue.c
b/drivers/staging/wilc1000/wilc_msgqueue.c
index 103
This patch renames pHandle to mq to avoid camelcase
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 12 ++--
drivers/staging/wilc1000/wilc_msgqueue.h | 2 +-
2 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_msgqueue.
This patch renames u32SendBufferSize to send_buf_size to avoid
camelcase.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 8
drivers/staging/wilc1000/wilc_msgqueue.h | 2 +-
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/wilc100
This patch renames hSem to sem to avoid camelcase.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 10 +-
drivers/staging/wilc1000/wilc_msgqueue.h | 2 +-
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_msgqueue.c
Three argument are checked at the beginning of wilc_mq_send whether
they are valid arguments or not. It is correct to use return error code
as -EINVAL, not -EFAULT.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
dif
This patch renames pstrMessage to new_msg to avoid camelcase.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 21 ++---
1 file changed, 10 insertions(+), 11 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_msgqueue.c
b/drivers/staging/wilc1000/
This patch renames pvRecvBuffer to recv_buf to avoid camelcase.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 8
drivers/staging/wilc1000/wilc_msgqueue.h | 2 +-
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_msg
There are over-commenting in wilc_msgqueue.h file. This comment is not
explain exactly what codes do and make checkpatch warning about "line
over 80 charcters". If necessary, comment will be added later with
preferred coding style.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_ms
This patch fixes logical continuations found by checkpatch
CHECK: Logical continuations should be on the previous line
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_msgq
This patch fixes coding style of kmalloc usage found by checkpatch.
CHECK: Prefer kmalloc(sizeof(*new_msg)...) over kmalloc(sizeof(struct
message)...)
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/dri
This patch renames pu32ReceivedLength to recv_len to avoid camelcase.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 7 +++
drivers/staging/wilc1000/wilc_msgqueue.h | 3 +--
2 files changed, 4 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/wilc1000/wi
This patch renames pstrMessage to msg to avoid camelcase.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_msgqueue.c | 20 ++--
1 file changed, 10 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_msgqueue.c
b/drivers/staging/wilc1000/wilc_
From: Liviu Dudau
ion_buffer_create() will allocate a buffer and then create a DMA
mapping for it, but it forgot to set the length of the page entries.
Signed-off-by: Liviu Dudau
Signed-off-by: Jon Medhurst
---
drivers/staging/android/ion/ion.c | 4 +++-
1 file changed, 3 insertions(+), 1 del
On 12/01/16 08:17, Spencer E. Olson wrote:
This change enables the mite DMA controller to only transfer the amount of
data needed by a command. By default, the old behavior of transferring the
entire comedi DMA data buffer is still in effect. These changes allow a
command to only transmit a lim
From: Gustavo Padovan
Creates the 'sync' dir on debugfs root dir and move the 'sync' file
to sync/info. This is the preparation to add more debug info and control.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/sync_debug.c | 21 +
1 file changed, 17 insertions(
From: Gustavo Padovan
These interfaces are not used nor have plans to be used in the near
future so remove them for a cleaner solution before de-staging the sync
framework.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/sync.c | 56
driver
From: Gustavo Padovan
'sync_pt' is actually declared as struct fence so to make the name means
its type we rename it to 'fence'.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/sync.c | 20 ++--
drivers/staging/android/sync.h | 2 +-
drivers/staging/andr
From: Gustavo Padovan
This remove CONFIG_SW_SYNC_USER and instead compile the sw_sync file into
debugpfs under /sync/sw_sync.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/Kconfig | 9 ---
drivers/staging/android/sw_sync.c| 129 ---
drive
From: Gustavo Padovan
Updates comments about functions and structures.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/sync.h | 45 --
1 file changed, 21 insertions(+), 24 deletions(-)
diff --git a/drivers/staging/android/sync.h b/drivers/sta
From: Gustavo Padovan
Hi,
The following patches are some clean ups on the sync framework before
we start the actual de-staging. The main changes here are the move of
SW_SYNC_USER to debugfs. Removal of struct sync_pt in favor of direct
use of struct fence. And the rename of sync_fence to sync_fi
From: Gustavo Padovan
With the removal of struct sync_pt sync_fence_create_dma() now takes
the same arguments as sync_fence_create() so let's keep only
sync_fence_create().
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/sync.c | 8 +---
drivers/staging/android/sync.h | 10
From: Gustavo Padovan
.dup and .compare are not used by the sync framework, so remove them
from sw_sync.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/sw_sync.c | 29 +
drivers/staging/android/sync.c| 6 --
drivers/staging/android/sync.h| 1
From: Gustavo Padovan
sync_file has a more close meaning to what a sync_fence really, a struct
that represent a file that can be used by userspace to get information on
a fence, or wait for it to be signaled.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/sync.c | 254 +++
From: Gustavo Padovan
struct sync_pt was just wrapping around struct fence and creating an
extra abstraction layer. The only two members of struct sync_pt, child_list
and active_list, were moved to struct fence in an earlier commit. After
removing those two members struct sync_pt is nothing more
From: Gustavo Padovan
All changes to timeline value come through the user via
sync_timeline_signal() calls. When sync_timeline_destroy() is called no
changes on timeline->value happens hence call sync_timeline_signal() with
no increment is pointless.
Signed-off-by: Gustavo Padovan
---
drivers/
From: Gustavo Padovan
signaled_pts is not used in this function.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/sync.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/android/sync.c b/drivers/staging/android/sync.c
index 3c2c8d0..9ec55ef 100644
--- a/drivers/stag
On 12/01/16 08:17, Spencer E. Olson wrote:
This patch implements for analog output the reinterpretation of stop_arg
when stop_src == TRIG_NONE to allow the user to specify the length of the
buffer that should be repeated. The intent is to allow a user to have a
specific buffer repeated as-is ind
On 12/01/16 08:17, Spencer E. Olson wrote:
This patch continues the implementation of reinterpreting stop_arg when
stop_src == TRIG_NONE for national instruments cdio output on e/m-series
devices. This is part of a series of patches that allow a user to have a
specific buffer repeated as-is inde
On 01/21/2016 03:57 AM, Jon Medhurst (Tixy) wrote:
From: Liviu Dudau
ion_buffer_create() will allocate a buffer and then create a DMA
mapping for it, but it forgot to set the length of the page entries.
Signed-off-by: Liviu Dudau
Signed-off-by: Jon Medhurst
---
drivers/staging/android/ion/
On Thu, Jan 21, 2016 at 12:27:59PM +0300, Dan Carpenter wrote:
> These are all checkpatch.pl warnings, not sparse warnings.
>
> regards,
> dan carpenter
>
Thanks for pointing this out. I will be more careful when choosing a subject in
the future.
Regards,
--Arthur Marble
___
On Thu, Jan 21, 2016 at 1:11 AM, Gujulan Elango, Hari Prasath (H.)
wrote:
> From: Hari Prasath Gujulan Elango
>
> This patch replaces the clk_get() with devm_clk_get().
> Accordingly,modified the error paths and removed clk_put() as well.
>
> Signed-off-by: Hari Prasath Gujulan Elango
> ---
> dr
On Thu, Jan 21, 2016 at 11:21:53AM -0800, Matt Ranostay wrote:
> > @@ -356,8 +356,6 @@ static int spear_adc_probe(struct platform_device *pdev)
> >
> > errout3:
> > clk_disable_unprepare(st->clk);
>
> Shouldn't errout3 now be errout2.. having a gap would seem odd.
>
> > -errout2:
> > -
On Thu, 2016-01-21 at 09:39 -0800, Laura Abbott wrote:
> On 01/21/2016 03:57 AM, Jon Medhurst (Tixy) wrote:
> > From: Liviu Dudau
> >
> > ion_buffer_create() will allocate a buffer and then create a DMA
> > mapping for it, but it forgot to set the length of the page entries.
> >
> > Signed-off-by:
On 01/21/2016 12:19 PM, Jon Medhurst (Tixy) wrote:
On Thu, 2016-01-21 at 09:39 -0800, Laura Abbott wrote:
On 01/21/2016 03:57 AM, Jon Medhurst (Tixy) wrote:
From: Liviu Dudau
ion_buffer_create() will allocate a buffer and then create a DMA
mapping for it, but it forgot to set the length of th
On Thu, Jan 21, 2016 at 11:21:53AM -0800, Matt Ranostay wrote:
> On Thu, Jan 21, 2016 at 1:11 AM, Gujulan Elango, Hari Prasath (H.)
> wrote:
> > From: Hari Prasath Gujulan Elango
> >
> > This patch replaces the clk_get() with devm_clk_get().
> > Accordingly,modified the error paths and removed clk
This patch passes vif instead of wilc to wilc_send_config_pkt and it's related
functions as well, because we need vif which is currently being used and
vif has wilc as well.
Change custom print with netdev_xxx format if there are custom print inside
the functions we have changed.
Function paramete
This patch moves the function wilc_send_config_pkt to wilc_wlan.c which
handles transport since the purpose of the function is sending/getting of
config information. coreconfiguator.[ch] will be rename with frame.[ch] later.
The print codes of the function is removed also and they will be implement
You should be running checkpatch.pl on your patches.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
What does TCP_ACK_FILTER do?
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
69 matches
Mail list logo