Cleanup ringbuffer code also fix some issues in the util services.
Vitaly Kuznetsov (9):
Drivers: hv: utils: fix memory leak on on_msg() failure
Drivers: hv: utils: rename outmsg_lock
Drivers: hv: utils: introduce HVUTIL_TRANSPORT_DESTROY mode
Drivers: hv: utils: fix crash when device is r
From: Vitaly Kuznetsov
inmsg should be freed in case of on_msg() failure to avoid memory leak.
Preserve the error code from on_msg().
Signed-off-by: Vitaly Kuznetsov
Signed-off-by: K. Y. Srinivasan
---
drivers/hv/hv_utils_transport.c |7 ---
1 files changed, 4 insertions(+), 3 deletio
From: Vitaly Kuznetsov
When Hyper-V host asks us to remove some util driver by closing the
appropriate channel there is no easy way to force the current file
descriptor holder to hang up but we can start to respond -EBADF to all
operations asking it to exit gracefully.
As we're setting hvt->mode
From: Vitaly Kuznetsov
The crash is observed when a service is being disabled host side while
userspace daemon is connected to the device:
[ 90.244859] general protection fault: [#1] SMP
...
[ 90.800082] Call Trace:
[ 90.800082] [] __fput+0xc8/0x1f0
[ 90.800082] [] fput+0xe/0x
From: Vitaly Kuznetsov
As a preparation to reusing outmsg_lock to protect test-and-set openrations
on 'mode' rename it the more general 'lock'.
Signed-off-by: Vitaly Kuznetsov
Signed-off-by: K. Y. Srinivasan
---
drivers/hv/hv_utils_transport.c | 14 +++---
drivers/hv/hv_utils_transp
From: Vitaly Kuznetsov
hv_ringbuffer_peek() does the same as hv_ringbuffer_read() without
advancing the read index. The only functional change this patch brings
is moving hv_need_to_signal_on_read() call under the ring_lock but this
function is just a couple of comparisons.
Signed-off-by: Vitaly
From: Vitaly Kuznetsov
Convert 6+-string comments repeating function names to normal kernel-style
comments and fix a couple of other comment style issues. No textual or
functional changes intended.
Signed-off-by: Vitaly Kuznetsov
Signed-off-by: K. Y. Srinivasan
---
drivers/hv/ring_buffer.c |
From: Vitaly Kuznetsov
Currently, there is only one user for hv_ringbuffer_read()/
hv_ringbuffer_peak() functions and the usage of these functions is:
- insecure as we drop ring_lock between them, someone else (in theory
only) can acquire it in between;
- non-optimal as we do a number of things
From: Vitaly Kuznetsov
smp_read_barrier_depends() does nothing on almost all arcitectures
including x86 and having it in the beginning of
hv_get_ringbuffer_availbytes() does not provide any guarantees anyway.
Signed-off-by: Vitaly Kuznetsov
Signed-off-by: K. Y. Srinivasan
---
include/linux/hy
From: Vitaly Kuznetsov
vmbus_recvpacket() and vmbus_recvpacket_raw() are almost identical but
there are two discrepancies:
1) vmbus_recvpacket() doesn't propagate errors from hv_ringbuffer_read()
which looks like it is not desired.
2) There is an error message printed in packetlen > bufferlen
Userspace can close the sync device while there are still active fence
points, in which case kernel produces the following warning:
[ 43.853176] [ cut here ]
[ 43.857834] WARNING: CPU: 0 PID: 892 at
/mnt/host/source/src/third_party/kernel/v3.18/drivers/staging/android/
Using fence->status to determine whether or not there are callbacks
remaining on the sync_fence is racy since fence->status may have been
decremented to 0 on another CPU before fence_check_cb_func() has
completed. By unconditionally calling fence_remove_callback() for each
fence in the sync_fence,
On Mon, Dec 14, 2015 at 04:01:40PM -0800, K. Y. Srinivasan wrote:
> From: Jake Oshins
>
> This patch exposes the function that hv_vmbus.ko uses to make hypercalls.
> This
> is necessary for retargeting an interrupt when it is given a new affinity.
>
> Since we are exporting this API, rename th
On Mon, Dec 14, 2015 at 04:01:53PM -0800, K. Y. Srinivasan wrote:
> From: Kamal Mostafa
>
> Use the local uapi headers to keep in sync with "recently" added #define's
> (e.g. VSS_OP_REGISTER1).
>
> Fixes: 3eb2094c59e89db2bedd401e23c7a870081c9edb
Please use the "correct" way of listing this:
Patch contains the spacing fixes that checkpatch prompted for,
as asked by the TODO.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/dgnc_cls.c| 4 +-
drivers/staging/dgnc/dgnc_driver.h | 8 --
drivers/staging/dgnc/dgnc_neo.c| 235 -
drive
Patch contains the CamelCase fixes & Macro fixes that
checkpatch prompted for, as asked by the TODO.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/dgnc_driver.c | 56 -
drivers/staging/dgnc/dgnc_driver.h | 25 ++--
drivers/staging/dgnc/dgnc_mgmt.c | 28 ++---
drivers/stag
Patch updates the TODO file.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/TODO | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/dgnc/TODO b/drivers/staging/dgnc/TODO
index 0e0825b..0bdfd26 100644
--- a/drivers/staging/dgnc/TODO
+++ b/drivers/staging/dgnc/TODO
@@ -1,
The original code defined macros in the source code, making it
harder to read. Moved them to the header file, as per the TODO file.
Updated the TODO file.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/skein/TODO | 1 -
drivers/staging/skein/skein_block.c | 6 --
drivers/stagi
> -Original Message-
> From: Greg KH [mailto:gre...@linuxfoundation.org]
> Sent: Monday, December 14, 2015 7:08 PM
> To: KY Srinivasan
> Cc: linux-ker...@vger.kernel.org; de...@linuxdriverproject.org;
> o...@aepfle.de; a...@canonical.com; vkuzn...@redhat.com;
> jasow...@redhat.com; Jake
On Mon, Dec 14, 2015 at 07:03:31PM -0500, Sanidhya Solanki wrote:
> Patch updates the TODO file.
>
> Signed-off-by: Sanidhya Solanki
> ---
> drivers/staging/dgnc/TODO | 1 -
> 1 file changed, 1 deletion(-)
>
> diff --git a/drivers/staging/dgnc/TODO b/drivers/staging/dgnc/TODO
> index 0e0825b..0
Can you tell me what was incorrect about them?
I thought you requested the dgnc patches to be resent without the
headers.
There are 3 of them because Dan Carpenter asked my patch to be broken
up so each one does only one thing. I also resent you the skein
subsystem patches, as I did not hear anythi
On Mon, Dec 14, 2015 at 07:45:25PM -0500, Sanidhya Solanki wrote:
> Can you tell me what was incorrect about them?
The subjects are all wrong, go look at them... PATCH twice? 1/3 for
every message? Same string for every message?
> I thought you requested the dgnc patches to be resent without th
Patch contains the spacing fixes that checkpatch prompted for,
as asked by the TODO.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/dgnc_cls.c| 4 +-
drivers/staging/dgnc/dgnc_driver.h | 8 --
drivers/staging/dgnc/dgnc_neo.c| 235 -
drive
Patch contains the CamelCase fixes & Macro fixes that
checkpatch prompted for, as asked by the TODO.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/dgnc_driver.c | 56 -
drivers/staging/dgnc/dgnc_driver.h | 25 ++--
drivers/staging/dgnc/dgnc_mgmt.c | 28 ++---
drivers/stag
Patch updates the TODO file.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/TODO | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/dgnc/TODO b/drivers/staging/dgnc/TODO
index 0e0825b..0bdfd26 100644
--- a/drivers/staging/dgnc/TODO
+++ b/drivers/staging/dgnc/TODO
@@ -1,
On Mon, Dec 14, 2015 at 08:22:47PM -0500, Sanidhya Solanki wrote:
> Patch contains the spacing fixes that checkpatch prompted for,
> as asked by the TODO.
>
> Signed-off-by: Sanidhya Solanki
What is the FIXED doing in the subject?
And the subject is horrid, please make it sane...
__
Hey,
Do you need new business?
Do you need new sales?
Do you need new customers?
Do you need new customer leads?
We can help you to generate new buyer leads and increase your
sales by our mailing service.
It will grow your business sales 1-2 times than what it is now.
Please reply for pricing a
Patch contains the spacing fixes that led to checkpatch.pl warnings.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/dgnc_cls.c| 4 +-
drivers/staging/dgnc/dgnc_driver.h | 8 --
drivers/staging/dgnc/dgnc_neo.c| 235 -
drivers/staging/dgnc/
Patch contains the spacing fixes that led to checkpatch.pl warnings.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/dgnc_cls.c| 4 +-
drivers/staging/dgnc/dgnc_driver.h | 8 --
drivers/staging/dgnc/dgnc_neo.c| 235
-
drivers/staging/dgnc/d
Patch contains the CamelCase fixes & Macro fixes that led to
checkpatch.pl errors.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/dgnc_driver.c | 56 -
drivers/staging/dgnc/dgnc_driver.h | 25 ++--
drivers/staging/dgnc/dgnc_mgmt.c | 28 ++---
drivers/staging/dgnc/dgnc_neo.
Patch updates the TODO file.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/TODO | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/dgnc/TODO b/drivers/staging/dgnc/TODO
index 0e0825b..0bdfd26 100644
--- a/drivers/staging/dgnc/TODO
+++ b/drivers/staging/dgnc/TODO
@@ -1,
On Tue, Dec 15, 2015 at 7:28 AM, Sanidhya Solanki wrote:
>
> Patch contains the spacing fixes that led to checkpatch.pl warnings.
>
> Signed-off-by: Sanidhya Solanki
> ---
> drivers/staging/dgnc/dgnc_cls.c| 4 +-
> drivers/staging/dgnc/dgnc_driver.h | 8 --
> drivers/staging/dgnc/dgnc_ne
Why is the "Re:" in the Subject?
Why is "Patch" in the subject"?
The Subject doesn't even make sense.
On Mon, Dec 14, 2015 at 08:58:30PM -0500, Sanidhya Solanki wrote:
> Patch contains the spacing fixes that led to checkpatch.pl warnings.
>
> Signed-off-by: Sanidhya Solanki
> ---
> drivers/st
101 - 133 of 133 matches
Mail list logo