On Fri, Dec 04, 2015 at 09:35:07AM +0100, Enric Balletbo i Serra wrote:
> +static int sp_wait_aux_op_finish(struct anx78xx *anx78xx)
> +{
> + u8 errcnt;
> + u8 val;
> + struct device *dev = &anx78xx->client->dev;
> +
> + errcnt = 150;
> + while (errcnt--) {
> + sp_re
On Mon, Dec 07, 2015 at 12:46:37PM +0530, Saurabh Sengar wrote:
> >> @@ -688,6 +689,8 @@ ssize_t spk_var_store(struct kobject *kobj, struct
> >> kobj_attribute *attr,
> >>
> >> if (ret == -ERESTART)
> >> pr_info("%s reset to default value\n", param->name);
> >
> > Is this reall
On Wed, Dec 02, 2015 at 03:56:27PM -0500, ira.we...@intel.com wrote:
> - for (i = tx->idx; i >= 0; i--) {
> - if (tx->iovecs[i].flags & TXREQ_FLAGS_IOVEC_LAST_PKT)
> - unpin_vector_pages(tx->iovecs[i].vec);
> + /*
> + * If we have
Inorder to notify the user that value is not successfuly set in sys
entry, error should be returned from store function instead of count
Signed-off-by: Saurabh Sengar
---
v2:
Hi Dan,
I will look more into this function in my free time.
For now just sending you this patch fixing ERANGE as commente
Please ignore this patch, I will look more in to this function and
will send a new patch in order to make this function neat.
On 7 December 2015 at 15:29, Saurabh Sengar wrote:
> Inorder to notify the user that value is not successfuly set in sys
> entry, error should be returned from store funct
This patch does the following:
* changed the complicated if statements to simple case statements
* in case of E_DEFAULT, no need to return error as ERESTART,
because this is the user asked for. Hence function should return success.
* ret variable is 0 always, hence removed it.
* removed one ternary
On Mon, 7 Dec 2015 11:37:31 +0530
Sudip Mukherjee wrote:
> And you moved skein_256_process_block() from skein_block.c to a header
> file. Is skein_256_process_block() a macro?
No, it is not a macro, it is a conditional. But as other conditionals
was already included in the header file, I felt th
Hello Laurent,
On 12/06/2015 12:10 AM, Laurent Pinchart wrote:
> Hi Javier,
>
> Thank you for the patch.
>
Thanks for your feedback.
> On Thursday 03 September 2015 18:00:32 Javier Martinez Canillas wrote:
>> The omap4iss driver initializes the entities and creates the pads links
>> before the
Hello Laurent,
On 12/06/2015 12:18 AM, Laurent Pinchart wrote:
> Hi Javier,
>
> Thank you for the patch.
>
> On Sunday 30 August 2015 00:06:13 Mauro Carvalho Chehab wrote:
>> From: Javier Martinez Canillas
>>
>> Assessing media_entity ID should now use media_entity_id() macro to
>
> Did you me
FOR MORE INFORMATION CONTACT: (unitednationdiplomaticenvoy2...@diplomats.com)
David Finch
Head of Law and Legal Services
Kingston College
D: 020 8268 3017
Visit Our Website
http://www.kingston-college.ac.uk
__
This message i
parser_param_start() had a goto Away, which went to nothing but
a return statement. Remove the goto, the CamelCased label, and
just return directly.
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/visorbus/visorchipset.c | 6 ++
1 file changed, 2 insertions(+), 4 deletions(-)
diff
Fix the only fixable parenthesis alignment issue in
visorchipset.c. The rest are unworkable because of the length
of the symbol names used.
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/visorbus/visorchipset.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/dri
The instructions for submitting patches state that changes destined for
networking should not be marked with a Cc to stable. This restriction does
not apply to the wireless portion of networking. The instructions are
updated to clarify this case.
Signed-off-by: Larry Finger
---
Kalle,
Is this c
Profiling has shown the the atomic is a performance issue
for the pio hot path.
If multiple cpus allocated an sc's buffer, the cacheline
containing the atomic will bounce from L0 to L0.
Convert the atomic to a percpu variable.
Reviewed-by: Jubin John
Signed-off-by: Mike Marciniszyn
---
driver
Removed unnecessary parentheses.
Signed-off-by: Chris Elliott
---
drivers/staging/rtl8188eu/core/rtw_debug.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_debug.c
b/drivers/staging/rtl8188eu/core/rtw_debug.c
index 2c4afb8..
ecclayout->oobavail is just redundant with the mtd->oobavail field.
Moreover, it prevents static const definition of ecc layouts since the
NAND framework is calculating this value based on the ecclayout->oobfree
field.
Signed-off-by: Boris Brezillon
---
drivers/mtd/devices/docg3.c
Signed-off-by: Boris Brezillon
---
include/linux/mtd/inftl.h | 1 -
1 file changed, 1 deletion(-)
diff --git a/include/linux/mtd/inftl.h b/include/linux/mtd/inftl.h
index 02cd5f9..8255118 100644
--- a/include/linux/mtd/inftl.h
+++ b/include/linux/mtd/inftl.h
@@ -44,7 +44,6 @@ struct INFTLrecord
Hello,
This patchset aims at getting rid of the nand_ecclayout limitations.
struct nand_ecclayout is defining fixed eccpos and oobfree arrays which
can only be increased by modifying the MTD_MAX_ECCPOS_ENTRIES_LARGE and
MTD_MAX_OOBFREE_ENTRIES_LARGE macros.
This approach forces us to modify the ma
->ecc_layout is not used by any board file. Kill this field to avoid any
confusion. New boards are encouraged to use the default ECC layout defined
in NAND core.
Signed-off-by: Boris Brezillon
---
arch/mips/include/asm/mach-jz4740/jz4740_nand.h | 2 --
drivers/mtd/nand/jz4740_nand.c
The s3c2410 is allowing board data to overload the default ECC layout
defined inside the driver, but this feature is not used by board
specific definitions.
Kill this field so that we can easily move to a model where ecclayout
are dynamically allocated by the NAND controller driver.
Signed-off-by:
The spinand_info struct embeds a pointer to an ecclayout definition, but
this field is never used in the mt29f driver.
Signed-off-by: Boris Brezillon
---
drivers/staging/mt29f_spinand/mt29f_spinand.h | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/mt29f_spinand/mt29f_spinand.h
Signed-off-by: Boris Brezillon
---
include/linux/mtd/nftl.h | 1 -
1 file changed, 1 deletion(-)
diff --git a/include/linux/mtd/nftl.h b/include/linux/mtd/nftl.h
index b059629..044daa0 100644
--- a/include/linux/mtd/nftl.h
+++ b/include/linux/mtd/nftl.h
@@ -50,7 +50,6 @@ struct NFTLrecord {
The mtd_eccpos(), mtd_oobfree() and mtd_eccbytes() helper functions have
been added to avoid direct accesses to the ecclayout, and thus allow for
future rework.
Use these helpers in all places where the oobfree[] and eccpos[] arrays
are referenced.
Signed-off-by: Boris Brezillon
---
drivers/mtd/
nand_bch_init() requires several arguments which could directly be deduced
from the mtd device. Get rid of those useless parameters.
nand_bch_init() is also requiring the caller to provide a proper eccbytes
value, while this value could be deduced from the ecc.size and
ecc.strength value. Fallback
The NAND core layer is already taking care of ecclayout propagation. Remove
this useless assignment.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/vf610_nfc.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/mtd/nand/vf610_nfc.c b/drivers/mtd/nand/vf610_nfc.c
index 1c86c6b..041
This field is not set in any board file and can thus be dropped.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/plat_nand.c | 1 -
include/linux/mtd/nand.h | 2 --
2 files changed, 3 deletions(-)
diff --git a/drivers/mtd/nand/plat_nand.c b/drivers/mtd/nand/plat_nand.c
index 06ac6c6..71
Use the mtd_set_ecclayout() helper instead of directly assigning the
mtd->ecclayout field.
Signed-off-by: Boris Brezillon
---
drivers/mtd/devices/docg3.c| 2 +-
drivers/mtd/mtdconcat.c| 2 +-
drivers/mtd/mtdpart.c | 2 +-
drivers/mtd/nand/nand_base.c | 2 +-
Add an mtd_set_ecclayout() helper function to avoid direct accesses to the
mtd->ecclayout field. This will ease future refactor of ECC layout
definition.
Signed-off-by: Boris Brezillon
---
include/linux/mtd/mtd.h | 6 ++
1 file changed, 6 insertions(+)
diff --git a/include/linux/mtd/mtd.h b
Implementing the mtd_ooblayout_ops interface is the new way of exposing
ECC/OOB layout to MTD users. Modify all NAND drivers to switch to this
approach.
Signed-off-by: Boris Brezillon
---
This commit is a collection of commits that have been squashed to into
a single one to limit the size of the
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/nand_bch.c | 33 +++--
1 file changed, 11 insertions(+), 22 deletions(-)
diff --git a/drivers/mtd/nand/nand_bch.c b/drivers/mtd/nand/nand_bch.c
index 9cff544..2937b49 100644
--- a/drivers/mtd/nand/nand_bch.c
+++ b/dr
Signed-off-by: Boris Brezillon
---
drivers/staging/mt29f_spinand/mt29f_spinand.c | 44 ---
1 file changed, 26 insertions(+), 18 deletions(-)
diff --git a/drivers/staging/mt29f_spinand/mt29f_spinand.c
b/drivers/staging/mt29f_spinand/mt29f_spinand.c
index cb9d5ab..967d50a
According to the ECC layout description the actual ecc.size is 512 bytes
and not mtd->writesize.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/lpc32xx_mlc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/mtd/nand/lpc32xx_mlc.c b/drivers/mtd/nand/lpc32xx_mlc.c
i
In order to make the ecclayout definition completely dynamic we need to
rework the way these different ECC layouts are defined and iterated.
Create the mtd_eccpos(), mtd_oobfree() and mtd_eccbytes() helpers to hide
ecclayout definition internals to their users.
Signed-off-by: Boris Brezillon
---
Signed-off-by: Boris Brezillon
---
drivers/mtd/devices/docg3.c | 34 +-
1 file changed, 29 insertions(+), 5 deletions(-)
diff --git a/drivers/mtd/devices/docg3.c b/drivers/mtd/devices/docg3.c
index 6b516e1..7463dd8 100644
--- a/drivers/mtd/devices/docg3.c
+++ b/dr
ECC layout definitions are currently exposed using the nand_ecclayout
struct which embeds oobfree and eccpos arrays with predefined size.
This approach was acceptable when the NAND were providing relatively small
OOB regions, but MLC and TLC now provide OOB regions of several hundreds
of bytes, whi
Implementing the mtd_ooblayout_ops interface is the new way of exposing
ECC/OOB layout to MTD users. Modify the onenand drivers to switch to this
approach.
Signed-off-by: Boris Brezillon
---
drivers/mtd/onenand/onenand_base.c | 144 +
include/linux/mtd/onenand
Replace the default nand_ecclayout definitions for large and small page
devices with the equivalent mtd_ooblayout_ops.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/nand_base.c | 138 +++
include/linux/mtd/nand.h | 3 +
2 files changed, 90 inse
Now that all mtd drivers have moved to the mtd_ooblayout_ops model we can
safely remove the struct nand_ecclayout definition, and all the remaining
places where it was still used.
Signed-off-by: Boris Brezillon
---
drivers/mtd/mtdchar.c | 12 ++--
drivers/mtd/mtdcore.c | 44 ---
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/nand_base.c | 8
drivers/mtd/nand/nand_bch.c | 9 -
include/linux/mtd/nand.h | 1 -
3 files changed, 18 deletions(-)
diff --git a/drivers/mtd/nand/nand_base.c b/drivers/mtd/nand/nand_base.c
index 6440c5d..85deacb 100644
--
Hi Boris,
[auto build test ERROR on next-20151207]
[cannot apply to staging/staging-testing v4.4-rc4 v4.4-rc3 v4.4-rc2 v4.4-rc4]
url:
https://github.com/0day-ci/linux/commits/Boris-Brezillon/mtd-rework-ECC-layout-definition/20151208-063127
config: i386-randconfig-x006-12070758 (attached as
On 2015-12-07 14:26, Boris Brezillon wrote:
> The NAND core layer is already taking care of ecclayout propagation. Remove
> this useless assignment.
Thx! I see, nand_scan_tail takes care of that...
Acked-by: Stefan Agner
>
> Signed-off-by: Boris Brezillon
> ---
> drivers/mtd/nand/vf610_nfc.c
Hi Boris,
[auto build test ERROR on next-20151207]
[cannot apply to staging/staging-testing v4.4-rc4 v4.4-rc3 v4.4-rc2 v4.4-rc4]
url:
https://github.com/0day-ci/linux/commits/Boris-Brezillon/mtd-rework-ECC-layout-definition/20151208-063127
config: powerpc-allyesconfig (attached as .config
Hi Boris,
[auto build test WARNING on next-20151207]
[cannot apply to staging/staging-testing v4.4-rc4 v4.4-rc3 v4.4-rc2 v4.4-rc4]
url:
https://github.com/0day-ci/linux/commits/Boris-Brezillon/mtd-rework-ECC-layout-definition/20151208-063127
reproduce: make htmldocs
All warnings (new ones
Hi Boris,
On Tue, Dec 8, 2015 at 9:26 AM, Boris Brezillon
wrote:
> Signed-off-by: Boris Brezillon
> ---
> drivers/staging/mt29f_spinand/mt29f_spinand.c | 44
> ---
> 1 file changed, 26 insertions(+), 18 deletions(-)
>
> diff --git a/drivers/staging/mt29f_spinand/mt29f_s
On Mon, 2015-12-07 at 22:02 +, Chris Elliott wrote:
> Removed unnecessary parentheses.
[]
> diff --git a/drivers/staging/rtl8188eu/core/rtw_debug.c
> b/drivers/staging/rtl8188eu/core/rtw_debug.c
[]
> @@ -149,7 +149,7 @@ int proc_get_fwstate(char *page, char **start,
> {
> struct net_dev
On 08.12.2015 07:25, Boris Brezillon wrote:
> The s3c2410 is allowing board data to overload the default ECC layout
> defined inside the driver, but this feature is not used by board
> specific definitions.
> Kill this field so that we can easily move to a model where ecclayout
> are dynamically al
The original code defined macros in the source code, making it
harder to read. Moved them to the header file, as per the TODO file.
Upadated the TODO file.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/skein/TODO | 1 -
drivers/staging/skein/skein_block.c | 6 --
drivers/stag
On Mon, 2015-12-07 at 23:25 +0100, Boris Brezillon wrote:
> ecclayout->oobavail is just redundant with the mtd->oobavail field.
> Moreover, it prevents static const definition of ecc layouts since
> the
> NAND framework is calculating this value based on the ecclayout-
> >oobfree
> field.
>
> Sign
Larry Finger writes:
> The instructions for submitting patches state that changes destined for
> networking should not be marked with a Cc to stable. This restriction does
> not apply to the wireless portion of networking. The instructions are
> updated to clarify this case.
>
> Signed-off-by: La
49 matches
Mail list logo