On Sun, Nov 08, 2015 at 08:33:16AM +0100, Othmar Pasteka wrote:
> Should I send a new version or is it a note for next time?
Send a new version.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproj
On Sun, Nov 8, 2015 at 2:17 AM, Dan Carpenter wrote:
> Don't resend, it's fine. I don't like re-reviewing patches and you
> don't like sending them. It's not like it introduces a bug or generate
> a warning with our current tools.
>
> But it's still important to understand how the one thing per
Remove the wrapper function cfs_wi_sched_lock() and replace all its
calls with the function it wrapped.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/libcfs/workitem.c | 22 --
1 file changed, 8 insertions(+), 14 deletions(-)
diff --git a/drivers/staging/
This patchset removes unnecessary wrapper functions from the file workitem
and replace all their calls with the function that they wrap.
After applying this patch, code becomes cleaner.
Shivani Bhardwaj (2):
staging: lustre: workitem: Remove cfs_wi_sched_lock wrapper
staging: lustre: workitem:
Remove the wrapper function cfs_wi_sched_unlock() and replace all its
calls with the function it wrapped.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/libcfs/workitem.c | 26 ++---
1 file changed, 10 insertions(+), 16 deletions(-)
diff --git a/drivers/st
Use a function to unregister framebuffer info and release its resources.
Signed-off-by: Mike Rapoport
---
drivers/staging/sm750fb/sm750.c | 25 +
1 file changed, 13 insertions(+), 12 deletions(-)
diff --git a/drivers/staging/sm750fb/sm750.c b/drivers/staging/sm750fb/sm75
Will be used in futher refactoring of driver _probe and _remove methods.
Signed-off-by: Mike Rapoport
---
drivers/staging/sm750fb/sm750.c | 24 +---
drivers/staging/sm750fb/sm750.h | 2 +-
2 files changed, 14 insertions(+), 12 deletions(-)
diff --git a/drivers/staging/sm750
In case of error during lynxfb_pci_probe, the function returned without
calling pci_disable_device. Fix it by adding pci_disable_device on the
error cleanup path.
Signed-off-by: Mike Rapoport
---
drivers/staging/sm750fb/sm750.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/
The par variable in lynxfb_pci_remove is only assigned a value and never
used afterwards. Remove it.
Signed-off-by: Mike Rapoport
---
drivers/staging/sm750fb/sm750.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/sm750fb/sm750.c b/drivers/staging/sm750fb/sm750.c
index 7eb38
Hi,
These patches refactor the lynxfb_pci_probe
v4 changes:
* address Dan's comments
v3 changes:
* rebased on current Greg's staging-testing
v2 changes:
* add pci_disable_device on the cleanup path
* return actual error rather than ENODEV
Mike Rapoport (7):
staging: sm750fb: disable PCI dev
The lynxfb_pci_probe always returned -ENODEV in case of error. Modify it
so that actual error code will be propogated to the caller.
Signed-off-by: Mike Rapoport
---
drivers/staging/sm750fb/sm750.c | 37 +
1 file changed, 17 insertions(+), 20 deletions(-)
dif
Split framebuffer allocation and registration into a dedicated function
to simplify lynxfb_pci_probe
Signed-off-by: Mike Rapoport
---
drivers/staging/sm750fb/sm750.c | 98 +
1 file changed, 41 insertions(+), 57 deletions(-)
diff --git a/drivers/staging/sm
Several pr_info statements in lynxfb_pci_probe seem like debug leftovers
and may be removed.
Signed-off-by: Mike Rapoport
---
drivers/staging/sm750fb/sm750.c | 8
1 file changed, 8 deletions(-)
diff --git a/drivers/staging/sm750fb/sm750.c b/drivers/staging/sm750fb/sm750.c
index c33c7ff
On Sun, Nov 8, 2015 at 6:29 AM, Ivan Safonov wrote:
> Duplicated code removed.
>
> Signed-off-by: Ivan Safonov
> ---
> drivers/staging/rtl8188eu/core/rtw_cmd.c | 6 ++
> 1 file changed, 2 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/staging/rtl8188eu/core/rtw_cmd.c
> b/drivers/sta
On Sun, Nov 8, 2015 at 8:37 AM, Ivan Safonov wrote:
> Ideally the function should not change the variables outside of its body.
>
> Signed-off-by: Ivan Safonov
> ---
> drivers/staging/rtl8188eu/hal/fw.c | 8
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/stag
Fix for checkpatch.pl complaints:
ERROR: that open brace { should be on the previous line
CHECK: spaces preferred around that '+' (ctx:VxV)
Signed-off-by: Othmar Pasteka
---
drivers/staging/sm750fb/sm750_cursor.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/stagi
On 11/08/2015 05:11 PM, Andy Shevchenko wrote:
On Sun, Nov 8, 2015 at 8:37 AM, Ivan Safonov wrote:
Ideally the function should not change the variables outside of its body.
Signed-off-by: Ivan Safonov
---
drivers/staging/rtl8188eu/hal/fw.c | 8
1 file changed, 4 insertions(+), 4 d
On Sun, Nov 8, 2015 at 2:21 AM, Dan Carpenter wrote:
> I haven't looked at it, sorry. You'll have to figure it out or if you
> complain to the original person who broken the build he can figure it
> out. You are still missing a Fixes tag.
>
> regards,
> dan carpenter
Here I will remove struct wi
Use kmalloc_array instead of kmalloc to allocate memory for an array.
Signed-off-by: Geliang Tang
---
drivers/staging/comedi/drivers/amplc_pci224.c | 8
drivers/staging/comedi/drivers/ni_670x.c | 5 +++--
2 files changed, 7 insertions(+), 6 deletions(-)
diff --git a/drivers/stagin
Use kmalloc_array instead of kmalloc to allocate memory for an array.
Signed-off-by: Geliang Tang
---
drivers/staging/rdma/amso1100/c2.c | 6 --
drivers/staging/rdma/ipath/ipath_file_ops.c | 8
2 files changed, 8 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/r
Use kmalloc_array instead of kmalloc to allocate memory for an array.
Signed-off-by: Geliang Tang
---
drivers/staging/lustre/lustre/libcfs/linux/linux-tracefile.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/lustre/lustre/libcfs/linux/linux-tracefile.c
Use kmalloc_array instead of kmalloc to allocate memory for an array.
Signed-off-by: Geliang Tang
---
drivers/staging/rtl8192u/r8192U_core.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8192u/r8192U_core.c
b/drivers/staging/rtl8192u/r8192U_core.c
in
On Sun, Nov 8, 2015 at 2:21 AM, Dan Carpenter wrote:
> I haven't looked at it, sorry. You'll have to figure it out or if you
> complain to the original person who broken the build he can figure it
> out. You are still missing a Fixes tag.
>
> regards,
> dan carpenter
Actually while building one
From: Fan Yong
Cleanup the a style issues for the lu_object_header_flags
enum by adding a comma for the last field. This is
broken out of patch http://review.whamcloud.com/6321.
Signed-off-by: Fan Yong
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-2914
Reviewed-on: http://review.whamcloud
For UMP and SMP machines the struct cfs_cpt_table are
defined differently. In the case handled by this patch
nodemask is defined as a integer for the UMP case and
as a pointer for the SMP case. This will cause a problem
for ost_setup which reads the nodemask directly. Instead
we create a UMP versio
From: Fan Yong
Add the ability to debug LFSCK to libcfs. This is
broken out of patch http://review.whamcloud.com/6321.
Signed-off-by: Fan Yong
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-2914
Reviewed-on: http://review.whamcloud.com/6321
Reviewed-by: Alex Zhuravlev
Reviewed-by: Andreas
From: frank zago
Adds __acquires / __releases / __must_hold sparse locking annotations to
several functions.
Fixes sparse warnings such as:
libcfs/libcfs/hash.c:127:1: warning: context imbalance in 'cfs_hash_spin_lock'
- wrong count at exit
libcfs/libcfs/hash.c:133:1: warning: context i
From: Fan Yong
Create a kernel side function that does the same
thing as userland strrstr. This is from patch
http://review.whamcloud.com/7666.
Signed-off-by: Fan Yong
ntel-bug-id: https://jira.hpdd.intel.com/browse/LU-3951
Reviewed-on: http://review.whamcloud.com/7666
Reviewed-by: Andreas Dilg
The ioctl IOC_LIBCFS_PING_TEST has not been used in
ages. The recent nidstring changes which moved all
the nidstring operations from libcfs to the LNet
layer but this ioctl code was still using an
nidstring operation that was causing an circular
dependency loop between libcfs and LNet.
Signed-off-
We need cfs_str2mask exported for our server code.
Even with the server code not available upstream
it would be nice to use the upstream code on Lustre
servers.
Signed-off-by: James Simmons
---
.../staging/lustre/lustre/libcfs/libcfs_string.c |1 +
1 files changed, 1 insertions(+), 0 delet
Remove the wrapper function mdc_kuc_reregister() and replace its call
with the function it wrapped. Also, comment has been added for clarity.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/mdc/mdc_request.c | 16
1 file changed, 4 insertions(+), 12 deletions(-
Remove the function mgc_ir_state_seq_show() as it is not
referenced/called anywhere.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/mgc/lproc_mgc.c | 5 -
1 file changed, 5 deletions(-)
diff --git a/drivers/staging/lustre/lustre/mgc/lproc_mgc.c
b/drivers/staging/lustre/l
On Sun, Nov 08, 2015 at 01:25:09PM +0530, Anjali Menon wrote:
> Added a blank line after declaration to fix the coding style
> error detected by checkpatch.pl
>
> WARNING: Missing a blank line after declarations
>
> Signed-off-by: Anjali Menon
> ---
> drivers/staging/android/ion/ion.c | 2 +-
>
On Sun, Nov 8, 2015 at 10:33 PM, Shivani Bhardwaj wrote:
> Remove the function mgc_ir_state_seq_show() as it is not
> referenced/called anywhere.
>
> Signed-off-by: Shivani Bhardwaj
> ---
> drivers/staging/lustre/lustre/mgc/lproc_mgc.c | 5 -
> 1 file changed, 5 deletions(-)
>
> diff --git a
On Sun, Nov 08, 2015 at 02:07:11PM +0700, Ivan Safonov wrote:
> Duplicated code removed.
>
> Signed-off-by: Ivan Safonov
> ---
> drivers/staging/rtl8188eu/core/rtw_cmd.c | 6 ++
> 1 file changed, 2 insertions(+), 4 deletions(-)
You sent 3 versions of this patch, is this series the "real" on
Hi Shivani,
[auto build test ERROR on: staging/staging-testing]
[also build test ERROR on: next-20151106]
[cannot apply to: v4.3]
url:
https://github.com/0day-ci/linux/commits/Shivani-Bhardwaj/staging-lustre-lproc_mgc-Remove-unused-function-mgc_ir_state_seq_show/20151109-010718
config: x86_64
Hi Shivani,
[auto build test WARNING on: staging/staging-testing]
[also build test WARNING on: next-20151106]
[cannot apply to: v4.3]
url:
https://github.com/0day-ci/linux/commits/Shivani-Bhardwaj/staging-lustre-lproc_mgc-Remove-unused-function-mgc_ir_state_seq_show/20151109-010718
config: i3
From: John L. Hammond
Remove the file /proc/fs/lustre/mdc/*/hsm_nl which was introduced "for
testing purposes."
Signed-off-by: John L. Hammond
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-2489
Reviewed-on: http://review.whamcloud.com/6656
Reviewed-by: jacques-Charles Lafoucriere
Reviewe
This patch series brings the kernel_comm code used by Lustre up
to the latest verison with various fixes and style improvements
which makes the code compliant with the linux kernel standard.
Henri Doreau (1):
staging: lustre: Prevent duplicate CT registrations
Hongchao Zhang (1):
staging: lus
From: Henri Doreau
Associate copytool registration to a given MDC import so that
multiple mounts of the same filesystem do not lead to having the
copytool registered multiple time.
Signed-off-by: Henri Doreau
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-3882
Reviewed-on: http://review.wh
During the removal of the cfs wrappers the kg_sem semaphore
was handled incorrectly. We need to take a write lock when
writing data to the kkuc_groups. The libcfs_kkuc_group_foreach
needs to only take a read lock. This makes use match the
OpenSFS development branch.
Signed-off-by: James Simmons
-
From: frank zago
Move the kernel portion from libcfs to obdclass. This code is
only used by lustre. This is broken out of the original patch
14270. The part covered by this change is as follows:
The original code in kernel_user_comm.c is split into two parts:
* obdclass/kernelcomm.c for the k
Fixup the comments to the linux kernel style for the source and
headers related to the kernel_comm work.
Signed-off-by: James Simmons
---
.../lustre/lustre/include/uapi_kernelcomm.h| 10 ++
.../staging/lustre/lustre/obdclass/kernelcomm.c| 12
2 files changed,
Add in missing braces for libcfs_kkuc_group_put();.
Signed-off-by: James Simmons
---
.../staging/lustre/lustre/obdclass/kernelcomm.c|4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/lustre/lustre/obdclass/kernelcomm.c
b/drivers/staging/lustre/lustre
From: frank zago
Split the kernel comm header in libcfs into two new headers
to handle both kernel space and user space for the lustre layer.
This is broken out of the original patch 14270. The part covered
by this change is as follows:
The original libcfs_kernelcomm.h header is split into three
The functon libcfs_kkuc_msg_put() returns -ENOSYS which is not
correct. Return -ENXIO instead if the kuc header is corrupt.
Signed-off-by: James Simmons
---
.../staging/lustre/lustre/obdclass/kernelcomm.c|4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/stag
The group variable was converted to an unsigned int in
libcfs_kkuc_group_add() to avoid a potential overflow.
The variable group is used in other kernelcomm functions
so it makes sense to convert the rest of the group
variables to unsigned int.
Signed-off-by: James Simmons
---
.../lustre/lustre/
From: Hongchao Zhang
In struct kkuc_reg, the "kr_data" is difficult to be freed
outside of libcfs, then it's better to change it to be
inline data instead of the data pointer.
Signed-off-by: Hongchao Zhang
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6485
Reviewed-on: http://review.whamc
Add in missing space arouund '+' in the kernel_comm code.
Signed-off-by: James Simmons
---
.../lustre/lustre/include/uapi_kernelcomm.h|2 +-
.../staging/lustre/lustre/obdclass/kernelcomm.c|2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/lu
Cleanup the last white space issues in the kernel comm code.
Signed-off-by: James Simmons
---
.../lustre/lustre/include/uapi_kernelcomm.h| 10 +-
.../staging/lustre/lustre/obdclass/kernelcomm.c|2 +-
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers
Fix checkpatch.pl reports of NULL comparison in kernel_comm.c.
Signed-off-by: James Simmons
---
.../staging/lustre/lustre/obdclass/kernelcomm.c| 18 +-
1 files changed, 9 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/lustre/lustre/obdclass/kernelcomm.c
b/driv
On Sun, Nov 8, 2015 at 8:51 AM, Ivan Safonov wrote:
> The reg_macid variable used only once. Also idx renamed to i and Adapter to
> adapter.
>
> Signed-off-by: Ivan Safonov
> ---
> drivers/staging/rtl8188eu/hal/usb_halinit.c | 11 ---
> 1 file changed, 4 insertions(+), 7 deletions(-)
>
On Sun, Nov 8, 2015 at 1:26 PM, Ivan Safonov wrote:
> On 11/08/2015 05:11 PM, Andy Shevchenko wrote:
>>
>> On Sun, Nov 8, 2015 at 8:37 AM, Ivan Safonov wrote:
>>>
>>> Ideally the function should not change the variables outside of its body.
>>> -static void _rtl88e_fill_dummy(u8 *pfwbuf, u32 *pf
This patch is to the linux_wlan.c file that fixes up break found during
make drivers/staging/wilc1000/linux_wlan.o
Patch add following things to file :
-init_irq declaration
-At preprocessor (!defined WILC_SDIO) to defination of init_irq
-At preprocessor (!defined WILC_SDIO) to defination isr_uh_r
Top posting beucase I am a bad person. Punit, you should have CC'd Glen
since this is his code.
The fix is still not right. It will cause an unused variable warning on
some configs.
To be honest, this code makes no sense. Why do we even have the wilc
variable in this function when we never use
From: Andreas Dilger
Update copyright messages in files modified by Intel employees
in 2015 by non-trivial patches. Exclude patches that are only
deleting code, renaming functions, or adding or removing whitespace.
Signed-off-by: Andreas Dilger
Intel-bug-id: https://jira.hpdd.intel.com/browse/
From: frank zago
A lot of symbols don't need to be exported at all because they are
only used in the module they belong to.
Signed-off-by: frank zago
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-5829
Reviewed-on: http://review.whamcloud.com/13320
Reviewed-by: James Simmons
Reviewed-by:
I just check the email, I will get back here after I check the patches related
with this issue.
regards,
glen lee.
On 2015년 11월 09일 06:59, Dan Carpenter wrote:
Top posting beucase I am a bad person. Punit, you should have CC'd Glen
since this is his code.
The fix is still not right. It wil
> From: devel [mailto:driverdev-devel-boun...@linuxdriverproject.org] On Behalf
> Of Eric Dumazet
> Sent: Sunday, November 8, 2015 3:36
> To: David Ahern
> Cc: net...@vger.kernel.org; Haiyang Zhang ; linux-
> ker...@vger.kernel.org; de...@linuxdriverproject.org; David Miller
>
> Subject: Re: linu
From: Dexuan Cui
Date: Mon, 9 Nov 2015 02:39:24 +
>> Throughput on a single TCP flow for a 40G NIC can be tricky to tune.
> Why is a single TCP flow trickier than multiple TCP flows?
> IMO it should be easier to analyze the issue of a single TCP flow?
Because a single TCP flow can only use o
> -Original Message-
> From: David Miller [mailto:da...@davemloft.net]
> Sent: Monday, November 9, 2015 10:53
> To: Dexuan Cui
> Cc: eric.duma...@gmail.com; d...@cumulusnetworks.com; Simon Xiao
> ; net...@vger.kernel.org; Haiyang Zhang
> ; linux-ker...@vger.kernel.org;
> de...@linuxdriverp
From: Dexuan Cui
Date: Mon, 9 Nov 2015 03:11:35 +
>> -Original Message-
>> From: David Miller [mailto:da...@davemloft.net]
>> Sent: Monday, November 9, 2015 10:53
>> To: Dexuan Cui
>> Cc: eric.duma...@gmail.com; d...@cumulusnetworks.com; Simon Xiao
>> ; net...@vger.kernel.org; Haiyan
> From: David Miller [mailto:da...@davemloft.net]
> Sent: Monday, November 9, 2015 11:24
> ...
> > Thanks, David!
> > I understand 1 TX queue is the bottleneck (however in Simon's
> > test, TX=1 => 36.7Gb/s, TX=8 => 37.7 Gb/s, so it looks the TX=1 bottleneck
> > is not so obvious).
> > I'm just won
On 9 November 2015 at 13:23, David Miller wrote:
> From: Dexuan Cui
> Date: Mon, 9 Nov 2015 03:11:35 +
>
>>> -Original Message-
>>> From: David Miller [mailto:da...@davemloft.net]
>>> Sent: Monday, November 9, 2015 10:53
>>> To: Dexuan Cui
>>> Cc: eric.duma...@gmail.com; d...@cumulus
From: John L. Hammond
Move the definition of the trace buffer type enum in
libcfs/libcfs/tracefile.h. Remove the then unneeded headers
libcfs/libcfs/linux/linux-tracefile.h and
libcfs/libcfs/posix/posix-tracefile.h.
Signed-off-by: John L. Hammond
Intel-bug-id: https://jira.hpdd.intel.com/brows
From: John L. Hammond
Remove comment about tracefile handling for user land
version of libcfs that no longer exist. Broken out of
patch http://review.whamcloud.com/11983.
Signed-off-by: John L. Hammond
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-2675
Reviewed-on: http://review.whamcloud
On Sun, Nov 8, 2015 at 7:31 PM, Dexuan Cui wrote:
>> From: David Miller [mailto:da...@davemloft.net]
>> Sent: Monday, November 9, 2015 11:24
>> ...
>> > Thanks, David!
>> > I understand 1 TX queue is the bottleneck (however in Simon's
>> > test, TX=1 => 36.7Gb/s, TX=8 => 37.7 Gb/s, so it looks the
67 matches
Mail list logo