Re: [PATCH 1/2] staging: fbtft: add support for ST7789V display controller

2015-10-11 Thread Dennis Menschel
Am 10.10.2015 um 17:36 schrieb Noralf Trønnes: > > Den 07.10.2015 22:15, skrev Dennis Menschel: >> This patch adds support for the Sitronix ST7789V display controller. >> The controller is intended for small color displays with a resolution >> of up to 320x240 pixels. >> >> Signed-off-by: Dennis M

Re: [PATCH 2/4] Staging: rtl8712: Use ether_addr_equal() over memcmp()

2015-10-11 Thread punit vara
On Sun, Oct 11, 2015 at 6:07 AM, kbuild test robot wrote: > Hi Punit, > > [auto build test WARNING on v4.3-rc4 -- if it's inappropriate base, please > ignore] > > reproduce: > # apt-get install sparse > make ARCH=x86_64 allmodconfig > make C=1 CF=-D__CHECK_ENDIAN__ > > > s

[PATCH] staging: rtl8712: fix negative level value

2015-10-11 Thread Luis de Bethencourt
range->avg_qual.level is of type uint8, so it shouldn't be assigned a negative number. Assigning it 0x100 - 78, which is the equivalent to (20 + -98) dBm when IW_QUAL_DBM is set. Signed-off-by: Luis de Bethencourt --- drivers/staging/rtl8712/rtl871x_ioctl_linux.c | 2 +- 1 file changed, 1 insert

[PATCH] staging: rtl8192u: r8192U_core: fix negative noise value

2015-10-11 Thread Luis de Bethencourt
ieee80211_rx_stats.noise is of type uint8, so it shouldn't be assigned a negative number. Assigning it 0x100 - 98, which is the equivalent to -98 dBm when IW_QUAL_DBM is set. Signed-off-by: Luis de Bethencourt --- drivers/staging/rtl8192u/r8192U_core.c | 4 ++-- 1 file changed, 2 insertions(+),

[PATCH] staging: rtl8192u: r8192U_wx: fix negative noise and level values

2015-10-11 Thread Luis de Bethencourt
range->max_qual.noise and level are of type uint8, so they shouldn't be assigned a negative number. Assigning them 0x100 - 98, and 0x100 - 78 which are the equivalent to -98 dBm and -78 dBm, respectively, when IW_QUAL_DBM is set. Signed-off-by: Luis de Bethencourt --- drivers/staging/rtl8192u/r8

Re: [PATCH 1/2] staging: fbtft: add support for ST7789V display controller

2015-10-11 Thread Noralf Trønnes
Den 11.10.2015 09:31, skrev Dennis Menschel: Am 10.10.2015 um 17:36 schrieb Noralf Trønnes: Den 07.10.2015 22:15, skrev Dennis Menschel: This patch adds support for the Sitronix ST7789V display controller. The controller is intended for small color displays with a resolution of up to 320x240 p

[PATCH] Staging: vt6655: Renamed uRATE to rate

2015-10-11 Thread Paul McQuade
Renamed uRATE to rate to avoid camelcase Signed-off-by: Paul McQuade --- drivers/staging/vt6655/rf.c | 12 ++-- drivers/staging/vt6655/rf.h | 4 ++-- 2 files changed, 8 insertions(+), 8 deletions(-) diff --git a/drivers/staging/vt6655/rf.c b/drivers/staging/vt6655/rf.c index c537321..4

Re: [PATCH v8 32/55] [media] media: use macros to check for V4L2 subdev entities

2015-10-11 Thread Sakari Ailus
Hi Mauro, On Sun, Aug 30, 2015 at 12:06:43AM -0300, Mauro Carvalho Chehab wrote: > Instead of relying on media subtype, use the new macros to detect > if an entity is a subdev or an A/V DMA entity. > > Please note that most drivers assume that there's just AV_DMA or > V4L2 subdevs. This is not tr

[PATCH 4/7] drivers/staging: make android sw_sync.c explicitly non-modular

2015-10-11 Thread Paul Gortmaker
The Kconfig currently controlling compilation of this code is: staging/android/Kconfig:config SW_SYNC staging/android/Kconfig:bool "Software synchronization objects" ...meaning that it currently is not being built as a module by anyone. Lets remove the modular code that is essentially or

[PATCH 1/7] drivers/staging: make android ashmem.c explicitly non-modular

2015-10-11 Thread Paul Gortmaker
The Kconfig currently controlling compilation of this code is: drivers/staging/android/Kconfig:config ASHMEM drivers/staging/android/Kconfig:bool "Enable the Anonymous Shared Memory Subsystem" ...meaning that it currently is not being built as a module by anyone. Lets remove the modular

[PATCH 6/7] drivers/staging: make android timed_output.c explicitly non-modular

2015-10-11 Thread Paul Gortmaker
The Kconfig currently controlling compilation of this code is: drivers/staging/android/Kconfig:config ANDROID_TIMED_OUTPUT drivers/staging/android/Kconfig:bool "Timed output class driver" ...meaning that it currently is not being built as a module by anyone. Lets remove the modular code

[PATCH 1/7] drivers/staging: make android ashmem.c explicitly non-modular

2015-10-11 Thread Paul Gortmaker
The Kconfig currently controlling compilation of this code is: drivers/staging/android/Kconfig:config ASHMEM drivers/staging/android/Kconfig:bool "Enable the Anonymous Shared Memory Subsystem" ...meaning that it currently is not being built as a module by anyone. Lets remove the modular

[PATCH 4/7] drivers/staging: make android sw_sync.c explicitly non-modular

2015-10-11 Thread Paul Gortmaker
The Kconfig currently controlling compilation of this code is: staging/android/Kconfig:config SW_SYNC staging/android/Kconfig:bool "Software synchronization objects" ...meaning that it currently is not being built as a module by anyone. Lets remove the modular code that is essentially or

[PATCH 6/7] drivers/staging: make android timed_output.c explicitly non-modular

2015-10-11 Thread Paul Gortmaker
The Kconfig currently controlling compilation of this code is: drivers/staging/android/Kconfig:config ANDROID_TIMED_OUTPUT drivers/staging/android/Kconfig:bool "Timed output class driver" ...meaning that it currently is not being built as a module by anyone. Lets remove the modular code

[PATCH 3/7] drivers/staging: make android tegra_ion.c properly tristate

2015-10-11 Thread Paul Gortmaker
The Kconfig currently controlling compilation of this code is: drivers/staging/android/ion/Kconfig:config ION_TEGRA drivers/staging/android/ion/Kconfig:tristate "Ion for Tegra" ...which led me to incorrectly conclude this file was built modular earlier. However the above CONFIG is just used

[PATCH 5/7] drivers/staging: make android lowmemorykiller.c explicitly non-modular

2015-10-11 Thread Paul Gortmaker
The Kconfig currently controlling compilation of this code is: drivers/staging/android/Kconfig:config ANDROID_LOW_MEMORY_KILLER drivers/staging/android/Kconfig:bool "Android Low Memory Killer" ...meaning that it currently is not being built as a module by anyone. Lets remove the modular

[PATCH 0/7] staging: make non-modular code explicitly non-modular

2015-10-11 Thread Paul Gortmaker
[resending; forgot to add lkml to Cc: -- sorry for those who get this 2x] In a previous merge window, we made changes to allow better delineation between modular and non-modular code in commit 0fd972a7d91d6e15393c449492a04d94c0b89351 ("module: relocate module_init from init.h to module.h"). This

[PATCH 2/7] drivers/staging: make android ion_page_pool.c explicitly non-modular

2015-10-11 Thread Paul Gortmaker
The Kconfig currently controlling compilation of this code is: drivers/staging/android/ion/Kconfig:menuconfig ION drivers/staging/android/ion/Kconfig:bool "Ion Memory Manager" ...meaning that it currently is not being built as a module by anyone. Lets remove the modular code that is essentia

[PATCH 2/7] drivers/staging: make android ion_page_pool.c explicitly non-modular

2015-10-11 Thread Paul Gortmaker
The Kconfig currently controlling compilation of this code is: drivers/staging/android/ion/Kconfig:menuconfig ION drivers/staging/android/ion/Kconfig:bool "Ion Memory Manager" ...meaning that it currently is not being built as a module by anyone. Lets remove the modular code that is essentia

[PATCH 5/7] drivers/staging: make android lowmemorykiller.c explicitly non-modular

2015-10-11 Thread Paul Gortmaker
The Kconfig currently controlling compilation of this code is: drivers/staging/android/Kconfig:config ANDROID_LOW_MEMORY_KILLER drivers/staging/android/Kconfig:bool "Android Low Memory Killer" ...meaning that it currently is not being built as a module by anyone. Lets remove the modular

[PATCH 7/7] drivers/staging: make emxx_udc.c explicitly non-modular

2015-10-11 Thread Paul Gortmaker
The Kconfig currently controlling compilation of this code is: drivers/staging/emxx_udc/Kconfig:config USB_EMXX drivers/staging/emxx_udc/Kconfig: bool "EMXX USB Function Device Controller" ...meaning that it currently is not being built as a module by anyone. Lets remove the modular code

[PATCH 3/7] drivers/staging: make android tegra_ion.c properly tristate

2015-10-11 Thread Paul Gortmaker
The Kconfig currently controlling compilation of this code is: drivers/staging/android/ion/Kconfig:config ION_TEGRA drivers/staging/android/ion/Kconfig:tristate "Ion for Tegra" ...which led me to incorrectly conclude this file was built modular earlier. However the above CONFIG is just used

[PATCH 7/7] drivers/staging: make emxx_udc.c explicitly non-modular

2015-10-11 Thread Paul Gortmaker
The Kconfig currently controlling compilation of this code is: drivers/staging/emxx_udc/Kconfig:config USB_EMXX drivers/staging/emxx_udc/Kconfig: bool "EMXX USB Function Device Controller" ...meaning that it currently is not being built as a module by anyone. Lets remove the modular code

[PATCH 0/7] staging: make non-modular code explicitly non-modular

2015-10-11 Thread Paul Gortmaker
In a previous merge window, we made changes to allow better delineation between modular and non-modular code in commit 0fd972a7d91d6e15393c449492a04d94c0b89351 ("module: relocate module_init from init.h to module.h"). This allows us to now ensure module code looks modular and non-modular code does

Re: [PATCH v8 32/55] [media] media: use macros to check for V4L2 subdev entities

2015-10-11 Thread Mauro Carvalho Chehab
Em Mon, 12 Oct 2015 00:07:52 +0300 Sakari Ailus escreveu: > Hi Mauro, > > On Sun, Aug 30, 2015 at 12:06:43AM -0300, Mauro Carvalho Chehab wrote: > > Instead of relying on media subtype, use the new macros to detect > > if an entity is a subdev or an A/V DMA entity. > > > > Please note that most

Re: [PATCH V1 2/3] taging: android: ion: Add ion driver for Hi6220 SoC platform

2015-10-11 Thread chenfeng
On 2015/10/10 23:00, Dan Carpenter wrote: > On Sat, Oct 10, 2015 at 02:48:22PM +0800, Chen Feng wrote: >> +static int hi6220_ion_probe(struct platform_device *pdev) >> +{ >> +int i; >> +int err = 0; >> +static struct ion_platform_heap *p_heap; >> + >> +idev = ion_device_create(NUL

[PATCH] staging: sm750fb: Fix the power state error in resume

2015-10-11 Thread Binbin Zhou
The PM_EVENT_RESUME state is needed when SM750 resume, otherwise it will be failed in the second time of continuous suspend/resume. Cc: Sudip Mukherjee Signed-off-by: Binbin Zhou Reviewed-by: Huacai Chen Reviewed-by: Teddy Wang --- drivers/staging/sm750fb/sm750.c | 1 + 1 file changed, 1 inse

Re: staging: wilc1000: WILC1000_DYNAMICALLY_ALLOCATE_MEMROY

2015-10-11 Thread Tony Cho
On 2015년 10월 09일 03:29, Stanislav Kholmanskikh wrote: Hi! I noticed that drivers/staging/wilc1000/Kconfic defines: config WILC1000_DYNAMICALLY_ALLOCATE_MEMROY bool "Dynamically allocate memory in real time" ---help--- This choice supports dynamic allocation of the

Re: staging: wilc1000: WILC1000_DYNAMICALLY_ALLOCATE_MEMROY

2015-10-11 Thread Tony Cho
On 2015년 10월 09일 03:47, Greg KH wrote: On Thu, Oct 08, 2015 at 09:29:35PM +0300, Stanislav Kholmanskikh wrote: Hi! I noticed that drivers/staging/wilc1000/Kconfic defines: config WILC1000_DYNAMICALLY_ALLOCATE_MEMROY bool "Dynamically allocate memory in real time" ---help---

Re: [PATCH 08/14] staging: wilc1000: remove typedef from tstrStatistics

2015-10-11 Thread Tony Cho
Hi Dan, I will find much clearer naming rules when sending version 2 for them. Thanks for your opinion, Tony. On 2015년 10월 09일 17:16, Dan Carpenter wrote: I feel like the name 'statistics' is very vague. I guess it's so vague that it's unlikely anyone else will try use it... regards, dan c

RE: [PATCH 02/10] Drivers: hv: utils: run polling callback always in interrupt context

2015-10-11 Thread KY Srinivasan
> -Original Message- > From: Olaf Hering [mailto:o...@aepfle.de] > Sent: Friday, October 9, 2015 4:29 AM > To: Vitaly Kuznetsov > Cc: KY Srinivasan ; gre...@linuxfoundation.org; linux- > ker...@vger.kernel.org; de...@linuxdriverproject.org; a...@canonical.com; > jasow...@redhat.com > Sub