The data link between the D/A data port and the D/A converter is a serial
link. The serial link requires about 8ms to complete a transfer. Use the
comedi_timeout() helper to ensure that there is not a previous transfer
still happening before trying to write new data to the channel.
For aesthetics,
Introduce a helper function for the common code used to clear any
pending interrupts.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/quatech_daqp_cs.c | 52
1 file changed, 25 insertions(+), 27 deletions(-)
di
Use the comedi_offset_munge() helper to do the offset binary to two's
complement conversion when writing a new analog output value.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/quatech_daqp_cs.c | 8 +++-
1 file changed, 3 insert
Fix the checkpatch.pl issues about:
CHECK: spaces preferred around that '<<' (ctx:VxV)
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/quatech_daqp_cs.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/s
For aesthetics, define a macro for the pacer clock options and rename
the CamelCase.
Remove the unnecessary local variable in daqp_ai_cmd() used to set the
control register.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/quatech_daqp_
Interrupts are only needed by this driver to support the analog input async
commands. Don't hook up the command support if pcmcia_request_irq() fails
instead of completely failing the (*auto_attach).
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/com
This is a PCMCIA driver and interrupts are always shared. Detect if
the hardware did not produce the interrupt and return IRQ_NONE so
that other drivers might handle it.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/quatech_daqp_cs.c
Reformat the multi-line comments in the kernel CodingStyle.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/quatech_daqp_cs.c | 83 +++-
1 file changed, 37 insertions(+), 46 deletions(-)
diff --git a/drivers/staging
Reorder the register map defines so that each register define is
followed by its bit defines.
For aesthetics, change all the register offsets to hex values and
use the BIT macro to define the register bits.
Also for aesthetics, move the DAQP_FIFO_SIZE and private data
definition after the registe
Hey,
Hope you are doing well!
We provide email marketing service to a number of businesses.
We can help your business reach the next level and generate more business
leads.
Please contact us so I can go over options for you.
Thanks and regards,
Jensen Lewis
Contact: mihuiyu...@sina.com
___
On Thu, Oct 01, 2015 at 09:34:51PM +0200, Boris Brezillon wrote:
> The ->read_xxx() methods are all passed the page number the NAND controller
> is supposed to read, but ->write_xxx() do not have such a parameter.
>
> This is a problem if we want to properly implement data
> scrambling/randomizati
From: Glen Lee
This patch removes unused variable already_claim and hWILCWFIDrv_2.
Signed-off-by: Glen Lee
Signed-off-by: Tony Cho
---
drivers/staging/wilc1000/wilc_wfi_netdevice.h | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_wfi_netdevice.h
b/drivers/st
This patch removes unused structure, tstrconfigPktInfo from the
coreconfigurator.c file.
Signed-off-by: Tony Cho
---
drivers/staging/wilc1000/coreconfigurator.c | 8
1 file changed, 8 deletions(-)
diff --git a/drivers/staging/wilc1000/coreconfigurator.c
b/drivers/staging/wilc1000/core
This patch removes typedef from enumerated types defined in
coreconfigurator.c file and also changes their names to avoid CamelCase
naming convention as shown:
- tenuBasicFrmType to basic_frame_type
- tenuFrmSubtype to sub_frame_type
- tenuInfoElemID to info_element_id
Signed-off-by: Tony Cho
--
From: Glen Lee
This patch removes undefined DEBUG_MODE and it's related codes.
We won't use this at the moment.
Signed-off-by: Glen Lee
Signed-off-by: Tony Cho
---
drivers/staging/wilc1000/linux_wlan.c | 63 ---
1 file changed, 63 deletions(-)
diff --git a/dri
From: Glen Lee
Remove function pointer cfg_wid_get and call the function
wilc_wlan_cfg_get_wid instead. Remove static from the function declaration.
Signed-off-by: Glen Lee
Signed-off-by: Tony Cho
---
drivers/staging/wilc1000/wilc_wlan.c | 2 +-
drivers/staging/wilc1000/wilc_wlan.h |
From: Glen Lee
This patch removes function pointer cfg_wid_set and call the function
wilc_wlan_cfg_set_wid instead. Remove static from the function declaration.
Signed-off-by: Glen Lee
Signed-off-by: Tony Cho
---
drivers/staging/wilc1000/wilc_wlan.c | 5 +++--
drivers/staging/wilc1000/wil
From: Glen Lee
This patch removes cfg_wid_get_val and call the function
wilc_wlan_cfg_get_wid_value. Remove static from the function declaration.
Signed-off-by: Glen Lee
Signed-off-by: Tony Cho
---
drivers/staging/wilc1000/wilc_wlan.c | 2 +-
drivers/staging/wilc1000/wilc_wlan.h | 1 -
From: Glen Lee
This patch removes function pointer rx_indicate and just call the function
wilc_wlan_cfg_indicate_rx instead. Remove static from the function
declration.
Signed-off-by: Glen Lee
Signed-off-by: Tony Cho
---
drivers/staging/wilc1000/wilc_wlan.c | 2 +-
drivers/staging/wilc100
From: Glen Lee
This patch removes function pointer cfg_init and call the function
wilc_wlan_cfg_init instead. Remove static from function declaration.
After removing cfg_init, the struct wilc_cfg_func_t is useless so just delete
it and it's related codes.
Signed-off-by: Glen Lee
Signed-off-by:
From: Glen Lee
This patch removes unused variable real_ndev.
Signed-off-by: Glen Lee
Signed-off-by: Tony Cho
---
drivers/staging/wilc1000/wilc_wfi_netdevice.h | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/wilc1000/wilc_wfi_netdevice.h
b/drivers/staging/wilc1000/wilc_wfi_
This is a patch to move open braces to the appropriate lines in
two instances in ieee80211_crypt_ccmp.c
Signed-off-by: Mike Dupuis
---
drivers/staging/rtl8192u/ieee80211/ieee80211_crypt_ccmp.c | 6 ++
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee
This is a patch to add missing lines after variable decalarations
in two functions in ieee80211_crypt_ccmp.c
Signed-off-by: Mike Dupuis
---
drivers/staging/rtl8192u/ieee80211/ieee80211_crypt_ccmp.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211
This is a patch to fix up instances where quoted strings are split
across multiple lines in several instances in ieee80211_crypt_ccmp.c
Signed-off-by: Mike Dupuis
---
.../rtl8192u/ieee80211/ieee80211_crypt_ccmp.c | 27 +-
1 file changed, 11 insertions(+), 16 deletions(-)
This is a series of patches to correct several checkpatch.pl warnings
and errors in ieee80211_crypt_ccmp.c.
Checkpatch.pl before/after summary:
before: total: 2 errors, 23 warnings, 23 checks, 474 lines checked
after: total: 0 errors, 10 warnings, 27 checks, 469 lines checked
Mike Dupuis (5):
This is a patch to correct block comment formatting in two
instances in ieee80211_crypt_ccmp.c
Signed-off-by: Mike Dupuis
---
drivers/staging/rtl8192u/ieee80211/ieee80211_crypt_ccmp.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee8021
This is a patch to correct indentation in one instance in
ieee80211_crypt_ccmp.c
Signed-off-by: Mike Dupuis
---
drivers/staging/rtl8192u/ieee80211/ieee80211_crypt_ccmp.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_crypt_ccmp.c
The ->read_xxx() methods are all passed the page number the NAND controller
is supposed to read, but ->write_xxx() do not have such a parameter.
This is a problem if we want to properly implement data
scrambling/randomization in order to mitigate MLC sensibility to repeated
pattern: to prevent bit
On Fri, Oct 02, 2015 at 07:56:28AM +0900, Chaehyun Lim wrote:
> On Fri, Oct 2, 2015 at 12:40 AM, Dan Carpenter
> wrote:
> > On Thu, Oct 01, 2015 at 10:43:55PM +0900, Chaehyun Lim wrote:
> >> This patch replaces int8_t with s8 that is a preferred type.
> >>
> >
> > It would be better to just use i
101 - 129 of 129 matches
Mail list logo