Hey there,
Not sure if you got my last email but wanted to touch base again.
I was wondering if you wanted to try our email marketing and lead
generation solutions.
We can help to grow your business fast by using our services.
We have worked on a number of projects and campaigns, all our packages
Fix sparse warning 'Using plain integer as NULL pointer' by replacing 0
with NULL in the assignment.
Signed-off-by: Anders Fridlund
---
drivers/staging/most/aim-network/networking.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/most/aim-network/networking.c
Move constants to the right of binary operators.
A simplified version of the semantic patch that makes this change is as
follows: (http://coccinelle.lip6.fr/)
//
@@
constant c;
expression e;
binary operator b = {==,!=,&,|};
@@
(
- c
+ e
b
- e
+ c
|
- c < e
+ e > c
)
//
Signed-off-by: Julia La
Move constants to the right of binary operators.
A simplified version of the semantic patch that makes this change is as
follows: (http://coccinelle.lip6.fr/)
//
@@
constant c;
expression e;
binary operator b = {==,!=,&,|};
@@
(
- c
+ e
b
- e
+ c
|
- c < e
+ e > c
)
//
Signed-off-by: Julia La
Typically, constants appear to the right of binary operators. The complete
semantic patch that performs this change is as follows
(http://coccinelle.lip6.fr/). In particular, it doesn't change long
sequences of bit ors, or comparisons that are checking that some
expression has a value that is bet
Move constants to the right of binary operators.
A simplified version of the semantic patch that makes this change is as
follows: (http://coccinelle.lip6.fr/)
//
@@
constant c;
expression e;
binary operator b = {==,!=,&,|};
@@
(
- c
+ e
b
- e
+ c
|
- c < e
+ e > c
)
//
Signed-off-by: Julia La
Move constants to the right of binary operators.
A simplified version of the semantic patch that makes this change is as
follows: (http://coccinelle.lip6.fr/)
//
@@
constant c;
expression e;
binary operator b = {==,!=,&,|};
@@
(
- c
+ e
b
- e
+ c
|
- c < e
+ e > c
)
//
Signed-off-by: Julia La
Move constants to the right of binary operators.
A simplified version of the semantic patch that makes this change is as
follows: (http://coccinelle.lip6.fr/)
//
@@
constant c;
expression e;
binary operator b = {==,!=,&,|};
@@
(
- c
+ e
b
- e
+ c
|
- c < e
+ e > c
)
//
Signed-off-by: Julia La
Move constants to the right of binary operators.
A simplified version of the semantic patch that makes this change is as
follows: (http://coccinelle.lip6.fr/)
//
@@
constant c;
expression e;
binary operator b = {==,!=,&,|};
@@
(
- c
+ e
b
- e
+ c
|
- c < e
+ e > c
)
//
Signed-off-by: Julia La
Move constants to the right of binary operators.
A simplified version of the semantic patch that makes this change is as
follows: (http://coccinelle.lip6.fr/)
//
@@
constant c;
expression e;
binary operator b = {==,!=,&,|};
@@
(
- c
+ e
b
- e
+ c
|
- c < e
+ e > c
)
//
Signed-off-by: Julia La
Move constants to the right of binary operators.
A simplified version of the semantic patch that makes this change is as
follows: (http://coccinelle.lip6.fr/)
//
@@
constant c;
expression e;
binary operator b = {==,!=,&,|};
@@
(
- c
+ e
b
- e
+ c
|
- c < e
+ e > c
)
//
Signed-off-by: Julia La
On Sat, 2015-08-29 at 19:30 +0200, Julia Lawall wrote:
> Move constants to the right of binary operators.
[]
> diff --git a/drivers/staging/lustre/lustre/ptlrpc/client.c
> b/drivers/staging/lustre/lustre/ptlrpc/client.c
[]
> @@ -2954,7 +2954,7 @@ void ptlrpc_init_xid(void)
> }
>
> /*
This driver is abusing MEDIA_ENT_T_V4L2_SUBDEV:
- it uses a hack to check if the remote entity is a subdev;
- it still uses the legacy entity subtype check macro, that
will be removed soon.
Signed-off-by: Mauro Carvalho Chehab
diff --git a/drivers/staging/media/davinci_vpfe/dm365_ipipe.c
b/d
From: Javier Martinez Canillas
Assessing media_entity ID should now use media_entity_id() macro to
obtain the entity ID, as a next patch will remove the .id field from
struct media_entity .
So, get rid of it, otherwise the omap4iss driver will fail to build.
Signed-off-by: Javier Martinez Canil
On omap3/omap4/davinci drivers, MEDIA_ENT_T_V4L2_SUBDEV macro is
abused in order to "simplify" the pad checks.
Basically, it does a logical or of this macro, in order to check
for a local index and if the entity is either a subdev or not.
As we'll get rid of MEDIA_ENT_T_V4L2_SUBDEV macro, replace
From: Javier Martinez Canillas
The struct media_entity has a .parent field that stores a pointer
to the parent struct media_device. But recently a media_gobj was
embedded into the entities and since struct media_gojb already has
a pointer to a struct media_device in the .mdev field, the .parent
f
That's the 8th version of the MC next generation patches.
Differences from version 7:
- Patches reworked to make the reviewers happy;
- Bug fixes;
- ALSA changes got their own separate patches;
- Javier patches got integrated into this series;
- media-entity.h structs are now properly documented;
This driver is abusing MEDIA_ENT_T_V4L2_SUBDEV, as it uses a
hack to check if the remote entity is a subdev. Get rid of it.
Signed-off-by: Mauro Carvalho Chehab
diff --git a/drivers/staging/media/omap4iss/iss_ipipe.c
b/drivers/staging/media/omap4iss/iss_ipipe.c
index e1a7b7ba7362..eb91ec48a21e
Instead of relying on media subtype, use the new macros to detect
if an entity is a subdev or an A/V DMA entity.
Please note that most drivers assume that there's just AV_DMA or
V4L2 subdevs. This is not true anymore, as we've added MC support
for DVB, and there are plans to add support for ALSA a
With the new API, a link can be either between two PADs or between an interface
and an entity. So, we need to use a better name for the function that create
links between two pads.
So, rename the such function to media_create_pad_link().
No functional changes.
This patch was created via this she
Greetings To You From Mr.Warren Edward Buffett,
You have been gifted $1.5 MILLION USD donation fund.I am still waiting for you
to contact me for details on how to claim this donation which i awarded to you.
I hope this information meet you well as I know you will be curious to know
why/how I
21 matches
Mail list logo