On Tue, Jun 30, 2015 at 11:54:02PM +0200, Michel von Czettritz wrote:
> Writing the output of cpu_to_le32 to an u32 or *(u32*) is an implicit
> cast and results in an sparse warning.
>
> Since param and mask won't be changed, the implicit cast can be avoided
> by creating local variables.
>
> Sig
On Tue, Jun 30, 2015 at 11:54:59PM +0200, Michel von Czettritz wrote:
> The return value of FillH2CCmd in rtl8723a_set_rssi_cmd and
> rtl8723a_set_raid_cmd is never checked. Both functions always return
> _SUCCESS.
>
> Both functions now return the return value of FillH2CCmd.
If they are never che
Thanks for review, my answers inline
On 01-07-2015 12:27, Sudip Mukherjee wrote:
On Wed, Jul 01, 2015 at 03:05:45AM +0530, Sohny Thomas wrote:
FIX 2 unnecessary braces found by checkpatch.pl
Signed-off-by: Sohny Thomas
---
drivers/staging/unisys/virtpci/virtpci.c | 11 ++-
1 file
I started reviewing this patch but then part way through I relized I
must be missing quite a bit of it...
On Tue, Jun 30, 2015 at 10:56:27AM -0700, Laura Abbott wrote:
> On 06/30/2015 08:34 AM, Andrew Andrianov wrote:
> >+static int ion_physmem_probe(struct platform_device *pdev)
> >+{
> >+int
On Wed, Jul 01, 2015 at 12:42:24PM +0530, Sudip Mukherjee wrote:
> On Tue, Jun 30, 2015 at 11:54:59PM +0200, Michel von Czettritz wrote:
> > The return value of FillH2CCmd in rtl8723a_set_rssi_cmd and
> > rtl8723a_set_raid_cmd is never checked. Both functions always return
> > _SUCCESS.
> >
> > Bo
On Tue, Jun 30, 2015 at 11:54:02PM +0200, Michel von Czettritz wrote:
> Writing the output of cpu_to_le32 to an u32 or *(u32*) is an implicit
> cast and results in an sparse warning.
>
> Since param and mask won't be changed, the implicit cast can be avoided
> by creating local variables.
>
> Sig
On Tue, Jun 30, 2015 at 03:35:01PM -0700, K. Y. Srinivasan wrote:
> From: ja...@microsoft.com
Jake, fix your git config.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinf
On Wed, 1 Jul 2015, Sohny Thomas wrote:
> Thanks for review, my answers inline
>
> On 01-07-2015 12:27, Sudip Mukherjee wrote:
> > On Wed, Jul 01, 2015 at 03:05:45AM +0530, Sohny Thomas wrote:
> > >
> > > FIX 2 unnecessary braces found by checkpatch.pl
> > >
> > > Signed-off-by: Sohny Thomas
>
On Wed, Jul 01, 2015 at 01:06:48PM +0530, Sohny Thomas wrote:
> >No, now this will introduce a new checkpatch warning that "else is not
> >required after return". why did you introduce this "else"?
> I did this so that the code is more readable and understandable, I
> checked and checkpatch didn't
On Tue, Jun 30, 2015 at 09:08:33PM -0700, matt mooney wrote:
> fix sparse warning in lustre/ptlrpc/ptlrpc_module.c:54:12:
> warning: symbol 'ptlrpc_init' was not declared. Should it be static?
>
> The __init macro is moved before the function name to match standard usage.
>
> Signed-off-by:
On Wed, Jul 01, 2015 at 10:50:42AM +0300, Dan Carpenter wrote:
> On Wed, Jul 01, 2015 at 12:42:24PM +0530, Sudip Mukherjee wrote:
> > On Tue, Jun 30, 2015 at 11:54:59PM +0200, Michel von Czettritz wrote:
> > > The return value of FillH2CCmd in rtl8723a_set_rssi_cmd and
> > > rtl8723a_set_raid_cmd i
On Wednesday 01 July 2015 01:32 PM, Sudip Mukherjee wrote:
> On Wed, Jul 01, 2015 at 01:06:48PM +0530, Sohny Thomas wrote:
>
>>> No, now this will introduce a new checkpatch warning that "else is not
>>> required after return". why did you introduce this "else"?
>> I did this so that the code is
SPC-2/3/4 specs state that "The standard INQUIRY data (see table ...)
shall contain at least 36 bytes". Hyper-V host doesn't always honor this
requirement, e.g. when there is no physical device present at a particular
LUN host sets Peripheral qualifier to 011b and Additional length to 0
(thus makin
On Thu, Jun 25, 2015 at 09:58:51AM -0400, Benjamin Romer wrote:
> From: Erik Arfvidson
>
> +static int
> +visorhid_init(void)
> +{
> + int rc = 0;
> +
> + spin_lock_init(&devnopool_lock);
> + dev_no_pool = kzalloc(BITS_TO_LONGS(MAXDEVICES), GFP_KERNEL);
> + if (!dev_no_pool) {
>
On Wed, Jul 01, 2015 at 02:04:48PM +0530, Sohny Thomas wrote:
> On Wednesday 01 July 2015 01:32 PM, Sudip Mukherjee wrote:
> > On Wed, Jul 01, 2015 at 01:06:48PM +0530, Sohny Thomas wrote:
>
> This is from linux-stable branch and I updated it just yesterday, so looks
> like the folders still th
i = virtpci_device_del(NULL /*no parent bus */, VIRTHBA_TYPE,
&scsi.wwnn, NULL);
- if (i) {
+ if (i)
return 1;
- }
- return 0;
+ else
+ return 0;
>>> No, now this will introduce a new checkpatch warni
Comment in struct Scsi_Host says that drivers are not supposed to access
__devices directly. storvsc_host_scan() doesn't happen in irq context
so we can just use shost_for_each_device().
Signed-off-by: Vitaly Kuznetsov
---
drivers/scsi/storvsc_drv.c | 9 +
1 file changed, 1 insertion(+),
On Wed, 1 Jul 2015, Sohny Thomas wrote:
> i = virtpci_device_del(NULL /*no parent bus */, VIRTHBA_TYPE,
> &scsi.wwnn, NULL);
> -if (i) {
> +if (i)
> return 1;
> -}
> -retu
On Wednesday 01 July 2015 02:45 PM, Sudip Mukherjee wrote:
> On Wed, Jul 01, 2015 at 02:04:48PM +0530, Sohny Thomas wrote:
>> On Wednesday 01 July 2015 01:32 PM, Sudip Mukherjee wrote:
>>> On Wed, Jul 01, 2015 at 01:06:48PM +0530, Sohny Thomas wrote:
>>
>
>> This is from linux-stable branch and
Pre-Win2012R2 hosts don't properly handle CHANNELMSG_UNLOAD and
wait_for_completion() hangs. Avoid sending such request on old hosts.
Signed-off-by: Vitaly Kuznetsov
---
drivers/hv/channel_mgmt.c | 4
1 file changed, 4 insertions(+)
diff --git a/drivers/hv/channel_mgmt.c b/drivers/hv/chann
This patch enables debugfs file /sys/kernel/debug/ion/heaps/system_shrink
to shrink pool and get pool size. It is already implemented
but not complete. This patch completes and enables it.
Reading the file returns pool size
in page unit and writing the number of pages shrinks pool.
It flushes all
This patch shrink page-pool by page unit.
The system shrinker calls ion_heap_shrink_count() to get nr_to_scan,
and pass it to ion_heap_shrink_scan().
The problem is the return value of ion_heap_shrink_count() is the number
of pages but ion_system_heap_shrink(), which is called by
ion_heap_shrink_s
Hello,
The ion has internal page pool to keep freed pages.
There is no way to shrink the pool so that the pool sometimes
grows too big.
For example my platform allocates some graphic memory via ion.
Sometimes the pool can be several hundreds MB. I want to
flush the pool before critical page short
Your subject needs a hint as to what part of the kernel it is changing,
please fix that up to match what other patches have looked like for this
file.
On Wed, Jul 01, 2015 at 08:55:21AM -0700, Leung Timothy Chi King wrote:
> Ran checkpatch.pl on driver/staging/rts5208/sd.c and foudn a WARNING
> 'e
The following checkpatch warning was fixed:
WARNING: else is not generally useful after a break or return
Signed-off-by: Leung Timothy Chi King
---
drivers/staging/rts5208/sd.c | 11 +--
1 file changed, 5 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/rts5208/sd.c b/drivers
On 07/01/2015 10:08 AM, Sudip Mukherjee wrote:
> On Wed, Jul 01, 2015 at 10:50:42AM +0300, Dan Carpenter wrote:
>> On Wed, Jul 01, 2015 at 12:42:24PM +0530, Sudip Mukherjee wrote:
>>> On Tue, Jun 30, 2015 at 11:54:59PM +0200, Michel von Czettritz wrote:
The return value of FillH2CCmd in rtl872
Ran checkpatch.pl on driver/staging/rts5208/sd.c and foudn a WARNING
'else is not generally useful after a break or return' on line 3523. I
removed the else without affecting the logic and the WARNING is gone. I
had compiled and modprobe rts5208 to double check as well.
Regards,
Tim
Signed-off-by
Michel von Czettritz writes:
> Writing the output of cpu_to_le32 to an u32 or *(u32*) is an implicit
> cast and results in an sparse warning.
>
> Since param and mask won't be changed, the implicit cast can be avoided
> by creating local variables.
>
> Signed-off-by: Michel von Czettritz
> ---
>
Dan Carpenter writes:
> On Tue, Jun 30, 2015 at 11:54:02PM +0200, Michel von Czettritz wrote:
>> Writing the output of cpu_to_le32 to an u32 or *(u32*) is an implicit
>> cast and results in an sparse warning.
>>
>> Since param and mask won't be changed, the implicit cast can be avoided
>> by crea
On 07/01/2015 10:31 PM, Jes Sorensen wrote:
> Michel von Czettritz writes:
>> Writing the output of cpu_to_le32 to an u32 or *(u32*) is an implicit
>> cast and results in an sparse warning.
>>
>> Since param and mask won't be changed, the implicit cast can be avoided
>> by creating local variables
Michel von Czettritz writes:
> On 07/01/2015 10:31 PM, Jes Sorensen wrote:
>> Michel von Czettritz writes:
>>> Writing the output of cpu_to_le32 to an u32 or *(u32*) is an implicit
>>> cast and results in an sparse warning.
>>>
>>> Since param and mask won't be changed, the implicit cast can be a
Mario Bambagini writes:
> Defines have been written in more than one line to match the 80-character
> rule. This error has been fixed 6 times in this file.
> The file is fully compliant with respect to the coding rules now.
Rules, maybe. But is it better, i.e., more readable?
> --- a/drivers/st
On Wed, 2015-07-01 at 09:59 +0200, Krzysztof Hałasa wrote:
> Mario Bambagini writes:
>
> > Defines have been written in more than one line to match the 80-character
> > rule. This error has been fixed 6 times in this file.
> > The file is fully compliant with respect to the coding rules now.
>
>
33 matches
Mail list logo