Added one line after variable declaration.
Signed-off-by: Tan Nguyen
---
drivers/staging/android/ion/ion.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/android/ion/ion.c
b/drivers/staging/android/ion/ion.c
index 6f48112..e44f5e6 100644
--- a/drivers/staging/android/ion/io
Hope you are doing well!
Our email marketing can generate tons of new customers for your business.
We would like to be your marketing partners and help your business reach
the new level.
We can increase your business sales 2-4 times than now.
Please contact us if you would require more informati
If CONFIG_88EU_AP_MODE is undefined, issue_asocrsp() is never referenced.
Fixes warning:
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c:891:13: warning:
‘issue_asocrsp’ defined but not used [-Wunused-function]
Signed-off-by: Luca Ceresoli
Fixes: 782eddd748d9 ("staging: rtl8188eu: unexport inte
If CONFIG_88EU_AP_MODE is undefined, OnAuth() is never referenced.
Fixes warning:
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c:2725:21: warning: ‘OnAuth’
defined but not used [-Wunused-function]
Signed-off-by: Luca Ceresoli
Fixes: 68345dd7bc26 ("staging: rtl8188eu: rtw_mlme_ext.c: unexport m
Use a helper function to manage SD erase status when SUPPORT_SD_LOCK is
defined
Signed-off-by: Fabio Falzoi
---
drivers/staging/rts5208/rtsx_chip.c | 38 -
1 file changed, 21 insertions(+), 17 deletions(-)
diff --git a/drivers/staging/rts5208/rtsx_chip.c
b/d
Use a helper function to manage aspm mode
Signed-off-by: Fabio Falzoi
---
drivers/staging/rts5208/rtsx_chip.c | 51 ++---
1 file changed, 30 insertions(+), 21 deletions(-)
diff --git a/drivers/staging/rts5208/rtsx_chip.c
b/drivers/staging/rts5208/rtsx_chip.c
ind
Use a helper function to manage ss_counter
Signed-off-by: Fabio Falzoi
---
drivers/staging/rts5208/rtsx_chip.c | 66 ++---
1 file changed, 33 insertions(+), 33 deletions(-)
diff --git a/drivers/staging/rts5208/rtsx_chip.c
b/drivers/staging/rts5208/rtsx_chip.c
in
Use a helper function to check if power off is needed.
Signed-off-by: Fabio Falzoi
---
drivers/staging/rts5208/rtsx_chip.c | 34 --
1 file changed, 20 insertions(+), 14 deletions(-)
diff --git a/drivers/staging/rts5208/rtsx_chip.c
b/drivers/staging/rts5208/rtsx_
rtsx_polling_func is a big function that manage a lot of independent
tasks.
This patch aims to refactor the code using a series of helper functions,
to make it more readable.
Plus, the following checkpatch warning is corrected:
* PARENTHESIS_ALIGNMENT at row 1246
Fabio Falzoi (7):
Staging: rts52
Use a helper function to manage idle state
Signed-off-by: Fabio Falzoi
---
drivers/staging/rts5208/rtsx_chip.c | 45 -
1 file changed, 25 insertions(+), 20 deletions(-)
diff --git a/drivers/staging/rts5208/rtsx_chip.c
b/drivers/staging/rts5208/rtsx_chip.c
in
Use a helper function to manage delink states
Signed-off-by: Fabio Falzoi
---
drivers/staging/rts5208/rtsx_chip.c | 141 ++--
1 file changed, 72 insertions(+), 69 deletions(-)
diff --git a/drivers/staging/rts5208/rtsx_chip.c
b/drivers/staging/rts5208/rtsx_chip.c
Use a helper function to manage lun modes when SUPPORT_OCP is defined
Signed-off-by: Fabio Falzoi
---
drivers/staging/rts5208/rtsx_chip.c | 97 -
1 file changed, 53 insertions(+), 44 deletions(-)
diff --git a/drivers/staging/rts5208/rtsx_chip.c
b/drivers/sta
On 12/06/15 21:20, julien.de...@gmail.com wrote:
From: Julien Dehee
comedi/comedi_fops.c
use ENODEV following open manual
comedi/drivers.c
use ENOTTY following ioctl manual
drivers/serial2002.c
use ENOTTY following ioctl manual
Signed-off-by: Julien Dehee
---
drivers/stagin
Nicholas Mc Guire writes:
> On Sat, 13 Jun 2015, Jes Sorensen wrote:
>
>> Nicholas Mc Guire writes:
>> > scanning for trivial bug-patters with coccinelle spatches returned:
>> > ./drivers/staging/rtl8723au/hal/rtl8723a_hal_init.c:1395
>> >WARNING: condition with no effect (if branch == else)
On Sun, Jun 14, 2015 at 02:53:21PM +0700, Tan Nguyen wrote:
> Added one line after variable declaration.
>
> Signed-off-by: Tan Nguyen
> ---
> drivers/staging/android/ion/ion.c | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/drivers/staging/android/ion/ion.c
> b/drivers/staging/androi
From: Niranjan Dighe
This patch removes spaces at the start of the line and replaces it
by tabs
Signed-off-by: Niranjan Dighe
diff --git a/drivers/staging/sm750fb/ddk750_dvi.h
b/drivers/staging/sm750fb/ddk750_dvi.h
index 50bcec2..cbd87c1 100644
--- a/drivers/staging/sm750fb/ddk750_dvi.h
+++ b
From: Niranjan Dighe
This patch fixes indentation issues by replacing spaces by tabs at
the start of line
Signed-off-by: Niranjan Dighe
diff --git a/drivers/staging/sm750fb/ddk750_dvi.c
b/drivers/staging/sm750fb/ddk750_dvi.c
index b2bf7e6..c73b74a 100644
--- a/drivers/staging/sm750fb/ddk750_d
This patch fixes indentation issues by replacing spaces by tabs at
the start of line
Signed-off-by: Niranjan Dighe
diff --git a/drivers/staging/sm750fb/ddk750_dvi.c
b/drivers/staging/sm750fb/ddk750_dvi.c
index b2bf7e6..c73b74a 100644
--- a/drivers/staging/sm750fb/ddk750_dvi.c
+++ b/drivers/sta
Apparently, there is some error in struct rt_8723a_firmware_hdr. Indeed,
according to the comments in the code, the first 6 fields should be confined
in the first 8 bytes, but they actually occupy 9 bytes. Moreover, the total
size of the struct is 33 bytes, while function rtl8723a_FirmwareDownload(
This patch makes field in struct rt_8723a_firmware_hdr use endianness-aware
types (__leXX), thus fixing the following sparse warnings:
CHECK drivers/staging/rtl8723au/hal/rtl8723a_hal_init.c
drivers/staging/rtl8723au/hal/rtl8723a_hal_init.c:263:37: warning: cast to
restricted __le16
drivers/stag
The size of field Rsvd1 in struct rt_8723a_firmware_hdr should be u8
otherwise we exceeds the boundaries of "LONG WORD 0". This patch fixes
the issue.
Signed-off-by: Daniele Alessandrelli
---
drivers/staging/rtl8723au/include/rtl8723a_hal.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Another cleanup series.
Most patches are pretty simple (fragmented a bit to make review easier).
Series should apply cleanly into staging-next (5c1043984) and
staging-testing (f996bd10).
Target tested (802.11N/2.4G/WPA2 network, DHCP, 1MB download, ping).
Mateusz Kulikowski (16):
staging: rtl
Delete unused enums, structures and macros.
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtl819x_HT.h | 128 --
1 file changed, 128 deletions(-)
diff --git a/drivers/staging/rtl8192e/rtl819x_HT.h
b/drivers/staging/rtl8192e/rtl819x_HT.h
index f7
Both functions are never used.
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtllib_softmac.c | 39 ---
1 file changed, 39 deletions(-)
diff --git a/drivers/staging/rtl8192e/rtllib_softmac.c
b/drivers/staging/rtl8192e/rtllib_softmac.c
index cb78782.
Field was initialized and never used.
This patch also removes chnl_op enum that was only
referenced by ChnkOp init code.
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtl819x_HT.h | 8
drivers/staging/rtl8192e/rtl819x_HTProc.c | 1 -
2 files changed, 9 deletions(-)
Delete macros, structure members and declarations etc. that are not
referenced anywhere in code.
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtllib.h | 448 --
1 file changed, 448 deletions(-)
diff --git a/drivers/staging/rtl8192e/rtllib.h
This function was declared but never unused.
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtllib.h | 1 -
drivers/staging/rtl8192e/rtllib_softmac.c | 5 -
2 files changed, 6 deletions(-)
diff --git a/drivers/staging/rtl8192e/rtllib.h
b/drivers/staging/rtl8192e/rtl
This function was declared but never unused.
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtllib.h | 1 -
drivers/staging/rtl8192e/rtllib_softmac.c | 12
2 files changed, 13 deletions(-)
diff --git a/drivers/staging/rtl8192e/rtllib.h
b/drivers/staging/rt
This function was declared but never unused.
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtllib.h| 3 --
drivers/staging/rtl8192e/rtllib_wx.c | 57
2 files changed, 60 deletions(-)
diff --git a/drivers/staging/rtl8192e/rtllib.h
b/dri
ENABLE_LOCK_DEBUG macro was never set, so condition that used
it can be resolved manually.
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtllib.h | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/rtl8192e/rtllib.h
b/drivers/staging/rtl8192e/rtllib.h
index f2f
Following members were removed:
- tmpJoinAction
- tmpSuppRateBuf
- bTmpIbpm
As a consequence several unused defines/enums/structs were
also removed from rtllib.h
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtllib.h | 36
1 file changed, 36
This function/callback was initialized and never called.
rtl8192_get_nic_desc_num() function that was default
implementation was also removed.
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtl8192e/rtl_core.c | 17 -
drivers/staging/rtl8192e/rtllib.h|
Variable was initialized and never used.
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtllib.h| 1 -
drivers/staging/rtl8192e/rtllib_rx.c | 2 --
2 files changed, 3 deletions(-)
diff --git a/drivers/staging/rtl8192e/rtllib.h
b/drivers/staging/rtl8192e/rtllib.h
index f785e
This function was declared but never unused.
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtllib.h | 1 -
drivers/staging/rtl8192e/rtllib_softmac.c | 41 ---
2 files changed, 42 deletions(-)
diff --git a/drivers/staging/rtl8192e/rtllib.h
b
This queue is never used, and function handler is empty
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtllib.h | 1 -
drivers/staging/rtl8192e/rtllib_softmac.c | 6 --
2 files changed, 7 deletions(-)
diff --git a/drivers/staging/rtl8192e/rtllib.h
b/drivers/staging/
Variable is always true; Resolve condition where it is used
(and change indentation of conditional expression).
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtllib.h | 1 -
drivers/staging/rtl8192e/rtllib_rx.c | 52 ++-
drivers/staging/
Current WIRELESS_EXT version is at least 22.
Resolve ifdefs and delete dead code.
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtllib.h | 12
1 file changed, 12 deletions(-)
diff --git a/drivers/staging/rtl8192e/rtllib.h
b/drivers/staging/rtl8192e/rtllib.h
index
Delete several members of rtllib_device including
their initializers if needed.
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtl8192e/rtl_core.c | 6 --
drivers/staging/rtl8192e/rtl8192e/rtl_dm.c | 1 -
drivers/staging/rtl8192e/rtllib.h| 12
dri
Added le16_to_cpu() conversion fixing the following warning in assignment
detected by sparse:
drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c:2157:30: warning:
invalid assignment: +=
drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c:2157:30:left side
has type unsigned long
driv
On 2015년 06월 12일 20:07, Sudip Mukherjee wrote:
On Fri, Jun 12, 2015 at 07:23:11PM +0900, Dean Lee wrote:
remove complete OS wrapper functions.
just a minor thing. It will be easy if you send your patches in series
instead of separate patches. your patch "remove oswrapper & type file"
is depen
On 2015년 06월 12일 23:34, Greg KH wrote:
On Fri, Jun 12, 2015 at 06:51:56PM +0900, Dean Lee wrote:
Remove the following warnings in the wilc_log.h:
- unnecessary whitespace before a quoted newline
- line over 80 characters
- single statement macros should not use a do {} while (0) loop.
Those a
On 2015년 06월 13일 00:26, Greg KH wrote:
On Fri, Jun 12, 2015 at 07:21:11PM +0900, Dean Lee wrote:
remove OS Wrapper function(wilc_oswrapper.h) is in our plan.
i removed OS Wrapper function and it's done.
and i found wilc_type.h file is does not used it.
so i deleted them and modify #include lin
On 2015년 06월 13일 00:28, Greg KH wrote:
On Fri, Jun 12, 2015 at 02:39:08PM +0900, Dean Lee wrote:
change own data type(WILC_Char) to common data type(s8)
Why not just 'char'?
And you are using these in "strings", so why not u8?
thanks,
greg k-h
i research some documents for change to commo
On Mon, Jun 15, 2015 at 09:47:04AM +0900, Dean.lee wrote:
>
>
> On 2015년 06월 13일 00:28, Greg KH wrote:
> >On Fri, Jun 12, 2015 at 02:39:08PM +0900, Dean Lee wrote:
> >>change own data type(WILC_Char) to common data type(s8)
> >Why not just 'char'?
> >
> >And you are using these in "strings", so w
change own data type(WILC_Char) to common data type(char)
Signed-off-by: Dean Lee
---
Change v2:
replace data type s8 -> char
---
drivers/staging/wilc1000/coreconfigurator.c | 24 +++
drivers/staging/wilc1000/coreconfigurator.h | 4 +-
drivers/staging/wilc1000/host_interface.c
On Sun, Jun 14, 2015 at 08:45:02PM +0200, Markus Böhme wrote:
> >This patch fixes indentation issues by replacing spaces by tabs at
> >the start of line
> >
> >Signed-off-by: Niranjan Dighe
> >
> >diff --git a/drivers/staging/sm750fb/ddk750_dvi.c
> >b/drivers/staging/sm750fb/ddk750_dvi.c
> >index
On Sat, Jun 13, 2015 at 09:57:05AM -0700, Joe Perches wrote:
>
> It seems ready to me.
>
> As far as I can tell, there's just a few niggles
> that could be done:
>
> Something like (too lazy to separate them into multiple patches)
Thanks. I will break into patches. Call me lazy for not having it
On Sun, Jun 14, 2015 at 05:17:43PM +, Dighe, Niranjan (N.) wrote:
> From: Niranjan Dighe
>
> This patch removes spaces at the start of the line and replaces it
> by tabs
You are also removing blank lines, adding blank lines, moving a ')' to
next line.
regards
sudip
__
On Sun, Jun 14, 2015 at 11:26:35PM +0200, Daniele Alessandrelli wrote:
> This patch makes field in struct rt_8723a_firmware_hdr use endianness-aware
> types (__leXX), thus fixing the following sparse warnings:
>
>
> Signed-off-by: Daniele Alessandrelli
> ---
> drivers/staging/rtl8723au/include
On Mon, 2015-06-15 at 10:47 +0530, Sudip Mukherjee wrote:
> On Sat, Jun 13, 2015 at 09:57:05AM -0700, Joe Perches wrote:
> > It's unfortunate there are so many #ifdef __BIG_ENDIAN uses.
> instead of #ifdef __BIG_ENDIAN can i then use a bool flag to check by if-else?
I think that'd be worse. Movin
On Mon, Jun 15, 2015 at 12:58:50AM +0200, Mateusz Kulikowski wrote:
> This function was declared but never unused.
After this patch we are getting two build warnings:
warning: ‘dequeue_mgmt’ defined but not used
warning: ‘rtllib_resume_tx’ defined but not used
regards
sudip
__
On June 15, 2015 8:38:01 AM GMT+02:00, Sudip Mukherjee
wrote:
>On Mon, Jun 15, 2015 at 12:58:50AM +0200, Mateusz Kulikowski wrote:
>> This function was declared but never unused.
>After this patch we are getting two build warnings:
>
>warning: ‘dequeue_mgmt’ defined but not used
>warning: ‘rtll
On Mon, Jun 15, 2015 at 08:41:17AM +0200, Mateusz Kulikowski wrote:
>
>
> On June 15, 2015 8:38:01 AM GMT+02:00, Sudip Mukherjee
> wrote:
> >On Mon, Jun 15, 2015 at 12:58:50AM +0200, Mateusz Kulikowski wrote:
> >> This function was declared but never unused.
> >After this patch we are getting t
On 15 June 2015 at 08:52, Sudip Mukherjee wrote:
> On Mon, Jun 15, 2015 at 08:41:17AM +0200, Mateusz Kulikowski wrote:
>>
>>
>> On June 15, 2015 8:38:01 AM GMT+02:00, Sudip Mukherjee
>> wrote:
>> >On Mon, Jun 15, 2015 at 12:58:50AM +0200, Mateusz Kulikowski wrote:
>> >> This function was declare
54 matches
Mail list logo