Re: [PATCH] staging/lustre/llite: Fix obd name after c&p error

2015-03-03 Thread Dan Carpenter
On Tue, Mar 03, 2015 at 02:39:36AM -0500, gr...@linuxhacker.ru wrote: > This really came from nowhere and I do not see this patch in any archives > of mailinglists I am subscribed to. > In fact Google cannot find it either. I was going to say something similar. It's not in linux-next either. re

Re: [PATCH RFC 1/3] Drivers: hv: kvp: convert userspace/kernel communication to using char device

2015-03-03 Thread Vitaly Kuznetsov
Radim Krčmář writes: > 2015-02-27 17:14+0100, Vitaly Kuznetsov: >> Re-implement the communication using misc char device. Use ioctl to do >> kernel/userspace version negotiation (doesn't make much sense at this moment >> as we're breaking backwards compatibility but can be used in future). > > Th

[PATCH] Staging: fbtft: move externs to header file

2015-03-03 Thread Drew Fustini
Move extern declartions from fbtft-core.c to fbtft header file. This resovles the warning from checkpatch.pl that "externs should be avoided in .c files". Signed-off-by: Drew Fustini --- drivers/staging/fbtft/fbtft-core.c | 5 - drivers/staging/fbtft/fbtft.h | 7 +++ 2 files changed

[PATCH 0/2] add SM750 framebuffer driver

2015-03-03 Thread Sudip Mukherjee
Hi Greg, As discussed with you previously, this series contains the SM750 driver. This driver was given to me by Silicon Motion and has been modified so that it compiles with the current kernel version and has been tested with next-20150303. I have a demo board (given by Silicon Motion) and it has

[PATCH 2/2] MAINTAINERS: update for sm750fb driver

2015-03-03 Thread Sudip Mukherjee
add myself and Teddy Wang as the Maintainer of the sm750 frame buffer driver. Signed-off-by: Sudip Mukherjee --- MAINTAINERS | 8 1 file changed, 8 insertions(+) diff --git a/MAINTAINERS b/MAINTAINERS index 9ee5466..1a51043 100644 --- a/MAINTAINERS +++ b/MAINTAINERS @@ -9340,6 +9340,14

Re: [PATCH] Staging: fbtft: move externs to header file

2015-03-03 Thread Sudip Mukherjee
On Tue, Mar 03, 2015 at 04:19:17AM -0600, Drew Fustini wrote: > Move extern declartions from fbtft-core.c to fbtft header file. This resovles > the warning from checkpatch.pl that "externs should be avoided in .c files". but now it adds 6 additional warning in checkpatch --strict "extern prototype

Re: [RFC 5/7] staging: fbtft: don't require platform data

2015-03-03 Thread Noralf Trønnes
Den 02.03.2015 12:31, skrev Dan Carpenter: On Mon, Mar 02, 2015 at 11:54:27AM +0100, Noralf Trønnes wrote: Add dummy platform data when it's not present. Signed-off-by: Noralf Trønnes --- drivers/staging/fbtft/fbtft-core.c | 6 ++ 1 file changed, 2 insertions(+), 4 deletions(-) diff -

Re: [RFC 3/7] staging: fbtft: add lcd controller abstraction

2015-03-03 Thread Noralf Trønnes
Den 02.03.2015 12:48, skrev Dan Carpenter: [snip] + if (ctrl->power_supply) { + ret = regulator_enable(ctrl->power_supply); + if (ret) { + dev_err(ctrl->lcdreg->dev, + "failed to enable power supply: %d\n", r

Re: [RFC 3/7] staging: fbtft: add lcd controller abstraction

2015-03-03 Thread Dan Carpenter
On Tue, Mar 03, 2015 at 12:57:29PM +0100, Noralf Trønnes wrote: > >>+ ret = ctrl->rotate(ctrl, rotation); > >>+ if (!ret) > >>+ ctrl->rotation = rotation; > >>+ > >>+ return ret; > >Better to check "if (ret)" consistently (error handling vs success > >handling). > Like this? > >

Re: [RFC 1/7] staging: fbtft: add lcd register abstraction

2015-03-03 Thread Noralf Trønnes
Den 02.03.2015 13:25, skrev Dan Carpenter: On Mon, Mar 02, 2015 at 11:54:23AM +0100, Noralf Trønnes wrote: diff --git a/drivers/staging/fbtft/lcdreg/lcdreg-debugfs.c b/drivers/staging/fbtft/lcdreg/lcdreg-debugfs.c [snip] +static int lcdreg_userbuf_to_u32(const char __user *user_buf, size_t c

Re: [RFC 1/7] staging: fbtft: add lcd register abstraction

2015-03-03 Thread Dan Carpenter
On Tue, Mar 03, 2015 at 01:19:52PM +0100, Noralf Trønnes wrote: > >>+static ssize_t lcdreg_debugfs_read_wr(struct file *file, > >>+ const char __user *user_buf, > >>+ size_t count, loff_t *ppos) > >>+{ > >>+ struct lcdreg *reg = file

Re: [PATCH] staging/lustre/llite: Fix obd name after c&p error

2015-03-03 Thread Greg Kroah-Hartman
On Tue, Mar 03, 2015 at 11:28:25AM +0300, Dan Carpenter wrote: > On Tue, Mar 03, 2015 at 02:39:36AM -0500, gr...@linuxhacker.ru wrote: > > > This really came from nowhere and I do not see this patch in any archives > > of mailinglists I am subscribed to. > > In fact Google cannot find it either. >

[PATCH 1/2] Staging: fbtft: fb_pcd8544: Fixed coding style errors and warnings

2015-03-03 Thread Cláudio Maia
The following errors were fixed: ERROR: code indent should use tabs where possible WARNING: line over 80 characters Signed-off-by: Cláudio Maia --- drivers/staging/fbtft/fb_pcd8544.c | 74 +++- 1 file changed, 39 insertions(+), 35 deletions(-) diff --git a/dri

[PATCH 2/2] Staging: fbtft: fb_pcd8544: Fixed coding style errors and warnings

2015-03-03 Thread Cláudio Maia
This patch corrects the comments' style. Signed-off-by: Cláudio Maia --- drivers/staging/fbtft/fb_pcd8544.c | 107 +++- 1 file changed, 58 insertions(+), 49 deletions(-) diff --git a/drivers/staging/fbtft/fb_pcd8544.c b/drivers/staging/fbtft/fb_pcd8544.c index

[PATCH] staging: dgap: Avoid name collision

2015-03-03 Thread Fabio Estevam
Building for ARM64 leads to the following build warning: In file included from drivers/staging/dgap/dgap.c:66:0: drivers/staging/dgap/dgap.h:124:0: warning: "PCI_IO_SIZE" redefined #define PCI_IO_SIZE 0x0020 ^ In file included from ./arch/arm64/include/asm/page.h:66:0, from

Re: [PATCH 1/2] Staging: fbtft: fb_pcd8544: Fixed coding style errors and warnings

2015-03-03 Thread Dan Carpenter
On Tue, Mar 03, 2015 at 12:54:38PM +, Cláudio Maia wrote: > The following errors were fixed: > > ERROR: code indent should use tabs where possible > WARNING: line over 80 characters > > Signed-off-by: Cláudio Maia Can you resend these but split up differently. > + write_reg(par, 0x22);

[PATCH 0/4] Staging: rtl8188eu rtw_efuse.c: fix coding style

2015-03-03 Thread Matteo Semenzato
From: Matteo Semenzato This patch fixes the following errors: ERROR: space prohibited before that ',' Signed-off-by: Matteo Semenzato --- drivers/staging/rtl8188eu/core/rtw_efuse.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rtl8188eu/core/rtw_efuse.

[PATCH 1/4] Staging: rtl8188eu rtw_ieee80211.c: fix coding style

2015-03-03 Thread Matteo Semenzato
From: Matteo Semenzato This patch fixes the following errors: ERROR: space prohibited before that ',' (ctx:WxW) ERROR: space prohibited before that ',' (ctx:WxW) Signed-off-by: Matteo Semenzato --- drivers/staging/rtl8188eu/core/rtw_ieee80211.c | 8 1 file changed, 4 insertions(+), 4

[PATCH 2/4] Staging: rtl8188eu rtw_mlme.c: fix coding style

2015-03-03 Thread Matteo Semenzato
From: Matteo Semenzato This patch fixes the following errors: ERROR: space prohibited before that ',' (ctx:WxW) ERROR: space prohibited before that ',' (ctx:WxW) Signed-off-by: Matteo Semenzato --- drivers/staging/rtl8188eu/core/rtw_mlme.c | 20 ++-- 1 file changed, 10 insertio

[PATCH 3/4] Staging: rtl8188eu rtw_mlme_ext.c: fix coding style

2015-03-03 Thread Matteo Semenzato
From: Matteo Semenzato This patch fixes the following errors: ERROR: space prohibited before that ',' (ctx:WxW) ERROR: space prohibited before that ',' (ctx:WxW) Signed-off-by: Matteo Semenzato --- drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 40 +-- 1 file changed,

[PATCH 4/4] Staging: rtl8188eu rtw_sta_mgt.c: fix coding style

2015-03-03 Thread Matteo Semenzato
From: Matteo Semenzato This patch fixes the following errors: ERROR: space prohibited before that ',' (ctx:WxW) ERROR: space prohibited before that ',' (ctx:WxW) Signed-off-by: Matteo Semenzato --- drivers/staging/rtl8188eu/core/rtw_sta_mgt.c | 14 +++--- 1 file changed, 7 insertions(+

Re: [RFC 3/7] staging: fbtft: add lcd controller abstraction

2015-03-03 Thread Noralf Trønnes
Den 03.03.2015 13:04, skrev Dan Carpenter: On Tue, Mar 03, 2015 at 12:57:29PM +0100, Noralf Trønnes wrote: + ret = ctrl->rotate(ctrl, rotation); + if (!ret) + ctrl->rotation = rotation; + + return ret; Better to check "if (ret)" consistently (error handling vs s

[PATCH v3 6/6] staging: unisys: remove LOGWRN() macros and uniklog.h

2015-03-03 Thread Benjamin Romer
Remove the last set of macros from uniklog.h. Without LOGWRN() and friends, uniklog.h is empty so we can delete the file itself as well. This macro was not used a lot but the file was included in many places. Signed-off-by: Benjamin Romer --- v2 - Fixed a mistake where some of the if statements

[PATCH v3 4/6] staging: unisys: remove LOGVER macro

2015-03-03 Thread Benjamin Romer
Remove the LOGVER macro from the drivers entirely. Signed-off-by: Benjamin Romer --- v2 - Fixed a mistake where some of the if statements had accidentally doubled tabs when the then clause was only one statement. v3 - Fixed the doubled tabs missed in v2, and added a patch for removing the ASSERT

[PATCH v3 2/6] staging: unisys: remove LOGINF macros

2015-03-03 Thread Benjamin Romer
Remove the LOGINF, LOGINFDEV, LOGINFDEVX, LOGINFNAME, PRINTKDRV, and INFODRV macros entirely from the driver set. Signed-off-by: Benjamin Romer --- v2 - Fixed a mistake where some of the if statements had accidentally doubled tabs when the then clause was only one statement. v3 - Fixed the doubl

[PATCH v3 1/6] staging: unisys: remove DBGINF, DBGVER, DEBUGDEV, and DEBUGDRV macros

2015-03-03 Thread Benjamin Romer
The messages put out by these macros are for driver debugging and aren't needed any more, so just remove all use of them, and the macros too. Signed-off-by: Benjamin Romer --- v2 - Fixed a mistake where some of the if statements had accidentally doubled tabs when the then clause was only one stat

[PATCH v3 3/6] staging: unisys: remove ASSERT() macro

2015-03-03 Thread Benjamin Romer
Remove the ASSERT macro from timskmod.h, and replace its single use with WARN_ON() instead. Signed-off-by: Benjamin Romer --- v2 - Fixed a mistake where some of the if statements had accidentally doubled tabs when the then clause was only one statement. v3 - Fixed the doubled tabs missed in v2,

[PATCH v3 0/6] staging: unisys: remove logging macros from all drivers

2015-03-03 Thread Benjamin Romer
This patch series removes all of the logging macros from the Unisys driver set, as well as the ASSERT() macro, which was really just a wrapper around a log macro. Log and error messages deemed necessary for the user will be added back in using standard kernel logging functions by future patches.

[PATCH v3 5/6] staging: unisys: remove ERRDEV macros

2015-03-03 Thread Benjamin Romer
Remove the LOGERR, LOGERRDEV, LOGERRDEVX, LOGERRNAME, LOGORDUMPERR macros from all the drivers. Signed-off-by: Benjamin Romer --- v2 - Fixed a mistake where some of the if statements had accidentally doubled tabs when the then clause was only one statement. v3 - Fixed the doubled tabs missed in

Re: [PATCH 0/4] Staging: rtl8188eu rtw_efuse.c: fix coding style

2015-03-03 Thread Sudip Mukherjee
On Tue, Mar 03, 2015 at 02:49:47PM +0100, Matteo Semenzato wrote: > From: Matteo Semenzato usually [PATCH 0/n] doesnot contain any patch, it can have a summary of your patch series. and since you are doing same type of change on rtl8188eu, i think you could have sent a single patch insted of a s

Re: [PATCH] Staging: fbtft: move externs to header file

2015-03-03 Thread Drew Fustini
On Tue, Mar 03, 2015 at 04:33:01PM +0530, Sudip Mukherjee wrote: > but now it adds 6 additional warning in checkpatch --strict > "extern prototypes should be avoided in .h files" Thanks, Sudip. I did not realize that was an option for checkpatch. I see now that there are additional warnings as yo

Re: [PATCH] Staging: fbtft: move externs to header file

2015-03-03 Thread Noralf Trønnes
Den 03.03.2015 11:19, skrev Drew Fustini: Move extern declartions from fbtft-core.c to fbtft header file. This resovles the warning from checkpatch.pl that "externs should be avoided in .c files". Signed-off-by: Drew Fustini --- drivers/staging/fbtft/fbtft-core.c | 5 - drivers/staging/

BONUS TNB ---- Gong Xi Fa Cai

2015-03-03 Thread TNB, Kuala Lumpur
Tenaga Nasional Berhad (TNB HQ)129 Jalan Bangsar, 59200 Kuala Lumpur, Kuala Lumpur, Malaysia This is an official notification from the headquarter of the Tenaga Nasional Berhad in conjunction with the Malaysian Water Association (MWA) informing you regarding the 2015 Tenaga Nasional Berhad Ch

Re: [PATCH RFC 1/3] Drivers: hv: kvp: convert userspace/kernel communication to using char device

2015-03-03 Thread Radim Krčmář
2015-03-03 10:53+0100, Vitaly Kuznetsov: > Radim Krčmář writes: > > 2015-02-27 17:14+0100, Vitaly Kuznetsov: > >> Re-implement the communication using misc char device. Use ioctl to do > >> kernel/userspace version negotiation (doesn't make much sense at this > >> moment > >> as we're breaking ba

[PATCH v2 1/3] drivers:pnp Add support for descendants claiming memory address space

2015-03-03 Thread Jake Oshins
This patch adds the concept of "descendant" device to the pnp layer, one which can claim memory mapped I/O space from the same regions of address space that its "aunts" and "uncles" are claiming from. This is more or less analogous to a device on an ISA bus that needs address space, but needs to a

[PATCH v2 0/3] Convert Hyper-V code to use the pnp layer

2015-03-03 Thread Jake Oshins
This set of patches changes the way that drivers in a Hyper-V VM find the memory-mapped I/O space that they need. The Hyper-V BIOS and UEFI implementations expose a couple of large regions of MMIO space to the guests using the ACPI namespace, with the expectation that the guest OS will subdivide t

[PATCH v2 3/3] drivers:hv Remove old MMIO management code

2015-03-03 Thread Jake Oshins
This patch removes the now-redundant code which examined the ACPI namespace directly for memory-mapped I/O regions for its children. Signed-off-by: Jake Oshins --- drivers/hv/vmbus_drv.c | 28 ++-- include/linux/hyperv.h | 2 -- 2 files changed, 2 insertions(+), 28 delet

[PATCH v2 2/3] drivers:hv Convert VMBus and its descendants to PnP

2015-03-03 Thread Jake Oshins
This patch makes hv_vmbus and the devices that it discovers use the pnp layer, so that address space claims made by these devices will hook into the regions of address space exposed by ACPI, which already hooks into the pnp layer. Previous feedback from Dan Carpenter has been incorporated. (Thank

李小姐,*#%发*%# 票 咨 询 Q:139 5101 6869 电:260 517 4212

2015-03-03 Thread 一行一个
李小姐,*#%发*%# 票 咨 询 验后付款,・#禾兑*・点最低! Q:139 5101 6869 电:260 517 4212 ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

[PATCH 1/2] Staging: fbtft: fb_pcd8544: Fixed coding style errors and warnings

2015-03-03 Thread Cláudio Maia
Fixed two warnings occurring in lines that are over 80 characters and which are not comments. Signed-off-by: Cláudio Maia --- drivers/staging/fbtft/fb_pcd8544.c |6 -- 1 file changed, 4 insertions(+), 2 deletions(-) diff --git a/drivers/staging/fbtft/fb_pcd8544.c b/drivers/staging/fbt

[PATCH 2/2] Staging: fbtft: fb_pcd8544: Fixed coding style errors and warnings

2015-03-03 Thread Cláudio Maia
This patch fixes the following errors by refactoring the comments' style: WARNING: line over 80 characters ERROR: code indent should use tabs where possible Signed-off-by: Cláudio Maia --- drivers/staging/fbtft/fb_pcd8544.c | 107 1 file changed, 59 inserti

[PATCH] Staging: dgnc: Fix checking return value of register_chrdev

2015-03-03 Thread Salah Triki
The failure code is negative. So check <0 instead of <=0. Signed-off-by: Salah Triki --- drivers/staging/dgnc/dgnc_driver.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/dgnc/dgnc_driver.c b/drivers/staging/dgnc/dgnc_driver.c index f177d3a..4341125 100644 -

[PATCH] Staging: dgnc: Fix return value code of dgnc_start

2015-03-03 Thread Salah Triki
Return the failure code from register_chrdev instead of -ENXIO. Signed-off-by: Salah Triki --- drivers/staging/dgnc/dgnc_driver.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/dgnc/dgnc_driver.c b/drivers/staging/dgnc/dgnc_driver.c index f177d3a..f9f5e83 10

Dear Rightful Owner of this e-mail address

2015-03-03 Thread info...@imf.org
Dear Rightful Owner of this e-mail address, I was directed by the Managing Director/Chairman of the Board of International Monetary Fund to inform you that the International Monetary Fund (IMF) has come across a large sum of money floating around in your name, following the International Mon

Re: [PATCH 1/2] Staging: fbtft: fb_pcd8544: Fixed coding style errors and warnings

2015-03-03 Thread Sudip Mukherjee
On Tue, Mar 03, 2015 at 11:47:18PM +, Cláudio Maia wrote: > Fixed two warnings occurring in lines that are over 80 characters and which > are not comments. commit message should not be more than 72 characters. > > Signed-off-by: Cláudio Maia > --- > static void set_addr_win(struct fbtft_pa

[PATCHv2 2/3] staging/lustre/libcfs: replace deprecated cpus_ calls with cpumask_

2015-03-03 Thread green
From: Oleg Drokin Rusty Russel advises that cpus_* functions are deprecated to work on cpumasks and cpumask_* functions should be called instead, otherwise problems with CPUMASK_OFFSTACK arise. Signed-off-by: Oleg Drokin --- .../staging/lustre/lustre/libcfs/linux/linux-cpu.c | 102 +++-

[PATCHv2 1/3] staging/lustre/ptlrpc: Do not use deprecated cpus_* functions

2015-03-03 Thread green
From: Oleg Drokin As per Rusty Russel, cpus_* functions are deprecated. When mixing cpumask_copy with cpus_weight, they operate on different sized masks if CPUMASK_OFFSTACK is enabled, causing an immediate assertion failure. Copying of cpumasks by assignment is also not allowed now. Additionally

[PATCHv2 3/3] staging/lustre/o2iblnd: Don't use cpus_weight

2015-03-03 Thread green
From: Oleg Drokin cpus_weight and for_each_cpu_mask are deprecated, so replace them with cpumask_weight and for_each_cpu respectively. Signed-off-by: Oleg Drokin --- drivers/staging/lustre/lnet/klnds/o2iblnd/o2iblnd.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/driv

[PATCHv2 0/3] Lustre: get rid of deprecated cpumask calls

2015-03-03 Thread green
From: Oleg Drokin A recent crash report with CONFIG_CPUMASK_OFFSTACK enabled set off a chain of emails through which I learned that cpus_* functions are deprecated and should not be really used to operate on cpumasks. These three patches do just that, replacing cpus_* and cpu_* calls with cpumas