On Thu, 22 Jan 2015, wrote:
> the title should be 5208.
sorry - that was a typo - should this be
resubmitted for traceability or is that not
necessary ?
>
> On 01/19/2015 03:25 PM, Nicholas Mc Guire wrote:
> > This is only an API consolidation and should make things more readable
> >
> >
struct ashmem_pin uses __u32 types that are defined in linux/types.h.
Signed-off-by: Gabriel Laskar
---
drivers/staging/android/uapi/ashmem.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/android/uapi/ashmem.h
b/drivers/staging/android/uapi/ashmem.h
index ba4743c..13df42d
Here was no Mexican Congress, and none had been convened since they were herded
together at the conclusion of the Mexican War under protection of American
troops. The condition of affairs in the United States was also extremely
favorable. The treasury was overflowing with California gold, under
Hello there,
[linux-3.19-rc5/drivers/staging/dgap/dgap.c:981]: (warning) Logical disjunction
always evaluates to true: conc_type != 65 || conc_type != 66.
Source code is
if (conc_type == 0 || conc_type != CX ||
conc_type != EPC) {
Suggest code rework.
Regards
Davi
On Thu, 2015-01-22 at 15:30 +0800, micky_ch...@realsil.com.cn wrote:
> update card drive settings, This setting can be used for rts5249
> rts524A and rts525A.
[]
> diff --git a/drivers/mfd/rts5249.c b/drivers/mfd/rts5249.c
> @@ -36,16 +36,16 @@ static u8 rts5249_get_ic_version(struct rtsx_pcr *pcr
On Thu, Jan 22, 2015 at 10:05:53AM +, David Binderman wrote:
> Hello there,
>
> [linux-3.19-rc5/drivers/staging/dgap/dgap.c:981]: (warning) Logical
> disjunction always evaluates to true: conc_type != 65 || conc_type != 66.
>
> Source code is
>
> if (conc_type == 0 || conc_type
Hello there,
Thanks for the confirmation. More of the same in the same file:
[linux-3.19-rc5/drivers/staging/dgap/dgap.c:1022]: (warning) Logical
disjunction always evaluates to true: module_type != 68 || module_type != 73.
Source code is
if (module_type == 0 || module_type != PORT
On 22/01/15 00:22, H Hartley Sweeten wrote:
A couple cleanup patches for the vmk80xx driver.
H Hartley Sweeten (2):
staging: comedi: vmk80xx: GPCT_RESET is not an (*insn_config) instruction
staging: comedi: vmk80xx: tidy up vmk80xx_cnt_insn_config()
drivers/staging/comedi/drivers/vmk80x
On Thu, Jan 22, 2015 at 10:20:44AM +, David Binderman wrote:
> I used the static analyser cppcheck to find these two bugs, but
> you might be able to find similar problems by using gcc compiler
> flag -Wlogical-op.
I turned it on, but GCC 4.7.2 doesn't find anything for me.
It complains about
Hello there,
> On Thu, Jan 22, 2015 at 10:20:44AM +, David Binderman wrote:
>> I used the static analyser cppcheck to find these two bugs, but
>> you might be able to find similar problems by using gcc compiler
>> flag -Wlogical-op.
>
> I turned it on,
On 21/01/15 22:11, H Hartley Sweeten wrote:
A couple misc patches for the ni_labpc drivers.
H Hartley Sweeten (6):
staging: comedi: ni_labpc_common: move comedi_alloc_devpriv() to common code
staging: comedi: ni_labpc_cs: remove unnecessary includes
staging: comedi: ni_labpc: remove unn
On Thu, Jan 22, 2015 at 10:24:49AM +0100, Gabriel Laskar wrote:
> struct ashmem_pin uses __u32 types that are defined in linux/types.h.
>
> Signed-off-by: Gabriel Laskar
> ---
> drivers/staging/android/uapi/ashmem.h | 1 +
> 1 file changed, 1 insertion(+)
What is broken without this change? Is
On Thu, 2015-01-22 at 11:19 +0800, Greg KH wrote:
> On Wed, Jan 21, 2015 at 06:53:31PM +0300, Dan Carpenter wrote:
> > Generally "delete code" patches are easy to review. But sometimes you
> > have to change formatting and remove variables and curly braces.
> >
> > $ grep LOG drivers/staging/unis
On Thursday, January 22, 2015 3:31 AM, Ian Abbott wrote:
> On 22/01/15 00:22, H Hartley Sweeten wrote:
>> A couple cleanup patches for the vmk80xx driver.
>>
>> H Hartley Sweeten (2):
>>staging: comedi: vmk80xx: GPCT_RESET is not an (*insn_config) instruction
>>staging: comedi: vmk80xx: tid
All channel work queues are named 'hv_vmbus_ctl', this makes them
indistinguishable in ps output and makes it hard to link to the corresponding
vmbus device. Rename them to hv_vmbus_ctl/N and make vmbus device names match,
e.g. now vmbus_1 device is served by hv_vmbus_ctl/1 work queue.
Signed-off-
This fixes sparse warnings like:
warning: symbol XXX was not declared. Should it be static?
by declaring all local functions static.
Signed-off-by: Krzysztof Adamski
---
drivers/staging/fbtft/fbtft-core.c | 47
1 file changed, 26 insertions(+), 21 delet
This patch fixes coding style of PCI device table declaration.
Signed-off-by: Krzysztof Adamski
---
drivers/staging/dgnc/dgnc_driver.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/dgnc/dgnc_driver.c
b/drivers/staging/dgnc/dgnc_driver.c
index f6
> -Original Message-
> From: Vitaly Kuznetsov [mailto:vkuzn...@redhat.com]
> Sent: Wednesday, January 21, 2015 11:02 AM
> To: KY Srinivasan; de...@linuxdriverproject.org
> Cc: Haiyang Zhang; linux-ker...@vger.kernel.org; Dexuan Cui
> Subject: [PATCH 2/3] Drivers: hv: vmbus: introduce vmbu
make ARCH=i386 allyesconfig fails with
drivers/staging/built-in.o: In function `reset':
(.text+0x2ae89d): multiple definition of `reset'
drivers/isdn/built-in.o:(.text+0x185dc2): first defined here
make[1]: *** [drivers/built-in.o] Error 1
___
devel mail
On Thu, 2015-01-22 at 19:55 +0100, Krzysztof Adamski wrote:
> This patch fixes coding style of PCI device table declaration.
[]
> diff --git a/drivers/staging/dgnc/dgnc_driver.c
> b/drivers/staging/dgnc/dgnc_driver.c
[]
> @@ -98,11 +98,11 @@ static struct timer_list dgnc_poll_timer;
>
>
> stat
On Thu, Jan 22, 2015 at 11:10:58AM -0800, Joe Perches wrote:
On Thu, 2015-01-22 at 19:55 +0100, Krzysztof Adamski wrote:
This patch fixes coding style of PCI device table declaration.
[]
diff --git a/drivers/staging/dgnc/dgnc_driver.c
b/drivers/staging/dgnc/dgnc_driver.c
[]
@@ -98,11 +98,11
This patch fixes coding style of PCI device table declaration.
Signed-off-by: Krzysztof Adamski
---
drivers/staging/dgnc/dgnc_driver.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/dgnc/dgnc_driver.c
b/drivers/staging/dgnc/dgnc_driver.c
index
The line above makes vel a 12-bit quantity (st->rx[] is u8). The
intention is to sign-extend vel using bit 11 as the sign bit. But
because of C's promotion rules "vel = (vel << 4) >> 4;" is actually a
no-op, since vel is promoted to int before the inner
shift. sign_extend32 works equally well for 8
On Mon, Jan 19, 2015 at 12:16:30PM +0200, Heba Aamer wrote:
> This patch fixes the following checkpatch.pl error:
> fix space prohibited before that ','
>
> Signed-off-by: Heba Aamer
Reviewed-by: Aya Mahfouz
> ---
> v2: added Signed-off line
>
> drivers/staging/vt6655/mac.c |2 +-
> 1 fi
On Mon, Jan 19, 2015 at 02:30:25PM +0200, Mohamed Lotfy Hammad wrote:
> This patch fixes the following checkpatch.pl error:
> fix space prohibited before that ','
>
> Signed-off-by: Mohamed Lotfy Hammad
Reviewed-by: Aya Mahfouz
> ---
> drivers/staging/vt6655/mac.h | 2 +-
> 1 file changed, 1 i
On Wed, Jan 21, 2015 at 01:08:48PM +0200, Heba Aamer wrote:
> This patch fixes the following checkpatch.pl warning:
> fix Prefer ether_addr_copy() over memcpy()
> if the Ethernet addresses are __aligned(2)
>
> Pahole showed that the 2 structs are aligned to u16
>
> struct vnt_mic_hdr {
>
Hi,
2015-01-22 19:14 GMT+09:00 Dan Carpenter :
>
> On Thu, Jan 22, 2015 at 10:05:53AM +, David Binderman wrote:
>> Hello there,
>>
>> [linux-3.19-rc5/drivers/staging/dgap/dgap.c:981]: (warning) Logical
>> disjunction always evaluates to true: conc_type != 65 || conc_type != 66.
>>
>> Source c
On 01/22/2015 05:01 PM, Nicholas Mc Guire wrote:
> sorry - that was a typo - should this be
> resubmitted for traceability or is that not
> necessary ?
resubmit, thanks.
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproj
solution and handles
corner cases correctly.
This patch was only compile tested with x86_64_defconfig + CONFIG_STAGING=y,
CONFIG_RTS5208=m
Patch is against 3.19.0-rc5 -next-20150122
drivers/staging/rts5208/rtsx_transport.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff
29 matches
Mail list logo