Correct coding style problem in pcl818.c. The coding style problems(29
warnings detected by checkpatch.pl) includes:
- line over 80 characters
- There is space before tabs
The changed file has been verified with checkpatch.pl to be clean for
warnings/errors.
Signed-off-by: Simon Guo
---
driver
On Tue, Jan 6, 2015 at 4:34 PM, atull wrote:
> On Tue, 6 Jan 2015, Rob Herring wrote:
>
>> On Tue, Jan 6, 2015 at 2:13 PM, wrote:
>> > From: Alan Tull
>> >
>> > New bindings document for Altera fpga manager.
>> >
>> > Signed-off-by: Alan Tull
>>
>> Acked-by: Rob Herring
>>
>> Like I said, thi
This is patch to file pcl812.c that fix line over 80
characters warning which is found by checkpatch.pl tool.
Signed-off-by: Jitendra kumar khasdev
---
drivers/staging/comedi/drivers/pcl812.c | 20 +---
1 file changed, 13 insertions(+), 7 deletions(-)
diff --git a/drivers/stagin
On Fri, 9 Jan 2015, Rob Herring wrote:
> On Tue, Jan 6, 2015 at 4:34 PM, atull wrote:
> > On Tue, 6 Jan 2015, Rob Herring wrote:
> >
> >> On Tue, Jan 6, 2015 at 2:13 PM, wrote:
> >> > From: Alan Tull
> >> >
> >> > New bindings document for Altera fpga manager.
> >> >
> >> > Signed-off-by: Alan
On Wed, 7 Jan 2015, Pavel Machek wrote:
> On Tue 2015-01-06 14:13:37, at...@opensource.altera.com wrote:
> > +
> > +What: /sys/class/fpga_manager//firmware
> > +Date: October 2014
> > +KernelVersion: 3.18
> > +Contact: Alan Tull
> > +Description: Name of the
2014-12-10 16:49 GMT+02:00 Greg KH :
> On Wed, Dec 10, 2014 at 07:09:59AM +, Al Viro wrote:
>> On Tue, Dec 09, 2014 at 10:56:12PM -0800, Shalin Mehta wrote:
>> > From: Shalin Mehta
>> >
>> > This issue is showed up while compiling with sparse. The iov_base in
>> > struct iovec struct explicit
On Thu, Jan 08, 2015 at 05:04:20PM +, KY Srinivasan wrote:
>
>
> > -Original Message-
> > From: Vitaly Kuznetsov [mailto:vkuzn...@redhat.com]
> > Sent: Thursday, January 8, 2015 8:02 AM
> > To: KY Srinivasan
> > Cc: gre...@linuxfoundation.org; de...@linuxdriverproject.org; Haiyang
> >
On Fri 2015-01-09 13:14:24, atull wrote:
> On Wed, 7 Jan 2015, Pavel Machek wrote:
>
> > On Tue 2015-01-06 14:13:37, at...@opensource.altera.com wrote:
> > > +
> > > +What:/sys/class/fpga_manager//firmware
> > > +Date:October 2014
> > > +KernelVersion: 3.18
> > > +Contact
On Mon, Dec 01, 2014 at 11:52:41AM +0100, Vitaly Kuznetsov wrote:
> When an SMP Hyper-V guest is running on top of 2012R2 Server and secondary
> cpus are sent offline (with echo 0 > /sys/devices/system/cpu/cpu$cpu/online)
> the system freeze is observed. This happens due to the fact that on newer
>
> -Original Message-
> From: gre...@linuxfoundation.org [mailto:gre...@linuxfoundation.org]
> Sent: Friday, January 9, 2015 12:48 PM
> To: KY Srinivasan
> Cc: Vitaly Kuznetsov; de...@linuxdriverproject.org; Haiyang Zhang; linux-
> ker...@vger.kernel.org
> Subject: Re: [PATCH 0/5] Tools: h
On Fri, Jan 09, 2015 at 08:58:08PM +, KY Srinivasan wrote:
> > Please resend everything, there has been a mess of different patches and
> > discussions and I can't figure out what should be applied and what should
> > not. I'll guess at a few easy ones, but getting the "correct"
> > ones from
> -Original Message-
> From: gre...@linuxfoundation.org [mailto:gre...@linuxfoundation.org]
> Sent: Friday, January 9, 2015 1:02 PM
> To: KY Srinivasan
> Cc: de...@linuxdriverproject.org; Haiyang Zhang; linux-
> ker...@vger.kernel.org
> Subject: Re: [PATCH 0/5] Tools: hv: fix compiler war
On Sun, Jan 04, 2015 at 04:22:35PM +0100, Piotr Kubus wrote:
> This is a patch to the dmm32at.c file that fixes up a code indent error found
> by the checkpatch.pl tool.
>
> Signed-off-by: Piotr Kubus
> ---
> drivers/staging/comedi/drivers/dmm32at.c | 2 +-
> 1 file changed, 1 insertion(+), 1 d
On Mon, Dec 29, 2014 at 02:42:56PM +0530, jitendra kumar khasdev wrote:
> This is a patch to the s626.c file that fixes up a space error
> found by the checkpatch.pl tool
>
> Signed-off-by: Jitendra Kumar Khasdev
> Reviewed-by: Ian Abbott
> ---
> drivers/staging/comedi/drivers/s626.c | 2 +-
>
On Tue, Jan 06, 2015 at 11:16:16AM +0100, Piotr Kubus wrote:
> Fixed a code indent error found by checkpatch.pl in dmm32at.c.
>
> Signed-off-by: Piotr Kubus
> ---
> v2: make the commit message clearer and shorter
>
> drivers/staging/comedi/drivers/dmm32at.c | 2 +-
> 1 file changed, 1 insertion
On Fri, Jan 09, 2015 at 10:05:56PM +0530, jitendra kumar khasdev wrote:
> This is patch to file pcl812.c that fix line over 80
> characters warning which is found by checkpatch.pl tool.
You also do something else in here, that you did not document, so I
can't accept this patch :(
On Fri, Dec 05, 2014 at 05:09:26PM -0500, Benjamin Romer wrote:
> Remove the ERRDRV() macro family and use pr_err directly everywhere it was
> used.
> Completely remove any error messages that used the macro but are redundant,
> for
> example, several of the messages were from memory allocation f
On Fri, Dec 05, 2014 at 05:09:27PM -0500, Benjamin Romer wrote:
> Remove the DBGINF() group of logging macros and use pr_debug() instead. Fix
> places that used the DBGINF() macro so they actually print the expected value,
> because they were not being compiled at all before the switchover.
>
> Si
On Fri, Dec 05, 2014 at 05:09:28PM -0500, Benjamin Romer wrote:
> Remove the entire set of LOGINFO() macros and replace them with calls to
> pr_info() instead.
>
> Signed-off-by: Ken Depro
> Signed-off-by: Benjamin Romer
> ---
> drivers/staging/unisys/include/timskmod.h | 5 --
> driv
On Fri, Dec 05, 2014 at 05:09:30PM -0500, Benjamin Romer wrote:
> Get rid of LOGWRN() and all related macros, and call pr_warn() directly
> instead.
Side note, are you setting pr_fmt() properly so that everything is
"unified" with these messages? No driver subsystem should ever use a
pr_* call u
On Fri, Jan 09, 2015 at 12:20:04PM +0800, Simon Guo wrote:
> Correct coding style problem in pcl818.c. The coding style problems(29
> warnings detected by checkpatch.pl) includes:
> - line over 80 characters
> - There is space before tabs
> The changed file has been verified with checkpatch.pl to
This is the patch to pcl812.c that fix 80 character line over warnings.
These warnings are identified by checkpatch.pl tool.
For this patch I have did following changes,
1. convert single line comment into multiline comment
2. provide tab sapce for indentation purpose
3. reduce extra space between
On Sat, Jan 10, 2015 at 09:54:39AM +0530, jitendra kumar khasdev wrote:
> This is the patch to pcl812.c that fix 80 character line over warnings.
> These warnings are identified by checkpatch.pl tool.
> For this patch I have did following changes,
> 1. convert single line comment into multiline com
This is patch to pcl812.c that fix line over 80 characters warning
which is found by checkpatch.pl tool. Reduce the extra space around
equal sign that fix warning.
Signed-off-by: Jitendra kumar khasdev
---
drivers/staging/comedi/drivers/pcl812.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion
When someone does 'make' in tools/hv/ issues appear:
- hv_fcopy_daemon is not being built;
- lots of compiler warnings.
This is just a cleanup. Compile-tested by myself on top of linux-next/master.
Piggyback this series and send "[PATCH 5/5] Tools: hv: do not add redundant '/'
in hv_start_fcopy()
From: Vitaly Kuznetsov
This patch addresses two types of compiler warnings:
... warning: comparison between signed and unsigned integer expressions
[-Wsign-compare]
and
... warning: pointer targets in passing argument N of .kvp_ differ in
signedness [-Wpointer-sign]
Signed-off-by: Vitaly K
From: Vitaly Kuznetsov
fcopyd in missing in the Makefile, add it there.
Signed-off-by: Vitaly Kuznetsov
Signed-off-by: K. Y. Srinivasan
---
tools/hv/Makefile |4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/tools/hv/Makefile b/tools/hv/Makefile
index bd22f78..99ffe6
From: Vitaly Kuznetsov
This patch addresses two types of compiler warnings:
... warning: unused variable .fd. [-Wunused-variable]
and
... warning: format .%s. expects argument of type .char *., but argument 5 has
type .__u16 *. [-Wformat=]
Signed-off-by: Vitaly Kuznetsov
Signed-off-by: K. Y. S
From: Vitaly Kuznetsov
We don't need to add additional '/' to smsg->path_name as snprintf("%s/%s")
does the right thing. Without the patch we get doubled '//' in the log message.
Signed-off-by: Vitaly Kuznetsov
Signed-off-by: K. Y. Srinivasan
---
tools/hv/hv_fcopy_daemon.c |6 --
1 fi
From: Vitaly Kuznetsov
fwrite() does not actually return the number of bytes written and
this value is being ignored anyway and ferror() is being called to
check for an error. As we assign to this variable and never use it
we get the following compile-time warning:
hv_kvp_daemon.c:149:9: warning:
This function was no longer used as of commit 2807904441d4 (staging:
line6: drop MIDI parameter sysfs attrs).
Signed-off-by: Chris Rorvick
---
drivers/staging/line6/pod.c | 9 -
drivers/staging/line6/pod.h | 2 --
2 files changed, 11 deletions(-)
diff --git a/drivers/staging/line6/pod.c
The `device_bit' member was no longer used as of commit 2807904441d4
(staging: line6: drop MIDI parameter sysfs attrs).
Signed-off-by: Chris Rorvick
---
drivers/staging/line6/driver.c | 44 +++---
drivers/staging/line6/driver.h | 5
drivers/staging/line6/pcm.h
Support for these devices appears to have never been completed. Remove
them from the device table along with a minimal amount of supporting
code.
Signed-off-by: Chris Rorvick
---
drivers/staging/line6/driver.c | 26 --
drivers/staging/line6/pcm.c | 2 --
drivers/st
Signed-off-by: Chris Rorvick
---
drivers/staging/line6/driver.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/line6/driver.c b/drivers/staging/line6/driver.c
index 6dc8a0d..acde205 100644
--- a/drivers/staging/line6/driver.c
+++ b/drivers/staging/line6/driver.c
@@ -61,7 +61
The line6usb driver references the device's idProduct and, in some
cases, the interface number in a number of places to determine device-
specific configuration values and to call device-specific functionality.
Rework code to leverage the device table matching more effectively.
Consolidate configur
The driver currently uses the device's idProduct as input to several
switch statements. In some cases this is not sufficiently granular and
the interface number must be taken into account.
Store the device type in `usb_line6' and key off of it instead. New
types can then be added that map to spe
Wrap USB_DEVICE to avoid repeating the Line 6 vendor ID.
Signed-off-by: Chris Rorvick
---
drivers/staging/line6/driver.c | 40 +---
1 file changed, 21 insertions(+), 19 deletions(-)
diff --git a/drivers/staging/line6/driver.c b/drivers/staging/line6/driver.c
The `LINE6_CAP_CTRL_PCM_HW' macro combines three capabilities to save
horizontal space when defining the properties entries. Now that these
are no longer limited to single lines this is not such a concern.
Specify capabilities individually when defining each property for
better clarity.
Signed-of
Including "BIT" in the macro name is pointless. Replace with "CAP" to
provide some context for what its value represents.
Signed-off-by: Chris Rorvick
---
drivers/staging/line6/driver.c | 8
drivers/staging/line6/midi.c | 2 +-
drivers/staging/line6/pcm.c | 2 +-
drivers/
The current logic uses the index of the matched entry from the device
table as an offset to the corresponding properties entry. The values
of the new `line6_device_type' enum are ordered such that they can be
used as an index into either of these arrays. Drop the device entry
lookup logic and use
These are now only used to build the device table. Each entry in this
table is already clearly documented as to what device it maps to so the
macros become unnecessary indirection.
Signed-off-by: Chris Rorvick
---
drivers/staging/line6/driver.c | 56 ++---
d
Define an enum containing the supported devices and associate each entry
in the device table to the respective value.
Signed-off-by: Chris Rorvick
---
drivers/staging/line6/driver.c | 54 --
drivers/staging/line6/driver.h | 21
2 files cha
The PODxt Live device has both a POD and a Variax interface. Add device
type entries for each of these.
Signed-off-by: Chris Rorvick
---
drivers/staging/line6/driver.c | 112 -
drivers/staging/line6/driver.h | 8 +--
drivers/staging/line6/pcm.c| 3
Specify the index of the properties entry explicitly to define this
structure more robustly. Also, drop the `L6PROP' macro in favor of
initializing each member explicitly on its own line since horizontal
space is limited and more attributes will be added later.
Signed-off-by: Chris Rorvick
---
The driver only supports interface 1 of the Pocket POD. Use the device
table to filter on this.
Signed-off-by: Chris Rorvick
---
drivers/staging/line6/driver.c | 12 ++--
1 file changed, 2 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/line6/driver.c b/drivers/staging/line
Casting the `struct usb_line6' pointer at the call point makes the code
difficult to read. This is substantially cleaned up by moving the cast
into the callees.
Signed-off-by: Chris Rorvick
---
drivers/staging/line6/driver.c | 13 -
drivers/staging/line6/pod.c| 3 ++-
drivers/s
The driver uses a different altsetting depending on the interface. Add
device type entries for each of these.
Signed-off-by: Chris Rorvick
---
drivers/staging/line6/driver.c | 41 -
drivers/staging/line6/driver.h | 3 ++-
drivers/staging/line6/pcm.c|
Casting the `struct usb_line6' pointer at the call point makes the code
difficult to read. This is substantially cleaned up by moving the cast
into the callees.
Signed-off-by: Chris Rorvick
---
drivers/staging/line6/driver.c | 21 ++---
drivers/staging/line6/pod.c | 8 ++
Commit 1027f476f507 (staging: line6: sync with upstream) removed PCM
from the Pocket POD capabilities but left the endpoint configuration.
Signed-off-by: Chris Rorvick
---
drivers/staging/line6/pcm.c | 5 -
1 file changed, 5 deletions(-)
diff --git a/drivers/staging/line6/pcm.c b/drivers/st
The driver only supports interface 0 of the TonePort UX2 and POD Studio
UX2 devices. Use the device table to filter on this.
Signed-off-by: Chris Rorvick
---
drivers/staging/line6/driver.c | 20
1 file changed, 4 insertions(+), 16 deletions(-)
diff --git a/drivers/staging/
The device type can now be used to determine the altsetting for the
interface. Drop the conditional logic and make this value a property.
Signed-off-by: Chris Rorvick
---
drivers/staging/line6/driver.c | 74 +-
drivers/staging/line6/driver.h | 2 ++
2 fi
Which *_disconnect() to call on disconnect is known at initialization.
Add a function pointer to the `usb_line6' struct and use to call into
the appropriate logic instead of evaluating the conditional logic.
Signed-off-by: Chris Rorvick
---
drivers/staging/line6/driver.c | 43 +
Remove declarations from the header and move the definitions up in the
source so they need not be forward declared.
Signed-off-by: Chris Rorvick
---
drivers/staging/line6/pod.c | 58 ++--
drivers/staging/line6/pod.h | 1 -
drivers/staging/line6/podhd.c
Which *_process_message() function (if any) to call when data is
received is known at initialization. Add a function pointer to the
`usb_line6' struct and use to call into the appropriate logic instead
of evaluating the conditional logic for each message.
Signed-off-by: Chris Rorvick
---
driver
The device type can now be used to determine the addresses of the
audio endpoints for the interface. Drop the conditional logic and make
these values properties.
Signed-off-by: Chris Rorvick
---
drivers/staging/line6/capture.c | 9
drivers/staging/line6/driver.c | 38 ++
The device type can now be used to determine the addresses of the
control endpoints for the interface. Drop the conditional logic and
make these values properties.
Signed-off-by: Chris Rorvick
---
drivers/staging/line6/driver.c | 73 +-
drivers/staging/li
In addition to some miscellaneous bug fixes and enhancements
implement a clockevent device based on the functionality supported by Hyper-V.
K. Y. Srinivasan (6):
Drivers: hv: hv_balloon: Make adjustments in computing the floor
Drivers: hv: hv_balloon: Fix a locking bug in the balloon driver
We currently release memory (balloon down) in the interrupt context and we also
post memory status while releasing memory. Rather than posting the status
in the interrupt context, wakeup the status posting thread to post the status.
This will address the inconsistent lock state that Sitsofe Wheeler
Currently, the API for sending a multi-page buffer over VMBUS is limited to
a maximum pfn array of MAX_MULTIPAGE_BUFFER_COUNT. This limitation is
not imposed by the host and unnecessarily limits the maximum payload
that can be sent. Implement an API that does not have this restriction.
Signed-off-
Make adjustments in computing the balloon floor. The current computation
of the balloon floor was not appropriate for virtual machines with more than
10 GB of assigned memory - we would get into situations where the host would
agressively balloon down the guest and leave the guest in an unusable st
We support memory hot-add in the Hyper-V balloon driver by hot adding an
appropriately
sized and aligned region and controlling the on-lining of pages within that
region
based on the pages that the host wants us to online. We do this because the
granularity and alignment requirements in Linux are
Correctly compute the local (gpadl) handle.
I would like to thank Michael Brown for seeing this bug.
Signed-off-by: K. Y. Srinivasan
Reported-by: Michael Brown
---
drivers/hv/channel.c |4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/hv/channel.c b/drivers/hv
Implement a clockevent device based on the timer support available on
Hyper-V.
In this version of the patch I have addressed Jason's review comments.
Signed-off-by: K. Y. Srinivasan
Reviewed-by: Jason Wang
---
arch/x86/include/uapi/asm/hyperv.h | 11 +
drivers/hv/hv.c|
63 matches
Mail list logo