Fix warnings:
drivers/staging/skein/skein_base.h:89:30: warning: shift too big (50) for type
int
...
drivers/staging/skein/skein_base.h:89:30: warning: shift too big (39)for type
int
drivers/staging/skein/skein_base.h:89:19: warning: too many warnings
Signed-off-by: Domagoj Trsan
---
drivers/s
On 15/11/14 15:55, Marcus Hufvudsson wrote:
Fixed checkpatch.pl error message. Space prohibited before that ','
Signed-off-by: Marcus Hufvudsson
---
drivers/staging/comedi/drivers/me4000.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/comedi/drivers/m
drivers/staging/rtl8723au/hal/rtl8723a_hal_init.c:747:1: warning: symbol
'rtl8723a_EfusePgPacketRead' was not declared. Should it be static?
Function 'rtl8723a_EfusePgPacketRead' seems to be unused in current
staging code.
Before, it was available as 'static s32 Hal_EfusePgPacketRead',
but code t
We found Freescale imx6 and Rockchip rk3288 and Ingenic JZ4780 (Xburst/MIPS)
use the interface compatible Designware HDMI IP, but they also have some
lightly differences, such as phy pll configuration, register width(imx hdmi
register is one byte, but rk3288 is 4 bytes width and can only be access
CHECK: Alignment should match open parenthesis
+ if ((hdmi->vic == 10) || (hdmi->vic == 11) ||
+ (hdmi->vic == 12) || (hdmi->vic == 13) ||
CHECK: braces {} should be used on all arms of this statement
+ if (hdmi->hdmi_data.video_mode.mdvi)
[...]
+ else {
[...]
Sign
drm driver may probe before the i2c bus, so the driver should
defer probing until it is available
Signed-off-by: Andy Yan
Reviewed-by: Daniel Kurtz
---
Changes in v12:
- refactor of_node_put(ddc_node)
Changes in v11: None
Changes in v10: None
Changes in v9: None
Changes in v8: None
Changes in
IMX6 and Rockchip RK3288 and JZ4780 (Ingenic Xburst/MIPS)
use the interface compatible Designware HDMI IP, but they
also have some lightly differences, such as phy pll configuration,
register width, 4K support, clk useage, and the crtc mux configuration
is also platform specific.
To reuse the imx
the original imx hdmi driver is under staging/imx-drm,
which depends on imx-drm, so move the imx hdmi driver out
to drm/bridge and rename imx-hdmi to dw_hdmi
handle encoder in dw_hdmi-imx.c, as most of the encoder
operation are platform specific such as crtc select and
panel format set
Signed-off
Signed-off-by: Andy Yan
---
Changes in v12: None
Changes in v11: None
Changes in v10: None
Changes in v9: None
Changes in v8:
- correct some spelling mistake
- modify ddc-i2c-bus and interrupt description
Changes in v7: None
Changes in v6: None
Changes in v5: None
Changes in v4: None
Changes in
On rockchip rk3288, only word(32-bit) accesses are
permitted for hdmi registers. Byte width accesses (writeb,
readb) generate an imprecise external abort.
Signed-off-by: Andy Yan
---
Changes in v12: None
Changes in v11: None
Changes in v10: None
Changes in v9: None
Changes in v8: None
Changes
some platform may not support all the display mode,
add mode_valid interface check it
also add drm_connector_register which add a debugfs
interface for dump display modes and edid information
Signed-off-by: Andy Yan
---
Changes in v12: None
Changes in v11: None
Changes in v10: None
Changes in v
HDMI_IH_I2CMPHY_STAT0 is a clear on write register, which indicates i2cm
operation status(i2c transfer done or error), every hdmi phy register
configuration must check this register to make sure the configuration
has complete. But the indication bit should be cleared after check, otherwise
the corr
RK3288 HDMI will not work without the spare bit of
HDMI_PHY_CONF0 enable
Signed-off-by: Andy Yan
---
Changes in v12: None
Changes in v11:
- split from patch
Changes in v10: None
Changes in v9: None
Changes in v8: None
Changes in v7: None
Changes in v6: None
Changes in v5: None
Changes in v4:
Signed-off-by: Andy Yan
---
Changes in v12: None
Changes in v11: None
Changes in v10: None
Changes in v9: None
Changes in v8:
- Add documentation for rockchip dw hdmi
Changes in v7: None
Changes in v6: None
Changes in v5: None
Changes in v4: None
Changes in v3: None
Changes in v2: None
.../de
Rockchip RK3288 hdmi is compatible with dw_hdmi
this patch is depend on patch by Mark Yao Add drm
driver for Rockchip Socs
see https://lkml.org/lkml/2014/10/8/201
Signed-off-by: Andy Yan
---
Changes in v12:
- add comment for the depend on patch
Changes in v11: None
Changes in v10:
- add more
Signed-off-by: stefan
---
drivers/staging/imx-drm/parallel-display.c | 6 ++
1 file changed, 6 insertions(+)
diff --git a/drivers/staging/imx-drm/parallel-display.c
b/drivers/staging/imx-drm/parallel-display.c
index 4ca61af..a67c1ad 100644
--- a/drivers/staging/imx-drm/parallel-display.c
++
Signed-off-by: stefan
---
drivers/staging/imx-drm/ipuv3-crtc.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/imx-drm/ipuv3-crtc.c
b/drivers/staging/imx-drm/ipuv3-crtc.c
index 720868b..71c741b 100644
--- a/drivers/staging/imx-drm/ipuv3-crtc.c
+++ b/drivers
> This patch removes all of the unnecessary spaces after casts within
> the virthba.c file. The checkpatch script was run again after these
> changes, and no "remove spaces after casts" checks were generated.
> Signed-off-by: Ken Depro
> ---
> drivers/staging/unisys/virthba/virthba.c | 130
> This patch fixes the CamelCase checks for methods/variables in
> virthba.c found with the checkpatch script.
> Signed-off-by: Ken Depro
> ---
> drivers/staging/unisys/virthba/virthba.c | 122 +++---
> 1 file changed, 61 insertions(+), 61 deletions(-)
Please disregard t
On Mon, Nov 17, 2014 at 05:21:48PM +0200, stefan wrote:
> Signed-off-by: stefan
We need a full name for your from header and your signed off by line.
(It's like signing a legal document that you didn't violate copyrights).
Also, could you explain a bit more in the changelog what the benifits
are
Fixed Subject line containing the entire patch description.
>88<
Remove an unecessary return statement in a void function.
Remove an unecessary space between a function name and the parentheses.
Signed-off-by: Thomas Wood
On Mon, Nov 17, 2014 at 11:11:36AM -0800, Thomas Wood wrote:
> Fixed Subject line containing the entire patch description.
> >88<
Ick, what is that here? Please put that below the --- line, otherwise I
have to hand-edit t
From: Jeff
Replaced cleanups: with err_rgn, err_ctx, and out_rgn in the file.
This is to have proper error and success handling. I also removed
the variable rc because like cleanups, rc is redundant in this file
Signed-off-by: Jeffrey Brown
---
drivers/staging/unisys/visorchipset/parser.c | 6
Remove an unecessary return statement in a void function.
Remove an unecessary space between a function name and the parentheses.
Signed-off-by: Thomas Wood
---
Fixed the subject line containing the entire description.
Removed an attempt at scissor lines.
drivers/staging/lustre/lnet/lnet/api-ni.
On Mon, Nov 17, 2014 at 02:46:35PM -0500, Jeffrey Brown wrote:
> From: Jeff
This doesn't match your signed-off-by: line, nor your From: line of your
email above. Why even have this line when it isn't needed, and wrong?
greg k-h
___
devel mailing list
Replaced cleanups: with err_rgn, err_ctx, and out_rgn in the file.
This is to have proper error and success handling. I also removed
the variable rc because like cleanups, rc is redundant in this file
Signed-off-by: Jeffrey Brown
---
drivers/staging/unisys/visorchipset/parser.c | 62 +++
Looks nice. Thanks, a lot!
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
FMODE_EXEC is type fmode_t but is used in operations
with integers which leads to sparse warnings:
drivers/staging/lustre/lustre/mdc/mdc_lib.c:198:21: warning: restricted fmode_t
degrades to integer
drivers/staging/lustre/lustre/mdc/mdc_locks.c:300:49: warning: restricted
fmode_t degrades to inte
On Mon, Nov 17, 2014 at 02:23:48PM -0800, Juston Li wrote:
> FMODE_EXEC is type fmode_t but is used in operations
> with integers which leads to sparse warnings:
> drivers/staging/lustre/lustre/mdc/mdc_lib.c:198:21: warning: restricted
> fmode_t degrades to integer
> drivers/staging/lustre/lustre/
On Tue, 2014-11-18 at 01:46 +0300, Dan Carpenter wrote:
> On Mon, Nov 17, 2014 at 02:23:48PM -0800, Juston Li wrote:
> > FMODE_EXEC is type fmode_t but is used in operations
> > with integers which leads to sparse warnings:
> > drivers/staging/lustre/lustre/mdc/mdc_lib.c:198:21: warning: restricted
This patch fixes the following sparse warning:
drivers/staging/rtl8723au/hal/rtl8723a_bt-coexist.c:343:36: warning:
cast to restricted __le16
by using the le16_to_cpus function.
Signed-off-by: Tobenna P. Igwe
---
drivers/staging/rtl8723au/hal/rtl8723a_bt-coexist.c |2 +-
1 file changed, 1
On Tue, Nov 18, 2014 at 01:45:41AM +, Tobenna P. Igwe wrote:
> This patch fixes the following sparse warning:
>
> drivers/staging/rtl8723au/hal/rtl8723a_bt-coexist.c:343:36: warning:
> cast to restricted __le16
>
> by using the le16_to_cpus function.
>
> Signed-off-by: Tobenna P. Igwe
> ---
On Mon, Nov 17, 2014 at 05:59:47PM -0800, Greg KH wrote:
> On Tue, Nov 18, 2014 at 01:45:41AM +, Tobenna P. Igwe wrote:
> > This patch fixes the following sparse warning:
> >
> > drivers/staging/rtl8723au/hal/rtl8723a_bt-coexist.c:343:36: warning:
> > cast to restricted __le16
> >
> > by usin
On Tue, Nov 18, 2014 at 02:51:45AM +, Tobenna Peter, Igwe wrote:
> On Mon, Nov 17, 2014 at 05:59:47PM -0800, Greg KH wrote:
> > On Tue, Nov 18, 2014 at 01:45:41AM +, Tobenna P. Igwe wrote:
> > > This patch fixes the following sparse warning:
> > >
> > > drivers/staging/rtl8723au/hal/rtl872
On Mon, Nov 17, 2014 at 04:23:08PM -0800, Juston wrote:
> Seems to be the case. Looked at some old commits (2.6.17) and found
> FMODE_EXEC was mainlined to allow lustre to be installed on a vanilla
> kernel.
We actually only care about the most recent kernel. I think you can
remove the ifdefs in
35 matches
Mail list logo