Adding Mark to the CC list. He might be able to test this, and also he
is the dgnc maintainer. Could you resend him the patches privately so
he doesn't have to download corrupted versions from the list archive?
regards,
dan carpenter
On Mon, Nov 03, 2014 at 01:06:25AM +0100, Konrad Zapalowicz w
Hi Mauro, Guennadi,
Am Dienstag, den 30.09.2014, 10:06 +0200 schrieb Philipp Zabel:
> Am Montag, den 29.09.2014, 18:10 -0400 schrieb Greg Kroah-Hartman:
> > On Mon, Sep 29, 2014 at 08:03:34PM +0200, Philipp Zabel wrote:
> > > Decrementing the reference count of the previous endpoint node allows to
On 31/10/14 19:04, H Hartley Sweeten wrote:
Commit (bf33eb4b4f57) introduced a some new helper functions to manipulate
the sample size.
This series removes the old 'bytes_per_sample()' helper and updates some
of the drivers to use the new helper functions to remove the hardcoded
assumption of th
On 02/11/14 22:12, Rickard Strandqvist wrote:
Remove unneeded #define. This was previously included in a patch set
two but patchset one was taken by mistake.
Signed-off-by: Rickard Strandqvist
---
drivers/staging/comedi/drivers/comedi_bond.c |3 +--
1 file changed, 1 insertion(+), 2 dele
Em Mon, 29 Sep 2014 20:03:34 +0200
Philipp Zabel escreveu:
> Decrementing the reference count of the previous endpoint node allows to
> use the of_graph_get_next_endpoint function in a for_each_... style macro.
> All current users of this function that pass a non-NULL prev parameter
> (that is, s
Caro usuário
Seu e-mail ultrapassou 2 GB criados pelo webmaster, que está atualmente em
execução no 2.30GB, o que não é possível enviar ou receber nova mensagem dentro
das próximas 24 horas, até que você verifique se você enviar e-mail da conta.
Por favor, informe seus dados abaixo para ver
Hi Andrey,
On 10/29/2014 05:03 PM, Andrey Utkin wrote:
> The used approach actually cannot prevent new encoder interrupt to
> appear, because interrupt handler can execute in different thread, and
> in current implementation there is still race condition regarding this.
I don't understand what yo
This commit adds the Digi Classic board implementation to the
staging/jsm driver.
The code here is taken from the staging/dgnc driver and modified to
match the serial/jsm state. This work is mostly based on the changes
that has been done to the code handling the Digi Neo cards with the
inspiration
This commit adds the UART structure for the Digi Classic cards. This
code comes from the staging/dgnc driver.
Signed-off-by: Konrad Zapalowicz
---
drivers/tty/serial/jsm/jsm.h | 59 +++-
1 file changed, 58 insertions(+), 1 deletion(-)
diff --git a/drivers
This commit enables support for the Digi Classic adapters line in the
jsm driver. This means changes in:
- device probing code
- device cleanup code
- driver description (Kconfig)
The init/cleanup code is based on the staging/dgnc driver.
Signed-off-by: Konrad Zapalowicz
This patch series renames the checkpatch.pl flagged CamelCase names in virtpci.c
Bryan Thompson (12):
staging: unisys: virtpci: Fix CamelCase Chipset_DriverInfo
staging: unisys: virtpci: Fix CamelCase virtpci device list head
staging: unisys: virtpci: Fix CamelCase virtpci device list lock
Rename the following local variables in virtpci_device_add()
pIoChan changed to io_chan
pDev changed to dev
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/unisys/virtp
Rename write_vbus_chpInfo() to write_vbus_chp_info() in virtpci.c
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.c
b/drivers/staging/unisys/virtpci
Rename the following fix_vbus_dev_info() parameters
devNo changed to dev_no
devType changed to dev_type
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c |6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.c
Rename VpcidevListLock to vpcidev_list_lock in virtpci.c
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c | 32 +++---
1 file changed, 16 insertions(+), 16 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.c
b/drivers/staging/u
Rename BusDriverInfo variable to bus_driver_info in virtpci.c
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c |9 +
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.c
b/drivers/staging/unisys/virtpci/virt
Rename fix_vbus_devInfo() to fix_vbus_dev_info().
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.c
b/drivers/staging/unisys/virtpci/virtpci.c
i
Rename VpcidevListHead to vpcidev_list_head in virtpci.c
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c | 32 +++---
1 file changed, 16 insertions(+), 16 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.c
b/drivers/staging/u
Rename write_vbus_devInfo() to write_vbus_dev_info() in virtpci.c
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c |6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.c
b/drivers/staging/unisys/virtpci/vir
Rename the following local variables in fix_vbus_dev_info()
Change pChan to chan
Change devInfo to dev_info
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/unisys/vir
Rename pDev to dev in delete_vbus_device()
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.c
b/drivers/staging/unisys/virtpci/virtpci.c
index a299b32..b6e
Rename write_vbus_busInfo() to write_vbus_bus_info() in virtpci.c
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.c
b/drivers/staging/unisys/virtpci
Rename Chipset_DriverInfo to chipset_driver_info in virtpci.c
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c |8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.c
b/drivers/staging/unisys/virtpci/virtp
From: Ken Depro
This patch removes some unneeded white space after casts within the
channel.c file. The checkpatch script was run after these changes,
and no further checks or warnings were seen.
Signed-off-by: Ken Depro
Signed-off-by: Ben Romer
---
drivers/staging/unisys/channels/channel.c
This is where we implement USB 2.0 and 3.0 roothubs. From the host's
perspective,
hub state is set and tracked just like any other USB roothub. Likewise, requests
to the roothub appear to be handled like any other wired USB request.
Signed-off-by: Sean O. Stalley
Signed-off-by: Stephanie Wallick
Signed-off-by: Sean O. Stalley
Signed-off-by: Stephanie Wallick
---
drivers/staging/Kconfig| 2 ++
drivers/staging/Makefile | 1 +
drivers/staging/mausb/Kconfig | 16
drivers/staging/mausb/Makefile | 3 +++
drivers/staging/mausb/
The Media Agnostic USB Specification outlines a number of managment
packet types for management and control functions. Each function is
initiated with a particular type of managment request packet and
completed with the corresponding management response packet. This
is where we fill the fields for
This is where we implement the behavior of a USB device controller for
the MA USB device-side driver. The MA UDC interfaces with a gadget driver
and appears to the driver as a regular UDC. However, instead of sending
USB packets over a wired USB bus, the MA UDC hands MA USB packets off to
a media s
Adds various scripts for building, loading and unloading the MA USB
drivers and a utility that can be used for connecting and disconnecting
the host and device drivers.
Signed-off-by: Sean O. Stalley
Signed-off-by: Stephanie Wallick
---
.../staging/mausb/scripts/build_load_connect.sh| 69 +
This is where we handle media specific packets and transport. The MS driver
interfaces with a media agnostic (MA) driver via a series of transfer pairs.
Transfer pairs consist of a set of functions to pass MA USB packets back
and forth between MA and MS drivers. There is one transfer pair per devic
This is where we create, store and handle endpoint and device structures
that are specific to the MA USB drivers. Each MA USB structure maps 1:1
with it's corresponding USB structure (e.g. there is one MA USB endpoint
per USB endpoint).
Signed-off-by: Sean O. Stalley
Signed-off-by: Stephanie Wall
Media Agnostic (MA) USB enables the USB protocol to be used over a wide
range of physical media. MA USB is a relatively new protocol and is
currently unsupported in the Linux kernel. This patch set adds the
following drivers with the following capabilities:
1) MA USB Host:
- provides func
This is where we handle MA USB packets. The structure and types of MA USB
packets are defined in the MA USB specification. When an MA USB driver
receives a USB packet, it translates it into a MA USB packet (or packets
if urb exceeds maximum USB packet size). When an MA USB packet is received,
the d
This is where we interface with the existing USB stack and implement the
functionality of a USB host controller driver. From the host's perspective,
we appear as just another USB host controller. However, instead of passing
traffic along a wired USB bus, the driver hands USB packets off for transpo
The MA USB Specification outlines packet types and a protocol for
bulk and interrupt transfers. This is where we implement that protocol.
MA USB transfers are initiated by the host via a TransferRequest packet.
The host then either sends data to the device via subsequent
TransferRequest packets (OU
On Mon, Nov 03, 2014 at 12:42:48PM -0800, Stephanie Wallick wrote:
> +#define DEBUG
I doubt you want this in the driver enabled by default :(
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/dr
On Mon, Nov 03, 2014 at 12:42:48PM -0800, Stephanie Wallick wrote:
> +EXPORT_SYMBOL(mausb_register_ms_driver);
EXPORT_SYMBOL_GPL()? I have to ask...
> +static int mausb_hcd_init(void)
> +{
> + int ret;
> +
> + /* register HCD driver */
> + ret = platform_driver_register(&mausb_driver
On Mon, Nov 03, 2014 at 12:42:57PM -0800, Stephanie Wallick wrote:
> --- /dev/null
> +++ b/drivers/staging/mausb/drivers/Makefile
> @@ -0,0 +1,20 @@
> +#MY_CFLAGS =-g -O0 -DEBUG_OUTPUT
Please remove that line, it's not ever to be used.
___
devel mailin
On Mon, Nov 03, 2014 at 12:42:57PM -0800, Stephanie Wallick wrote:
> --- /dev/null
> +++ b/drivers/staging/mausb/TODO
> @@ -0,0 +1,14 @@
> +TODO:
> + - checkpatch.pl cleanups
Is this still true?
And why does this need to be a staging driver? What's wrong with making
it a "real" driver now?
On Mon, Nov 03, 2014 at 01:18:16PM -0800, Greg KH wrote:
> On Mon, Nov 03, 2014 at 12:42:48PM -0800, Stephanie Wallick wrote:
> > +#define DEBUG
>
> I doubt you want this in the driver enabled by default :(
>
Thank you for catching, will remove in the next patch version.
On Fri, Oct 31, 2014 at 09:57:30AM -0400, Benjamin Romer wrote:
> Remove the typedef and just use struct visorchipset_externalport_info instead.
> Fix all CamelCase names:
>
> switchNo => switch_no
> externalPortNo => external_port_no
> networkZoneGuid => network_zone_uuid
> pdPort => pd_port
> ip
On Fri, Oct 31, 2014 at 09:57:31AM -0400, Benjamin Romer wrote:
> Get rid of the typedef and use struct visorchipset_internalport_info and fix
> CamelCase member names:
>
> switchNo => switch_no
> internalPortNo => internal_port_no
> busNo => bus_no
> devNo => dev_no
> Reserved1 => reserved1
> Res
On Fri, Oct 31, 2014 at 09:57:29AM -0400, Benjamin Romer wrote:
> Remove the typedef and use struct visorchipset_switch_info instead. Fix all
> CamelCase member names:
>
> switchNo => switch_no
> switchTypeGuid => switch_type_uuid
> authService1 => authservice1
> authService2 => authservice2
> aut
On Mon, Nov 03, 2014 at 01:21:39PM -0800, Greg KH wrote:
> On Mon, Nov 03, 2014 at 12:42:48PM -0800, Stephanie Wallick wrote:
> > +EXPORT_SYMBOL(mausb_register_ms_driver);
>
> EXPORT_SYMBOL_GPL()? I have to ask...
>
The source is dual-licenced under BSD and GPL. It was our understanding
that dual
On Sat, Nov 01, 2014 at 10:47:22AM +0800, Chen Weixiang wrote:
> Remove following code style errors from ft1000/ft1000-usb/ft1000_debug.c
> and ft1000/ft1000-pcmcia/ft1000_hw.c:
> ERROR: spaces required around that '=' (ctx:VxV)
> ERROR: spaces required around that '<' (ctx:VxV)
> ERROR: spaces req
On Sat, Nov 01, 2014 at 04:53:38PM -0700, Joe Perches wrote:
> Use normal kernel style, indentation and alignment.
>
> git diff -w shows no difference
>
> Signed-off-by: Joe Perches
> ---
> drivers/staging/ft1000/ft1000-pcmcia/boot.h| 34 +-
> drivers/staging/ft1000/ft1000-pcmcia/ft10
Dan Carpenter , Gulsah Kose ,
Tuomas Tynkkynen ,
Matina Maria Trompouki
Cc: linux-me...@vger.kernel.org, de...@driverdev.osuosl.org,
linux-ker...@vger.kernel.org
Bcc:
Subject: [PATCH] staging: media: lirc: replace dev_err by pr_err
Reply-To:
This patch replaces dev_err by pr_err since the val
This patch replaces dev_err by pr_err since the value
of ir is NULL when the message is displayed.
Signed-off-by: Aya Mahfouz
---
drivers/staging/media/lirc/lirc_zilog.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/media/lirc/lirc_zilog.c
b/drivers/staging
On Mon, Nov 03, 2014 at 04:04:42PM -0800, steph wrote:
> On Mon, Nov 03, 2014 at 01:21:39PM -0800, Greg KH wrote:
> > On Mon, Nov 03, 2014 at 12:42:48PM -0800, Stephanie Wallick wrote:
> > > +EXPORT_SYMBOL(mausb_register_ms_driver);
> >
> > EXPORT_SYMBOL_GPL()? I have to ask...
> >
> The source i
On Sun, Nov 02, 2014 at 12:40:13PM +0100, Konrad Zapalowicz wrote:
> On 11/01, Aya Mahfouz wrote:
> > This patch removes one debug message and replaces a dev_err
> > call by pr_err.
>
> Usually you would like to send this as two separate patches because
> replacing a debug message is way different
On Tue, Nov 04, 2014 at 08:07:01AM +0900, DaeSeok Youn wrote:
> Greg,
>
> check this patch, please.
> This patch was rebased on staging-testing tree.
>
> Thanks.
>
> regards,
> Daeseok Youn
>
>
> 2014-10-31 10:20 GMT+09:00 Daeseok Youn :
3 days after sending this? Please give me a chance, I
On Sun, Oct 19, 2014 at 02:37:28AM +0530, Devendra Naga wrote:
> The error_handling for class_create, device_create are taken care
> by the respective goto statements. The failure code from class_create and
> device_create are assigned to the variable rc to return a proper value.
>
> Also removed
Joe Perches (2):
staging: ft1000: Whitespace neatening
ASoC: staging: ft1000: Logging message neatening
drivers/staging/ft1000/ft1000-pcmcia/boot.h| 34 +-
drivers/staging/ft1000/ft1000-pcmcia/ft1000.h | 30 +-
drivers/staging/ft1000/ft1000-pcmcia/ft1000_cs.c | 50 +-
dri
On Mon, Nov 03, 2014 at 04:25:44PM -0800, Joe Perches wrote:
> Use a more common logging style.
>
> o Convert DEBUG macros to pr_debug
> o Add pr_fmt
> o Remove embedded function names from pr_debug
> o Convert printks to pr_
> o Coalesce formats and align arguments
> o Add missing terminating new
On Mon, Nov 03, 2014 at 04:13:55PM -0800, Greg KH wrote:
> On Mon, Nov 03, 2014 at 04:04:42PM -0800, steph wrote:
> > On Mon, Nov 03, 2014 at 01:21:39PM -0800, Greg KH wrote:
> > > On Mon, Nov 03, 2014 at 12:42:48PM -0800, Stephanie Wallick wrote:
> > > > +EXPORT_SYMBOL(mausb_register_ms_driver);
>
Use a more common logging style.
o Convert DEBUG macros to pr_debug
o Add pr_fmt
o Remove embedded function names from pr_debug
o Convert printks to pr_
o Coalesce formats and align arguments
o Add missing terminating newlines
Signed-off-by: Joe Perches
---
drivers/staging/ft1000/ft1000-pcmcia/
Hi Martyn,
Thanks for your help from previous emails. I managed to talk to my
board using a VME-USB board. Now I am back to working with an SBC, and
I have a different setup this time around, let me describe it:
1. SBC in slot 0 of a VME64 chassis (with 2 slots), and the bottom one
being a slot
> -Original Message-
> From: devel [mailto:driverdev-devel-boun...@linuxdriverproject.org] On
> Behalf Of Dexuan Cui
> Sent: Tuesday, October 21, 2014 17:56 PM
> To: gre...@linuxfoundation.org; linux-ker...@vger.kernel.org; driverdev-
> de...@linuxdriverproject.org; o...@aepfle.de; a...@can
On Mon, 2014-11-03 at 16:36 -0800, Greg Kroah-Hartman wrote:
> On Mon, Nov 03, 2014 at 04:25:44PM -0800, Joe Perches wrote:
> > Use a more common logging style.
> >
> > o Convert DEBUG macros to pr_debug
> > o Add pr_fmt
> > o Remove embedded function names from pr_debug
> > o Convert printks to p
59 matches
Mail list logo