On Fri, Sep 19, 2014 at 02:57:03AM +, Drokin, Oleg wrote:
> 4. Sometimes we need large allocations. general kmalloc is less
> reliable as system lives on and memory fragmentation worsens. So we
> have this "allocations over 2-4 pages get switched to vmalloc" logic,
> if there's a way to do that
On Thu, Sep 18, 2014 at 11:55:36PM +0200, Rene Kolarik wrote:
> Hello,
>
> I'm sending this as a part of Eudyptula Challenge.
>
> Rene Kolarik
Send it inline.
Read the first paragraph of Documentation/email-clients.txt.
Choose a better subject.
Add a patch description.
Split it into one type of
->u.generic_elem.len is a user controlled number between 0-255. We
should limit it to avoid memory corruption.
Signed-off-by: Dan Carpenter
diff --git a/drivers/staging/vt6655/hostap.c b/drivers/staging/vt6655/hostap.c
index 0dd87d4..73429f4 100644
--- a/drivers/staging/vt6655/hostap.c
+++ b/dr
Signed-off-by: Luca Ellero
---
drivers/staging/comedi/drivers/ni_usb6501.c | 29 ++-
1 file changed, 28 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c
b/drivers/staging/comedi/drivers/ni_usb6501.c
index 6a4f965..f0b8f11 100644
---
This series of patches add counter support for NI USB-6501. I tested it on my
device and it works fine.
Changes for v2:
- rewrite patch 3/9 changelog: replace "fix" with "cleanup"
- avoid sparse warnings
- add SDF_LSAMPL flag to counter subdevice
Changes for v3:
- remove useless checks
- remove e
Rename ni6501_send_command to ni6501_port_command
Signed-off-by: Luca Ellero
---
drivers/staging/comedi/drivers/ni_usb6501.c |8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c
b/drivers/staging/comedi/drivers/ni_usb6501.c
i
Remove useless test in ni6501_send_command. The check is useless since this
function is called only in this driver.
Signed-off-by: Luca Ellero
---
drivers/staging/comedi/drivers/ni_usb6501.c |3 ---
1 file changed, 3 deletions(-)
diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c
b/d
Add counter support for NI USB-6501.
The following functions are introduced:
- ni6501_counter_command()
- ni6501_cnt_insn_config()
- ni6501_cnt_insn_read()
- ni6501_cnt_insn_write()
Signed-off-by: Luca Ellero
---
drivers/staging/comedi/drivers/ni_usb6501.c | 167 ++-
1
ni6501_auto_attach(): replace spaces with tabs to get proper alignment
Signed-off-by: Luca Ellero
---
drivers/staging/comedi/drivers/ni_usb6501.c |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c
b/drivers/staging/comedi/drive
ni6501_send_command(): remove empty lines in case statements
Signed-off-by: Luca Ellero
---
drivers/staging/comedi/drivers/ni_usb6501.c | 15 ---
1 file changed, 15 deletions(-)
diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c
b/drivers/staging/comedi/drivers/ni_usb6501.c
Cleanup response_size in ni6501_send_command (READ_PORT command).
No logical/functional change is introduced by this patch.
Signed-off-by: Luca Ellero
---
drivers/staging/comedi/drivers/ni_usb6501.c |3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/comedi/d
On Sep 19, 2014, at 5:11 AM, Dan Carpenter wrote:
> On Fri, Sep 19, 2014 at 02:57:03AM +, Drokin, Oleg wrote:
>> 4. Sometimes we need large allocations. general kmalloc is less
>> reliable as system lives on and memory fragmentation worsens. So we
>> have this "allocations over 2-4 pages get
Hello!
First, thanks for your patches and efforts spent on these cleanups.
On Sep 19, 2014, at 12:45 AM, Julia Lawall wrote:
> With respect to the upper case lower case issue, does the thing need to be
> a macro? I think that the lowercase is more or less fine, but only if
> what is behind i
On Fri, 19 Sep 2014, Drokin, Oleg wrote:
> Hello!
>
>First, thanks for your patches and efforts spent on these cleanups.
>
> On Sep 19, 2014, at 12:45 AM, Julia Lawall wrote:
>
> > With respect to the upper case lower case issue, does the thing need to be
> > a macro? I think that the lower
On Friday, September 19, 2014 4:51 AM, Luca Ellero wrote:
> This series of patches add counter support for NI USB-6501. I tested it on my
> device and it works fine.
>
> Changes for v2:
> - rewrite patch 3/9 changelog: replace "fix" with "cleanup"
> - avoid sparse warnings
> - add SDF_LSAMPL flag t
Leeuwarden, The Netherlands.
https://www.swisslotto.ch/
Swiss-Nederland’s Winning Notification..!!!CONGRATULATION YOU ARE A
WINNER!!!.
The Board of Directors, members of staff and the International Promotion
Department of the SWISS-LOTTO Satellite lottery, Netherlands wishes to inform
you
On Sun, Sep 14, 2014 at 04:59:03PM +0100, Mark Einon wrote:
> Fix two lines where mixed tabs and spaces were used for indenting.
>
> Signed-off-by: Mark Einon
> ---
> drivers/staging/et131x/et131x.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/staging/et1
17 matches
Mail list logo