On Thu, Jul 24, 2014 at 09:50:14PM +0300, Igor Bezukh wrote:
> Removed redundant comments from card.h header file.
>
> Signed-off-by: Igor Bezukh
> ---
> drivers/staging/vt6655/80211hdr.h |7 ---
> drivers/staging/vt6655/80211mgr.h | 38
> -
> drive
lprocfs_wr_atomic is defined in
drivers/staging/lustre/lustre/obdclass/lprocfs_status.c with its second argument
with the __user attribute:
int lprocfs_wr_atomic(struct file *file, const char __user *buffer,
unsigned long count, void *data)
but its declaration in drivers/staging/lus
Greg KH wrote:
>
> Really
>
Obviously not, I'm sorry. :(
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
Many return statements in void function were present at the end of
functions, with no effect. They now are removed.
This fixes a bunch of checkpatch warnings.
Signed-off-by: Guillaume Clement
---
drivers/staging/vt6655/80211mgr.c| 36 ---
drivers/staging/vt6655/b
For structs definitions, the braces should be at the end of the
line. Reported by checkpatch.
Signed-off-by: Guillaume Clement
---
drivers/staging/vt6655/bssdb.h | 3 +--
drivers/staging/vt6655/device.h | 15 +--
drivers/staging/vt6655/key.h| 9 +++--
drivers/staging/vt665
This should be "static inline", not "inline static". Reported by
checkpatch.
Signed-off-by: Guillaume Clement
---
drivers/staging/vt6655/device.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/vt6655/device.h b/drivers/staging/vt6655/device.h
index 7c7fec
This patch fixes the missing blank lines after declarations in vt6655
reported by checkpatch.
Signed-off-by: Guillaume Clement
---
drivers/staging/vt6655/80211mgr.c| 1 +
drivers/staging/vt6655/baseband.c| 1 +
drivers/staging/vt6655/bssdb.c | 7 +++
drivers/staging/vt6655/c
This patchset fixes a lot of minor checkpatch and sparse warnings.
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
Braces should not be in a separate line for multi-line if
statements. This fixes warnings reported by checkpatch.
Signed-off-by: Guillaume Clement
---
drivers/staging/vt6655/wcmd.c | 5 +++--
drivers/staging/vt6655/wpa.c | 8
2 files changed, 7 insertions(+), 6 deletions(-)
diff --git
Function braces should be on a separate line. Reported by checkpatch.
Signed-off-by: Guillaume Clement
---
drivers/staging/vt6655/device_main.c | 90
drivers/staging/vt6655/rxtx.c| 6 ++-
2 files changed, 64 insertions(+), 32 deletions(-)
diff --git
The MAC_MAX_CONTEXT_SIZE macro was not enclosed into parenthesis,
which might have caused hard to debug errors, and caused a sparse
warning.
Since it is unused, we might as well remove it.
Signed-off-by: Guillaume Clement
---
drivers/staging/vt6655/mac.h | 1 -
1 file changed, 1 deletion(-)
di
Some whitespace were missing, causing checkpatch warnings and altering
readability.
Signed-off-by: Guillaume Clement
---
drivers/staging/vt6655/device_main.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/vt6655/device_main.c
b/drivers/staging/vt6
We were using 0 instead of NULL to initialize a pointer, which caused
a sparse warning.
Signed-off-by: Guillaume Clement
---
drivers/staging/vt6655/device_main.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/vt6655/device_main.c
b/drivers/staging/vt6655/dev
This fixes break "break is not useful after a goto or return"
checkpatch warnings.
Signed-off-by: Guillaume Clement
---
drivers/staging/vt6655/rf.c | 2 --
drivers/staging/vt6655/wpa.c | 1 -
2 files changed, 3 deletions(-)
diff --git a/drivers/staging/vt6655/rf.c b/drivers/staging/vt6655/rf.c
Sparse reported that the data from tagSCmdRequest is given by
userspace, so it should be tagged as such.
Later, we were memcomparing and dereferencing it without first copying
it, fix that as well.
Signed-off-by: Guillaume Clement
---
drivers/staging/vt6655/iocmd.h | 2 +-
drivers/staging/vt66
This fixes the "trailing statements should be on next line" checkpatch
warning.
Signed-off-by: Guillaume Clement
---
drivers/staging/vt6655/card.c| 6 --
drivers/staging/vt6655/device_main.c | 6 --
2 files changed, 8 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/vt
This fixes several spaces added just before a newline in debug
strings, reported by checkpatch.
Signed-off-by: Guillaume Clement
---
drivers/staging/vt6655/card.c| 2 +-
drivers/staging/vt6655/device_main.c | 53 -
drivers/staging/vt6655/dpc.c | 13 --
This fixes several "braces {} are not necessary for single statement
blocks" checkpatch warnings.
Signed-off-by: Guillaume Clement
---
drivers/staging/vt6655/power.c | 3 +--
drivers/staging/vt6655/vntwifi.c | 3 +--
drivers/staging/vt6655/wmgr.c| 3 +--
3 files changed, 3 insertions(+), 6
Lots of printk are used in vt6655, replace them with the pr_*
equivalent.
Signed-off-by: Guillaume Clement
---
drivers/staging/vt6655/card.c| 12 +++---
drivers/staging/vt6655/device_cfg.h | 2 +-
drivers/staging/vt6655/device_main.c | 71 ++--
drivers/s
Fix sparse warnings:
drivers/staging/rtl8188eu/core/rtw_cmd.c:52:5: warning:
symbol '_rtw_enqueue_cmd' was not declared. Should it be static?
drivers/staging/rtl8188eu/core/rtw_wlan_util.c:1225:5: warning:
symbol 'wifirate2_ratetbl_inx' was not declared. Should it be static?
drivers/staging/rtl
Excuse me, I did not see the patch details, but I guess it is about
whether welcome a new member to upstream kernel. For me, I have 3 ideas
about it if I am a newbie or a normal kernel developer:
- Do I have enough basic skills for it?
- Do I developed one or more another real world project
On Thu, Jul 24, 2014 at 10:15 PM, Chen Gang wrote:
>
> Excuse me, I did not see the patch details, but I guess it is about
> whether welcome a new member to upstream kernel. For me, I have 3 ideas
> about it if I am a newbie or a normal kernel developer:
>
> - Do I have enough basic skills for it
On 07/25/2014 10:20 AM, Nick Krause wrote:
> On Thu, Jul 24, 2014 at 10:15 PM, Chen Gang wrote:
>>
>> Excuse me, I did not see the patch details, but I guess it is about
>> whether welcome a new member to upstream kernel. For me, I have 3 ideas
>> about it if I am a newbie or a normal kernel dev
On Thu, Jul 24, 2014 at 10:47 PM, Chen Gang wrote:
>
>
> On 07/25/2014 10:20 AM, Nick Krause wrote:
>> On Thu, Jul 24, 2014 at 10:15 PM, Chen Gang wrote:
>>>
>>> Excuse me, I did not see the patch details, but I guess it is about
>>> whether welcome a new member to upstream kernel. For me, I have
Move the /proc/visorchipset/parahotplug interface to sysfs under
/sys/devices/platform/visorchipset/parahotplug/deviceenabled and
/sys/devices/platform/visorchipset/parahotplug/devicedisabled.
The parahotplug interface is used to deal with SR-IOV recovery situations on
s-Par guest partitions. The
This patch set moves the parahotplug interface in the visorchipset module from
procfs to sysfs, and removes the visorchipset/partition tree from proc. It also
includes some code cleanup in the new sysfs handler functions.
In version 4 of the set, the accidental inclusion of a change to the Makefil
Debugging information for the guest's channels was being exposed in proc.
Remove the code that creates these entries, which are no longer needed.
Signed-off-by: Benjamin Romer
---
v4: this patch accidentally picked up a Makefile change intended only for
testing. The change was removed.
v3: patch
On 07/25/2014 10:53 AM, Nick Krause wrote:
> On Thu, Jul 24, 2014 at 10:47 PM, Chen Gang wrote:
>>
>>
>> On 07/25/2014 10:20 AM, Nick Krause wrote:
>>> On Thu, Jul 24, 2014 at 10:15 PM, Chen Gang
>>> wrote:
Excuse me, I did not see the patch details, but I guess it is about
whet
On Thu, Jul 24, 2014 at 11:09 PM, Chen Gang wrote:
>
>
> On 07/25/2014 10:53 AM, Nick Krause wrote:
>> On Thu, Jul 24, 2014 at 10:47 PM, Chen Gang wrote:
>>>
>>>
>>> On 07/25/2014 10:20 AM, Nick Krause wrote:
On Thu, Jul 24, 2014 at 10:15 PM, Chen Gang
wrote:
>
> Excuse me, I
On 07/25/2014 11:13 AM, Nick Krause wrote:
> On Thu, Jul 24, 2014 at 11:09 PM, Chen Gang wrote:
>>
>>
>> On 07/25/2014 10:53 AM, Nick Krause wrote:
>>> On Thu, Jul 24, 2014 at 10:47 PM, Chen Gang
>>> wrote:
On 07/25/2014 10:20 AM, Nick Krause wrote:
> On Thu, Jul 24, 2014 at
On Thu, Jul 24, 2014 at 11:21 PM, Chen Gang wrote:
>
>
> On 07/25/2014 11:13 AM, Nick Krause wrote:
>> On Thu, Jul 24, 2014 at 11:09 PM, Chen Gang wrote:
>>>
>>>
>>> On 07/25/2014 10:53 AM, Nick Krause wrote:
On Thu, Jul 24, 2014 at 10:47 PM, Chen Gang
wrote:
>
>
> On 07/2
On 07/25/2014 11:30 AM, Nick Krause wrote:
> On Thu, Jul 24, 2014 at 11:21 PM, Chen Gang wrote:
>>
>>
>> On 07/25/2014 11:13 AM, Nick Krause wrote:
>>> On Thu, Jul 24, 2014 at 11:09 PM, Chen Gang
>>> wrote:
On 07/25/2014 10:53 AM, Nick Krause wrote:
> On Thu, Jul 24, 2014 at
On Thu, Jul 24, 2014 at 11:34 PM, Chen Gang wrote:
>
>
> On 07/25/2014 11:30 AM, Nick Krause wrote:
>> On Thu, Jul 24, 2014 at 11:21 PM, Chen Gang wrote:
>>>
>>>
>>> On 07/25/2014 11:13 AM, Nick Krause wrote:
On Thu, Jul 24, 2014 at 11:09 PM, Chen Gang
wrote:
>
>
> On 07/2
On 07/25/2014 11:39 AM, Nick Krause wrote:
> On Thu, Jul 24, 2014 at 11:34 PM, Chen Gang wrote:
>>
>>
>> On 07/25/2014 11:30 AM, Nick Krause wrote:
>>> On Thu, Jul 24, 2014 at 11:21 PM, Chen Gang
>>> wrote:
On 07/25/2014 11:13 AM, Nick Krause wrote:
> On Thu, Jul 24, 2014 at
101 - 134 of 134 matches
Mail list logo