Am Donnerstag, 3. Juli 2014, 21:15:57 schrieb Pawel Lebioda:
> Hi,
>
> This patch fixes coding style warnings reported by checkpatch.pl:
> "Missing a blank line after declarations".
thanks. Looking at the checkpatch output, its requirement of at
least 4 lines of help text looks like a bit overkil
Hi there!
I'm trying to modify msi_wmi driver to get it work with mediakeys on my MSI
GE60 laptop.
By default, I get "Unknown event received" message.
For now, I diagnosed that event, that every key press produces has 0x03 (
ACPI_TYPE_BUFFER?) type, instead of 0x01 (ACPI_TYPE_INTEGER) which in-
Hi Russell,
Am Donnerstag, den 03.07.2014, 17:52 +0100 schrieb Russell King:
> Use the generic DRM OF helper to locate the possible CRTCs for the
> encoder, thereby shrinking the imx-drm driver some more.
Great, I especially like that now we don't go -EPROBE_DEFER anymore as
soon as a single crtc
Using the for_each_... macro should make the code bit shorter and
easier to read. This patch also properly decrements the endpoint node
reference count before returning out of the loop.
Signed-off-by: Philipp Zabel
---
drivers/staging/imx-drm/imx-drm-core.c | 9 +++--
1 file changed, 3 inser
Note that while of_graph_get_next_endpoint decrements the reference count
of the child node passed to it, of_node_put(child) still has to be called
manually when breaking out of the loop.
Signed-off-by: Philipp Zabel
---
include/linux/of_graph.h | 4
1 file changed, 4 insertions(+)
diff --
Decreasing the reference count of the previous endpoint node allows to use
the of_graph_get_next_endpoint function in a for_each_... style macro.
Signed-off-by: Philipp Zabel
---
drivers/of/base.c | 9 +
1 file changed, 1 insertion(+), 8 deletions(-)
diff --git a/drivers/of/base.c b/dri
Using the for_each_... macro should make the code a bit shorter and
easier to read.
Signed-off-by: Philipp Zabel
---
drivers/gpu/drm/drm_of.c | 8 ++--
1 file changed, 2 insertions(+), 6 deletions(-)
diff --git a/drivers/gpu/drm/drm_of.c b/drivers/gpu/drm/drm_of.c
index 46d9678..1b315b6 100
Hi,
decrementing the reference count of the previous endpoint node parameter to
of_graph_get_next_endpoint allows to wrap the function in a for_each macro.
This series removes the remaining workaround in imx-drm, adds the macro
for_each_endpoint_of_node, and switches the current users to it. It b
We will decrease the prev node reference count in of_graph_get_next_endpoint
instead.
Signed-off-by: Philipp Zabel
---
drivers/staging/imx-drm/imx-drm-core.c | 10 +-
1 file changed, 1 insertion(+), 9 deletions(-)
diff --git a/drivers/staging/imx-drm/imx-drm-core.c
b/drivers/staging/im
The dgap_init_pci() calls only pci_register_driver().
It doesn't need to make a function for that.
Signed-off-by: Daeseok Youn
---
drivers/staging/dgap/dgap.c | 11 +--
1 files changed, 1 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/dgap/dgap.c b/drivers/staging/dgap/dg
dgap_dl_wait and kme_wait are not used in dgap.
Signed-off-by: Daeseok Youn
---
drivers/staging/dgap/dgap.c |8
drivers/staging/dgap/dgap.h |1 -
2 files changed, 0 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/dgap/dgap.c b/drivers/staging/dgap/dgap.c
index b193d2
is gives a NULL pointer dereference error when match is NULL (as passed
by component_master_add() below). Observed this while testing linux-next
kernel (next-20140704) on Exynos based board with DRM enabled.
> + if (IS_ERR(match))
> + return PTR_ERR(match);
&g
match->num);
>
>^
> This gives a NULL pointer dereference error when match is NULL (as passed
> by component_master_add() below). Observed this while testing linux-next
> kernel (next-20140704) on Exynos based board with DRM enabled.
Thanks for you
/* Reallocate the match array for its true size */
>> > + match = component_match_realloc(dev, match, match->num);
>>
>>^
>> This gives a NULL pointer dereference error when match is NULL (as passed
>> by component_master_add()
; >>
> >> ^
> >> This gives a NULL pointer dereference error when match is NULL (as passed
> >> by component_master_add() below). Observed this while testing linux-next
> >> kernel (next-20140704) on Exynos based board with DRM enabled.
e match array for its true size */
>> >> > + match = component_match_realloc(dev, match, match->num);
>> >>
>> >>^
>> >> This gives a NULL pointer dereference error when match is NULL (as passed
>> >>
This patch introduces the use of managed interfaces like devm_kzalloc,
devm_ioremap, dmam_alloc_coherent, devm_request_irq and does away with
the calls to functions to free the allocated memory in the probe and
remove functions. Also, the labels are removed in the probe function.
Signed-off-by: Hi
Hi,
I'm going over some "older" drivers in the staging tree and wanted to
ask about cptm1217 and ste_rmi4. They've been in staging for three and a
half years now, waiting for the upstream Synaptics RMI4 drivers. From
what I understand, the RMI4 development is happening in the
synaptics-rmi4 branch
Hi,
This patch fixes the following warning reported by checkpatch.pl:
WARNING: else is not generally useful after a break or return
#235: FILE: drivers/staging/nvec/nvec.c:235:
Regards
Pawel Lebioda
Signed-off-by: Pawel Lebioda
drivers/staging/nvec/nvec.c | 3 +--
1 file changed, 1 insertion(
Fix checkpatch warning:
WARNING: kfree(NULL) is safe this check is probably not required
Cc: Greg Kroah-Hartman
Cc: Daeseok Youn
Cc: de...@driverdev.osuosl.org
Signed-off-by: Fabian Frederick
---
drivers/staging/cxt1e1/pmcc4_drv.c | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff
Hi,
This patch fixes the following warning reported by checkpatch.pl:
WARNING: Possible unnecessary 'out of memory' message
#811: FILE: drivers/staging/nvec/nvec.c:811
Regards
Pawel Lebioda
Signed-off-by: Pawel Lebioda
drivers/staging/nvec/nvec.c | 5 ++---
1 file changed, 2 insertions(+), 3
Hi,
This patch fixes almost all 'missing blank line after declaration'
warnings reported by checkpatch.pl for drivers/staging/bcm.
Regards
Pawel Lebioda
Signed-off-by: Pawel Lebioda
drivers/staging/bcm/CmHost.c| 1 +
drivers/staging/bcm/IPv6Protocol.c | 6 ++
drivers/staging/bcm/I
On Fri, Jul 04, 2014 at 09:57:50PM +0200, Pawel Lebioda wrote:
> Hi,
>
> This patch fixes the following warning reported by checkpatch.pl:
>
> WARNING: else is not generally useful after a break or return
> #235: FILE: drivers/staging/nvec/nvec.c:235:
>
> Regards
> Pawel Lebioda
>
> Signed-off-b
23 matches
Mail list logo