On Mon, Sep 02, 2013 at 08:18:40AM +0200, Bojan Prtvar wrote:
> This fixes the following sparse warnings
> drivers/staging/android/binder.c:1703:5: warning: symbol
> 'binder_thread_write' was not declared. Should it be static?
> drivers/staging/android/binder.c:2058:6: warning: symbol 'binder_stat
ANDROID_BINDER_IPC used the functions which need depend on MMU, so need
let it depend on MMU too, or compiling fails.
The related error:
drivers/built-in.o: In function `binder_update_page_range':
drivers/staging/android/binder.c:599: undefined reference to `map_vm_area'
drivers/staging/and
On 2013-09-01 20:42, Ben Hutchings wrote:
The Fastwel UNIOxx-5 is a PCI/104 board so put COMEDI_UNIOXX5 under
COMEDI_ISA_DRIVERS.
ITYM a PC/104 board.
The PCI-20001C is, surprisingly, an ISA card, so also put
COMEDI_II_PCI20KC under COMEDI_ISA_DRIVERS.
COMEDI_II_PCI20KC has already been mov
From: Micky Ching
The new phase searching method is more concise, and makes the code
easier to understand.
Signed-off-by: Micky Ching
---
drivers/mmc/host/rtsx_pci_sdmmc.c | 107 +++--
1 file changed, 30 insertions(+), 77 deletions(-)
diff --git a/drivers/mmc/
There are two places where duplicate code is located. Moreover, there is a
custom implementation of the sscanf() functionality. This patch makes code
quite simplier and cleaner.
Signed-off-by: Andy Shevchenko
---
drivers/staging/silicom/bpctl_mod.c | 188 +---
1 f
There are two places where duplicate code is located. Moreover, there is a
custom implementation of the sscanf() functionality. This patch makes code
quite simplier and cleaner.
Signed-off-by: Andy Shevchenko
---
drivers/staging/silicom/bpctl_mod.c | 188 +---
1 f
On 2013-08-30 18:46, H Hartley Sweeten wrote:
Consolidate the boilerplate code used to mask and set the output channels of
DIO and DO subdevices.
v3: fix [PATCH 01/21] to prevent overflow when calculating s->io_bits
fix [PATCH 02/21] so only the valid channels in the subdevice are modified
checkpatch.pl complains that extern prototypes should be avoided in .h files
Signed-off-by: Bojan Prtvar
---
drivers/staging/android/timed_output.h |4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/android/timed_output.h
b/drivers/staging/android/timed_
Hello,
Is this an active email address? If yes,please send a reply..Checking for
confirmation.
Thanks!
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
Hello,
Is this an active email address? If yes,please send a reply..Checking for
confirmation.
Thanks!
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
The rcv_pend_lock spinlock isn't used anymore. remove it.
Signed-off-by: Mark Einon
---
drivers/staging/et131x/et131x.c |2 --
1 file changed, 2 deletions(-)
create mode 100644 drivers/staging/et131x/Module.symvers
diff --git a/drivers/staging/et131x/Module.symvers
b/drivers/staging/et131
Remove braces from a few single line if statements.
Signed-off-by: Mark Einon
---
drivers/staging/et131x/et131x.c | 39 +++
1 file changed, 15 insertions(+), 24 deletions(-)
diff --git a/drivers/staging/et131x/et131x.c b/drivers/staging/et131x/et131x.c
inde
Ignoring checkpatch for some lines - now just over 80 chars, but much
more readable.
Signed-off-by: Mark Einon
---
drivers/staging/et131x/et131x.c | 120 +--
1 file changed, 40 insertions(+), 80 deletions(-)
diff --git a/drivers/staging/et131x/et131x.c b/dri
phy_lock is no longer used in any useful code, it's all been moved into
a phy_device. Remove the lock definition and init.
Signed-off-by: Mark Einon
---
drivers/staging/et131x/et131x.c |3 ---
1 file changed, 3 deletions(-)
diff --git a/drivers/staging/et131x/et131x.c b/drivers/staging/et13
On Mon, Sep 02, 2013 at 10:23:22PM +0100, Mark Einon wrote:
> Remove braces from a few single line if statements.
>
No. Leave them if they are around a multi-line indent. The original is
more readable.
regards,
dan carpenter
___
devel mailing list
d
Well, there is no need to use strcmp since we can make a test of similar
semantic by using the var_id field of param.
I moved the test into the VAR_NUM:VAR_TIME case since VAR_STRING will never be
"voice".
spk_xlate isn't used anymore (in line 628), then there is no difference between
using cp
16 matches
Mail list logo