Hi
[This is an automated email]
This commit has been processed because it contains a "Fixes:" tag
fixing commit: 457b9a6f09f0 ("Staging: android: add binder driver").
The bot has tested the following trees: v5.7.11, v5.4.54, v4.19.135, v4.14.190,
v4.9.231, v4.4.231.
v5.7.11: Build OK!
v5.4.54:
Thanks a lot for the detailed explanation, I understood now.
Martijn
On Tue, Jul 28, 2020 at 4:50 PM Jann Horn wrote:
>
> On Tue, Jul 28, 2020 at 3:50 PM Martijn Coenen wrote:
> > On Mon, Jul 27, 2020 at 2:04 PM Jann Horn wrote:
> > > - task B opens /dev/binder once, creating binder_proc inst
make a
call on handle 1?
>
> And then, if P2 does *NOT* accept the incoming transaction work, but
> instead closes the binder fd, we get a crash.
>
> Solve it by preventing the context manager from using ACQUIRE on ref 0.
> There shouldn't be any legitimate reason for the context m
> instead closes the binder fd, we get a crash.
>
> Solve it by preventing the context manager from using ACQUIRE on ref 0.
> There shouldn't be any legitimate reason for the context manager to do
> that.
>
> Additionally, print a warning if someone manages to find ano
Greetings,
I was searching through a local business directory when I found your
profile. I am Soliciting On-Behalf of my private client who is
interested in having a serious business investment in your country. If
you have a valid business, investment or project he can invest
back to me for more
Greetings,
I was searching through a local business directory when I found your
profile. I am Soliciting On-Behalf of my private client who is
interested in having a serious business investment in your country. If
you have a valid business, investment or project he can invest
back to me for more
From: Gao Xiang
It's better to use atomic_cond_read_relaxed, which is implemented
in hardware instructions to monitor a variable changes currently
for ARM64, instead of open-coded busy waiting.
Reviewed-by: Chao Yu
Signed-off-by: Gao Xiang
---
drivers/staging/erofs/internal.h | 30 +++
On Tue, Nov 20, 2018 at 10:34:18PM +0800, Gao Xiang wrote:
> It's better to use atomic_cond_read_relaxed, which is implemented
> in hardware instructions to monitor a variable changes currently
> for ARM64, instead of open-coded busy waiting.
>
> Reviewed-by: Chao Yu
> Signed-off-by: Gao Xiang
>
It's better to use atomic_cond_read_relaxed, which is implemented
in hardware instructions to monitor a variable changes currently
for ARM64, instead of open-coded busy waiting.
Reviewed-by: Chao Yu
Signed-off-by: Gao Xiang
---
drivers/staging/erofs/internal.h | 30 ++---
NATWEST BANK PLC,
10 Southwark Street ,
London Bridge , London - UK
SE1 1TT
RC: 121878
Our Ref: NTB/WESTMIN/INTER-15
Your Ref: Affidavit: AFX 076GD7B24
Tell=+447035969549
Fax+448435643403
REF:- INSTRUCTION TO CREDIT YOUR ACCOUNT WITH THE SUM OF (US$10Million)
This is the second time we are
Once locks are added, binder_ref's will only be accessed
safely with the proc lock held. Refactor the inc/dec paths
to make them atomic with the binder_get_ref* paths and
node inc/dec. For example, instead of:
ref = binder_get_ref(proc, handle, strong);
...
binder_dec_ref(ref, strong)
When initiating a transaction, the target_node must
have a strong ref on it. Then we take a second
strong ref to make sure the node survives until the
transaction is complete.
Signed-off-by: Todd Kjos
---
drivers/android/binder.c | 22 +-
1 file changed, 17 insertions(+), 5
From: Laurentiu Tudor
Drop unneeded get_device() call at device creation
and, as per documentation, drop reference count
after using device_find_child() return.
Signed-off-by: Laurentiu Tudor
---
v3:
- no changes
drivers/staging/fsl-mc/bus/dprc-driver.c | 1 +
drivers/staging/fsl-mc/bus/fsl-
From: Laurentiu Tudor
Drop unneeded get_device() call at device creation
and, as per documentation, drop reference count
after using device_find_child() return.
Signed-off-by: Laurentiu Tudor
---
drivers/staging/fsl-mc/bus/dprc-driver.c | 1 +
drivers/staging/fsl-mc/bus/fsl-mc-bus.c | 1 -
2
On Fri, Feb 03, 2017 at 10:17:53AM +, Laurentiu Tudor wrote:
> Hi Greg,
>
> Thanks for having a look. Comment below.
>
> On 02/03/2017 11:56 AM, Greg KH wrote:
> > On Wed, Feb 01, 2017 at 05:43:22AM -0600, laurentiu.tu...@nxp.com wrote:
> >> From: Laurentiu Tudor
> >>
> >> Drop unneeded get_
Hi Greg,
Thanks for having a look. Comment below.
On 02/03/2017 11:56 AM, Greg KH wrote:
> On Wed, Feb 01, 2017 at 05:43:22AM -0600, laurentiu.tu...@nxp.com wrote:
>> From: Laurentiu Tudor
>>
>> Drop unneeded get_device() call at device creation
>> and, as per documentation, drop reference count
On Wed, Feb 01, 2017 at 05:43:22AM -0600, laurentiu.tu...@nxp.com wrote:
> From: Laurentiu Tudor
>
> Drop unneeded get_device() call at device creation
> and, as per documentation, drop reference count
> after using device_find_child() return.
>
> Signed-off-by: Laurentiu Tudor
> ---
> drivers
From: Laurentiu Tudor
Drop unneeded get_device() call at device creation
and, as per documentation, drop reference count
after using device_find_child() return.
Signed-off-by: Laurentiu Tudor
---
drivers/staging/fsl-mc/bus/dprc-driver.c | 1 +
drivers/staging/fsl-mc/bus/fsl-mc-bus.c | 1 -
2
Vitaly
> > Kuznetsov
> > Cc: Thomas Gleixner ; Ingo Molnar
> > ; H. Peter Anvin ; x...@kernel.org;
> > Haiyang Zhang ; k...@vger.kernel.org; linux-
> > ker...@vger.kernel.org; de...@linuxdriverproject.org; Denis V . Lunev
> > ; Roman Kagan
> > Subject: [PATC
org;
> Haiyang Zhang ; k...@vger.kernel.org; linux-
> ker...@vger.kernel.org; de...@linuxdriverproject.org; Denis V . Lunev
> ; Roman Kagan
> Subject: [PATCH 01/15] hyperv: consolidate TSC ref page definitions
>
> Consolidate the guest-side and kvm-side definitions for Hyper-V TSC
>
Consolidate the guest-side and kvm-side definitions for Hyper-V TSC
reference page.
While at this, rewrite read_hv_clock_tsc using the existing helpers.
Signed-off-by: Roman Kagan
---
arch/x86/include/asm/kvm_host.h| 2 +-
arch/x86/include/uapi/asm/hyperv.h | 4 +--
drivers/hv/hyperv_vmbu
From: Bobi Jam
'commit 77605e41a26f ("staging/lustre/clio: add pages into writeback cache
in batches")' adds a page to a list aggregate issuing them to writeback
cache; A page add is referenced in llite/vvp io scope, while writeback
cache commit de-refers it under osc sub io scope, and enabling -
On Mon, Nov 16, 2015 at 03:22:11PM -0500, Benjamin Romer wrote:
> From: Tim Sell
>
> This is NOT technically required for the code as it stands now, but will
> be needed for subsequent patches.
>
> Signed-off-by: Tim Sell
> Signed-off-by: Benjamin Romer
>
> ---
> v2: resources are released in
From: Tim Sell
This is NOT technically required for the code as it stands now, but will
be needed for subsequent patches.
Signed-off-by: Tim Sell
Signed-off-by: Benjamin Romer
---
v2: resources are released in the reverse order they were acquired, as per
Dan Carpenter's comment.
---
driv
visorinput: use kref ref-counting
> for device data struct
>
> On Thu, Nov 12, 2015 at 09:21:14PM +, Sell, Timothy C wrote:
> > > -Original Message-
> > > From: Greg KH [mailto:gre...@linuxfoundation.org]
> > > Sent: Thursday, November 12, 2015 4:12
linuxdriverproject.org; *S-Par-
> > Maintainer
> > Subject: Re: [PATCH 3/9] staging: unisys: visorinput: use kref ref-counting
> > for device data struct
> >
> > On Thu, Nov 12, 2015 at 09:07:24PM +, Sell, Timothy C wrote:
> > > What should I do with thi
visorinput: use kref ref-counting
> for device data struct
>
> On Thu, Nov 12, 2015 at 09:07:24PM +, Sell, Timothy C wrote:
> > What should I do with this patchset?
>
> What patchset?
"[PATCH 0/9] staging: unisys: visorinput fixes and enhancements",
submitt
On Thu, Nov 12, 2015 at 09:07:24PM +, Sell, Timothy C wrote:
> What should I do with this patchset?
What patchset?
> Some history: it was fixing this one little line in
> drivers/staging/unisys/visorinput/Kconfig that triggered this patchset:
>
> depends on UNISYSSPAR && UNISYS_VISORBU
--Original Message-
> From: Sell, Timothy C
> Sent: Saturday, October 17, 2015 2:10 PM
> To: 'Greg KH'
> Cc: Romer, Benjamin M; driverdev-devel@linuxdriverproject.org; *S-Par-
> Maintainer
> Subject: RE: [PATCH 3/9] staging: unisys: visorinput: use kref ref-counti
visorinput: use kref ref-counting
> for device data struct
>
> On Sat, Oct 17, 2015 at 05:04:43PM +, Sell, Timothy C wrote:
> > > -Original Message-
> > > From: Greg KH [mailto:gre...@linuxfoundation.org]
> > > Sent: Saturday, October 17, 2015 12:51
linuxdriverproject.org; *S-Par-
> > Maintainer
> > Subject: Re: [PATCH 3/9] staging: unisys: visorinput: use kref ref-counting
> > for device data struct
> >
> > On Sat, Oct 17, 2015 at 04:34:28PM +, Sell, Timothy C wrote:
> > > > How can you guarantee it
visorinput: use kref ref-counting
> for device data struct
>
> On Sat, Oct 17, 2015 at 04:34:28PM +, Sell, Timothy C wrote:
> > > How can you guarantee it? Please document that somehow, I don't see
> it
> > > here in this patch how that can be true, but
ome code comments. Basically they will amount to this:
> * The kref is initialized to 1 in _probe(), and the book-end for that is
> the devdata_put() in _remove().
> * devdata_get() / devdata_put() is called to keep the ref valid during
> interrupt processing in visorinput_channel_interrupt
visorinput: use kref ref-counting
> for device data struct
>
> On Sat, Oct 17, 2015 at 03:04:37PM +, Sell, Timothy C wrote:
> > > -Original Message-
> > > From: Greg KH [mailto:gre...@linuxfoundation.org]
> > > Sent: Saturday, October 17, 2015 1:59 A
l@linuxdriverproject.org; Sell,
> > Timothy C
> > Subject: Re: [PATCH 3/9] staging: unisys: visorinput: use kref ref-counting
> > for device data struct
> >
> > On Fri, Oct 16, 2015 at 10:06:48AM -0400, Benjamin Romer wrote:
> > > From: Tim Sell
> > >
visorinput: use kref ref-counting
> for device data struct
>
> On Fri, Oct 16, 2015 at 10:06:48AM -0400, Benjamin Romer wrote:
> > From: Tim Sell
> >
> > This is NOT technically required for the code as it stands now, but will
> > be needed for subsequent patch
On Fri, Oct 16, 2015 at 10:06:48AM -0400, Benjamin Romer wrote:
> From: Tim Sell
>
> This is NOT technically required for the code as it stands now, but will
> be needed for subsequent patches.
>
> Signed-off-by: Tim Sell
> Signed-off-by: Benjamin Romer
> ---
> drivers/staging/unisys/visorinp
: [PATCH 3/9] staging: unisys: visorinput: use kref ref-counting
> for device data struct
>
> On Fri, Oct 16, 2015 at 10:06:48AM -0400, Benjamin Romer wrote:
> > @@ -526,7 +549,8 @@ visorinput_channel_interrupt(struct visor_device
> *dev)
> > int xmotion, ymotion, zmoti
On Fri, Oct 16, 2015 at 10:06:48AM -0400, Benjamin Romer wrote:
> @@ -526,7 +549,8 @@ visorinput_channel_interrupt(struct visor_device *dev)
> int xmotion, ymotion, zmotion, button;
> int i;
>
> - struct visorinput_devdata *devdata = dev_get_drvdata(&dev->device);
> + struct v
From: Tim Sell
This is NOT technically required for the code as it stands now, but will
be needed for subsequent patches.
Signed-off-by: Tim Sell
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/visorinput/visorinput.c | 45 --
1 file changed, 35 insertions(+),
This driver no longer supports a "legacy" attach mechanism that searches
for a suitable PCI device and increments it's reference count, but since
the common "detach" handler `pci230_detach()` still has a left-over
`pci_dev_put()`, a matching `pci_dev_get()` is needed in the
"auto_attach" handler `p
This driver no longer supports a "legacy" attach mechanism that searches
for a suitable PCI device and increments it's reference count, but since
the common "detach" handler `pci224_detach()` still has a left-over
`pci_dev_put()`, a matching `pci_dev_get()` is needed in the
"auto_attach" handler `p
Now that this driver no longer supports "manual" attachment of PCI
devices in its `attach` hook (`pc236_attach()`), it no longer has code
that searches for a suitable PCI device and increments its reference
count. Since the driver no longer has any reason for incrementing and
decrementing the PCI
43 matches
Mail list logo