On Mon, Mar 16, 2015 at 12:25:31PM +0300, Dan Carpenter wrote:
> Both "bits.e" and "BIT_CHK(bits, LCD_BIT_E_MASK)" are terrible. The new
> one is worse because it takes more words to tell you nothing and because
> it is wrong since E is a flag not a mask.
Yep, I agree. Maybe simply renaming "bits
On Sun, Mar 15, 2015 at 10:03:56AM +0100, Isaac Lleida wrote:
> This path implements a bit array representing the LCD signal states instead
> of the old "struct bits", which used char to represent a single bit. This
> will reduce the memory usage.
Sudip told you to line wrap the changelog but it
This path implements a bit array representing the LCD signal states instead of
the old "struct bits", which used char to represent a single bit. This will
reduce the memory usage.
Signed-off-by: Isaac Lleida
---
v4: fixed a bug in BIT_CHK()
drivers/staging/panel/panel.c | 86 +