On 12/17/2013 03:28 PM, Dan Carpenter wrote:
On Tue, Dec 17, 2013 at 10:36:58AM +0800, micky_ch...@realsil.com.cn wrote:
diff --git a/drivers/mfd/rtsx_pcr.h b/drivers/mfd/rtsx_pcr.h
index 947e79b..26b52ec 100644
--- a/drivers/mfd/rtsx_pcr.h
+++ b/drivers/mfd/rtsx_pcr.h
@@ -63,4 +63,12 @@ static
On Tue, Dec 17, 2013 at 10:36:58AM +0800, micky_ch...@realsil.com.cn wrote:
> void rtl8411b_init_params(struct rtsx_pcr *pcr)
> {
> - pcr->extra_caps = EXTRA_CAPS_SD_SDR50 | EXTRA_CAPS_SD_SDR104;
> - pcr->num_slots = 2;
> - pcr->ops = &rtl8411b_pcr_ops;
> -
> - pcr->flags = 0;
> -
On Tue, Dec 17, 2013 at 10:36:58AM +0800, micky_ch...@realsil.com.cn wrote:
> diff --git a/drivers/mfd/rtsx_pcr.h b/drivers/mfd/rtsx_pcr.h
> index 947e79b..26b52ec 100644
> --- a/drivers/mfd/rtsx_pcr.h
> +++ b/drivers/mfd/rtsx_pcr.h
> @@ -63,4 +63,12 @@ static inline u8 map_sd_drive(int idx)
> #de
From: Micky Ching
in order to remove duplicated code in rtl8411, we make 8411 as the base
init params, and other like-8411 chips will just change the different
value with 8411, this can save some source code.
Signed-off-by: Lee Jones
Signed-off-by: Micky Ching
---
drivers/mfd/rtl8411.c | 6