Replaced kmalloc(x*y, ...) with kcalloc(x,y,...)
Signed-off-by: Vitaly Osipov
---
drivers/staging/rtl8712/rtl871x_mlme.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8712/rtl871x_mlme.c
b/drivers/staging/rtl8712/rtl871x_mlme.c
index 26b8f37..8561841
n E;
identifier V;
@@
T *V;
...
- V = kzalloc(sizeof(T), E);
+ V = kzalloc(sizeof(*V), E);
Signed-off-by: Vitaly Osipov
---
drivers/staging/rtl8712/rtl871x_cmd.c | 94 --
drivers/staging/rtl8712/rtl871x_io.c | 2 +-
drivers/staging/rtl8712/rtl871x_mlme.c | 8 +--
driv
);
...
- memset(E1,0,E2);
Signed-off-by: Vitaly Osipov
---
drivers/staging/lustre/lnet/klnds/o2iblnd/o2iblnd.c | 5 -
drivers/staging/lustre/lnet/klnds/socklnd/socklnd.c | 4
drivers/staging/lustre/lnet/lnet/router.c| 1 -
drivers/staging/lustre/lnet/selftest
It makes more sense to return PTR_ERR(iss->iss_ctrlclk) here. The
current code looks like an oversight in pasting the block just above
this one.
Signed-off-by: Vitaly Osipov
---
drivers/staging/media/omap4iss/iss.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/driv
After the commit 91d435f replaced _malloc with kmalloc, smatch picked up a
couple of new warnings. This fixes the warning:
warn: returning -1 instead of -ENOMEM is sloppy
Signed-off-by: Vitaly Osipov
---
drivers/staging/rtl8712/usb_ops_linux.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion
After the commit 91d435f replaced _malloc with kmalloc, smatch picked up a
couple of new warnings. This fixes warnings:
warn: struct type mismatch 'writePTM_parm vs setdig_parm'
warn: struct type mismatch 'writePTM_parm vs setra_parm'
The difference is u8 vs unsigned char.
S
(E, GFP_ATOMIC);
Signed-off-by: Vitaly Osipov
---
drivers/staging/rtl8712/hal_init.c| 2 +-
drivers/staging/rtl8712/mlme_linux.c | 3 +-
drivers/staging/rtl8712/osdep_service.h | 5 --
drivers/staging/rtl8712/rtl8712_recv.c| 6 +-
drivers/staging/rtl8712
would make the code less readable.
Signed-off-by: Vitaly Osipov
---
drivers/staging/wlan-ng/p80211conv.c | 31 +
drivers/staging/wlan-ng/p80211netdev.c | 11 ++-
drivers/staging/wlan-ng/p80211req.c| 6 +-
drivers/staging/wlan-ng/prism2fw.c | 101
Sure - resent as v2 yesterday.
Regards,
Vitaly
On Sun, May 4, 2014 at 9:31 AM, Greg Kroah-Hartman
wrote:
> On Sun, Apr 27, 2014 at 01:02:03AM +1000, Vitaly Osipov wrote:
>> return -EFAULT instead of the value returned by copy_from_user()
>>
>> Signed-off-by: Vitaly Osipov
return -EFAULT instead of the value returned by copy_from_user()
Signed-off-by: Vitaly Osipov
---
Revised against today's staging-next branch.
.../lustre/lustre/libcfs/linux/linux-module.c | 11 ---
1 file changed, 4 insertions(+), 7 deletions(-)
diff --git a/drivers/st
In ll_ioctl_fiemap(), a user-supplied value is used to calculate a
length of a buffer which is later allocated with user data.
Signed-off-by: Vitaly Osipov
---
drivers/staging/lustre/lustre/llite/file.c |4
1 file changed, 4 insertions(+)
diff --git a/drivers/staging/lustre/lustre
return -EFAULT instead of the value returned by copy_from_user()
Signed-off-by: Vitaly Osipov
---
.../lustre/lustre/libcfs/linux/linux-module.c | 11 ---
1 file changed, 4 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/lustre/lustre/libcfs/linux/linux-module.c
b
Removed redundant NULL checks before calling kfree()
Signed-off-by: Vitaly Osipov
---
drivers/staging/dgnc/dgnc_driver.c | 13 -
1 file changed, 4 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/dgnc/dgnc_driver.c
b/drivers/staging/dgnc/dgnc_driver.c
index b1a39b2
Fixed several sparse "warning: incorrect type" by replacing int
declarations with gfp_t
Signed-off-by: Vitaly Osipov
---
.../staging/lustre/include/linux/libcfs/libcfs.h |1 +
drivers/staging/lustre/lustre/libcfs/module.c |3 ++-
drivers/staging/lustre/lustre/libcfs/t
All files in drivers/staging/wlan-ng updated to use pr_err
Signed-off-by: Vitaly Osipov
---
drivers/staging/wlan-ng/p80211conv.c | 24 +--
drivers/staging/wlan-ng/p80211netdev.c |7 ++-
drivers/staging/wlan-ng/p80211req.c|3 +-
drivers/staging/wlan-ng/prism2fw.c
Thanks, that's helpful - I for some reason thought that multi-part
patch had to have more or less uniform subject. We the checkpatch.pl
people come from http://www.eudyptula-challenge.org/, where at some
stage we are told to submit a patch for a single style issue in the
staging tree. All newbies..
tcm825x.c:
changed printk to pr_info
Signed-off-by: Vitaly Osipov
---
drivers/staging/media/omap24xx/tcm825x.c |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/media/omap24xx/tcm825x.c
b/drivers/staging/media/omap24xx/tcm825x.c
index 2326481..3367ccd
tcm825x.c and tcm825x.h:
fixing ERROR: Macros with complex values should be enclosed in parenthesis
Signed-off-by: Vitaly Osipov
---
drivers/staging/media/omap24xx/tcm825x.c |8
drivers/staging/media/omap24xx/tcm825x.h |4 ++--
2 files changed, 6 insertions(+), 6 deletions
-off-by: Vitaly Osipov
---
drivers/staging/media/omap24xx/tcm825x.c | 40 +++---
drivers/staging/media/omap24xx/tcm825x.h |4 +--
2 files changed, 22 insertions(+), 22 deletions(-)
diff --git a/drivers/staging/media/omap24xx/tcm825x.c
b/drivers/staging/media
19 matches
Mail list logo