On Fri, Nov 13, 2015 at 6:33 PM, Sudip Mukherjee
wrote:
>
> On Wed, Nov 11, 2015 at 11:03:34PM +0530, Shivani Bhardwaj wrote:
> > On Wed, Nov 11, 2015 at 11:01 PM, Greg KH
> > wrote:
> > > On Wed, Nov 11, 2015 at 10:51:36PM +0530, Shivani Bhardwaj wrote:
> > &
On Wed, Nov 11, 2015 at 11:01 PM, Greg KH wrote:
> On Wed, Nov 11, 2015 at 10:51:36PM +0530, Shivani Bhardwaj wrote:
>> On Wed, Nov 11, 2015 at 4:24 PM, kbuild test robot wrote:
>> > Hi Shivani,
>> >
>> > [auto build test ERROR on staging/staging-testing]
>
On Wed, Nov 11, 2015 at 4:24 PM, kbuild test robot wrote:
> Hi Shivani,
>
> [auto build test ERROR on staging/staging-testing]
> [also build test ERROR on v4.3 next-2015]
>
> url:
> https://github.com/0day-ci/linux/commits/Shivani-Bhardwaj/staging-
Remove the wrapper function cl_lock_lockdep_init() and replace its only
call with the function it wrapped.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/obdclass/cl_lock.c | 7 +--
1 file changed, 1 insertion(+), 6 deletions(-)
diff --git a/drivers/staging/lustre/lustre
.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/include/cl_object.h | 1 -
drivers/staging/lustre/lustre/llite/rw26.c | 5 -
drivers/staging/lustre/lustre/llite/vvp_io.c| 2 +-
drivers/staging/lustre/lustre/obdclass/cl_io.c | 14 --
drivers
Remove unnecessary wrapper function cl_lock_descr_fid() and replace all
its calls with the function it wrapped.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/obdclass/cl_io.c | 12
1 file changed, 4 insertions(+), 8 deletions(-)
diff --git a/drivers/staging
Remove the wrapper function ll_finish_md_op_data() and replace all
its calls with the standard function kfree() that it wraps. Also,
prototype of the function is removed as it is no longer of any use.
Signed-off-by: Shivani Bhardwaj
---
Changes in v2:
Fix commit message and merge a patch
Replace the calls of the function ll_finish_md_op_data() with the
standard function kfree().
Signed-off-by: Shivani Bhardwaj
---
Changes in v2:
Fix commit message and merge a patch
drivers/staging/lustre/lustre/llite/llite_nfs.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion
Substitute standard function kfree() in place of the function
ll_finish_md_op_data().
Signed-off-by: Shivani Bhardwaj
---
Changes in v2:
Fix commit message and merge a patch
drivers/staging/lustre/lustre/llite/llite_close.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff
Substitute the standard function kfree() for the function
ll_finish_md_op_data().
Signed-off-by: Shivani Bhardwaj
---
Changes in v2:
Fix commit message and merge a patch
drivers/staging/lustre/lustre/llite/symlink.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a
Change the calls of the function ll_finish_md_op_data() to the
standard function kfree().
Signed-off-by: Shivani Bhardwaj
---
Changes in v2:
Fix commit message and merge a patch
drivers/staging/lustre/lustre/llite/xattr_cache.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion
Replace the calls of the function ll_finish_md_op_data() with the
standard function kfree().
Signed-off-by: Shivani Bhardwaj
---
Changes in v2:
Fix commit message and merge a patch
drivers/staging/lustre/lustre/llite/namei.c | 12 ++--
1 file changed, 6 insertions(+), 6
Replace the calls of the function ll_finish_md_op_data() with the
standard function kfree().
Signed-off-by: Shivani Bhardwaj
---
Changes in v2:
Fix commit message and merge a patch
drivers/staging/lustre/lustre/llite/file.c | 24
1 file changed, 12 insertions
Replace the calls of the function ll_finish_md_op_data() with the
standard function kfree().
Signed-off-by: Shivani Bhardwaj
---
Changes in v2:
Fix commit message and merge a patch
drivers/staging/lustre/lustre/llite/dir.c | 14 +++---
1 file changed, 7 insertions(+), 7
This patchset removes an unnecessary wrapper function, its prototype and
replaces all its calls in different files with the standard function
that it wraps.
After applying this patch, code becomes cleaner.
Changes in v2:
Fix commit message and merge a patch
Shivani Bhardwaj (8
On Tue, Nov 10, 2015 at 12:48 AM, Simmons, James A. wrote:
>>On Mon, Nov 9, 2015 at 7:07 PM, Michał Kępień wrote:
Remove the function ll_finish_md_op_data() and replace all its calls
with the standrd function ll_finish_md_op_data().
>>>
>>> I believe you meant to write "standard functio
Remove the wrapper function lustre_posix_acl_xattr_free() and replace its
call in the file xattr with the function kfree() that it wrapped. Also,
its prototype from the header lustre_eacl is removed as it is no longer
of any use.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre
On Mon, Nov 9, 2015 at 7:07 PM, Michał Kępień wrote:
>> Remove the function ll_finish_md_op_data() and replace all its calls
>> with the standrd function ll_finish_md_op_data().
>
> I believe you meant to write "standard function kfree()".
>
Yes. I am so sorry. Should I be sending the whole serie
On Sun, Nov 8, 2015 at 10:33 PM, Shivani Bhardwaj wrote:
> Remove the function mgc_ir_state_seq_show() as it is not
> referenced/called anywhere.
>
> Signed-off-by: Shivani Bhardwaj
> ---
> drivers/staging/lustre/lustre/mgc/lproc_mgc.c | 5 -
> 1 file changed, 5 deleti
Remove the function mgc_ir_state_seq_show() as it is not
referenced/called anywhere.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/mgc/lproc_mgc.c | 5 -
1 file changed, 5 deletions(-)
diff --git a/drivers/staging/lustre/lustre/mgc/lproc_mgc.c
b/drivers/staging/lustre
Remove the wrapper function mdc_kuc_reregister() and replace its call
with the function it wrapped. Also, comment has been added for clarity.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/mdc/mdc_request.c | 16
1 file changed, 4 insertions(+), 12 deletions
Remove the wrapper function cfs_wi_sched_unlock() and replace all its
calls with the function it wrapped.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/libcfs/workitem.c | 26 ++---
1 file changed, 10 insertions(+), 16 deletions(-)
diff --git a/drivers
Remove the wrapper function cfs_wi_sched_lock() and replace all its
calls with the function it wrapped.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/libcfs/workitem.c | 22 --
1 file changed, 8 insertions(+), 14 deletions(-)
diff --git a/drivers/staging
This patchset removes unnecessary wrapper functions from the file workitem
and replace all their calls with the function that they wrap.
After applying this patch, code becomes cleaner.
Shivani Bhardwaj (2):
staging: lustre: workitem: Remove cfs_wi_sched_lock wrapper
staging: lustre: workitem
On Sun, Nov 8, 2015 at 2:17 AM, Dan Carpenter wrote:
> Don't resend, it's fine. I don't like re-reviewing patches and you
> don't like sending them. It's not like it introduces a bug or generate
> a warning with our current tools.
>
> But it's still important to understand how the one thing per
On Sat, Nov 7, 2015 at 4:15 PM, Dan Carpenter wrote:
> This one should have been folded in with the last one. Really the whole
> series could have been sent as one patch, but especially the last two
> should have been folded together.
>
> regards,
> dan carpenter
>
Thanks Dan! Could you please s
Remove the function agl_list_empty() and replace its calls with the
function it wrapped.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/llite/statahead.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/lustre/lustre/llite
Remove the wrapper sa_received_empty() and replace its calls with the
function it wrapped.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/llite/statahead.c | 22 +++---
1 file changed, 11 insertions(+), 11 deletions(-)
diff --git a/drivers/staging/lustre
Remove the wrapper function agl_first_entry() and replace its calls with
the function list_entry() that it wraps.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/llite/statahead.c | 19 ---
1 file changed, 8 insertions(+), 11 deletions(-)
diff --git a/drivers
Remove the function sa_first_received_entry() and replace all its calls
with the function list_entry() that it wraps.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/llite/statahead.c | 10 ++
1 file changed, 2 insertions(+), 8 deletions(-)
diff --git a/drivers
Remove the function ll_sa_entry_unhashed() and replace all its calls
with the function list_empty() that it wrapped.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/llite/statahead.c | 9 ++---
1 file changed, 2 insertions(+), 7 deletions(-)
diff --git a/drivers/staging
.
Shivani Bhardwaj (5):
Staging: lustre: statahead: Remove ll_sa_entry_unhashed wrapper
Staging: lustre: statahead: Remove sa_first_received_entry wrapper
Staging: lustre: statahead: Remove agl_first_entry wrapper
Staging: lustre: statahead: Remove sa_received_empty wrapper
Staging: lustre
Remove the function stride_page_count() and replace its calls with the
function stride_pg_count() that it wraps.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/llite/rw.c | 12 +++-
1 file changed, 3 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/lustre
On Sat, Nov 7, 2015 at 1:02 PM, Dilger, Andreas
wrote:
> On 2015/11/06, 10:19, "Shivani Bhardwaj" wrote:
>
>>Remove the prototype of function cfs_trace_free_string_buffer() as it is
>>no longer needed.
>
> These patches would be a lot more useful if the s
Remove the prototype of the function ll_finish_md_op_data() as it is no
longer needed.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/llite/llite_internal.h | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/lustre/lustre/llite/llite_internal.h
b/drivers
Substitute standard function kfree() in place of the function
ll_finish_md_op_data().
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/llite/llite_close.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/lustre/lustre/llite/llite_close.c
b
Remove the function ll_finish_md_op_data() and replace all its calls
with the standrd function ll_finish_md_op_data().
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/llite/llite_lib.c | 13 -
1 file changed, 4 insertions(+), 9 deletions(-)
diff --git a/drivers
Replace the calls of the function ll_finish_md_op_data() with the
standard function kfree().
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/llite/llite_nfs.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/lustre/lustre/llite/llite_nfs.c
b
Substitute the standard function kfree() for the function
ll_finish_md_op_data().
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/llite/symlink.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/lustre/lustre/llite/symlink.c
b/drivers
Change the calls of the function ll_finish_md_op_data() to the standard
function kfree().
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/llite/xattr_cache.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/lustre/lustre/llite/xattr_cache.c
Replace the calls of the function ll_finish_md_op_data() with thr
stndard function kfree().
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/llite/namei.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/lustre/lustre/llite
Replace the calls of the function ll_finish_md_op_data() with the
standard function kfree().
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/llite/file.c | 24
1 file changed, 12 insertions(+), 12 deletions(-)
diff --git a/drivers/staging/lustre
Replace the calls of the function ll_finish_md_op_data() with the
standard function kfree().
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/llite/dir.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/lustre/lustre/llite/dir.c
This patchset removes an unnecessary wrapper function and replaces all
its calls in different files with the standard function that it wrapped.
Also, one patch removes its prototype.
After applying this patch, code becomes cleaner.
Shivani Bhardwaj (9):
Staging: lustre: dir: Replace function
Remove the function ldlm_pool_set_limit() and replace its calls with the
function it wrapped.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/ldlm/ldlm_pool.c | 12 ++--
1 file changed, 2 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/lustre/lustre/ldlm
Remove the function ldlm_pool_get_limit() and replace its calls with the
function it wrapped.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/ldlm/ldlm_pool.c | 10 +-
1 file changed, 1 insertion(+), 9 deletions(-)
diff --git a/drivers/staging/lustre/lustre/ldlm
Remove the function ldlm_pl2ns() and replace its calls with the function
it wrapped.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/ldlm/ldlm_pool.c | 25 +
1 file changed, 13 insertions(+), 12 deletions(-)
diff --git a/drivers/staging/lustre/lustre
This patchset removes different wrapper functions from the file ldlm_pool
and replaces their calls with the function they wrapped.
After applying this patchset, code becomes cleaner.
Shivani Bhardwaj (3):
Staging: lustre: ldlm_pool: Remove unneeded wrapper function
Staging: lustre: ldlm_pool
Remove the prototype of function cfs_trace_free_string_buffer() as it is
no longer needed.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/libcfs/tracefile.h | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/lustre/lustre/libcfs/tracefile.h
b/drivers/staging
Remove the function cfs_trace_free_string_buffer() as it can be replaced
with the standard function kfree().
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/libcfs/tracefile.c | 9 ++---
1 file changed, 2 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/lustre
Replace the calls of function cfs_trace_free_string_buffer() with
kfree() as the former function is not required.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/libcfs/module.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/lustre
This patchset removes a wrapper function, its prototype and replace its calls
in different files with a standard function.
After applying this patch, code becomes cleaner.
Shivani Bhardwaj (3):
Staging: lustre: module: Replace function calls
Staging: lustre: tracefile: Remove wrapper function
Remove the function ll_check_page() and replace all its calls with the
function it wrapped.
Signed-off-by: Shivani Bhardwaj
---
drivers/staging/lustre/lustre/llite/dir.c | 9 ++---
1 file changed, 2 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/lustre/lustre/llite/dir.c
b
On Mon, Nov 2, 2015 at 7:13 AM, glen lee wrote:
> Hi Shivani Bhardwaj,
>
> Thank you for the patches.
>
> I am writing this new mail thread since I didn't received about following
> patch which is applied recently.
>
> https://git.kernel.org/cgit/linux/kernel/git/gre
54 matches
Mail list logo