On Mon, Jul 13, 2020 at 02:41:19PM +0100, Ian Abbott wrote:
> On 13/07/2020 14:34, Greg KH wrote:
> > On Sun, Jul 12, 2020 at 12:36:28PM +0530, Saurav Girepunje wrote:
> > > Remove below warning in das1800.c
> > > WARNING: possible condition with no effect (if == else)
Remove below warning in das1800.c
WARNING: possible condition with no effect (if == else)
Signed-off-by: Saurav Girepunje
---
drivers/staging/comedi/drivers/das1800.c | 6 --
1 file changed, 6 deletions(-)
diff --git a/drivers/staging/comedi/drivers/das1800.c
b/drivers/staging/comedi
ize. So initialized next_request to NEXT_REQ_GET_FIRMWARE
for return in other case.
Signed-off-by: Saurav Girepunje
---
drivers/staging/greybus/bootrom.c | 6 ++
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/greybus/bootrom.c
b/drivers/staging/greybus/bootro
Remove unneeded variable "ret". Issues reported by coccicheck.
Signed-off-by: Saurav Girepunje
---
drivers/staging/vt6656/card.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/vt6656/card.c b/drivers/staging/vt6656/card.c
index 7958fc1..654c
fix warning reorted by coccicheck
WARNING: possible condition with no effect (if == else)
Signed-off-by: Saurav Girepunje
---
drivers/staging/rtl8723bs/hal/HalBtc8723b2Ant.c | 8
1 file changed, 8 deletions(-)
diff --git a/drivers/staging/rtl8723bs/hal/HalBtc8723b2Ant.c
b/drivers
fix warning reorted by coccicheck
WARNING: possible condition with no effect (if == else)
Signed-off-by: Saurav Girepunje
---
drivers/staging/rtl8723bs/core/rtw_mlme.c | 14 ++
1 file changed, 2 insertions(+), 12 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_mlme.c
fix warning reorted by coccicheck
WARNING: possible condition with no effect (if == else)
Signed-off-by: Saurav Girepunje
---
drivers/staging/comedi/drivers/das1800.c | 6 --
1 file changed, 6 deletions(-)
diff --git a/drivers/staging/comedi/drivers/das1800.c
b/drivers/staging/comedi
On 25/01/20 11:00 +0100, Johan Hovold wrote:
On Sat, Jan 25, 2020 at 02:14:03PM +0530, Saurav Girepunje wrote:
fix uninitialized variables issue found using static code analysis tool
Which tool is that?
(error) Uninitialized variable: offset
(error) Uninitialized variable: size
Signed-off
fix uninitialized variables issue found using static code analysis tool
(error) Uninitialized variable: offset
(error) Uninitialized variable: size
Signed-off-by: Saurav Girepunje
---
drivers/staging/greybus/bootrom.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers
Remove return variables, return the values
directly, as the functions all return 0 in all cases.
Signed-off-by: Saurav Girepunje
---
drivers/staging/rtl8723bs/os_dep/ioctl_linux.c | 15 +--
1 file changed, 5 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/rtl8723bs
Remove unused variable ret from functions rtw_mp_ioctl_hdl,
rtw_get_ap_info, rtw_mp_efuse_set, rtw_tdls, rtw_tdls_get .
Signed-off-by: Saurav Girepunje
---
drivers/staging/rtl8723bs/os_dep/ioctl_linux.c | 15 +--
1 file changed, 5 insertions(+), 10 deletions(-)
diff --git a/drivers
As the "else if" and "else" branch body are identical the condition
has no effect. So drop the "else if" condition
Signed-off-by: Saurav Girepunje
---
drivers/staging/rtl8723bs/core/rtw_cmd.c | 10 --
1 file changed, 10 deletions(-)
diff --git a/drivers/st
As the "else if" and "else" branch body are identical the condition
has no effect. So drop the "else if" condition.
Signed-off-by: Saurav Girepunje
---
drivers/staging/rtl8723bs/os_dep/ioctl_linux.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/dr
As the "else if" and "else" branch body are identical the condition
has no effect. So drop the "else if" condition.
Signed-off-by: Saurav Girepunje
---
drivers/staging/rtl8723bs/os_dep/ioctl_linux.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/dr
As the "else if" and "else" branch body are identical the condition
has no effect. So drop the else if condition.
Signed-off-by: Saurav Girepunje
---
drivers/staging/rtl8723bs/hal/hal_btcoex.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/s
Add spaces around '-', '+', '&','|' and '?' to improve readability
and follow kernel coding style in rtw_ap.c
Signed-off-by: Saurav Girepunje
---
drivers/staging/rtl8723bs/core/rtw_ap.c | 88 -
1 file changed, 4
Remove Unnecessary parentheses around padapter->mlmepriv,
pmlmeext->mlmext_info and pmlmeinfo->network in rtw_ap.c
Signed-off-by: Saurav Girepunje
---
drivers/staging/rtl8723bs/core/rtw_ap.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/driver
Correct spelling mistake in rtw_ap.c
Signed-off-by: Saurav Girepunje
---
drivers/staging/rtl8723bs/core/rtw_ap.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_ap.c
b/drivers/staging/rtl8723bs/core/rtw_ap.c
index 7bd5c61b055c
Add spaces around '-', '+', '>>','<<' and '*' to improve readability
and follow kernel coding style.
Signed-off-by: Saurav Girepunje
---
drivers/staging/rtl8188eu/core/rtw_efuse.c | 128 ++---
1 file changed, 6
Remove Unnecessary parentheses around precvframe->list,
pmlmeext->mlmext_info and precvpriv->free_recv_queue
Signed-off-by: Saurav Girepunje
---
drivers/staging/rtl8188eu/core/rtw_recv.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/rtl81
Removed Unnecessary parentheses around "padapter->mlmepriv",
"pmlmeext->mlmext_info" and "pmlmeinfo->network"
Signed-off-by: Saurav-Girepunje
---
drivers/staging/rtl8723bs/core/rtw_ap.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
RTWAP:Fixed Coding function and style issues
Removed Unnecessary parentheses
Signed-off-by: Saurav-Girepunje
---
drivers/staging/rtl8723bs/core/rtw_ap.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_ap.c
b/drivers/staging/rtl8723bs
22 matches
Mail list logo