struct nbu2ss_ep *ep parameter in functions _nbu2ss_ep0_in_transfer()
and _nbu2ss_ep0_out_transfer() is not used anywhere inside. Hence,
removed.
Signed-off-by: Ravi Teja Darbha
---
drivers/staging/emxx_udc/emxx_udc.c | 12 +---
1 file changed, 5 insertions(+), 7 deletions(-)
diff
The cleanup1 label does nothing but return. Better way is to return
immediately instead of using goto. Hence, removed.
Signed-off-by: Ravi Teja Darbha
---
drivers/staging/emxx_udc/emxx_udc.c | 9 +++--
1 file changed, 3 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/emxx_udc
Fixed NULL comparison style as suggested by checkpatch.pl
Signed-off-by: Ravi Teja Darbha
---
drivers/staging/emxx_udc/emxx_udc.c | 62 ++---
1 file changed, 31 insertions(+), 31 deletions(-)
diff --git a/drivers/staging/emxx_udc/emxx_udc.c
b/drivers/staging
Fixed multiple blank lines warning by checkpatch.pl
Signed-off-by: Ravi Teja Darbha
---
drivers/staging/emxx_udc/emxx_udc.c | 9 -
drivers/staging/emxx_udc/emxx_udc.h | 26 --
2 files changed, 35 deletions(-)
diff --git a/drivers/staging/emxx_udc/emxx_udc.c
b
FSF mailing address is no longer required to be specified. Hence
removed.
Signed-off-by: Ravi Teja Darbha
---
drivers/staging/emxx_udc/emxx_udc.c | 4
drivers/staging/emxx_udc/emxx_udc.h | 4
2 files changed, 8 deletions(-)
diff --git a/drivers/staging/emxx_udc/emxx_udc.c
b/drivers
Fix several coding style issue as suggested by checkpatch.pl with
--strict option
Ravi Teja Darbha (3):
staging: emxx_udc: Remove FSF mailing address
staging: emxx_udc: Avoid using multiple blank lines
staging: emxx_udc: Fix NULL comparison style
drivers/staging/emxx_udc/emxx_udc.c | 75
Prefer kernel type u32 over uint32_t to maintain uniformity.
Signed-off-by: Ravi Teja Darbha
---
drivers/staging/goldfish/goldfish_nand_reg.h | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/goldfish/goldfish_nand_reg.h
b/drivers/staging/goldfish
Fixed NULL comparison style as suggested by checkpatch.pl with --strict
option.
Signed-off-by: Ravi Teja Darbha
---
drivers/staging/goldfish/goldfish_nand.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/goldfish/goldfish_nand.c
b/drivers/staging
Why would you use a macro to avoid code duplication?
Regards,
Ravi Teja
On Mon, Jul 06, 2015 at 05:57:06PM +0530, Sudip Mukherjee wrote:
> That is why the macro is there, to avoid the duplication of code.
___
devel mailing list
What you need to do is to replace all DGNC_VERIFY_BOARD() macro calls with its
definition.
Regards,
Ravi Teja
On Sun, Jul 05, 2015 at 11:46:28PM +0530, Arjun Krishna Babu wrote:
> This patch fixes the checkpatch.pl warning:
>
> WARNING: Macros with flow control statements should b
else is not generally useful after a break or return, hence removed.
Signed-off-by: Ravi Teja Darbha
---
drivers/staging/rts5208/xd.c | 10 --
1 file changed, 4 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/rts5208/xd.c b/drivers/staging/rts5208/xd.c
index 10fea7b..42d8d82
Else condition after if statement is not necessary, hence removed.
Signed-off-by: Ravi Teja Darbha
---
drivers/staging/rts5208/xd.c | 10 --
1 file changed, 4 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/rts5208/xd.c b/drivers/staging/rts5208/xd.c
index 10fea7b..42d8d82
Fix line over 80 characters warning.
Signed-off-by: Ravi Teja Darbha
---
drivers/staging/rtl8712/rtl8712_recv.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8712/rtl8712_recv.c
b/drivers/staging/rtl8712/rtl8712_recv.c
index fcb8c61..4fa2540 100644
Fix line over 80 characters warning.
Signed-off-by: Ravi Teja Darbha
---
drivers/staging/rtl8712/rtl8712_recv.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8712/rtl8712_recv.c
b/drivers/staging/rtl8712/rtl8712_recv.c
index fcb8c61..4fa2540 100644
();
else if(condition3)
return false;
else
break;
}
The else condition here cannot be eliminated
Signed-off-by: Ravi Teja Darbha
---
drivers/staging/rtl8712/rtl8712_recv.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8712
This patch fixes checkpatch warnings
Signed-off-by: Ravi Teja Darbha
---
drivers/staging/unisys/visorbus/visorchipset.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/unisys/visorbus/visorchipset.c
b/drivers/staging/unisys/visorbus
16 matches
Mail list logo