Hi Christian,
On 21 November 2017 at 19:35, Christian Gromm
wrote:
> This patch fixes the type used to manage the channels of an
> registered MOST interface.
>
> Signed-off-by: Christian Gromm
> ---
> drivers/staging/most/core.h | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff -
Hi Christian,
On 21 November 2017 at 19:35, Christian Gromm
wrote:
> For the MOST packet channel there are two dedicated USB endpoints. But
> internally the hardware has actually one channel for data forwarding from
> and to MOST. To have the hardware clean up its state machine correctly in
> cas
Hi Christian,
On 21 November 2017 at 19:34, Christian Gromm
wrote:
> This patch takes out the struct device of struct most_aim, because it is
> not needed.
Patch 9 adds struct device to struct most_aim and this patch removes
it. I think not adding struct device to struct most_aim in patch 9 is
a
Hi Christian,
On 21 November 2017 at 19:35, Christian Gromm
wrote:
> This patch stops the core from generating a module owned class and
> registering it with the kernel. It is needed, because there is no need for
Should be "It is not needed". Not is missing.
> a default MOST class to be present
Hi Christian,
On 21 November 2017 at 19:35, Christian Gromm
wrote:
> The designator of a module that proivdes means to interface userspace is
> called an AIM. Since this name seems to be unappropiate, this kind of
> moduels are going to be referred to as componetns. This is done because
> such mo
Hi Christian,
On 21 November 2017 at 19:34, Christian Gromm
wrote:
> This patch set fixes bugs and integrates the driver to the kernel's device
> model by revising its architecture. Part of this change is rearranging the
> directory layout, renaming of files and folders and thereby creating a
> c
Greg,
On 20 October 2017 at 20:31, Greg KH wrote:
> On Fri, Oct 20, 2017 at 08:15:23PM +0530, PrasannaKumar Muralidharan wrote:
>> Hi Greg,
>>
>> On 20 October 2017 at 12:40, Greg KH wrote:
>> > On Fri, Oct 20, 2017 at 12:15:56PM +0530, PrasannaKumar Muralidh
Hi Christian,
On 20 October 2017 at 14:35, Christian Gromm
wrote:
> Hi Prasanna,
>
> the reason why the TODO file doesn't list anything, is because by
> the time we initially committed the driver upstream, we didn't know
> what work is really necessary to move the sources out of staging.
> (We wo
Hi Greg,
On 20 October 2017 at 12:40, Greg KH wrote:
> On Fri, Oct 20, 2017 at 12:15:56PM +0530, PrasannaKumar Muralidharan wrote:
>> Hi Christian,
>>
>> It has been a couple of years since most was added to the staging
>> tree. Except for review the TODO list does
Hi Christian,
It has been a couple of years since most was added to the staging
tree. Except for review the TODO list does not mention things that are
required to destage it. Wondering why most is still in staging tree.
Thanks,
PrasannaKumar
___
devel m
Hi Christian,
On 12 July 2017 at 17:48, Christian Gromm wrote:
>
> Hi,
>
> Microchip is planning to introduce a driver for a new companion chip series
> capable of electical energy measurement. However, we are not sure which
> location in the source tree is the most suitable. First thought was to
Add spaces around + for better readability of the code.
Signed-off-by: PrasannaKumar Muralidharan
---
drivers/staging/vt6655/device_main.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/vt6655/device_main.c
b/drivers/staging/vt6655/device_main.c
index
> Since it is _not_ assured that the code will run under all circumstances,
> I don't want this patch to be applied at this point.
>
> To be able to decide on the removal of the volatile keyword, we need to run
> some tests on real hardware. This ain't something we can tell by just
> looking at the
> Your subject line contains a spelling mistake :(
I have sent an email with this fixed.
Regards,
PrasannaKumar
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
From: PrasannaKumar Muralidharan
Remove unnecessary __cplusplus check in header files as it is not
required.
Signed-off-by: PrasannaKumar Muralidharan
---
drivers/staging/most/hdm-dim2/dim2_errors.h | 8
drivers/staging/most/hdm-dim2/dim2_hal.h| 8
drivers/staging/most
> Are you sure you can just remove these markings? Does the code work the
> same? What is properly locking these values? Why were they marked this
> way in the first place?
I could not test the change due to lack of hardware.
Given that the code works without lock and as volatile does not
guar
From: PrasannaKumar Muralidharan
Remove unnecessary use of volatile for 'request_counter' and
'service_counter' members.
Signed-off-by: PrasannaKumar Muralidharan
---
drivers/staging/most/hdm-dim2/dim2_hal.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
From: PrasannaKumar Muralidharan
Remove atomic_counter_t typedef, use int instead.
Signed-off-by: PrasannaKumar Muralidharan
---
drivers/staging/most/hdm-dim2/dim2_hal.h | 6 ++
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/most/hdm-dim2/dim2_hal.h
b
From: PrasannaKumar Muralidharan
Remove unnecessary __cplusplus check in header files as it is not
required.
Signed-off-by: PrasannaKumar Muralidharan
---
drivers/staging/most/hdm-dim2/dim2_errors.h | 8
drivers/staging/most/hdm-dim2/dim2_hal.h| 8
drivers/staging/most
I will provide a revised patch.
Thanks,
PrasannaKumar
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
The git commit message appeared as email subject so I assumed that
would suffice. Wondering if that would be required. Will add if it is
required.
Thanks,
PrasannaKumar
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproje
From: PrasannaKumar Muralidharan
Signed-off-by: PrasannaKumar Muralidharan
---
drivers/staging/most/hdm-dim2/dim2_errors.h | 8
drivers/staging/most/hdm-dim2/dim2_hal.h| 8
drivers/staging/most/hdm-dim2/dim2_reg.h| 8
3 files changed, 24 deletions(-)
diff
From: PrasannaKumar Muralidharan
Remove usage of volatile for 'request_counter' and 'service_counter'
members as they are not mapped with any IO register. Remove
atomic_counter_t as it not necessary anymore.
Signed-off-by: PrasannaKumar Muralidharan
---
drivers/s
According to Android porting guide tinyalsa will work for ALSA
drivers, it is included in the Android open source project tree.
Change in their build configuration should be enough to use this
patch.
I think it is better to get your question answered before proceeding
further. I don't have a clue
back with result.
I missed ccing lkml while sending the patch. Should I resend the
patch? I am still learning the process of sending patches.
Thanks,
PrasannaKumar
On 22 February 2016 at 21:54, Greg KH wrote:
> On Mon, Feb 22, 2016 at 09:20:24PM +0530, PrasannaKumar Muralidharan wrote:
>
From: PrasannaKumar Muralidharan
Modified goldfish audio driver to use ALSA framework. Only playback support
is implemented. After fixing review comments capture support will be
implemented. Only able to compile test so sending as RFC.
Signed-off-by: PrasannaKumar Muralidharan
---
drivers
26 matches
Mail list logo