+ ntohl(t->wmanIfCmnCpsArqDeliverInOrder);
> + t->wmanIfCmnCpsArqRxPurgeTimeout =
> + ntohs(psfLocalSet->u16ARQRxPurgeTimeOut);
> + t->wmanIfCmnCpsArqRxPurgeTimeout =
> + ntohl(t->wmanIfCmnCpsArqRxPurgeTimeout);
> t->
dex++) {
I guess I am not clear on why these loops need to be "outsourced" ... both
this and copy_sf_table() are only called once and from the same indentation
level as the functions replacing them ... maybe I am missing something?
jake
--
Jake Edge - j...@edge2.net - http://www.edge2.net
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
memcpy(host_info->aTxPktSizeHist, Adapter->aTxPktSizeHist,
> sizeof(UINT32) * MIBS_MAX_HIST_ENTRIES);
> - memcpy(pstHostMibs->stHostInfo.aRxPktSizeHist, Adapter->aRxPktSizeHist,
> + memcpy(host_info->aRxPktSizeHist, Adapter->aRxPktSiz
On Wed, 21 May 2014 01:52:17 +0400 Anton Saraev wrote:
> On Tue, May 20, 2014 at 10:24:11AM -0600, Jake Edge wrote:
> > On Tue, 20 May 2014 10:47:57 -0400 Jason Cooper wrote:
> >
> > but some kind of tests are needed to ensure nothing breaks before
> > digging into tha
with at
this point. That rats nest of ifdefs in skein_block.c needs attention,
but some kind of tests are needed to ensure nothing breaks before
digging into that ...
jake
--
Jake Edge - LWN - j...@lwn.net - http://lwn.net
___
devel mailing
Rename a few more variables and structure member names to lower case.
Signed-off-by: Jake Edge
---
against staging-next branch of staging tree
drivers/staging/skein/skein.c | 148 +-
drivers/staging/skein/skein.h | 34
drivers/staging
fix some comment typos
Signed-off-by: Jake Edge
---
against staging-next branch of staging tree
drivers/staging/skein/threefish_api.h | 18 +-
1 file changed, 9 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/skein/threefish_api.h
b/drivers/staging/skein
in one file, made sense.
Jake Edge (3):
move all threefish block functions to one file, remove unneeded
include
fix some comment typos
Rename a few more variables and structure member names to lower case.
drivers/staging/skein/Makefile |4 +-
drivers/staging/skein
Clean up file names and locations. Get rid of include/ directory and move
those up to the top-level. Rename files to get rid of upper case. Remove
skeinBlockNo3F.c as it was unused (temporary file or something?).
Signed-off-by: Jake Edge
---
v3: against staging-next branch of staging tree
.
>
> Is that ok with you?
Sure, that seems fine ... I only had fairly minor quibbles, the vast
majority of it is good stuff ...
Not sure it's useful (or even the right way to go about it), but, if it
is, Greg (or Jason or whoever) can add my:
Reviewed-by: Jake Edge
to the patch
&X0; Xptr[1] = &X1; Xptr[2] = &X2; Xptr[3] = &X3;
> + const u64 *X_ptr[4]; /* use for debugging (help cc put Xn in regs) */
> +
> + X_ptr[0] = &X0; X_ptr[1] = &X1; X_ptr[2] = &X2; X_ptr[3] = &X3;
bunch of Xs in through here too ... is
#include
> -#include
> +#include
incidentally, none of the threefish_*_block.c files actually needs
linux/string.h ... there may be other files where that's true too, it
seems to have just gotten added everywhere ...
jake
--
Jake Edge - LWN - j...@lwn.net - http://lwn.net
_
worth
deleting it in this patch or a separate one, it seems to me.
jake
--
Jake Edge - LWN - j...@lwn.net - http://lwn.net
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
to clean up some other
stuff (function names, etc.) on hold and see how far Anton got ...
fwiw, I did look at the lists to see if someone had already been
working on this stuff, which is why it is such a good idea make sure the
patches get posted publicly ...
jake
--
Jake Edge - LWN -
Clean up file names and locations. Get rid of include/ directory and move
those up to the top-level. Rename files to get rid of upper case. Remove
skeinBlockNo3F.c as it was unused (temporary file or something?).
Signed-off-by: Jake Edge
---
Against next-20140516
v2: use git format-patch
On Sun, 18 May 2014 11:42:53 -0700 Joe Perches wrote:
> On Sun, 2014-05-18 at 12:36 -0600, Jake Edge wrote:
> > Clean up file names and locations. Get rid of include/ directory
> > and move those up to the top-level. Rename files to get rid of
> > upper case. Remove skein
ee80211_crypto_wep_init' was not declared. Should it
be static?
drivers/staging/rtl8187se//ieee80211/ieee80211_crypt_wep.c:269:6:
warning: symbol 'ieee80211_crypto_wep_exit' was not declared. Should it
be static?
by adding an include file into source files and moving some
decla
Fix 4 checkpatch errors, many warnings in bcm/hostmibs.c
Signed-off-by: Jake Edge
---
Against next-20140403
v3: fixes suggested by Dan Carpenter
v2: fixes suggested by Joe Perches
There are still some > 80 length lines that require more substantive rework
to fix.
drivers/staging/
From: Jake Edge
Fix 4 checkpatch errors, many warnings in bcm/hostmibs.c
Against next-20140328 tree
Signed-off-by: Jake Edge
---
There were two > 80 lines that I couldn't find a sensible way to split
up, otherwise it is checkpatch clean
v2: fixes suggested by Joe Perches
diff
On Sun, 23 Mar 2014 10:45:09 -0700 Joe Perches wrote:
> On Sat, 2014-03-22 at 09:50 -0600, Jake Edge wrote:
> > Fix 4 checkpatch errors, many warnings in bcm/hostmibs.c
>
> Making code checkpatch clean shouldn't be the primary goal here.
Perhaps not, but it was *my* goal :)
From: Jake Edge
Fix 4 checkpatch errors, many warnings in bcm/hostmibs.c
Against next-20140321 tree
Signed-off-by: Jake Edge
---
There were two > 80 lines that I couldn't find a sensible way to split up,
otherwise it is checkpatch clean
diff --git a/drivers/staging/bcm/host
21 matches
Mail list logo