lso be removed in this same patch:
* Licensed under the GPL-2 or later.
And lastly, MODULE_LICENSE() should also be checked, which appear
to be correct in its current form.
> /*
> * ADIS16203 Programmable 360 Degrees Inclinometer
> *
> --
> 2.1.4
>
--
Hima
On Wed, Jan 02, 2019 at 01:25:27PM -0800, Matt Ranostay wrote:
>
> > On Dec 24, 2018, at 01:58, Himanshu Jha wrote:
> >
> >> On Fri, Dec 21, 2018 at 03:26:26PM -0800, Amir Mahdi Ghorbanian wrote:
> >> Replaced bool in struct with unsigned int bitfield to con
;
> + unsigned intchop_en : 1;
> + unsigned intbuf_en : 1;
> + unsigned intunipolar_en : 1;
> + unsigned intburnout_curr_en : 1;
> };
>
> #endif /* IIO_ADC_AD7192_H_ */
> --
> 2.7.4
>
Goodluck!
-
> Signed-off-by: Marcelo Schmitt
> Signed-off-by: Gabriel Capella
> ---
Use `./scripts/get_maintainer.pl ` to list the DT
maintainers and the relevant mailing list.
--
Himanshu Jha
Undergraduate Student
Department of Electronics & Communication
Guru Tegh B
tree/bindings/iio/resolver/ad2s1210.txt
Cc'ed to devictree list + Rob(DT Maintainer).
Just wondering why didn't it came up till now from the IIO reviewers ? v7!!
--
Himanshu Jha
Undergraduate Student
Department of Electronics & Communication
Guru Tegh Bahadur Instit
aranteed to be -1..0
Regardless, integer conversion rules will kick in.
> But the :1 adds instructions, so at least for only one bool, where little
> space is saved, it is probably not worth it.
True, we should reply on a promised guideline rather than possibility.
--
Himanshu Jha
Undergra
ble alignement issues" in CHECK report is difficult to figure
out by just doing a glance analysis. :)
Linus also suggested to use bool as the base type i.e., `bool x:1` but
again sizeof(_Bool) is implementation defined ranging from 1-4 bytes.
And since this issue is added to checkpatch now, very
I missing something?
Your patch applies fine.
I think the problem is on Lars end due to Thunderbird.
In the meantime, you can verify the patch using:
$ git am
Also, you can try to use `git send-email` to send patches.
--
Himanshu Jha
Undergraduate Student
Depa
-email`.
Also, as a safety measure you may use the `--dry-run` flag
of `git send-email` to see how it would look like when you
send the patch.
Thanks
--
Himanshu Jha
Undergraduate Student
Department of Electronics & Communication
Guru Tegh Bahadur Institute of Technology
__
ps://www.kernel.org/doc/html/latest/process/submitting-patches.html#the-canonical-patch-format
Hope that helps!
--
Himanshu Jha
Undergraduate Student
Department of Electronics & Communication
Guru Tegh Bahadur Institute of Technology
___
devel mailing
Remove few unused headers files since the adis core handles the buffer and
sysfs support.
Signed-off-by: Himanshu Jha
---
drivers/staging/iio/accel/adis16201.c | 3 ---
1 file changed, 3 deletions(-)
diff --git a/drivers/staging/iio/accel/adis16201.c
b/drivers/staging/iio/accel/adis16201.c
Use GENMASK to improve readability and remove the local variables used to
store intermediate data.
Signed-off-by: Himanshu Jha
---
drivers/staging/iio/accel/adis16201.c | 34 +++---
1 file changed, 15 insertions(+), 19 deletions(-)
diff --git a/drivers/staging/iio
Move adis16201 driver out of staging and merge into mainline
IIO subsystem.
Signed-off-by: Himanshu Jha
---
drivers/iio/accel/Kconfig | 12 ++
drivers/iio/accel/Makefile| 1 +
drivers/iio/accel/adis16201.c | 321 ++
drivers
Split the line over 80 characters limit to fix checkpatch
warning.
Signed-off-by: Himanshu Jha
---
drivers/staging/iio/accel/adis16201.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/iio/accel/adis16201.c
b/drivers/staging/iio/accel/adis16201.c
index
Prefer reverse christmas tree ordering of declarations to improve
readability.
Signed-off-by: Himanshu Jha
---
v2:
-no change in this patch.
drivers/staging/iio/accel/adis16201.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/iio/accel/adis16201.c
b
Move the adis16201 driver out of staging directory and merge to the
mainline IIO subsystem.
Signed-off-by: Himanshu Jha
---
v2:
-no change in this patch.
drivers/iio/accel/Kconfig | 12 ++
drivers/iio/accel/Makefile| 1 +
drivers/iio/accel/adis16201.c
In adis16201_read_raw() adjust an argument to match an open parentheses
using tabs and spaces.
Signed-off-by: Himanshu Jha
---
v2:
-aligned perfectly to match open parentheses.
drivers/staging/iio/accel/adis16201.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers
Clarify the conversion and formation of resultant data in the
adis16201_read_raw() with sufficient comments and remove the unnecessary
comments.
Signed-off-by: Himanshu Jha
---
v2:
-clarify voltage base conversions.
drivers/staging/iio/accel/adis16201.c | 27 ++-
1
Group register definitions with its register field bits to improve
readability and easy identification. A small comment is also added to
denote the purpose/functionality of the grouped register definitions.
Signed-off-by: Himanshu Jha
---
v2:
-reordered patch series.
drivers/staging/iio
Use sign_extned32() for 32 bit sign extending rather than hard coding.
Signed-off-by: Himanshu Jha
---
v2:
-no change in this patch.
drivers/staging/iio/accel/adis16201.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/iio/accel/adis16201.c
b
Remove few unnecessary comments since the macro definitions clearly
justify their purpose.
Signed-off-by: Himanshu Jha
---
v2:
-reodered patch series.
drivers/staging/iio/accel/adis16201.c | 36 ---
1 file changed, 36 deletions(-)
diff --git a/drivers
Add a _REG suffix to distinguish between registers and the register bit
fileds.
Signed-off-by: Himanshu Jha
---
v2:
-reordered patch series.
drivers/staging/iio/accel/adis16201.c | 84 +--
1 file changed, 42 insertions(+), 42 deletions(-)
diff --git a
: Himanshu Jha
---
v2:
-explained every change in the process of renaming macros.
drivers/staging/iio/accel/adis16201.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/iio/accel/adis16201.c
b/drivers/staging/iio/accel/adis16201.c
index 0fae8aa
to
suggest more cleanups/fix while pointing inline to the patch, the
necessary changes. The framing of patch is made consistent with the
datasheet naming where possible.
For all the patches:
Suggested-by: Jonathan Cameron
https://marc.info/?l=linux-iio&m=151775804702998&w=2
Himanshu Jha (
AG_STAT_ALARM1 BIT(8)
> +#define ADIS16209_DIAG_STAT_SELFTEST_FAIL_BIT 5
> +#define ADIS16209_DIAG_STAT_SPI_FAIL_BIT3
> +#define ADIS16209_DIAG_STAT_FLASH_UPT_BIT 2
#define ADIS16209_STAT_FLASH_UPT_FAIL_BIT2
?
It represents flash update fail bit!
--
Thanks
Himan
On Wed, Mar 07, 2018 at 08:50:30PM +, Jonathan Cameron wrote:
> On Mon, 5 Mar 2018 13:19:29 +0530
> Himanshu Jha wrote:
>
> > Clarify the conversion and formation of resultant data in the
> > adis16201_read_raw() with sufficient comments.
> >
> > Signed-off
such as
Fatory Reset, Software Reset, etc.
See, it is difficult to point the perfect names than the suitable ones!
And let's just leave these *bikeshedding* ;-)
--
Thanks
Himanshu Jha
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
Move the adis16201 driver out of staging directory and merge to the
mainline IIO subsystem.
Signed-off-by: Himanshu Jha
---
drivers/iio/accel/Kconfig | 12 ++
drivers/iio/accel/Makefile| 1 +
drivers/iio/accel/adis16201.c | 323
Use switch statement instead of if-else pair to explicitly match
the only two channels present.
Signed-off-by: Himanshu Jha
---
drivers/staging/iio/accel/adis16201.c | 7 +--
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/iio/accel/adis16201.c
b/drivers
Clarify the conversion and formation of resultant data in the
adis16201_read_raw() with sufficient comments.
Signed-off-by: Himanshu Jha
---
drivers/staging/iio/accel/adis16201.c | 10 ++
1 file changed, 10 insertions(+)
diff --git a/drivers/staging/iio/accel/adis16201.c
b/drivers
Use sign_extned32() for 32 bit sign extending rather than hard coding the
same.
Signed-off-by: Himanshu Jha
---
drivers/staging/iio/accel/adis16201.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/iio/accel/adis16201.c
b/drivers/staging/iio/accel
Prefer reverse christmas tree ordering of declarations to improve
readability.
Signed-off-by: Himanshu Jha
---
drivers/staging/iio/accel/adis16201.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/iio/accel/adis16201.c
b/drivers/staging/iio/accel
In adis16201_read_raw() adjust an argument to match an open parentheses
using tabs.
Signed-off-by: Himanshu Jha
---
drivers/staging/iio/accel/adis16201.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/iio/accel/adis16201.c
b/drivers/staging/iio/accel
Addition of _REG suffix to the register definitions allows a distinction
between registers and register fields. The various registers and its field
bits are grouped together to improve readability and easy indentification.
Signed-off-by: Himanshu Jha
---
drivers/staging/iio/accel/adis16201.c
Arrange header files in alphabetical sequence to improve readability.
Signed-off-by: Himanshu Jha
---
drivers/staging/iio/accel/adis16201.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/iio/accel/adis16201.c
b/drivers/staging/iio/accel/adis16201.c
s have been tested using 0-day test service with success.
Himanshu Jha (11):
Staging: iio: accel: Prefer alphabetical sequence of header files
Staging: iio: accel: Add a blank space before returns
Staging: iio: accel: Remove unnecessary comments
Staging: iio: accel: Rename few macro definiti
Rename few macros with appropriate names specifying their usage/function.
Signed-off-by: Himanshu Jha
---
drivers/staging/iio/accel/adis16201.c | 17 -
1 file changed, 8 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/iio/accel/adis16201.c
b/drivers/staging/iio
Remove unnecessary comments since the definitions are pretty clear
with their macro names.
Signed-off-by: Himanshu Jha
---
drivers/staging/iio/accel/adis16201.c | 82 +--
1 file changed, 10 insertions(+), 72 deletions(-)
diff --git a/drivers/staging/iio/accel
Adding a blank space before/after some returns improves readability.
Signed-off-by: Himanshu Jha
---
drivers/staging/iio/accel/adis16201.c | 4
1 file changed, 4 insertions(+)
diff --git a/drivers/staging/iio/accel/adis16201.c
b/drivers/staging/iio/accel/adis16201.c
index 0f6a204
*/
> *val = 0;
> - *val2 = 25000; /* 0.025 degree */
> + *val2 = 25000;
> return IIO_VAL_INT_PLUS_MICRO;
> default:
> return -EINVAL;
>
t;GPL v2");
should also be changed to
MODULE_LICENSE("GPL");
as explained by Philippe Ombredanne to me in my patch series.
I am not sure if you're subscribed to the IIO mailing list but you can find
all the update suggestions from the above link. :)
--
T
On Mon, Feb 12, 2018 at 05:57:31PM +0300, Dan Carpenter wrote:
> On Mon, Feb 12, 2018 at 08:05:22PM +0530, Himanshu Jha wrote:
> > But these should be done when we have *more* instances.
> >
> > For eg:
> > I added a tab space in function static int adis16201_read_
On Mon, Feb 12, 2018 at 04:18:26PM +0300, Dan Carpenter wrote:
> I think -M is prefered for these types of diffs? Not sure.
I wrote about that in the cover letter if you missed. :)
> On Mon, Feb 12, 2018 at 05:24:59PM +0530, Himanshu Jha wrote:
> > +static int adis16201_probe(struc
On Mon, Feb 12, 2018 at 03:10:56PM +0100, Philippe Ombredanne wrote:
> On Mon, Feb 12, 2018 at 12:54 PM, Himanshu Jha
> wrote:
> > Move the adis16201 driver out of staging directory and merge to the
> > mainline IIO directory.
> >
> > Signed-off-by: Himanshu Jha
>
Hi Dan,
On Mon, Feb 12, 2018 at 03:53:12PM +0300, Dan Carpenter wrote:
> On Mon, Feb 12, 2018 at 05:24:57PM +0530, Himanshu Jha wrote:
> > Remove some unnecessary comments by giving appropriate name to macros.
> > Therefore, add _REG suffix for control registers. Also,
readability.
Signed-off-by: Himanshu Jha
---
drivers/staging/iio/accel/adis16201.c | 226 --
1 file changed, 79 insertions(+), 147 deletions(-)
diff --git a/drivers/staging/iio/accel/adis16201.c
b/drivers/staging/iio/accel/adis16201.c
index b2145c9..011d2c5
Use SPDX identifier format instead of GPLv2. Also, rearrange the headers
in the alphabetical order.
Signed-off-by: Himanshu Jha
---
drivers/staging/iio/accel/adis16201.c | 7 +++
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/iio/accel/adis16201.c
b/drivers
Use sign_extend32 function instead of manually coding it. Also, adjust a
switch block to explicitly match channels and return -EINVAL as default
case which improves code readability.
Signed-off-by: Himanshu Jha
---
drivers/staging/iio/accel/adis16201.c | 13 -
1 file changed, 8
Move the adis16201 driver out of staging directory and merge to the
mainline IIO directory.
Signed-off-by: Himanshu Jha
---
drivers/iio/accel/Kconfig | 12 ++
drivers/iio/accel/Makefile| 1 +
drivers/iio/accel/adis16201.c | 315
to
suggest more cleanups/fix while pointing inline to the patch the
necessary changes.
All the patches have been tested using 0-day test service with success.
For all the patches:
Suggested-by: Jonathan Cameron
Himanshu Jha (4):
staging: iio: accel: adis16201: Use SPDX identifier
staging:
casting to void pointer from any pointer type and vice-versa is done
implicitly and therefore casting is not needed in such a case.
Signed-off-by: Himanshu Jha
---
drivers/staging/rtl8723bs/hal/hal_btcoex.c| 14 +++
drivers/staging/rtl8723bs/hal/hal_com.c | 4 +-
drivers
casting to void pointer from any pointer type and vice-versa is done
implicitly and therefore casting is not needed in such a case.
Signed-off-by: Himanshu Jha
---
drivers/staging/rtl8723bs/os_dep/mlme_linux.c | 4 ++--
drivers/staging/rtl8723bs/os_dep/osdep_service.c | 2 +-
drivers
casting to void pointer from any pointer type and vice-versa is done
implicitly and therefore casting is not needed in such a case.
Signed-off-by: Himanshu Jha
---
drivers/staging/rtl8723bs/core/rtw_cmd.c | 2 +-
drivers/staging/rtl8723bs/core/rtw_mlme_ext.c | 2 +-
drivers/staging
call to memset to assign 0 value immediately after allocating
memory with kzalloc is unnecesaary as kzalloc allocates the memory
filled with 0 value.
Signed-off-by: Himanshu Jha
---
drivers/staging/rtl8188eu/core/rtw_mlme.c | 3 ---
drivers/staging/rtl8188eu/os_dep/ioctl_linux.c | 2 --
2
calling memcpy immediately after memset with the same region of memory
makes memset redundant.
Signed-off-by: Himanshu Jha
---
drivers/staging/rtlwifi/base.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/rtlwifi/base.c b/drivers/staging/rtlwifi/base.c
index b81f0a9..63ce708
On Mon, Aug 28, 2017 at 09:19:06AM +0300, Dan Carpenter wrote:
> On Mon, Aug 28, 2017 at 01:43:31AM +0530, Himanshu Jha wrote:
> > calling memcpy immediately after memset with the same region of memory
> > makes memset redundant.
> >
> > Build successfully.
> &g
calling memcpy immediately after memset with the same region of memory
makes memset redundant.
Build successfully.
Signed-off-by: Himanshu Jha
---
drivers/staging/rtl8723bs/core/rtw_ioctl_set.c | 1 -
drivers/staging/rtl8723bs/core/rtw_mlme.c | 2 --
drivers/staging/rtl8723bs/os_dep
On Sun, Aug 27, 2017 at 10:06:47AM -0500, Larry Finger wrote:
> On 08/26/2017 03:47 PM, Himanshu Jha wrote:
> >Kfree on NULL pointer is a no-op and therefore checking is redundant.
> >
> >Signed-off-by: Himanshu Jha
> >---
>
> Acked-by: Larry Finger
>
&
call to memset to assign 0 value immediately after allocating
memory with kzalloc is unnecesaary as kzalloc allocates the memory
filled with 0 value.
Build and tested it.
Signed-off-by: Himanshu Jha
---
drivers/staging/rtlwifi/halmac/halmac_88xx/halmac_api_88xx.c | 2 --
drivers/staging
Kfree on NULL pointer is a no-op and therefore checking is redundant.
Signed-off-by: Himanshu Jha
---
.../staging/media/atomisp/pci/atomisp2/css2400/sh_css_firmware.c| 6 ++
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git
a/drivers/staging/media/atomisp/pci/atomisp2/css2400
Kfree on NULL pointer is a no-op and therefore checking is redundant.
Signed-off-by: Himanshu Jha
---
drivers/staging/rtl8723bs/os_dep/ioctl_linux.c | 18 ++
1 file changed, 6 insertions(+), 12 deletions(-)
diff --git a/drivers/staging/rtl8723bs/os_dep/ioctl_linux.c
b/drivers
Fixed coding style issue for function declaration.
Signed-off-by: Himanshu Jha
---
drivers/staging/unisys/visorbus/visorbus_main.c | 18 --
1 file changed, 12 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/unisys/visorbus/visorbus_main.c
b/drivers/staging/unisys
62 matches
Mail list logo